Subject: [Ice] Charter discussion comments/Q's

From: Toerless Eckert <[email-masked]>
Date: Tue, 8 Sep 2015 10:52:22 -0700

Couple of thoughts questions

a) WOuld be good to restructure charter to first explain stuff that has
   and still happens witout ICE group. And then whats planned for the
   ICE wg. Right now, what's planned for ICE wg is hidden in the middle
   of background explanations

b) Right now it seems the only statement about planned work is:

   "The goal of the ICE Working Group is to consolidate the various initiatives to update ICE to make it more suitable for the WebRTC environment but also to all the current usages of ICE."

    Aka: one sentence. Thats would be record slim.
    
    If a WG can be created with one sentence statement of work, i'd love to repeat 
    that for other WGs because i hate charter bashing ;-)) (kidding... somewhat ;-)

c) I would definitely like to see a statement about "work to allow ICE
   to proliferate better into other/new environments/solutions" - and not constrain
   only to current ones as the current sentence implies.
   
   Obviously it's a matter of milestones later in the
   charter bashing to define what such new work could be, but hopefully
   we can have a BOF with proposals for such work (i have something in mind).

d) I have today only seen ICE being used in traditional SIP/WbRTC, eg: with
   UDP. so i am not really up to speed how much ICE has already been defined
   to support/enhance other use case areas and/or whether these could be
   of interest to the ICE WG:

   -> negotiation/pinhole-poking for reliable transports - TCP/SCTP,
      especially when not over UDP (over UDP it's obvious thart we could
      use ICE).
   
   -> enhancing happy eyeballs selection not only for addresses, but
      also transport protocols.
  
   (don't hit me too hard if the answers to these questions would be obvious
    if i would read through all the STUN/TURN/ICE RFCs ;-))

e) Pal and i did have some other idea, but that's probbly better explained
   in a draft for a BOF than in email ;-)

Thanks
    Toerless

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Wed, 9 Sep 2015 07:25:17 +0000

> On 08 Sep 2015, at 19:52, Toerless Eckert (eckert) <[email-masked]> wrote:
> 

Good question.

We are not aiming to charter any new work. The plan is to move work that is already chartered and rearrange how we are working on that. By moving work out of MMUSIC into a new and shiny working group we might get a chance to get the “network people” more interested in helping out with ICE. 

With this approach my understanding is that there is no need for a BoF. 

>    that for other WGs because i hate charter bashing ;-)) (kidding… somewhat ;-)
> 

Slim and to the point. It is there to emphasis what is actually going on with ICE nowadays. 

There are initiatives like “shaved ICE” trying to minimise bandwidth spent during connectivity checks. This might help webRTC clients in bandwidth constrained environments. 

And there is the “passive aggressive” initiative that can significantly help reduce the complexity (At eat for new implementations). Small but important improvements that makes ICE better suited for webRTC and hopefully other applications. 

In addition to that there is work underway to measure and figuring out how ICE behaves in the wild.

I think the best description of what we are trying to do is; TWeaking ICE (TWICE) :-)

>   we can have a BOF with proposals for such work (i have something in mind).

A BoF would be helpful for new “features” and solving new problems. Outcome might be to do work in TAPS or get the ICE WG rechartered or something similar. Or maybe spin up a new WG to solve a small problem and then move on?  

>   in a draft for a BOF than in email ;-)

I think the above would be a good bar BoF discussion. In a nice bar where both apps and trnsp people feel comfortable. 

But lets first see if any new ICE WG spins up.

.-.
Pål-Erik

> Thanks
>    Toerless
> 
> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice