Subject: [Ice] RFC5245bis loopback interface

From: Lennart Grahl <[email-masked]>
Date: Wed, 14 Mar 2018 22:35:22 +0100

Hey everyone,

I have a quick question. RFC5245bis section 5.1.1.1 mentions that...

"Addresses from a loopback interface MUST NOT be included in the
candidate addresses."

My question is rather simple: Why? If I'm connecting to the same device,
loopback seems perfectly fine to me.

Cheers
Lennart

---

From: Nils Ohlmeier <[email-masked]>
Date: Wed, 14 Mar 2018 18:48:32 -0700

> On Mar 14, 2018, at 14:35, Lennart Grahl <[email-masked]> wrote:
> 

Not that I know/remember the reason. But each additional candidate comes with costs of trying another candidate pair.
Since loopback has very low chances of succeeding it makes sense to avoid waisting cycles on this.

BTW you can turn on the loopback interface in Firefox ICE via a user prefs if that helps in your case.

Best
  Nils Ohlmeier

---

From: Ari Keränen <[email-masked]>
Date: Thu, 15 Mar 2018 09:08:47 +0000

> On 15 Mar 2018, at 3.48, Nils Ohlmeier <[email-masked]> wrote:
> 

Yes, that's pretty much the reason. Also giving non-local endpoint loopback address can result in interesting behavior. And you can still connect on the same device via the other addresses (link-local, autoconfig, etc.).

Cheers,
Ari 

> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice