Subject: Re: [Ice] Trickle: Example in Section 17

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 2 Mar 2018 14:16:59 -0700

On 2/28/18 12:02 AM, Christer Holmberg wrote:
> Hi,
> 
> I think the example in Section 17 should be more detailed. Currently I
> wouldn’t even consider the flow an example – it’s just a high-level
> visualisation of trickle :)

It's not an example, it's an "example flow", i.e., a visualization. This
probably belongs in the introduction.

> Perhaps using the example in Section 15 of 5245bis as base, and then add
> some trickle stuff there?

Right, that would be a true example, instead of the flow visualization.
We'll look into adding this. (An actual protocol example is more
appropriate for draft-ietf-mmusic-trickle-ice-sip.)

Peter

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 2 Mar 2018 21:28:05 +0000

Hi,

>> wouldn't even consider the flow an example - it's just a high-level 
> It's not an example, it's an "example flow", i.e., a visualization. This probably belongs in the introduction.

I don't think it's even an "example flow", but we don't need to argue about that :) 

My point is that it only shows that you can send initial candidates, and then trickle more.

>> Perhaps using the example in Section 15 of 5245bis as base, and then 
>> add some trickle stuff there?
>

I think that would be very useful.

> We'll look into adding this. (An actual protocol example is more appropriate for draft-ietf-mmusic-trickle-ice-sip.)

The example in 5245bis is protocol independent.

I don't think the important thing to show is that you can trickle candidates, but more how it affects the checks etc.

Regards,

Christer