Subject: Re: [Ice] Draft new: draft-holmberg-ice-premature-00

From: Ari Keränen <[email-masked]>
Date: Fri, 1 Mar 2019 14:55:27 +0000

ICE WG,

This draft suggests a small but important fix to the standardized ICE procedures. We are now considering adopting this draft and getting it published as soon as possible. Please have a look at it and let us know if you have any concerns on this way forward.

Cheers,
Ari

> On 27 Feb 2019, at 17.09, Christer Holmberg <[email-masked]> wrote:
> 
> Hi, 
>  
> Today, 8445 defines that if an ICE endpoint discards its candidates and is not able to form candidate pairs, or when the test of all pairs fail, the ICE agent will trigger ICE failure.
>  
> The ICE agent may do this before it has received any connectivity checks from the remote peer, and such connectivity checks might trigger candidate pairs that work.
>  
> Me and Justin put together a draft that updates RFC 8445, by indicating that an ICE agent should wait (there is a suggested duration) for remote connectivity checks before it triggers ICE failure.
>  
> Link:
>  
> https://datatracker.ietf.org/doc/draft-holmberg-ice-premature/
>  
> For the GitHub fans:
>  
> https://github.com/cdh4u/draft-ice-premature
>  
> Regards,
>  
> Christer

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 05 Mar 2019 22:47:50 -0500

This looks reasonable.  The timer might need to be longer than the connectivity check timer, to account for skew in start times, but I doubt that will have any impact in practice.

The document needs an abstract.

Section 3 is quite repetitive.  It really only says one thing.  It could list the ways in which the checklist becomes empty without waiting for a connectivity check timer to run out a little more succintly.

On Sat, Mar 2, 2019, at 01:55, Ari Keränen wrote:
> ICE WG,
> 
> This draft suggests a small but important fix to the standardized ICE 
> procedures. We are now considering adopting this draft and getting it 
> published as soon as possible. Please have a look at it and let us know 
> if you have any concerns on this way forward.
> 
> 
> Cheers,
> Ari
> 
> 
> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice
>

---

From: Justin Uberti <[email-masked]>
Date: Tue, 5 Mar 2019 21:22:59 -0800

Abstract PR here <https://github.com/cdh4u/draft-ice-premature/pull/4>.

Section 3 is intentionally verbose because the conditions that can cause
this are fairly subtle and distinct (and have not been pointed out until
now). If we think this is overly explanatory, it could be tightened up
easily.

On Tue, Mar 5, 2019 at 7:47 PM Martin Thomson <[email-masked]> wrote:

> This looks reasonable.  The timer might need to be longer than the
> connectivity check timer, to account for skew in start times, but I doubt
> that will have any impact in practice.
>
> Section 3 is quite repetitive.  It really only says one thing.  It could
> list the ways in which the checklist becomes empty without waiting for a
> connectivity check timer to run out a little more succintly.
>
> > > Today, 8445 defines that if an ICE endpoint discards its candidates
> and is not able to form candidate pairs, or when the test of all pairs
> fail, the ICE agent will trigger ICE failure.
> > >
> > > The ICE agent may do this before it has received any connectivity
> checks from the remote peer, and such connectivity checks might trigger
> candidate pairs that work.
> > >
> > > Me and Justin put together a draft that updates RFC 8445, by
> indicating that an ICE agent should wait (there is a suggested duration)
> for remote connectivity checks before it triggers ICE failure.
> > >
> > > Link:
> > >