Subject: Re: [Icnrg-harmonization] NDN use of nameless Data

From: Cedric Westphal <[email-masked]>
Date: Wed, 7 Sep 2016 18:34:42 +0000

Hi,

Sent from HUAWEI AnyOffice
From:[email-masked]
To:Ravi Ravindran,
Cc:[email-masked],[email-masked],[email-masked],[email-masked],
Date:2016-09-07 11:15:11
Subject:Re: [Icnrg-harmonization] NDN use of nameless Data

In SNAMP, the Interest Name is always used first, then the Link(s) if the name cannot be matched in the FIB.  If you want to do some traffic engineering routing on the Interest in your domain, I think putting your own domain-specific label on the Interest is the right thing to do.  You do one name/link lookup on ingress, make a decision, then execute on that decision, not repeat it at every hop.  When the Interest egresses your domain, the Interest name and Link(s) are as they were when they entered your domain.

CW: if you are routing on a domain specific label, you are not routing on name. Maybe it's fine architecturally, but we need to make it clear since the order becomes at the router to look at label first, then I guess, name.

If your domain is authoritative for the name, you should be ignoring the Link(s) anyway, as the name should be in your FIB.  So if you have proper routing for the name, then tunneling and links are not needed.  If you want to do traffic engineering routing that is not easily handled with shortest path routing, then you want to tunnel.

Marc

> On Sep 7, 2016, at 10:56 AM, Ravi Ravindran <[email-masked]> wrote:
>
> ". On the other hand, if the Interest arrives with some directives (including things like a Link object that might divert the Interest to some other path), the ISP ought not to delete it or override it in order to force traffic onto their own CDN or other service."
>
> - Why ?, what if the ICN services are hosted in my edge cloud, there should be a cheaper solution to re-direct the Interest instead of costly tunneling process. We can still keep the link-object, if one want to carry the overhead, add another forwarding label and re-direct it. That way the edge service still gets the Interest with the original Link object header.
>
> Regards,
> Ravi
>
> -----Original Message-----
> From: David Oran [mailto:[email-masked]]
> Sent: Wednesday, September 07, 2016 10:12 AM
> To: Ravi Ravindran
> Cc: Alex Afanasyev; [email-masked]; Mark Mosko; Lixia Zhang
> Subject: Re: [Icnrg-harmonization] NDN use of nameless Data
>
>
>> On Sep 7, 2016, at 12:27 PM, Ravi Ravindran <[email-masked]> wrote:
>>
>> Not sure, how tunneling is different from overwriting link objects, isn’t it serving the same purpose ?.
> No, With tunneling the original Interest with any Link objects or other directives, pops out at the tunnel endpoint,  rather than having been over-written.
>
>> Rather than seeing it doing ugly thing, my opinion is that in a virtualized ICN infrastructure, there will be a lot of customization of services.
> Sure. That’s not my point. My point was that ISPs often over-ride user intent. If the user does not put directives in the Interest the ISP is obviously free to optimize anything they want. On the other hand, if the Interest arrives with some directives (including things like a Link object that might divert the Interest to some other path), the ISP ought not to delete it or override it in order to force traffic onto their own CDN or other service.
>
>> So if the provider is offering content delivery or providing mobility service to particular name prefix, it should have the ability leverage the domain knowledge to handles those Interest flows more intelligently.
> Sure, modulo the cautions I mention above.
>
>> IMO, for a good foreseeable future we are going to have a demarcation between the users and the infrastructure providers,
> This statement makes me very nervous, as it harkens back to the old Bell-shaped heads that divided the world inappropriately into UNIs and NNIs.
>
>> and flows are going to subjected to policies that benefit its network and users.
> Where those interests are aligned, of course. For better or worse, that’s not always the case.
>
> DaveO.
>
>>
>> Regards,
>> Ravi
>>
>> -----Original Message-----
>> From: David Oran [mailto:[email-masked]]
>> Sent: Wednesday, September 07, 2016 5:58 AM
>> To: Ravi Ravindran
>> Cc: Alex Afanasyev; [email-masked]; Mark Mosko; Lixia Zhang
>> Subject: Re: [Icnrg-harmonization] NDN use of nameless Data
>>
>>
>>> On Sep 6, 2016, at 3:12 PM, Ravi Ravindran <[email-masked]> wrote:
>>>
>>> I think this discussion would be on similar lines with the discovery mechanism, if you want to overload the network to handle this feature or handle it as an overlaid protocol.
>>>
>>> But I think the situation is simpler here,  considering NDN already proposes the link usage in the Interest packet, which is not different from forwarding-labels we discuss in our draft. The main difference here is with its semantics, and to broaden its scope to include its management by the infrastructure provider as well.
>>>
>> For the use case Ravi is focused on (control of forwarding by an administrative domain when Interests arrive at a domain boundary), it seems that tunneling is superior to using Link objects or routing hints. This is so that the policing of ingress and checking of the authenticity of Link objects only has to be done at entry, and not at every hop.
>>
>> Otherwise, domains will do ugly things like removing link objects at the domain boundary in order to protect the forwarding behavior of their interior forwarders. We’ve seen similar lossage with IP where ISPs blow away DSCPs and ECN marks on entry; I’d rather not repeat those mistakes with ICN.
>>
>> DaveO.
>>
>>
>>> Regards,
>>> Ravi
>>>
>>> -----Original Message-----
>>> From: Alex Afanasyev [mailto:[email-masked]]
>>> Sent: Tuesday, September 06, 2016 12:03 PM
>>> To: Ravi Ravindran
>>> Cc: Dave Oran; [email-masked]; Lixia Zhang; Mark Mosko
>>> Subject: Re: [Icnrg-harmonization] NDN use of nameless Data
>>>
>>>
>>>> On Sep 6, 2016, at 11:59 AM, Ravi Ravindran <[email-masked]> wrote:
>>>>
>>>> Within the context of Interest Names and Links, there is nothing new here. My point is about the semantics of a link and its interpretation by the network, which can vary with different situations and has to be accommodated. For e.g. in our implementations, we implement CCN routing using ONOS. Here the links are inserted by the edge nodes, and used to route in the network. And for something like mobility there is no state for the Interest names in the network at all, hence with this knowledge looking up by the name is of no use.
>>>
>>> If the network doesn't use the application names, wouldn't it be equivalent (=straightforward) to just encapsulate both Interest and Data packets into a special "network adaptation" protocol to move them within that network?
>>>
>>> ---
>>> Alex
>>>
>>>> -----Original Message-----
>>>> From: Icnrg-harmonization [mailto:[email-masked]] On Behalf Of David Oran
>>>> Sent: Tuesday, September 06, 2016 11:50 AM
>>>> To: Ravi Ravindran
>>>> Cc: [email-masked]; Lixia Zhang; Mark Mosko; Alex Afanasyev
>>>> Subject: Re: [Icnrg-harmonization] NDN use of nameless Data
>>>>
>>>>
>>>>> On Sep 6, 2016, at 2:31 PM, Ravi Ravindran <[email-masked]> wrote:
>>>>>
>>>>> The difference is, if the network has knowledge of a resource, and explicitly knows how to reach it via a link that encodes a named storage service, host, or a border node that takes the interest to another domain.
>>>> Why isn’t that just a FIB entry? What am I missing?
>>>>
>>>>> Then the network should be able to mark it (also insert such a link if required) so that the forwarder uses the link to route the Interest to that name,
>>>> that’s an interesting design point, independent of the whole locator thing. Should forwarders be allowed to insert routing hints, or only consumers? What kind of on-path attacks get opened by this? Can forwarding paths be diagnosed better/worse if this is allowed? Who is responsible for checking the signature on such routing information? Is am I ok with the Russian ISP checking signatures on links purporting to point to the U.S. but signed by the North Koreans?
>>>>
>>>>> instead of working with an assumption that finding the resource with the Interest name and the link is equally likely.
>>>> The “likeliness” is usually represented by routing metrics. Why invent something special?
>>>>
>>>>>
>>>>> Regards,
>>>>> Ravi
>>>>>
>>>>> -----Original Message-----
>>>>> From: David Oran [mailto:[email-masked]]
>>>>> Sent: Tuesday, September 06, 2016 11:20 AM
>>>>> To: Ravi Ravindran
>>>>> Cc: [email-masked]; Lixia Zhang; Mark Mosko; Alex Afanasyev
>>>>> Subject: Re: [Icnrg-harmonization] NDN use of nameless Data
>>>>>
>>>>>
>>>>>> On Sep 6, 2016, at 2:17 PM, Ravi Ravindran <[email-masked]> wrote:
>>>>>>
>>>>>> I'm OK with using the terms Link or Hints, its use as a locator is a special case, considering the scope of the Link Alex mentioned. But the forwarder should be able to distinguish these two behavior, i.e. use it as a hint or use it as explicit locator considering different network contexts.
>>>>>>
>>>>> What do you think the difference is? I don’t see any.
>>>>>
>>>>>> Regards,
>>>>>> Ravi
>>>>>>
>>>>>> -----Original Message-----
>>>>>> From: David Oran [mailto:[email-masked]]
>>>>>> Sent: Tuesday, September 06, 2016 7:53 AM
>>>>>> To: Ravi Ravindran
>>>>>> Cc: Alex Afanasyev; [email-masked]; Mark Mosko; Lixia Zhang
>>>>>> Subject: Re: [Icnrg-harmonization] NDN use of nameless Data
>>>>>>
>>>>>>
>>>>>>> On Sep 6, 2016, at 10:32 AM, Ravi Ravindran <[email-masked]> wrote:
>>>>>>>
>>>>>>> I agree with the distinction between link and locator, but in administered domains 'links' will most likely will  be used as locators, as you have absolute knowledge of the cache/storage, or the attachment point of the device etc. In this case, links can be given priority over the names in the Interest packet, and avoid trying to route on both these names simultaneously.
>>>>>>>
>>>>>> This to me illustrates very well why the term “locator” is really problematic in the context of ICN. Let’s get rid of it.
>>>>>> There are two related but separate functions:
>>>>>>
>>>>>> a) how does a forwarder match an interest to either a local application or a cached copy of the data object.
>>>>>> b) how does a forwarder decide where to forward the interest if (a) above returns “not found”.
>>>>>> Neither of these requires anything like a locator.
>>>>>>
>>>>>> A forwarder can use any information it has at its disposal to figure (b) out. It could have a useful LPM entry in its FIB matching a prefix of the name in the interest. It could consult an oracle. It could send the Interest to the CIA (who knows where the data is). If could send the interest to the NSA, who undoubtedly already has it. It could us a hint in the Interest message (e.g. a Link). None of these is a “locators”. Or perhaps they all are, in which case the term is equally usless.
>>>>>>
>>>>>>
>>>>>>
>>>>>>> Regards,
>>>>>>> Ravi
>>>>>>>
>>>>>>> -----Original Message-----
>>>>>>> From: Alex Afanasyev [mailto:[email-masked]]
>>>>>>> Sent: Monday, September 05, 2016 11:12 PM
>>>>>>> To: Ravi Ravindran
>>>>>>> Cc: Lixia Zhang; [email-masked]; [email-masked]
>>>>>>> Subject: Re: [Icnrg-harmonization] NDN use of nameless Data
>>>>>>>
>>>>>>>
>>>>>>>> On Sep 5, 2016, at 10:23 PM, Ravi Ravindran <[email-masked]> wrote:
>>>>>>>>
>>>>>>>> I’m not sure if there is any disagreement about this that, there are two types of names in ICN, one what application binds to, and managed by the application providers, called identifiers. And the names that are relevant to the network layer to identify networks, routers, border nodes, hosts etc, managed by the infrastructure provider, hence topological and can be used for routing, late binding etc, which we call locators.
>>>>>>>
>>>>>>> I don't fully agree with the distinction.  Some names will be managed by the operators.  However, it does not mean that only those names can be used to forward Interests.  While I cannot predict future for real, I can see that prefixes for the "popular data" (e.g., from google, amazon, netflix, etc.) will be reachable directly.
>>>>>>>
>>>>>>> If we still have routing system similar to what we have today (I'm leaving the door open here), then not-so-popular application data would need to be mapped to other names that can guide the interests.
>>>>>>>
>>>>>>>> Isn’t the link defined in SNAMP paper same as locators ?
>>>>>>>
>>>>>>> I think this is a continuation of the discussion we had a few meetings back.  There is similarity, but there is also semantical differences from what word "locator" implies:
>>>>>>>
>>>>>>> - (1) The link from SNAMP paper is a hint for the routers on where the data may be available.
>>>>>>> - (2) The link does not imply that interests must be forwarded to a specific "location" to retrieve data, e.g., data can be retrieved from without using the link or on the way(s) pointed by the link.
>>>>>>> - (3) The name in the link might not be even a "location", just a direction(s) or way(s) to follow to have a chance to meet the data.  Here I would like to highlight the fact that some name prefixes would be announced from different places, i.e., the way(s) to meet the data is not pre-determined.
>>>>>>>
>>>>>>> --
>>>>>>> Alex
>>>>>>>
>>>>>>>>
>>>>>>>> Regards,
>>>>>>>> Ravi
>>>>>>>>
>>>>>>>> From: Lixia Zhang [mailto:[email-masked]]
>>>>>>>> Sent: Monday, September 05, 2016 5:14 PM
>>>>>>>> To: Ravi Ravindran
>>>>>>>> Cc: [email-masked]; [email-masked]
>>>>>>>> Subject: Re: [Icnrg-harmonization] NDN use of nameless Data
>>>>>>>>
>>>>>>>>
>>>>>>>> On Sep 1, 2016, at 11:24 AM, Ravi Ravindran <[email-masked]> wrote:
>>>>>>>>
>>>>>>>> But one big difference here with CCNx is that, in NDN is that all objects are named.
>>>>>>>>
>>>>>>>> Yes, hence the name of the architecture: named data networking :-)
>>>>>>>>
>>>>>>>>
>>>>>>>> I think we should reconsider this notion of nameless objects in CCNx, and define a way to carry locator names in the Interest messages.
>>>>>>>>
>>>>>>>> Regards,
>>>>>>>> Ravi
>>>>>>>>
>>>>>>>> To me the so called "locator" is another misconception.
>>>>>>>>
>>>>>>>> Lixia
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> From: Icnrg-harmonization [mailto:[email-masked]] On Behalf Of [email-masked]
>>>>>>>> Sent: Thursday, September 01, 2016 8:24 AM
>>>>>>>> To: [email-masked]
>>>>>>>> Subject: [Icnrg-harmonization] NDN use of nameless Data
>>>>>>>>
>>>>>>>> There has been a bit of talk about CCNx making explicit the use of nameless objects, but I’d like to point out that one can do essentially the same thing in NDN using the Interest Link.  If CCNx were to adopt the Link approach to routing indirection, it could be done this way too (though using the ContentObjectHashRestriction field, not the implicit digest).
>>>>>>>>
>>>>>>>> This is based on the 0.2-alpha-3 NDN packet format specification and the SNAMP-NDN-Scalability.pdf paper.  If I have misread something, please let me know.
>>>>>>>>
>>>>>>>> The NDN spec says a Name is zero or more NameComponent.  Therefore, I can create a Data object with an empty name.  In an Interest, I can put one NameComponent of type ImplicitSha256DigestComponent and set Min/Max SuffixComponents to 0 and then include one or more Link objects in the Interest for routing.
>>>>>>>>
>>>>>>>> My understanding of NDN is that because the ImplicitSha256DigestComponent is not in the FIB, a forwarder will forward via the Link.  The nameless Data Object – having 0 name components – will have a FullName of only its ImplicitSha256DigestComponent and that will match the name in the Interest.
>>>>>>>>
>>>>>>>> I believe this use of NDN also maintains the property we were going after in CCNx nameless objects in that one cannot poison the cache by feting a Data object by hash that could then later be confused with a Data object being fetched by prefix or name (unless one put a 0 component name in the Interest with MaxSuffixComponents of at least 1 and used Link routing).
>>>>>>>>
>>>>>>>> Marc
>>>>>>>> _______________________________________________
>>>>>>>> Icnrg-harmonization mailing list
>>>>>>>> [email-masked]
>>>>>>>> https://www.irtf.org/mailman/listinfo/icnrg-harmonization
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> Icnrg-harmonization mailing list
>>>>>>>> [email-masked]
>>>>>>>> https://www.irtf.org/mailman/listinfo/icnrg-harmonization
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> Icnrg-harmonization mailing list
>>>>>>> [email-masked]
>>>>>>> https://www.irtf.org/mailman/listinfo/icnrg-harmonization
>>>>>>
>>>>>> _______________________________________________
>>>>>> Icnrg-harmonization mailing list
>>>>>> [email-masked]
>>>>>> https://www.irtf.org/mailman/listinfo/icnrg-harmonization
>>>>>
>>>>> _______________________________________________
>>>>> Icnrg-harmonization mailing list
>>>>> [email-masked]
>>>>> https://www.irtf.org/mailman/listinfo/icnrg-harmonization
>>>>
>>>> _______________________________________________
>>>> Icnrg-harmonization mailing list
>>>> [email-masked]
>>>> https://www.irtf.org/mailman/listinfo/icnrg-harmonization
>>>
>>> _______________________________________________
>>> Icnrg-harmonization mailing list
>>> [email-masked]
>>> https://www.irtf.org/mailman/listinfo/icnrg-harmonization
>>
>

_______________________________________________
Icnrg-harmonization mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg-harmonization

---

From: <[email-masked]>
Date: Wed, 7 Sep 2016 18:54:07 +0000

On Sep 7, 2016, at 11:34 AM, Cedric Westphal <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Sent from HUAWEI AnyOffice
From:[email-masked]<mailto:[email-masked]>
To:Ravi Ravindran,
Cc:[email-masked]<mailto:[email-masked]>,[email-masked]<mailto:[email-masked]>,[email-masked]<mailto:[email-masked]>,[email-masked]<mailto:[email-masked]>,
Date:2016-09-07 11:15:11
Subject:Re: [Icnrg-harmonization] NDN use of nameless Data

Perhaps there was a terminology problem.  Maybe this is more clear.  When the Interest with Names + Links enters your domain, you do one routing decision, add a label, then switch on that label, and on exit from the domain the label falls away leaving the original packet name and links.  I don’t believe one needs to route at every hop.  It really depends how one wants to organize one’s domain.  Another common topology is to switch on ingress to route reflectors, make a routing decision, then switch again.  I think all that should be invisible to the L3 ICN addressing.

Marc

> On Sep 7, 2016, at 10:56 AM, Ravi Ravindran <[email-masked]<mailto:[email-masked]>> wrote:
>
> Cc: Alex Afanasyev; [email-masked]<mailto:[email-masked]>; Mark Mosko; Lixia Zhang
>> On Sep 7, 2016, at 12:27 PM, Ravi Ravindran <[email-masked]<mailto:[email-masked]>> wrote:
>>
>> Cc: Alex Afanasyev; [email-masked]<mailto:[email-masked]>; Mark Mosko; Lixia Zhang
>>> On Sep 6, 2016, at 3:12 PM, Ravi Ravindran <[email-masked]<mailto:[email-masked]>> wrote:
>>>
>>> Cc: Dave Oran; [email-masked]<mailto:[email-masked]>; Lixia Zhang; Mark Mosko
>>>> On Sep 6, 2016, at 11:59 AM, Ravi Ravindran <[email-masked]<mailto:[email-masked]>> wrote:
>>>>
>>>> Cc: [email-masked]<mailto:[email-masked]>; Lixia Zhang; Mark Mosko; Alex Afanasyev
>>>>> On Sep 6, 2016, at 2:31 PM, Ravi Ravindran <[email-masked]<mailto:[email-masked]>> wrote:
>>>>>
>>>>> Cc: [email-masked]<mailto:[email-masked]>; Lixia Zhang; Mark Mosko; Alex Afanasyev
>>>>>> On Sep 6, 2016, at 2:17 PM, Ravi Ravindran <[email-masked]<mailto:[email-masked]>> wrote:
>>>>>>
>>>>>> Cc: Alex Afanasyev; [email-masked]<mailto:[email-masked]>; Mark Mosko; Lixia Zhang
>>>>>>> On Sep 6, 2016, at 10:32 AM, Ravi Ravindran <[email-masked]<mailto:[email-masked]>> wrote:
>>>>>>>
>>>>>>> Cc: Lixia Zhang; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
>>>>>>>> On Sep 5, 2016, at 10:23 PM, Ravi Ravindran <[email-masked]<mailto:[email-masked]>> wrote:
>>>>>>>>
>>>>>>>> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
>>>>>>>> On Sep 1, 2016, at 11:24 AM, Ravi Ravindran <[email-masked]<mailto:[email-masked]>> wrote:
>>>>>>>>
>>>>>>>> From: Icnrg-harmonization [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
>>>>>>>> To: [email-masked]<mailto:[email-masked]>
>>>>>>>> [email-masked]<mailto:[email-masked]>
>>>>>>>> [email-masked]<mailto:[email-masked]>
>>>>>>> [email-masked]<mailto:[email-masked]>
>>>>>> [email-masked]<mailto:[email-masked]>
>>>>> [email-masked]<mailto:[email-masked]>
>>>> [email-masked]<mailto:[email-masked]>
>>> [email-masked]<mailto:[email-masked]>

_______________________________________________
Icnrg-harmonization mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg-harmonization