Subject: [icnrg] ICNRG next steps

From: Börje Ohlman <[email-masked]>
Date: Fri, 8 Jun 2012 10:21:40 +0200

I have now remodeled the ICNRG Wiki to help us in our continued work in the ICNRG, please see
http://trac.tools.ietf.org/group/irtf/trac/wiki/icnrg
This page is intended to be a dynamic page where everyone is offered to contribute. So this page is a complement to the official homepage of the RG, http://irtf.org/icnrg.

We are planning to have the first official ICNRG @ IETF 84, Vancouver, Canada, July 29-August 3, 2012. It is time that we start to plan for what we would like to have on the agenda at that meeting. We should devote some time to discuss how to best organize our work and form some groups that can address the work items that we choose to focus on. We also like to see some good technical presentations. It is probably a good idea to try to focus those around a specific topic to enable a good discussion. Proposals for work items, topics for technical presentations as well as specific proposals for presentations are welcome. Proposals can be send to this list and/or be entered to the Wiki.

	Börje

---

From: Paulo Mendes <[email-masked]>
Date: Mon, 18 Jun 2012 14:14:05 +0100

Hi Boerje

As for the Vancouver meeting I would like to contribute with a technical presentation about the application of the Information-centric networking approach to disruptive scenarios. This is inline with the goal to devise solutions that are relevant for evolving the Internet at large.

This presentation, which can be entitle "Information-centric Opportunistic Networking", aims to foster discussion about the application of ICN over opportunistic networks, trying to: i) highlight major research issues (e.g. naming, routing and in-network caching); ii) identify the interaction with other architectures, such as the one being worked on the DTNRG; iii) identify traffic models and traces that reflect daily usage (important since ICN is boosted by the users' need for information, which depends on their daily routines).

The final goal is to contribute to the ICN problem statement and main concepts as well as to define the borderline with other approaches, such as the DTN approach ..

In the presentation I can also introduce the experimental activities that we are developing in the Amazon region in cooperation with the University Federal of Pará.

Paulo

P.S. What are the wiki credentials? 

On Jun 8, 2012, at 9:21 AM, Börje Ohlman wrote:

> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

-------------------------------------------------------------
Paulo Mendes, Ph.D
Scientific Director for Innovation of the Research Unit in Informatics Systems and Technologies (SITI)
Secretary of the ACM SIGCOMM Chapter - Portugal
University Lusofona, Portugal
[email-masked]
http://siti.ulusofona.pt/~pmendes
Tel.: 217 515 500 Fax: 21 757 7006

---

From: Börje Ohlman <[email-masked]>
Date: Wed, 20 Jun 2012 04:42:20 +0200

Hi Paulo,

Thanks for offering this presentation, please put it on the Wiki. 
Regarding credentials for the Wiki, the only thing that should be needed is that your register yourself as a user of the IRTF Wiki, you should then be able to edit our page (and most other pages, as I understand it). If you have any problems please contact Dirk or Dave as I'm currently on vacation and will be offline for the next couple of weeks.

	Börje

---

From: Damien Saucez <[email-masked]>
Date: Wed, 20 Jun 2012 12:45:36 +0200

Dear Börje, Dear all,

We would like to contribute to the Vancouver meeting with a discussion about the congestion
control and fairness in information centric network with in-network caching. We have discovered
that even though in-network caching can dramatically reduce server load, it might also negatively
impact the fairness in the network. This observation has very deep consequences in the design
of the congestion control mechanism for information-centric networking.

Our goal is thus to contribute to the ICN problem statement to make sure that fairness will be
respected.

Best regards,

Damien Saucez

---

From: David R Oran <[email-masked]>
Date: Wed, 20 Jun 2012 09:19:08 -0400

Sounds like an interesting talk!
Can we see a preview?

---

From: Paulo Mendes <[email-masked]>
Date: Wed, 20 Jun 2012 14:57:16 +0100

Hi

I just included another entry on the "Proposed technical topics" of the meeting agenda on the Wiki.

In order to take care of all the travel logistics, it will be useful to know the meeting day. When can we have that information?

Paulo

---

From: Paulo Mendes <[email-masked]>
Date: Wed, 20 Jun 2012 15:00:49 +0100

Hi David

As for my presentation, I still didn't compile the slides.. However, I'm planning to release them to the mailing list (may be via the wiki) weeks before the meeting...  I plan to describe what we are doing in our project, what is the main characteristics of the architecture that we are planning to evaluate, and what are the issues that we see as having an impact on ICNRG and that we could contribute to.

Paulo

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 20 Jun 2012 15:07:01 +0000

> In order to take care of all the travel logistics, it will be useful to know the meeting day. When can we have that information?

According to http://www.ietf.org/meeting/cutoff-dates-2012.html#IETF84, on 2012-07-06.

But! Note that IETF meetings run from Monday morning to Friday afternoon, and last-minute scheduling changes are common. If you only come for part of the week and the meeting time changes, don't complain.

Lars

---

From: Paulo Mendes <[email-masked]>
Date: Wed, 20 Jun 2012 16:20:18 +0100

Hi Lars

Thanks for the extra info... 

Paulo

---

From: Ashok Narayanan <[email-masked]>
Date: Mon, 25 Jun 2012 10:25:14 -0400

Hi Borje, all,

We'd like to start the discussion on routing protocol formats (BGP, OSPF) for carrying NDN routes. Of interest would be schemes that can carry URI-type routes which are usable by both NDN and other CDN-style architectures. At this point, defining a straw man scheme would give the community a place to build around. To start this, we would like a slot at Vancouver to present proposed BGP extensions for carrying content URI routes, which are for both NDN and other ICN/CDN schemes that are URI based. We will submit an associated draft (-00) with this.

Thanks
-Ashok, Stefano and Brian

---

From: Dirk Kutscher <[email-masked]>
Date: Tue, 26 Jun 2012 12:25:13 +0000

Hi Damien,

Thanks.  If you have any pointers to your work, please consider sharing them here.

We will come back with an agenda proposal in a couple of days.

Best regards,
Dirk

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Damien Saucez
> Sent: Mittwoch, 20. Juni 2012 12:46
> To: Börje Ohlman
> Cc: Chadi Barakat; Alfredo Grieco; [email-masked]
> Subject: Re: [icnrg] ICNRG next steps
> 
> Dear Börje, Dear all,
> 
> We would like to contribute to the Vancouver meeting with a discussion
> about the congestion control and fairness in information centric network
> with in-network caching. We have discovered that even though in-network
> caching can dramatically reduce server load, it might also negatively impact
> the fairness in the network. This observation has very deep consequences in
> the design of the congestion control mechanism for information-centric
> networking.
> 
> Our goal is thus to contribute to the ICN problem statement to make sure
> that fairness will be respected.
> 
> 
> Best regards,
> 
> Damien Saucez
> 
> 
> > As for the Vancouver meeting I would like to contribute with a technical
> presentation about the application of the Information-centric networking
> approach to disruptive scenarios. This is inline with the goal to devise
> solutions that are relevant for evolving the Internet at large.
> >
> > This presentation, which can be entitle "Information-centric Opportunistic
> Networking", aims to foster discussion about the application of ICN over
> opportunistic networks, trying to: i) highlight major research issues (e.g.
> naming, routing and in-network caching); ii) identify the interaction with
> other architectures, such as the one being worked on the DTNRG; iii) identify
> traffic models and traces that reflect daily usage (important since ICN is
> boosted by the users' need for information, which depends on their daily
> routines).
> >
> > The final goal is to contribute to the ICN problem statement and main
> concepts as well as to define the borderline with other approaches, such as
> the DTN approach ..
> >
> > In the presentation I can also introduce the experimental activities that we
> are developing in the Amazon region in cooperation with the University
> Federal of Pará.
> >
> > Paulo
> >
> >> This page is intended to be a dynamic page where everyone is offered to
> contribute. So this page is a complement to the official homepage of the RG,
> http://irtf.org/icnrg.
> >>
> >> We are planning to have the first official ICNRG @ IETF 84, Vancouver,
> Canada, July 29-August 3, 2012. It is time that we start to plan for what we
> would like to have on the agenda at that meeting. We should devote some
> time to discuss how to best organize our work and form some groups that
> can address the work items that we choose to focus on. We also like to see
> some good technical presentations. It is probably a good idea to try to focus
> those around a specific topic to enable a good discussion. Proposals for work
> items, topics for technical presentations as well as specific proposals for
> presentations are welcome. Proposals can be send to this list and/or be
> entered to the Wiki.
> >>
> >> 	Börje
> >>
> > Scientific Director for Innovation of the Research Unit in Informatics
> > Systems and Technologies (SITI) Secretary of the ACM SIGCOMM Chapter -
> > Portugal University Lusofona, Portugal [email-masked]

---

From: Dirk Kutscher <[email-masked]>
Date: Tue, 26 Jun 2012 12:26:56 +0000

Hi Ashok, Stefano, and Brian,

Thanks for that - looking forward to your draft.

Best regards,
Dirk

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ashok Narayanan
Sent: Montag, 25. Juni 2012 16:25
To: Börje Ohlman
Cc: [email-masked]; Brian Field; Stefano Previdi
Subject: Re: [icnrg] ICNRG next steps

Hi Borje, all,

Thanks

          Börje

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 26 Jun 2012 13:42:18 +0100

Hi Börje,

If there's time, I'd like to present our ni naming
draft [1] that might be of interest.

A short slot is fine. I guess it might be of interest to
use that as a lead into a discussion about the use of
crypto in/with ICN names. I've added a bullet for that
to the proposed topics in the wiki.

Cheers,
S

[1] http://tools.ietf.org/html/draft-farrell-decade-ni

---

From: Damien Saucez <[email-masked]>
Date: Wed, 27 Jun 2012 10:01:20 +0200

Hello Dirk,

As we are polishing the paper for its submission on July 20th, I propose to
send it to the mailing list then. Ok?

Cheers,

Damien Saucez

---

From: Matthias Waehlisch <[email-masked]>
Date: Thu, 28 Jun 2012 14:21:40 +0200

Hi,

  we would like to give a talk about "Some Threats in Content-Centric 
Routing" at the Vancouver meeting. For background, there is a SIGCOMM 
poster abstract [1] and a more elaborated ongoing discussion paper [2].

Thanks
  matthias

[1] http://page.mi.fu-berlin.de/waehl/papers/wsv-bipmc-12.pdf
[2] http://arxiv.org/abs/1205.4778v1

-- 
Matthias Waehlisch
.  Freie Universitaet Berlin, Inst. fuer Informatik, AG CST
.  Takustr. 9, D-14195 Berlin, Germany
.. mailto:[email-masked] .. http://www.inf.fu-berlin.de/~waehl
:. Also: http://inet.cpt.haw-hamburg.de .. http://www.link-lab.net

---

From: "Pier Luca Montessoro" <[email-masked]>
Date: Thu, 28 Jun 2012 16:04:12 +0200

Dear all,

referring to our previous message, we would like to inform you that it is
now available the Internet draft "REBOOK: a Network Resource Booking
Algorithm" (http://tools.ietf.org/html/draft-montessoro-rebook), by Pier
Luca Montessoro and Riccardo Bernardini. Moreover, our paper "Congestion
Avoidance Through Deterministic, Adaptive and Scalable Resource
Reservation", submitted to the ICNRG workshop, refers to some papers that
now can be found here: 

"REBOOK: a deterministic, robust and scalable resource booking algorithm":
http://web.diegm.uniud.it/pierluca/public_html/research/papers/Rebook.pdf

"Efficient Management and Packets Forwarding for Multimedia Flows":
http://web.diegm.uniud.it/pierluca/public_html/research/papers/IMFM.pdf

"Distributed Linked Data Structures for Efficient Access to Information
within Routers":
http://web.diegm.uniud.it/pierluca/public_html/research/papers/DLDS.pdf

"A novel algorithm for dynamic admission control of elastic flows":
http://web.diegm.uniud.it/pierluca/public_html/research/papers/elastic_flows
_FITCE_2011.pdf

As said, we would like to contribute to the discussion with a presentation
of our research results, which address the congestion control problem with a
new paradigm and open new scenarios for many applications, including cloud
services and content-centric networking. 

Best regards,
Pier Luca and Riccardo

> > I have now remodeled the ICNRG Wiki to help us in our 
> continued work 
> > in the ICNRG, please see 
> > This page is intended to be a dynamic page where everyone 
> is offered to contribute. So this page is a complement to the 
> official homepage of the RG, http://irtf.org/icnrg.
> > 
> > We are planning to have the first official ICNRG @ IETF 84, 
> Vancouver, Canada, July 29-August 3, 2012. It is time that we 
> start to plan for what we would like to have on the agenda at 
> that meeting. We should devote some time to discuss how to 
> best organize our work and form some groups that can address 
> the work items that we choose to focus on. We also like to 
> see some good technical presentations. It is probably a good 
> idea to try to focus those around a specific topic to enable 
> a good discussion. Proposals for work items, topics for 
> technical presentations as well as specific proposals for 
> presentations are welcome. Proposals can be send to this list 
> and/or be entered to the Wiki.
> > 
> > 	Börje
> > 
> > 
>