Subject: [icnrg] Fwd: [IP] Future Internet Architecture: Content-Centric Networking » a memory of the past

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 4 Jun 2012 06:59:10 +0000

It might be worth checking out the 1973 paper, if it can be found.

Begin forwarded message:

> From: David Farber <[email-masked]>
> Subject: [IP] Future Internet Architecture: Content-Centric Networking » a memory of the past
> Date: June 2, 2012 20:39:37 GMT+02:00
> To: ip <[email-masked]>
> Reply-To: <[email-masked]>
> 
> Funny, but the DCS project that we did in 1970s under NSF funding used a "content-centric" Local network and it yielded many important advantages.  Unfortunately the techniques used were eliminated by those who picked up parts of the effort  since they saw no need for it :-) -- Farber, D.J., J. Feldman, F.R. Heinrich, M.D. Hopwood, K.C. Larson, D.C. Loomis, and L.A. Rowe. "The Distributed Computing System." Proc. Seventh Annual IEEE Computer
> Society International Conference, (Feb. 1973), pp. 31-34.
> 
> Dave
> 
> 
> "Next month, a little more than a year after the National Science Foundation (NSF) launched the Future Internet Architecture (FIA) program, 100 researchers will gather in Palo Alto, CA, to discuss the progress in “content-centric networking” (CCN) – a new direction for organizing Internet traffic that aims to provide greater security and faster connectivity.
> 
> Content-centric networking represents a shift from today’s focus on using network addresses to find content. Instead it proposes a protocol that specifically defines and tracks content. Backers say it represents an evolutionary change similar to IP forwarding.
> 
> 
> 
> “We think it’s definitely a concept that will change how people design high performance hardware,” said Jim Thornton, a principal engineer who leads a dozen researchers at PARC working in the area.
> 
> 
> The goal of the meeting will be to have the research community share work, exchange ideas, and begin to shape the kind of content ID and router frameworks needed to make the CCN concept work.
> 
> “We are trying to define and validate what you could think of as an Internet Protocol for content,” said Thornton. “It’s this kind of work with people experimenting with apps and use cases that will push toward the design of a core protocol,” he said."
> 
> 
> 
> 
> -------------------------------------------
> Archives: https://www.listbox.com/member/archive/247/=now
> RSS Feed: https://www.listbox.com/member/archive/rss/247/5548937-080cdcbf
> Modify Your Subscription: https://www.listbox.com/member/?member_id=5548937&id_secret=5548937-3cd253d4
> Unsubscribe Now: https://www.listbox.com/unsubscribe/?member_id=5548937&id_secret=5548937-f6d5c528&post_id=20120602143942:5037F13C-ACE2-11E1-9CD4-99B932936F3D
> Powered by Listbox: http://www.listbox.com

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 04 Jun 2012 14:42:09 +0100

> It might be worth checking out the 1973 paper, if it can be found.

I can't find the original paper or the UCIrvine TR 4 that described DCS
but there is an outline here:
https://w2.eff.org/Misc/Publications/David_Farber/distributed_computing_farber.article

There is also a more extensive description in Colin Whitby-Strevens
report of a his expedition to the USA in 1975:
http://dl.acm.org/citation.cfm?id=1015836&dl=ACM&coll=DL&CFID=103298737&CFTOKEN=24607974

Not quite on the scale we are contemplating these days!

I have vague recollections that the system that ran on the University of
Cambridge (UK) Fast Ring System a little later had some similarities.
Turning out the dustier recesses of my bookshelves .. Needham and
Herbert's book on the Cambridge Distributed Computing System from 1982
ISBN 0-201-14092-6 (not, I think, the one of the same name that Farber
wrote about in another paper) describes the File Servers that ran on the
Cambridge Ring System.  Files were accessed via capabilities so to that
extent it was content-centric and it also ran (one) special caching
machine that could be used as an alternative to direct interaction with
the file server(s). It would have been (I suspect) quite easy to
implement multiple such caches but the system scale  was not that big.  

Regards,
Elwyn

> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg