Subject: [icnrg] Information centric networking based on Software Defined Networking

From: mareb Hussein <[email-masked]>
Date: Sun, 20 Mar 2016 20:25:57 +0300

my project is about design and implementation of information centric
network based on Software Defined Networking .
my question is what is  the difference between    CONET protocol and CCNx
protocol in implementation of  ICN ?  and what is the best protocol to
implement ICN.

Regards
Mareb

---

From: Ravi Ravindran <[email-masked]>
Date: Sun, 20 Mar 2016 18:18:31 +0000

Hi Mareb,

To add to your first comment, we have always build our  CCN prototypes making it programmable using NFV/SDN frameworks. I’m not sure about CONET, but CCN is a good protocol to virtualize its transport using application defined controllers.

http://www.itu.int/en/ITU-T/focusgroups/imt-2020/Documents/Workshop-Turin/ravi-slides.pdf

Regards,
Ravi

From: icnrg [mailto:[email-masked]] On Behalf Of mareb Hussein
Sent: Sunday, March 20, 2016 10:26 AM
To: [email-masked]
Subject: [icnrg] Information centric networking based on Software Defined Networking

my project is about design and implementation of information centric network based on Software Defined Networking .
my question is what is  the difference between    CONET protocol and CCNx protocol in implementation of  ICN ?  and what is the best protocol to implement ICN.

Regards
Mareb

---

From: "Trossen, Dirk" <[email-masked]>
Date: Mon, 21 Mar 2016 09:03:21 +0000

Hi Mareb,

There’ll be an upcoming ICC 2016 paper that shows how to realize the PURSUIT ICN flavour over SDN with constant-size flow tables.

Best,

Dirk

Dirk Trossen • Principal Engineer • InterDigital UK, Inc.
Shoreditch Business Center, 64 Great Eastern Street, London,  EC2A 3QR • T: +44 207.749.9178 • [email-masked] • www.InterDigital.com<http://www.interdigital.com>

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

From: icnrg [mailto:[email-masked]] On Behalf Of Ravi Ravindran
Sent: 20 March 2016 18:19
To: mareb Hussein <[email-masked]>; [email-masked]
Subject: Re: [icnrg] Information centric networking based on Software Defined Networking

Hi Mareb,

Regards,
Ravi

From: icnrg [mailto:[email-masked]] On Behalf Of mareb Hussein
Sent: Sunday, March 20, 2016 10:26 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [icnrg] Information centric networking based on Software Defined Networking

Regards
Mareb