Subject: Re: [icnrg] request for comments on Requirements and Challenges for IoT over ICN

From: "Wissingh, B.F. (Bastiaan)" <[email-masked]>
Date: Fri, 11 Mar 2016 10:22:23 +0000

Hi,

First of all, an interesting and good piece of work. I only have some minor comments to add.

  *   Section 2.5, the first paragraph could be restructured to make the different contextual information examples more clear.
  *   Section 6.4 - Transportation, I don’t fully agree that the sensors that are being build into cars are only intended for internal vehicle functions (as mentioned in that section), so maybe that can be formulated differently? Take for example the CACC (Cooperative Adaptive Cruise Control) or platooning use case, which can interact on sensor information provided by other vehicles via ITS-G5.
  *   Section 6.4, I guess the second challenge is meant as “in real-time” instead of “on real-time”?

Best regards,
Bastiaan

Van: icnrg <[email-masked]<mailto:[email-masked]>> namens "Jagodits, Thomas" <[email-masked]<mailto:[email-masked]>>
Datum: vrijdag 11 maart 2016 00:24
Aan: Ravi Ravindran <[email-masked]<mailto:[email-masked]>>, Dirk Kutscher <[email-masked]<mailto:[email-masked]>>
CC: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Onderwerp: Re: [icnrg] request for comments on Requirements and Challenges for IoT over ICN

Hello,

Please see comments below:

a.      [2.3 – first paragraph] Delay and jitter may also be considered a resource constraint. This in particular applies to satellite or other space based devices. Note that this is independent of bandwidth which is already mentioned.

b.      [2.12 – new item?] Not clear if this is implicitly covered but new Management mechanisms and metrics need to be developed.

c.      [5.7 - security] Also the need to cater to security constraints of content that has not yet been published (as listed in 5.1).

d.      [6.3 – last paragraph] Last bullet can be reworded to improve clarity.

Regards,
Thomas Jagodits
From: icnrg [mailto:[email-masked]] On Behalf Of Rahman, Akbar
Sent: Thursday, March 10, 2016 4:04 PM
To: Ravi Ravindran; Dirk Kutscher
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [icnrg] request for comments on Requirements and Challenges for IoT over ICN

Hi Ravi,

Thanks.  I agree with your suggested approach for addressing my points.

Best Regards,

Akbar

From: Ravi Ravindran [mailto:[email-masked]]
Sent: Thursday, March 10, 2016 3:24 PM
To: Rahman, Akbar <[email-masked]<mailto:[email-masked]>>; Dirk Kutscher <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: request for comments on Requirements and Challenges for IoT over ICN

Thanks Akbar, please see my comments inline.

Regards,
Ravi

From: Rahman, Akbar [mailto:[email-masked]]
Sent: Thursday, March 10, 2016 11:05 AM
To: Dirk Kutscher
Cc: Ravi Ravindran; [email-masked]<mailto:[email-masked]>
Subject: RE: request for comments on Requirements and Challenges for IoT over ICN

Re-sending my comments as there appears to have been a mailing list problem the first time …

/Akbar

From: Rahman, Akbar
Sent: Wednesday, March 09, 2016 2:47 PM
To: 'Dirk Kutscher' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: request for comments on Requirements and Challenges for IoT over ICN

Hi Dirk,

I read the draft and it was a very good piece of work overall.  I did however have the following comments/questions:

(1)    The reference to CORE [5] in section 3.2 is confusing.  The CORE WG is not really chartered for “network operators [to] use standard APIs to build common IoT gateways and servers for their customers”.   Specifically, I think the references to network operators and gateways is confusing in the context of CORE WG.

I think the CORE WG should instead be described in a new section along with HTTP (which seems to be completely missing btw) where the model is the current popular RESTful Web Services approach.  See for example https://tools.ietf.org/html/rfc7230#section-2.2 and https://tools.ietf.org/html/rfc7252#section-1

Ravi> We will remove the CORE reference ,  and instead include some text around how work in CORE and HTTP-REST APIs are being used towards building such overlay IoT platforms.

(2)    Section 5.4 (Routing and Forwarding) should also reference the latest IETF protocols for routing in IoT specific networks as described in ROLL WG https://datatracker.ietf.org/wg/roll/charter/ .  My point is that there is already some divergence between traditional IP routing and some IoT specific routing (e.g. for low powered networks as covered in ROLL).  So this is another dimension that an ICT-IoT will have to take into consideration.

Ravi > Instead of 5.4, considering ROLL is in the context of current IP based deployment, we will address this comment in Section 3.2.

Best Regards,

Akbar

From: icnrg [mailto:[email-masked]] On Behalf Of Dirk Kutscher
Sent: Wednesday, March 09, 2016 4:12 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [icnrg] request for comments on Requirements and Challenges for IoT over ICN

Hi all,

friendly reminder.

Best regards,
Dirk

From: Dirk Kutscher
Sent: Dienstag, 16. Februar 2016 14:47
To: [email-masked]<mailto:[email-masked]>
Subject: request for comments on Requirements and Challenges for IoT over ICN

Hi all,

In November, the authors of the two previous drafts on IoT/ICN submitted a merged version:

https://datatracker.ietf.org/doc/draft-zhang-icnrg-icniot-requirements/

We have not seen much feedback on this yet.

If would be great if people could give it a read and provided some feedback to the authors.

We’d like to move forward with it eventually and would like to have a new version before IETF-95 – so your comments would be appreciated.

Thanks,
Chairs

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: Ravi Ravindran <[email-masked]>
Date: Fri, 11 Mar 2016 17:16:25 +0000

Thanks Bastiaan, we will address those comments.

Regards,
Ravi

From: Wissingh, B.F. (Bastiaan) [mailto:[email-masked]]
Sent: Friday, March 11, 2016 2:22 AM
To: Ravi Ravindran; Dirk Kutscher
Cc: [email-masked]
Subject: Re: [icnrg] request for comments on Requirements and Challenges for IoT over ICN

Hi,

Best regards,
Bastiaan

Hello,

Regards,
Thomas Jagodits

Hi Ravi,

Best Regards,

Akbar

Regards,
Ravi

/Akbar

From: Rahman, Akbar

Hi Dirk,

Best Regards,

Akbar

Hi all,

friendly reminder.

Best regards,
Dirk

From: Dirk Kutscher

Hi all,

Thanks,
Chairs