Subject: [icnrg] Link to our comprehensive survey on ICN Security, Privacy, and Access Control.

From: Satyajayant Misra <[email-masked]>
Date: Thu, 10 Mar 2016 19:21:25 -0700

Dear ICNRG Colleagues and Chairs, 

A lot of us have felt a need for a comprehensive survey on the state of the art in ICN Security, Privacy, and Access Control and outstanding challenges. In our group, we started working on a survey six months ago to fill this need. The survey is currently in submission in IEEE Communications on Surveys and Tutorials, but for the benefit of the community we have published it on arXiv. 

Please find the link enclosed: http://arxiv.org/abs/1603.03409. 

We eagerly look forward to critical feedback from the community. Thanks in advance for weighing in.  

With best regards, 
 -Jay

--
Satyajayant “Jay” Misra
Associate Professor 
Computer Science Department
New Mexico State University
Homepage: http://www.cs.nmsu.edu/~misra

---

From: Matthias Waehlisch <[email-masked]>
Date: Fri, 11 Mar 2016 11:49:14 +0100

Dear Jay,

  many thanks for sharing this huge amount of work!

  [Caveat: I didn't read the full survey yet. I will thus focus on the 
part that is very well-known to me.]

  (1) The Backscatter paper [110] is incorrectly classified as "Other 
General Contributions". This paper, including previous shorter versions 
published at SIGCOMM'12, IFIP Networking'13, is one of the first 
publications that extensively analyzed denial of service attacks (and 
other attacks) on ICN/NDN.

  (2) Content poisoning attack is not limited to fake payload, I would 
say. An attacker may also inject content to poison routes (also briefly 
discussed in the Backscatter paper).

  (3) You might want to take a look into "Revisiting Countermeasures 
Against NDN Interest Flooding" ICN'15.

Cheers
  matthias

On Thu, 10 Mar 2016, Satyajayant Misra wrote:

> A lot of us have felt a need for a comprehensive survey on the state 
> of the art in ICN Security, Privacy, and Access Control and 
> outstanding challenges. In our group, we started working on a survey 
> six months ago to fill this need. The survey is currently in 
> submission in IEEE Communications on Surveys and Tutorials, but for 
> the benefit of the community we have published it on arXiv.
> 
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
> 

-- 
Dr. Matthias Waehlisch
.  Freie Universitaet Berlin, Inst. fuer Informatik, AG CST
.  Takustr. 9, D-14195 Berlin, Germany
.. mailto:[email-masked] .. http://www.inf.fu-berlin.de/~waehl
:. Also: http://inet.haw-hamburg.de .. http://www.link-lab.net

---

From: "Satyajayant \"Jay\" Misra" <[email-masked]>
Date: Fri, 11 Mar 2016 04:34:06 -0700

Dear Matthias,

Many thanks for the information. We will incorporate them in the paper immediately. You should see it in the future version. Looking forward to more feedback.

With best regards,
Jay (Satyajayant) Misra
Associate Professor 
Computer Science
www.cs.nmsu.edu

> On Mar 11, 2016, at 3:49 AM, Matthias Waehlisch <[email-masked]> wrote:
> 
> Dear Jay,
>

---

From: "Jagodits, Thomas" <[email-masked]>
Date: Wed, 16 Mar 2016 12:11:41 +0000

Hello,

Comments on that survey are as follows:

a.      [1] There is a claim that ‘enhances several facets of user experience ‘. But there is nothing specific to substantiate this.

b.      [Table VIII] Quantify communication overhead.

This is a nice survey.

Regards,

Thomas Jagodits

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Satyajayant Misra
Sent: Thursday, March 10, 2016 9:21 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [icnrg] Link to our comprehensive survey on ICN Security, Privacy, and Access Control.

With best regards,

 -Jay

--

Satyajayant “Jay” Misra

Associate Professor

icnrg mailing list

[email-masked]<mailto:[email-masked]>

---

From: Satyajayant Misra <[email-masked]>
Date: Wed, 16 Mar 2016 11:31:42 -0600

Hi Thomas, 

Thank you for the comments. Will incorporate them. 

With best regards, 
 -Jay

> On Mar 16, 2016, at 6:11 AM, Jagodits, Thomas <[email-masked]> wrote:
> 
> Hello,
>  
> Please find the link enclosed: http://arxiv.org/abs/1603.03409 <http://arxiv.org/abs/1603.03409>.
>  
> Homepage: http://www.cs.nmsu.edu/~misra <http://www.cs.nmsu.edu/~misra>
>  
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/icnrg <https://www.irtf.org/mailman/listinfo/icnrg>