Subject: [icnrg] Problem while creating udp listener in Metis control

From: achute sharma <[email-masked]>
Date: Tue, 15 Mar 2016 11:10:23 +0000 (UTC)

Hi , 

I am trying to add a udp listener to the metis control, But it is unable to add. I am using the latest CCNx_Distillery (https://github.com/PARC/CCNx_Distillery)  to compile and run.I am trying to make two nodes communicate with each other. I am able to do this using tcp but when I try to add udp listener on my server side. with the command  add listener udp remote1 10.13.13.101 9695 I get the following errors :
in metis_daemon:
Assert /home/achute/ccnxD/src/Metis/ccnx/forwarder/metis/config/metis_ConfigurationListeners.c:80 _setupUdpListenerOnInet() (success) Failed to add UDP listener on inet4://10.13.13.101:9695 to ListenerSetmetis_daemon() [0x4123bb]metis_daemon() [0x412bf8]metis_daemon(metisConfigurationListeners_Add+0x88) [0x412ea0]metis_daemon() [0x411ce4]metis_daemon(metisConfiguration_Receive+0x225) [0x412145]metis_daemon(metisForwarder_Receive+0x108) [0x41739d]metis_daemon() [0x424cdb]/home/achute/ccnxD/usr/lib/libparc.so.1(+0x38b24) [0x7f850815fb24]/usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(+0x17a9c) [0x7f850782fa9c]/usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x845) [0x7f8507826015]/home/achute/ccnxD/usr/lib/libparc.so.1(parcEventScheduler_Start+0xd4) [0x7f850815e6fe]metis_daemon(metisDispatcher_Run+0x88) [0x414d85]metis_daemon(main+0x4f5) [0x4104ac]/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f8507d83ec5]metis_daemon() [0x40f849]Aborted (core dumped)
in Metis_control :

IllegalValue /home/achute/ccnxD/src/Libccnx-transport-rta/ccnx/api/control/controlPlaneInterface.c:271 controlPlaneInterface_GetCPIMessageType() IllegalValue Illegal value for 'json': Expected CpiMessageType, actual { "notifyStatus" : { "connectionId" : 10, "statusCode" : 5, "message" : "Socket operation returned closed by remote" } }/home/achute/ccnxD/usr/lib/libccnx_api_control.so.1(controlPlaneInterface_GetCPIMessageType+0x170) [0x7f98bd5696a2]/home/achute/ccnxD/usr/lib/libccnx_api_control.so.1(cpi_GetMessageType+0x28) [0x7f98bd5696d8]/home/achute/ccnxD/usr/lib/libccnx_api_control.so.1(ccnxControl_IsACK+0x18) [0x7f98bd55f247]metis_control() [0x4086c9]metis_control() [0x4088f5]metis_control() [0x408afc]metis_control(metisCommandParser_DispatchCommand+0x58) [0x406bab]metis_control(metisControlState_DispatchCommand+0x8e) [0x405789]metis_control(metisControlState_Interactive+0x166) [0x4058f1]metis_control(main+0x1e9) [0x405149]/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f98bcadfec5]metis_control() [0x4049e9]Aborted (core dumped)

Can some one please help me figure out where I am wrong with this . and if there is anything that I have missed, Same with tcp works. but not with udp.

---

From: <[email-masked]>
Date: Tue, 15 Mar 2016 16:49:36 +0000

Hi Achute.

A couple of quick things.  First, can you send bug reports to the ccnx mailing list?  There are a couple of users who are on that list but not on this one and for these types of questions they might be of help (or find the discussion helpful).

Secondly, we’re phasing out Metis.  Could you try your configuration with Athena?

Cheers,

Nacho

--
Nacho (Ignacio) Solis
Protocol Architect
Principal Scientist
Palo Alto Research Center (PARC)
+1(650)812-4458
[email-masked]

On 3/15/16, 4:10 AM, "icnrg on behalf of achute sharma" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi ,

I am trying to add a udp listener to the metis control, But it is unable to add. I am using the latest CCNx_Distillery (https://github.com/PARC/CCNx_Distillery)  to compile and run.
I am trying to make two nodes communicate with each other. I am able to do this using tcp but when I try to add udp listener on my server side. with the command  add listener udp remote1 10.13.13.101 9695 I get the following errors :

in metis_daemon:

Assert /home/achute/ccnxD/src/Metis/ccnx/forwarder/metis/config/metis_ConfigurationListeners.c:80 _setupUdpListenerOnInet() (success) Failed to add UDP listener on inet4://10.13.13.101:9695 to ListenerSet
metis_daemon() [0x4123bb]
metis_daemon() [0x412bf8]
metis_daemon(metisConfigurationListeners_Add+0x88) [0x412ea0]
metis_daemon() [0x411ce4]
metis_daemon(metisConfiguration_Receive+0x225) [0x412145]
metis_daemon(metisForwarder_Receive+0x108) [0x41739d]
metis_daemon() [0x424cdb]
/home/achute/ccnxD/usr/lib/libparc.so.1(+0x38b24) [0x7f850815fb24]
/usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(+0x17a9c) [0x7f850782fa9c]
/usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x845) [0x7f8507826015]
/home/achute/ccnxD/usr/lib/libparc.so.1(parcEventScheduler_Start+0xd4) [0x7f850815e6fe]
metis_daemon(metisDispatcher_Run+0x88) [0x414d85]
metis_daemon(main+0x4f5) [0x4104ac]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f8507d83ec5]
metis_daemon() [0x40f849]
Aborted (core dumped)

in Metis_control :

IllegalValue /home/achute/ccnxD/src/Libccnx-transport-rta/ccnx/api/control/controlPlaneInterface.c:271 controlPlaneInterface_GetCPIMessageType() IllegalValue Illegal value for 'json': Expected CpiMessageType, actual { "notifyStatus" : { "connectionId" : 10, "statusCode" : 5, "message" : "Socket operation returned closed by remote" } }
/home/achute/ccnxD/usr/lib/libccnx_api_control.so.1(controlPlaneInterface_GetCPIMessageType+0x170) [0x7f98bd5696a2]
/home/achute/ccnxD/usr/lib/libccnx_api_control.so.1(cpi_GetMessageType+0x28) [0x7f98bd5696d8]
/home/achute/ccnxD/usr/lib/libccnx_api_control.so.1(ccnxControl_IsACK+0x18) [0x7f98bd55f247]
metis_control() [0x4086c9]
metis_control() [0x4088f5]
metis_control() [0x408afc]
metis_control(metisCommandParser_DispatchCommand+0x58) [0x406bab]
metis_control(metisControlState_DispatchCommand+0x8e) [0x405789]
metis_control(metisControlState_Interactive+0x166) [0x4058f1]
metis_control(main+0x1e9) [0x405149]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f98bcadfec5]
metis_control() [0x4049e9]
Aborted (core dumped)

---

From: <[email-masked]>
Date: Tue, 15 Mar 2016 16:49:12 +0000

Achute,

There have been others who have run into similar issues with Metis and UDP, Athena doesn’t appear to have a problem configuring UDP. We’ve been in the process of transitioning users from Metis to Athena recently (https://github.com/PARC/Athena) and there should be a users guide pushed shortly, in the mean time example scripts are in the distribution that may be of assistance (https://github.com/PARC/Athena/tree/master/ccnx/forwarder/athena/command-line/scripts).

Kev

On Mar 15, 2016, at 4:10 AM, achute sharma <[email-masked]<mailto:[email-masked]>> wrote:

Hi ,

in metis_daemon:

in Metis_control :

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg