Subject: [icnrg] the difference among data, content and information

From: "Xuan Liu " <[email-masked]>
Date: Mon, 30 May 2016 15:50:43 +0800

Dear colleague,

What is the difference among data, content and information in the context of networking?

And is there any definite authoritative interpretation on the issue?

Regards,
Xuan Liu(刘旋)
Future Network Research Center, Southeast University

---

From: <[email-masked]>
Date: Mon, 30 May 2016 16:39:54 +0000

You could look at the paper “From Data to Wisdom” by Russell Ackoff (1989 I think).  This paper also answers that question: Bellinger, Gene, Durval Castro, and Anthony Mills. "Data, information, knowledge, and wisdom." (2004).

In a nutshell:

-          Data is just symbols (numbers).

-          Information is answers to questions (based on the data) such as who, what, where, when.  It puts the data in context.

-          Knowledge (sometimes called Intelligence) is the ability to reason on information.  Sometimes it is put as answering “how.”

-          Understanding is the answer to “why.”  It is the ability to reason on knowledge.

As you posted this question to the ICNRG, maybe it is worth putting this in the context of networking.

In CCNx, we have “Content Objects” that have a “Payload” field.  In NDN, we have a “Data” packet with a “Content” field (equivalent to the Payload field in CCNx).

All of these things are “data” in the above definition, and the Interest, Content Object, and Data packets, with TLV structure, provide easy to parse Information (in the above definition).  The Payload fields are opaque to the network and one would need application context to derive information from them, or understand one of the special PayloadType (ConentType) types.

Typically, in ICN, we are interested in using Information (the context of a packet) to make forwarding decisions for that packet.  For efficiency reasons, as it may be done at many hops, we want this to be explicitly expressed in a packet field rather than inferred from application payload.

There are other techniques in attribute based networking (e.g. CBN) to use general attributes, like a list of keywords, and perform some sort or predicate match (perhaps defined in a subscription) or a best match on the attributes.

Marc

From: icnrg <[email-masked]> on behalf of Xuan Liu <[email-masked]>
Date: Monday, May 30, 2016 at 12:50 AM
To: "[email-masked]" <[email-masked]>
Subject: [icnrg] the difference among data, content and information

Dear colleague,

________________________________
Regards,
Xuan Liu(刘旋)
Future Network Research Center, Southeast University