Subject: [icnrg] ICN BOF not approved

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 13 Jun 2016 09:09:24 +0000

Hi,

you may have sen on https://trac.tools.ietf.org/bof/trac/wiki/WikiStart#Transport that the IESG decided that this proposal is not considered ready for an IETF BOF at this time. Several issues were raised, and the consensus was that the the ICNRG - from where the proposal originated - should spend some of their Berlin agenda time on discussing it.

Here is my *personal* opinion on some of the kinds of answers that could be helpful to the IESG to consider such a BOF request in the future:

* whether CCNX has the backing to be put forward as the ICNRG consensus technology in this space for IETF adoption (c.f., the bundle protocol recently moving from the DTNRG to the DTN WG)

* whether sufficient real-world experience has been gathered and documented to make the case for CCNX in the IETF (e.g., operations/management, but also architectural integration with the rest of the Internet architecture)

* whether the security characteristics of CCNX are adequate (and adequately understood) for IETF standardization

* whether the originators of CCNX are comfortable with giving up change control to the IETF, and whether the IPR licensing for against CCNX is congruent with typical IETF standards

Lars

---

From: Dirk Kutscher <[email-masked]>
Date: Mon, 13 Jun 2016 09:58:01 +0000

Hi,

Thanks for sharing this, Lars. These are fair questions that seem worth clarifying.

If anyone has additional comments or issues they'd like to share, please let us (ICNRG) know. Or, feel free to send your input to ICNRG chairs, so that we can prepare a discussion with the proponents and the community.

--
Best regards,
Dirk

> Am 13.06.2016 um 11:11 schrieb Eggert, Lars <[email-masked]>:
> 
> Hi,
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 13 Jun 2016 07:52:16 -0500

Hi, Lars,

On Mon, Jun 13, 2016 at 4:58 AM, Dirk Kutscher <[email-masked]>
wrote:

> If anyone has additional comments or issues they'd like to share, please
> let us (ICNRG) know. Or, feel free to send your input to ICNRG chairs, so
> that we can prepare a discussion with the proponents and the community.
>
> --
> Best regards,
> Dirk
>
>
>
> > you may have sen on
> https://trac.tools.ietf.org/bof/trac/wiki/WikiStart#Transport that the
> IESG decided that this proposal is not considered ready for an IETF BOF at
> this time. Several issues were raised, and the consensus was that the the
> ICNRG - from where the proposal originated - should spend some of their
> Berlin agenda time on discussing it.
> >
> > Here is my *personal* opinion on some of the kinds of answers that could
> be helpful to the IESG to consider such a BOF request in the future:
> >
> > * whether CCNX has the backing to be put forward as the ICNRG consensus
> technology in this space for IETF adoption (c.f., the bundle protocol
> recently moving from the DTNRG to the DTN WG)
> >
> > * whether sufficient real-world experience has been gathered and
> documented to make the case for CCNX in the IETF (e.g.,
> operations/management, but also architectural integration with the rest of
> the Internet architecture)
> >
> > * whether the security characteristics of CCNX are adequate (and
> adequately understood) for IETF standardization
> >
> > * whether the originators of CCNX are comfortable with giving up change
> control to the IETF, and whether the IPR licensing for against CCNX is
> congruent with typical IETF standards
> >
> > Lars
>

That's a good summary of the questions that came up - thank you for sending
it.

I'd only add one other thing - the IESG and IAB noted that there was
discussion about the proposed charter on the ICNRG mailing list, which was
good, but this would not have been visible to most IETF participants, who
would be expected to provide feedback on whether a charter request is ready
for approval as a working group.

At some point in time, it would be helpful to request a new IETF mailing
list for charter discussion, and to announce the creation of that mailing
list at appropriate places in the IETF. When that point in time arrives,
I'd be happy to approve creation of the mailing list, and the procedure for
that is at http://www.ietf.org/list/nonwg.html.

I'll be in Berlin, and am happy to chat with people on anything I can help
with.

Thanks, and best wishes for work on this topic.

Spencer, as AD for this BOF request

---

From: "Dave Oran (oran)" <[email-masked]>
Date: Mon, 13 Jun 2016 13:14:11 +0000

See below…

> On Jun 13, 2016, at 8:52 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Hi, Lars,
> 
> On Mon, Jun 13, 2016 at 4:58 AM, Dirk Kutscher <[email-masked]>wrote:
> Hi,
> 
[snip]
> 
> I'd only add one other thing - the IESG and IAB noted that there was discussion about the proposed charter on the ICNRG mailing list, which was good, but this would not have been visible to most IETF participants, who would be expected to provide feedback on whether a charter request is ready for approval as a working group. 
> 
> At some point in time, it would be helpful to request a new IETF mailing list for charter discussion, and to announce the creation of that mailing list at appropriate places in the IETF. When that point in time arrives, I'd be happy to approve creation of the mailing list, and the procedure for that is at http://www.ietf.org/list/nonwg.html.
> 
This is clearly the right thing to do, once a decision is made to try for a WG. Before that time, it fragments the discussions and makes it harder for people to concentrate on the (substantial) research and protocol design work that is the main focus of ICNRG.

> I'll be in Berlin, and am happy to chat with people on anything I can help with.
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 13 Jun 2016 08:20:08 -0500

Hi, Dave,

On Mon, Jun 13, 2016 at 8:14 AM, Dave Oran (oran) <[email-masked]> wrote:

> > On Mon, Jun 13, 2016 at 4:58 AM, Dirk Kutscher <[email-masked]
> >wrote:
> > Hi,
> >
> This is clearly the right thing to do, once a decision is made to try for
> a WG. Before that time, it fragments the discussions and makes it harder
> for people to concentrate on the (substantial) research and protocol design
> work that is the main focus of ICNRG.

Yes, exactly. The point in time to request an IETF mailing list has
probably not arrived yet :-)

Spencer

---

From: "Z.W. Yan" <[email-masked]>
Date: Tue, 14 Jun 2016 09:45:02 +0800

Hi, all,
Then we should make ICN go out from the lab further:
1) implement it in more application scenarios and test its efficiency.
2) design the co-existence architecture of ICN and TCP/IP.

Zhiwei Yan

2016-06-14 

发件人： Eggert, Lars 
发送时间： 2016-06-13  17:11:27 
收件人： [email-masked] 
抄送： IAB IAB; [email-masked]; Internet ResearchSteering Group 
主题： [icnrg] ICN BOF not approved 
 
Hi,
you may have sen on https://trac.tools.ietf.org/bof/trac/wiki/WikiStart#Transport that the IESG decided that this proposal is not considered ready for an IETF BOF at this time. Several issues were raised, and the consensus was that the the ICNRG - from where the proposal originated - should spend some of their Berlin agenda time on discussing it.
Here is my *personal* opinion on some of the kinds of answers that could be helpful to the IESG to consider such a BOF request in the future:
* whether CCNX has the backing to be put forward as the ICNRG consensus technology in this space for IETF adoption (c.f., the bundle protocol recently moving from the DTNRG to the DTN WG)
* whether sufficient real-world experience has been gathered and documented to make the case for CCNX in the IETF (e.g., operations/management, but also architectural integration with the rest of the Internet architecture)
* whether the security characteristics of CCNX are adequate (and adequately understood) for IETF standardization
* whether the originators of CCNX are comfortable with giving up change control to the IETF, and whether the IPR licensing for against CCNX is congruent with typical IETF standards
Lars
_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Trossen, Dirk" <[email-masked]>
Date: Tue, 14 Jun 2016 07:48:53 +0000

All,

The evolutionary story of ICN’s coexistence with the current IP-based Internet is something we proposed last year as a ‘migration’ draft. This might be the point of taking this up within the ICNRG.

As this note, the meeting slot I requested on providing an update of the EU-funded POINT efforts represent one such evolutionary story by allowing for IP-based services to run over an ICN-based network (which in turn might run on top of an SDN transport network). More of this will come in the interims meeting of the ICNRG but I mention this here due to the context of the ‘operational’ and ‘evolutionary’ discussion.

Best,

Dirk

From: icnrg [mailto:[email-masked]] On Behalf Of Z.W. Yan
Sent: 14 June 2016 02:45
To: [email-masked]; [email-masked]
Cc: IAB IAB <[email-masked]>; [email-masked]; Internet ResearchSteering Group <[email-masked]>
Subject: Re: [icnrg] ICN BOF not approved

Hi, all,

Zhiwei Yan

2016-06-14
________________________________
发件人： Eggert, Lars
发送时间： 2016-06-13  17:11:27
收件人： [email-masked]<mailto:[email-masked]>
抄送： IAB IAB; [email-masked]<mailto:[email-masked]>; Internet ResearchSteering Group
主题： [icnrg] ICN BOF not approved
Hi,
you may have sen on https://trac.tools.ietf.org/bof/trac/wiki/WikiStart#Transport that the IESG decided that this proposal is not considered ready for an IETF BOF at this time. Several issues were raised, and the consensus was that the the ICNRG - from where the proposal originated - should spend some of their Berlin agenda time on discussing it.
Here is my *personal* opinion on some of the kinds of answers that could be helpful to the IESG to consider such a BOF request in the future:
* whether CCNX has the backing to be put forward as the ICNRG consensus technology in this space for IETF adoption (c.f., the bundle protocol recently moving from the DTNRG to the DTN WG)
* whether sufficient real-world experience has been gathered and documented to make the case for CCNX in the IETF (e.g., operations/management, but also architectural integration with the rest of the Internet architecture)
* whether the security characteristics of CCNX are adequate (and adequately understood) for IETF standardization
* whether the originators of CCNX are comfortable with giving up change control to the IETF, and whether the IPR licensing for against CCNX is congruent with typical IETF standards
Lars
_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg