Subject: [icnrg] Duplicate Content Sharing

From: Boubakr NOUR <[email-masked]>
Date: Wed, 8 Mar 2017 14:57:23 +0800

Hello,

I’d like to know how ICN network can treat the same shared content with 
different names.
Assuming that I’m sharing a document or a video with name *X*, the 
_*same *__*content *_can be shared in someplace by someone else using 
another name Y, and so on.
How can ICN treat this case!

Best regards,

-- 
Boubakr NOUR (Ph.D Candidate)
School of Computer Science
Beijing Institute of Technology

---

From: "Z.W. Yan" <[email-masked]>
Date: Wed, 8 Mar 2017 16:12:17 +0800

Hi, 
As in the current Internet, the content is identified by its specific name.
Then different names will be treated as different content.
That is the reason we use the hierarchical naming scheme in ICN/NDN as DNS works today.

2017-03-08 

Z.W. Yan @ CNNIC

发件人： Boubakr NOUR 
发送时间： 2017-03-08  14:57:47 
收件人： icnrg 
抄送： 
主题： [icnrg] Duplicate Content Sharing 
 
Hello,
I’d like to know how ICN network can treat the same shared content with different names.
Assuming that I’m sharing a document or a video with name X, the same content can be shared in someplace by someone else using another name Y, and so on.
How can ICN treat this case!
Best regards,
-- 
Boubakr NOUR (Ph.D Candidate)
School of Computer Science
Beijing Institute of Technology

---

From: Syed Hassan Ahmed <[email-masked]>
Date: Wed, 8 Mar 2017 17:27:29 +0900

Dear Boubakr Nour,

Thanks for your question. I have had a similar query on a different mailing
list. I am attaching a link to it.

​
http://www.lists.cs.ucla.edu/pipermail/ndn-interest/2016-July/001190.html

This issue is still there and we are looking forward to having some
sophisticated name resolution scheme. Having similar content under two
different names will lead the consumer to generate two Interest packets.

Best Regards,
Syed Hassan Ahmed,
Kyungpook National University,
Daegu, Republic of Korea.
https://sites.google.com/site/shahmedknu/

On Wed, Mar 8, 2017 at 5:12 PM, Z.W. Yan <[email-masked]> wrote:

> ------------------------------
> Z.W. Yan @ CNNIC
> ------------------------------
> *发件人：* Boubakr NOUR
> *发送时间：* 2017-03-08  14:57:47
> *收件人：* icnrg
> *抄送：*
> *主题：* [icnrg] Duplicate Content Sharing
>
> Hello,
>
> Assuming that I’m sharing a document or a video with name *X*, the *same **content
> *can be shared in someplace by someone else using another name Y, and so
> on.
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>
>