Subject: [icnrg] FW: New Version Notification for draft-wissingh-icnrg-terminology-01.txt

From: "Wissingh, B.F. (Bastiaan)" <[email-masked]>
Date: Mon, 20 Mar 2017 11:05:12 +0000

Hi all,

We’ve uploaded a new version of the draft regarding ICN Terminology in which we’ve been addressing comments we received on the first version of the draft, so please have a look at the document. See details below.

Best,
Bastiaan

Op 13-03-17 22:09 heeft [email-masked] <[email-masked]> geschreven:

    A new version of I-D, draft-wissingh-icnrg-terminology-01.txt
    has been successfully submitted by Bastiaan Wissingh and posted to the
    IETF repository.
    
    Name:		draft-wissingh-icnrg-terminology
    Revision:	01
    Title:		Information-Centric Networking (ICN): Terminology
    Document date:	2017-03-13
    Group:		Individual Submission
    Pages:		15
    URL:            https://www.ietf.org/internet-drafts/draft-wissingh-icnrg-terminology-01.txt
    Status:         https://datatracker.ietf.org/doc/draft-wissingh-icnrg-terminology/
    Htmlized:       https://tools.ietf.org/html/draft-wissingh-icnrg-terminology-01
    Diff:           https://www.ietf.org/rfcdiff?url2=draft-wissingh-icnrg-terminology-01
    
    Abstract:
       Information Centric Networking (ICN) is a new paradigm where network
       communications are accomplished by requesting named content, instead
       of sending packets to destination addresses.  Named Data Networking
       (NDN) and Content-Centric Networking (CCN) are two prominent ICN
       architectures.  This document provides an overview of the terminology
       and definitions that have been used in describing concepts in these
       two projects.  While there are other ICN architectures, they are not
       part of the NDN and CCN vision and as such are out of scope for this
       document.

    
    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.
    
    The IETF Secretariat

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: Boubakr NOUR <[email-masked]>
Date: Wed, 22 Mar 2017 10:49:23 +0800

Hello,

In the following draft (Information-Centric Networking (ICN): 
Terminology), I found the following paragraph, I am confusing about the 
*Name-Content binding phase*.

“In ICN, verification of a data packet’s name-to-content binding is 
achieved through /cryptographic means/, either by (1) a /cryptographic 
signature /that explicitely binds an application-chosen name to a data 
packet’s content, or (2) relying on an implicit name (cryptographic hash 
of the data packet) that the data consumer obtained through other means.”

Is this means that the same content with different names should have the 
same signature or hash. Is the cryptographic signature/hash applied only 
on content without taking in consideration other parameters such us: 
name itself, owner of content, timestamps…?

Best regards,

On 3/20/2017 7:05 PM, Wissingh, B.F. (Bastiaan) wrote:
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

-- 
Boubakr NOUR (Ph.D Candidate)
School of Computer Science
Beijing Institute of Technology

---

From: [email-masked]
Date: Wed, 22 Mar 2017 07:06:08 +0100 (CET)

On Wed, 22 Mar 2017, Boubakr NOUR wrote:

> In the following draft (Information-Centric Networking (ICN): Terminology), I found the
> following paragraph, I am confusing about the Name-Content binding phase.
> 
> “In ICN, verification of a data packet’s name-to-content binding is achieved through
> cryptographic means, either by (1) a cryptographic signature that explicitely binds an
> application-chosen name to a data packet’s content, or (2) relying on an implicit name
> (cryptographic hash of the data packet) that the data consumer obtained through other means.”
> 
> Is this means that the same content with different names should have the same signature or
> hash. Is the cryptographic signature/hash applied only on content without taking in
> consideration other parameters such us: name itself, owner of content, timestamps…?

No: as soon as one element changes, so will the signature as well as the 
packet's implicit name because both cover the whole packet.

But this is ok: what remains a constant in this picture of moving parts 
is the trust model, for example the key used to sign the packet; or the 
trust in the source from where the hash value of the packet was obtained 
(an example source could be a manifest, which would be signed).

best, christian

> We’ve uploaded a new version of the draft regarding ICN Terminology in which we’ve been address
> ing comments we received on the first version of the draft, so please have a look at the docume
> nt. See details below.
> 
> Best,
> Bastiaan
> 
> This message may contain information that is not intended for you. If you are not the addressee
>  or if this message was sent to you by mistake, you are requested to inform the sender and dele
> te the message. TNO accepts no liability for the content of this e-mail, for the manner in whic
> h you use it and for damage of any kind resulting from the risks inherent to the electronic tra
> nsmission of messages.