Subject: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

From: Börje Ohlman <[email-masked]>
Date: Fri, 15 Dec 2017 12:08:02 +0000

Hi all,

After the discussion we had on this draft in Singapore the ICNRG Chairs would like ask for additional comments from the mailing list on adopting this draft as an RG document. Please  let us know your support for this or if you have some concerns.

ICN Research Group                                        Prakash Suthar
Internet-Draft                                              Milan Stolic
Intended status: Informational                               Anil Jangam
                                                           Cisco Systems
                                                            Dirk Trossen
                                                       InterDigital Inc.
Expires: May 16, 2018                                  November 12, 2017

          Native Deployment of ICN in LTE, 4G Mobile Networks
                    draft-suthar-icnrg-icn-lte-4g-04

Abstract

   LTE, 4G mobile networks use IP based transport for control plane to
   establish the data session and user plane for actual data delivery.
   In existing architecture, IP transport used in user plane is not
   optimized for data transport, which leads to an inefficient data
   delivery. IP unicast routing from server to clients is used for
   delivery of multimedia content to User Equipment (UE), where each
   user gets a separate stream. From bandwidth and routing perspective
   this approach is inefficient. Multicast and broadcast technologies
   have emerged recently for mobile networks, but their deployments are
   very limited or at an experimental stage due to complex architecture
   and radio spectrum issues. ICN is a rapidly emerging technology with
   built-in features for efficient multimedia data delivery, however
   majority of the work is focused on fixed networks. The main focus of
   this draft is on native deployment of ICN in cellular mobile networks
   by using ICN in 3GPP protocol stack. ICN has an inherent capability
   for multicast, anchorless mobility, security and it is optimized for
   data delivery using local caching at the edge. The native ICN (it
   runs directly on cellular layer 2 protocols like PDCP/RLC/MAC/L1) or
   dual stack (along with IP) deployment will bring all inherent
   benefits and help in optimizing mobile networks.

From the chairs’s perspective, this draft has seen some review in the group, and the general feedback suggests that this is useful work.

It’s not ready for publication of course, but turning it into an RG document means that we as a group can work together on the important topic of how ICN can be deployed in LTE, 4G Mobile Networks.

Thanks,
            Börje, Dave, Dirk

---

From: "Rahman, Akbar" <[email-masked]>
Date: Fri, 15 Dec 2017 13:45:15 +0000

I support WG adoption.  I think it is a valuable document that opens up opportunities to deploy ICN in the existing large-scale 4G cellular infrastructure.

From: icnrg [mailto:[email-masked]] On Behalf Of Börje Ohlman
Sent: Friday, December 15, 2017 7:08 AM
To: icnrg <[email-masked]>
Subject: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

Hi all,

                                                           Cisco Systems

                                                            Dirk Trossen

                                                       InterDigital Inc.

Abstract

Thanks,
            Börje, Dave, Dirk

[Banner]<http://www.interdigital.com>
[Banner]<http://ir.interdigital.com/File/Index?KeyFile=37447876>
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Fri, 15 Dec 2017 11:50:46 -0200

Support +1

On Fri, Dec 15, 2017 at 11:45 AM, Rahman, Akbar <
[email-masked]> wrote:

> I support WG adoption.  I think it is a valuable document that opens up
> opportunities to deploy ICN in the existing large-scale 4G cellular
> infrastructure.
>
>
>
> *From:* icnrg [mailto:[email-masked]] *On Behalf Of *Börje Ohlman
> *Sent:* Friday, December 15, 2017 7:08 AM
> *To:* icnrg <[email-masked]>
> *Subject:* [icnrg] RG adoption of the draft: Native Deployment of ICN in
> LTE, 4G Mobile Networks
>
>
>
> Hi all,
>
> After the discussion we had on this draft in Singapore the ICNRG Chairs
> would like ask for additional comments from the mailing list on adopting
> this draft as an RG document. Please  let us know your support for this or
> if you have some concerns.
>
>
>
>
>
> From the chairs’s perspective, this draft has seen some review in the
> group, and the general feedback suggests that this is useful work.
>
> It’s not ready for publication of course, but turning it into an RG
> document means that we as a group can work together on the important topic
> of how ICN can be deployed in LTE, 4G Mobile Networks.
>
> Thanks,
>             Börje, Dave, Dirk
>
>  <http://www.interdigital.com>
>  <http://ir.interdigital.com/File/Index?KeyFile=37447876>
>
> This e-mail is intended only for the use of the individual or entity to
> which it is addressed, and may contain information that is privileged,
> confidential and/or otherwise protected from disclosure to anyone other
> than its intended recipient. Unintended transmission shall not constitute
> waiver of any privilege or confidentiality obligation. If you received this
> communication in error, please do not review, copy or distribute it, notify
> me immediately by email, and delete the original message and any
> attachments. Unless expressly stated in this e-mail, nothing in this
> message or any attachment should be construed as a digital or electronic
> signature.
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>
>

---

From: "Trossen, Dirk" <[email-masked]>
Date: Fri, 15 Dec 2017 15:34:19 +0000

+1 for adoption!

From: icnrg [mailto:[email-masked]] On Behalf Of Rahman, Akbar
Sent: 15 December 2017 13:45
To: Börje Ohlman <[email-masked]>; icnrg <[email-masked]>
Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

From: icnrg [mailto:[email-masked]] On Behalf Of Börje Ohlman
Sent: Friday, December 15, 2017 7:08 AM
To: icnrg <[email-masked]<mailto:[email-masked]>>
Subject: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

Hi all,

                                                           Cisco Systems

                                                            Dirk Trossen

                                                       InterDigital Inc.

Abstract

Thanks,
            Börje, Dave, Dirk

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Sun, 17 Dec 2017 14:07:09 +0100

Support +1

On Fri, 2017-12-15 at 11:50 -0200, Christian Esteve Rothenberg wrote:
> Support +1
> 
> On Fri, Dec 15, 2017 at 11:45 AM, Rahman, Akbar <Akbar.Rahman@interdi
> gital.com> wrote:
> > I support WG adoption.  I think it is a valuable document that
> > opens up opportunities to deploy ICN in the existing large-scale 4G
> > cellular infrastructure.
> >  
> > After the discussion we had on this draft in Singapore the ICNRG
> > Chairs would like ask for additional comments from the mailing list
> > on adopting this draft as an RG document. Please  let us know your
> > support for this or if you have some concerns.
> >  
> >  
> >                                                            Cisco
> > Systems
> >                                                             Dirk
> > Trossen
> >                                                        InterDigital
> > Inc.
> > >From the chairs’s perspective, this draft has seen some review in
> > the group, and the general feedback suggests that this is useful
> > work.
> > 
> > document means that we as a group can work together on the
> > important topic of how ICN can be deployed in LTE, 4G Mobile
> > Networks.
> > 
> > Thanks,
> >             Börje, Dave, Dirk
> > 
> > 
> >  
> >  
> >  This e-mail is intended only for the use of the individual or
> > entity to which it is addressed, and may contain information that
> > is privileged, confidential and/or otherwise protected from
> > disclosure to anyone other than its intended recipient. Unintended
> > transmission shall not constitute waiver of any privilege or
> > confidentiality obligation. If you received this communication in
> > error, please do not review, copy or distribute it, notify me
> > immediately by email, and delete the original message and any
> > attachments. Unless expressly stated in this e-mail, nothing in
> > this message or any attachment should be construed as a digital or
> > electronic signature.

---

From: Jungha Hong <[email-masked]>
Date: Mon, 18 Dec 2017 03:00:52 +0000

I also support adoption.

Thanks,

Jungha Hong

________________________________
보낸 사람 : "Carlos Jesús Bernardos Cano" <[email-masked]>
보낸 날짜 : 2017-12-17 22:07:28 ( +09:00 )
받는 사람 : Christian Esteve Rothenberg <[email-masked]>, Rahman, Akbar <[email-masked]>
참조 : Börje Ohlman <[email-masked]>, icnrg <[email-masked]>
제목 : Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

Support +1

> On Fri, Dec 15, 2017 at 11:45 AM, Rahman, Akbar

> > From: icnrg [mailto:[email-masked]] On Behalf Of Börje

> > Ohlman

> > To: icnrg

> > Subject: [icnrg] RG adoption of the draft: Native Deployment of ICN

> > in LTE, 4G Mobile Networks

> > ICN Research Group Prakash

> > Suthar

> > Internet-Draft Milan

> > Stolic

> > Intended status: Informational Anil

> > Jangam

> > Expires: May 16, 2018 November 12,

> > 2017

> > LTE, 4G mobile networks use IP based transport for control plane

> > to

> > establish the data session and user plane for actual data

> > delivery.

> > delivery of multimedia content to User Equipment (UE), where

> > each

> > user gets a separate stream. From bandwidth and routing

> > perspective

> > this approach is inefficient. Multicast and broadcast

> > technologies

> > have emerged recently for mobile networks, but their deployments

> > are

> > very limited or at an experimental stage due to complex

> > architecture

> > and radio spectrum issues. ICN is a rapidly emerging technology

> > with

> > built-in features for efficient multimedia data delivery,

> > however

> > majority of the work is focused on fixed networks. The main

> > focus of

> > this draft is on native deployment of ICN in cellular mobile

> > networks

> > by using ICN in 3GPP protocol stack. ICN has an inherent

> > capability

> > for multicast, anchorless mobility, security and it is optimized

> > for

> > data delivery using local caching at the edge. The native ICN

> > (it

> > runs directly on cellular layer 2 protocols like

> > PDCP/RLC/MAC/L1) or

icnrg mailing list

[email-masked]

---

From: Hitoshi Asaeda <[email-masked]>
Date: Mon, 18 Dec 2017 20:52:20 +0900

I support adoption.

Best,

Hitoshi

> 2017/12/15 21:08, Börje Ohlman <[email-masked]> wrote:
> 
> Hi all,
>

---

From: Daniel Corujo <[email-masked]>
Date: Mon, 18 Dec 2017 12:00:56 +0000

Dear all,

+1 support.

Best regards,

Daniel Corujo
Instituto de Telecomunicações - Pólo de Aveiro
http://www.it.pt

Watch our VIDEO: https://youtu.be/lI8DnmBnEtU
Internet Technology Letters Journal is accepting publications: http://onlinelibrary.wiley.com/journal/10.1002/(ISSN)2476-1508

> On 18 Dec 2017, at 11:52, Hitoshi Asaeda <[email-masked]> wrote:
> 
> I support adoption.
> 
> Best,
> 
> Hitoshi
> 
>

---

From: Cedric Westphal <[email-masked]>
Date: Mon, 18 Dec 2017 20:48:50 +0000

+1

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Carlos Jesús Bernardos Cano
Sent: Sunday, December 17, 2017 5:07 AM
To: Christian Esteve Rothenberg; Rahman, Akbar
Cc: Börje Ohlman; icnrg
Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

Support +1

---

From: Greg White <[email-masked]>
Date: Tue, 19 Dec 2017 18:35:53 +0000

I support adoption as well.

-Greg

On 12/18/17, 1:48 PM, "icnrg on behalf of Cedric Westphal" <[email-masked] on behalf of [email-masked]> wrote:

    +1
    
    -----Original Message-----
    From: icnrg [mailto:[email-masked]] On Behalf Of Carlos Jesús Bernardos Cano
    Sent: Sunday, December 17, 2017 5:07 AM
    To: Christian Esteve Rothenberg; Rahman, Akbar
    Cc: Börje Ohlman; icnrg
    Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks
    
    Support +1

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 19 Dec 2017 14:18:07 -0500

+1
> On Dec 19, 2017, at 1:35 PM, Greg White <[email-masked]> wrote:
>

---

From: <[email-masked]>
Date: Wed, 20 Dec 2017 09:34:12 +0000

Definitely a very good idea. If adopted we are willing to contribute our 4G (including 5G under development) core network infrastructure at University of Surrey for validation/evaluation purpose.

Regards,

Ning

________________________________
From: icnrg <[email-masked]> on behalf of Greg White <[email-masked]>
Sent: Tuesday, December 19, 2017 6:35 PM
To: icnrg
Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

-Greg

    +1

    -----Original Message-----
    From: icnrg [mailto:[email-masked]] On Behalf Of Carlos Jesús Bernardos Cano
    Sent: Sunday, December 17, 2017 5:07 AM
    To: Christian Esteve Rothenberg; Rahman, Akbar
    Cc: Börje Ohlman; icnrg
    Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

    Support +1

---

From: Ravi Ravindran <[email-masked]>
Date: Thu, 21 Dec 2017 05:07:15 +0000

While we look at ICN enablement in more mature LTE, we also have the following draft exploring the opportunity in the emerging 5GC architecture, https://tools.ietf.org/html/draft-ravi-icnrg-5gc-icn-00 , where we welcome contributions from researchers exploring this space.

Regards,
Ravi

From: icnrg [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, December 20, 2017 1:34 AM
To: [email-masked]; [email-masked]
Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

Regards,

Ning

________________________________
From: icnrg <[email-masked]<mailto:[email-masked]>> on behalf of Greg White <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, December 19, 2017 6:35 PM
To: icnrg
Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

-Greg

On 12/18/17, 1:48 PM, "icnrg on behalf of Cedric Westphal" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:

    +1

    -----Original Message-----
    From: icnrg [mailto:[email-masked]] On Behalf Of Carlos Jesús Bernardos Cano
    Sent: Sunday, December 17, 2017 5:07 AM
    To: Christian Esteve Rothenberg; Rahman, Akbar
    Cc: Börje Ohlman; icnrg
    Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

    Support +1

    <mailto:Akbar.Rahman@interdi%0b   %20> > gital.com> wrote:
    > > >From the chairs's perspective, this draft has seen some review in
    > > It's not ready for publication of course, but turning it into an RG
    > > [email-masked]<mailto:[email-masked]>
    > [email-masked]<mailto:[email-masked]>

    _______________________________________________
    icnrg mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.irtf.org/mailman/listinfo/icnrg
    _______________________________________________
    icnrg mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.irtf.org/mailman/listinfo/icnrg

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Trossen, Dirk" <[email-masked]>
Date: Thu, 21 Dec 2017 09:01:39 +0000

Ravi,

would considerations around a dual-stack nature (with convergence layer to support IP over ICN applications) make sense similar to the ongoing 4GLTE draft? If so, I'd be happy to contribute to such new section.

Best,

Dirk

________________________________
From: icnrg <[email-masked]> on behalf of Ravi Ravindran <[email-masked]>
Sent: 21 December 2017 5:07 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

Regards,

Ravi

Regards,

Ning

-Greg

    +1

    -----Original Message-----
    From: icnrg [mailto:[email-masked]] On Behalf Of Carlos Jesús Bernardos Cano
    Sent: Sunday, December 17, 2017 5:07 AM
    To: Christian Esteve Rothenberg; Rahman, Akbar
    Cc: Börje Ohlman; icnrg
    Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

    Support +1

---

From: Ravi Ravindran <[email-masked]>
Date: Thu, 21 Dec 2017 12:04:17 +0000

Sure Dirk, we do touch upon discussion on the UE side dual stack or using the unstructured PDU provision, but we could elaborate further on these design choices. I'll get in touch with you offline to discuss this.

Regards,
Ravi

From: Trossen, Dirk [mailto:[email-masked]]
Sent: Thursday, December 21, 2017 1:02 AM
To: Ravi Ravindran <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

Ravi,

Best,

Dirk
________________________________
From: icnrg <[email-masked]<mailto:[email-masked]>> on behalf of Ravi Ravindran <[email-masked]<mailto:[email-masked]>>
Sent: 21 December 2017 5:07 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

Regards,

Ravi

From: icnrg [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Wednesday, December 20, 2017 1:34 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

Regards,

Ning

-Greg

    +1

    -----Original Message-----
    From: icnrg [mailto:[email-masked]] On Behalf Of Carlos Jesús Bernardos Cano
    Sent: Sunday, December 17, 2017 5:07 AM
    To: Christian Esteve Rothenberg; Rahman, Akbar
    Cc: Börje Ohlman; icnrg
    Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

    Support +1

---

From: "David Oran" <[email-masked]>
Date: Fri, 22 Dec 2017 10:58:56 -0500

The ICNRG community has given strong support on the mailing list for adoption of https://datatracker.ietf.org/doc/draft-suthar-icnrg-icn-lte-4g/ as a Research Group work item. The chairs therefore declare this draft adopted.

During the poll, the following comment was received:

- Ning Wang proposed “we are willing to contribute our 4G (including 5G under development) core network infrastructure at University of Surrey for validation/evaluation purpose.”

We hope this can be addressed as the draft progresses.

**Authors:**

*Please re-issue the draft as “draft-irtf-icnrg-icn-lte-4g” at your earliest convenience.*

Congratulations on the support for this work and the chairs look forward to progressing this further toward approval for publication as an Informational RFC.

Börje, Dave, and Dirk.

---

From: Anil Jangam <[email-masked]>
Date: Fri, 22 Dec 2017 08:34:36 -0800

Thank you Dave!

Thank you everyone for the support and voting for the draft.

We will submit a revised version of draft and share it at the earliest.

/anil.

On Dec 22, 2017 7:59 AM, "David Oran" <[email-masked]> wrote:

> The ICNRG community has given strong support on the mailing list for
> adoption of https://datatracker.ietf.org/doc/draft-suthar-icnrg-icn-
> lte-4g/ as a Research Group work item. The chairs therefore declare this
> draft adopted.
>
>    - Ning Wang proposed “we are willing to contribute our 4G (including
>    5G under development) core network infrastructure at University of Surrey
>    for validation/evaluation purpose.”
>
> *Authors:*
> Congratulations on the support for this work and the chairs look forward
> to progressing this further toward approval for publication as an
> Informational RFC.
>
> Börje, Dave, and Dirk.
>

---

From: <[email-masked]>
Date: Sat, 23 Dec 2017 15:37:23 +0000

Dear David, all:

  Great to see this through. If there is a general interest I can invite colleagues who will attend IETF101 in London to Surrey University to visit our 4G/5G core network. Our campus is 40 minutes by train from London.

Regards,

Ning

________________________________
From: icnrg <[email-masked]> on behalf of David Oran <[email-masked]>
Sent: Friday, December 22, 2017 3:58 PM
To: icnrg
Subject: Re: [icnrg] RG adoption of the draft: Native Deployment of ICN in LTE, 4G Mobile Networks

  *   Ning Wang proposed “we are willing to contribute our 4G (including 5G under development) core network infrastructure at University of Surrey for validation/evaluation purpose.”

Authors:

Please re-issue the draft as “draft-irtf-icnrg-icn-lte-4g” at your earliest convenience.

Börje, Dave, and Dirk.