Subject: [Id-event] I-D Action: draft-ietf-secevent-token-13.txt

From: [email-masked]
Date: Wed, 09 May 2018 17:26:18 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Security Events WG of the IETF.

        Title           : Security Event Token (SET)
        Authors         : Phil Hunt
                          Michael B. Jones
                          William Denniss
                          Morteza Ansari
	Filename        : draft-ietf-secevent-token-13.txt
	Pages           : 31
	Date            : 2018-05-09

Abstract:
   This specification defines the Security Event Token (SET) data
   structure.  A SET describes statements of fact from the perspective
   of an issuer about a subject.  These statements of fact represent an
   event that occurred directly to or about a security subject, for
   example, a statement about the issuance or revocation of a token on
   behalf of a subject.  This specification is intended to enable
   representing security- and identity-related events.  A SET is a JSON
   Web Token (JWT), which can be optionally signed and/or encrypted.
   SETs can be distributed via protocols such as HTTP.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-secevent-token/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-secevent-token-13
https://datatracker.ietf.org/doc/html/draft-ietf-secevent-token-13

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-secevent-token-13

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Phil Hunt <[email-masked]>
Date: Wed, 9 May 2018 17:30:25 -0700

Apologies for 2 drafts today. Draft 13 addresses a comment from Martin Vigoureux regarding a non-normative MAY. Thanks to Mike who noticed it on the document status. We wanted to get this nit addressed ahead of tomorrow's telechat.

Regards,

Phil

Oracle Corporation, Identity Cloud Services Architect
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On May 9, 2018, at 5:26 PM, [email-masked] wrote:
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsecevent-2Dtoken_&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=YVELA0RpOT--40Tf54lOELsgAxNO-FqnUrEJlREH7Uw&s=TKCt4s8_UAzD0LKg3XRy1ArveQ4Kz4AF7AUgOFPQOrE&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dsecevent-2Dtoken-2D13&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=YVELA0RpOT--40Tf54lOELsgAxNO-FqnUrEJlREH7Uw&s=uj9ERlh8rz9AmLq1jI3iNDT7idBLijfPqLATbME0rwk&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dsecevent-2Dtoken-2D13&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=YVELA0RpOT--40Tf54lOELsgAxNO-FqnUrEJlREH7Uw&s=tHlycQjNI-NTpHHR5FWN08hbbtLOxF4ikw7QGDdv2BM&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dsecevent-2Dtoken-2D13&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=YVELA0RpOT--40Tf54lOELsgAxNO-FqnUrEJlREH7Uw&s=lnlHG42k_dDatVYguj9I-Tdf-tMTF4kfL_3Wlmw-N3w&e=
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=YVELA0RpOT--40Tf54lOELsgAxNO-FqnUrEJlREH7Uw&s=g2q0nvtYwyVHQ82FuJvjJMHnTmxiKTYIs5qtVYFeYHw&e=
> 
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=YVELA0RpOT--40Tf54lOELsgAxNO-FqnUrEJlREH7Uw&s=Z1U5RerOt4KIpZVUmC1gFkZ1gYDd0cEHIjy4warxMfA&e=

---

From: Mike Jones <[email-masked]>
Date: Thu, 10 May 2018 00:33:59 +0000

Martin, for some reason we hadn't seen your comment until I looked at the IESG status in the datatracker.  The change you suggested has been made and we acknowledged your contribution.

                                                                Thanks again,
                                                                -- Mike and Phil

From: Id-event <[email-masked]> On Behalf Of Phil Hunt
Sent: Wednesday, May 9, 2018 5:30 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Id-event] I-D Action: draft-ietf-secevent-token-13.txt

Regards,

Phil

Oracle Corporation, Identity Cloud Services Architect
@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

On May 9, 2018, at 5:26 PM, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

The IETF datatracker status page for this draft is:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsecevent-2Dtoken_&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=YVELA0RpOT--40Tf54lOELsgAxNO-FqnUrEJlREH7Uw&s=TKCt4s8_UAzD0LKg3XRy1ArveQ4Kz4AF7AUgOFPQOrE&e=<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker..ietf.org_doc_draft-2Dietf-2Dsecevent-2Dtoken_&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=YVELA0RpOT--40Tf54lOELsgAxNO-FqnUrEJlREH7Uw&s=TKCt4s8_UAzD0LKg3XRy1ArveQ4Kz4AF7AUgOFPQOrE&e=>

A diff from the previous version is available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf..org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dsecevent-2Dtoken-2D13&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=YVELA0RpOT--40Tf54lOELsgAxNO-FqnUrEJlREH7Uw&s=lnlHG42k_dDatVYguj9I-Tdf-tMTF4kfL_3Wlmw-N3w&e=

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf..org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=YVELA0RpOT--40Tf54lOELsgAxNO-FqnUrEJlREH7Uw&s=Z1U5RerOt4KIpZVUmC1gFkZ1gYDd0cEHIjy4warxMfA&e=