Subject: [Id-event] WG Last Call for draft-ietf-secevent-http-poll-03 - until Aug. 28

From: Yaron Sheffer <[email-masked]>
Date: Wed, 7 Aug 2019 16:29:11 +0300

This is to announce working group last call on this draft 
(https://datatracker.ietf.org/doc/draft-ietf-secevent-http-poll/).

Please send your comments to the list. Even if you are perfectly happy 
with the draft, please let us know that you support its publication 
as-is by posting to the list.

Because of the summer holidays, this last call is open for 3 weeks, 
until Aug. 28.

Thanks,

     Dick and Yaron

---

From: Mike Jones <[email-masked]>
Date: Thu, 15 Aug 2019 19:52:03 +0000

I support the publication of this draft.

				-- Mike

-----Original Message-----
From: Id-event <[email-masked]> On Behalf Of Yaron Sheffer
Sent: Wednesday, August 7, 2019 6:29 AM
To: SecEvent <[email-masked]>
Subject: [Id-event] WG Last Call for draft-ietf-secevent-http-poll-03 - until Aug. 28

This is to announce working group last call on this draft (https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-secevent-http-poll%2F&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7C21e8c49267744dff8acd08d71b3b4550%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637007813697234665&amp;sdata=GpeOhfKoVYD5I%2F1n9ebDVKV%2F%2Bl0xNp9c%2BRfddOaxUuM%3D&amp;reserved=0).

Thanks,

     Dick and Yaron

_______________________________________________
Id-event mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fid-event&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7C21e8c49267744dff8acd08d71b3b4550%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637007813697234665&amp;sdata=rEcwirRhx4WvVxkdFHEAuoXME58ycYxQWod0tAzlT50%3D&amp;reserved=0

---

From: Adam Dawes <[email-masked]>
Date: Thu, 15 Aug 2019 13:00:12 -0700

On Thu, Aug 15, 2019 at 12:52 PM Mike Jones <Michael.Jones=
[email-masked]> wrote:

> This is to announce working group last call on this draft (
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-secevent-http-poll%2F&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7C21e8c49267744dff8acd08d71b3b4550%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637007813697234665&amp;sdata=GpeOhfKoVYD5I%2F1n9ebDVKV%2F%2Bl0xNp9c%2BRfddOaxUuM%3D&amp;reserved=0
> ).
>
>
> https://www.ietf.org/mailman/listinfo/id-event
>

---

From: Brian Campbell <[email-masked]>
Date: Thu, 15 Aug 2019 14:10:38 -0600

+1

On Thu, Aug 15, 2019 at 2:00 PM Adam Dawes <adawes=
[email-masked]> wrote:

> [email-masked] <[email-masked]>> wrote:
>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Thu, 15 Aug 2019 22:07:35 +0000

I support publishing this draft.

From: Id-event <[email-masked]> on behalf of Brian Campbell <bcampbell=[email-masked]>
Date: Thursday, August 15, 2019 at 1:11 PM
To: Adam Dawes <adawes=[email-masked]>
Cc: Yaron Sheffer <[email-masked]>, Mike Jones <Michael.Jones=[email-masked]>, SecEvent <[email-masked]>
Subject: Re: [Id-event] WG Last Call for draft-ietf-secevent-http-poll-03 - until Aug. 28

+1

On Thu, Aug 15, 2019 at 2:00 PM Adam Dawes <adawes=[email-masked]<mailto:[email-masked]>> wrote:
I support the publication of this draft.

On Thu, Aug 15, 2019 at 12:52 PM Mike Jones <Michael.Jones=[email-masked]<mailto:[email-masked]>> wrote:
I support the publication of this draft.

                                -- Mike

-----Original Message-----
From: Id-event <[email-masked]<mailto:[email-masked]>> On Behalf Of Yaron Sheffer
Sent: Wednesday, August 7, 2019 6:29 AM
To: SecEvent <[email-masked]<mailto:[email-masked]>>
Subject: [Id-event] WG Last Call for draft-ietf-secevent-http-poll-03 - until Aug. 28

Thanks,

     Dick and Yaron

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fid-event&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7C21e8c49267744dff8acd08d71b3b4550%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637007813697234665&amp;sdata=rEcwirRhx4WvVxkdFHEAuoXME58ycYxQWod0tAzlT50%3D&amp;reserved=0
_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event
_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event

CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited..  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 15 Aug 2019 21:46:56 -0700

Thank you all for your support, but please use this opportunity to 
actually review the draft (even if you've read it in the past) and 
provide comments. Even if the draft is very good, it is probably not 
perfect.

Thanks,
	Yaron

On 15/08/2019 15:07, Morteza Ansari (moransar) wrote:
> *From: *Id-event <[email-masked]> on behalf of Brian Campbell 
> <bcampbell=[email-masked]>
> *Date: *Thursday, August 15, 2019 at 1:11 PM
> *To: *Adam Dawes <adawes=[email-masked]>
> *Cc: *Yaron Sheffer <[email-masked]>, Mike Jones 
> <Michael.Jones=[email-masked]>, SecEvent <[email-masked]>
> *Subject: *Re: [Id-event] WG Last Call for 
> draft-ietf-secevent-http-poll-03 - until Aug. 28
> 
> +1
> 
> On Thu, Aug 15, 2019 at 2:00 PM Adam Dawes 
> <adawes=[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     On Thu, Aug 15, 2019 at 12:52 PM Mike Jones
>     <Michael.Jones=[email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>         From: Id-event <[email-masked]
>         <mailto:[email-masked]>> On Behalf Of Yaron Sheffer
>         To: SecEvent <[email-masked] <mailto:[email-masked]>>
>         Subject: [Id-event] WG Last Call for
>         draft-ietf-secevent-http-poll-03 - until Aug. 28
> 
>         (https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-secevent-http-poll%2F&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7C21e8c49267744dff8acd08d71b3b4550%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637007813697234665&amp;sdata=GpeOhfKoVYD5I%2F1n9ebDVKV%2F%2Bl0xNp9c%2BRfddOaxUuM%3D&amp;reserved=0).
> 
> 
>         [email-masked] <mailto:[email-masked]>
>         [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>
> */CONFIDENTIALITY NOTICE: This email may contain confidential and 
> privileged material for the sole use of the intended recipient(s). Any 
> review, use, distribution or disclosure by others is strictly 
> prohibited..  If you have received this communication in error, please 
> notify the sender immediately by e-mail and delete the message and any 
> file attachments from your computer. Thank you./*
>

---

From: Dick Hardt <[email-masked]>
Date: Fri, 23 Aug 2019 11:41:01 -0700

Reminder per Yaron's note below.

On Thu, Aug 15, 2019 at 9:47 PM Yaron Sheffer <[email-masked]> wrote:

> >         (

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Wed, 28 Aug 2019 23:44:27 +0000

On my latest read-through I noticed a couple items that need to be addressed prior to publication:

  1.  The draft currently forbids static Bearer tokens (§4.4.1: “Bearer tokens MUST have a limited lifetime…). There are legitimate use cases for static tokens when dealing with less sophisticated clients/services. I suggest changing the MUST to a SHOULD, or indicating the guidance applies to dynamically generated tokens.

  2.  The draft does not describe error responses from the SET Transmitter, e.g., in response to a malformed poll request. This requires a separate set of error codes, since the existing ones are specific to SET reception/processing errors. Additionally, §2.5 must be amended to allow the SET Transmitter to immediately return an error response even when long polling is requested by the SET Receiver.

--
Annabelle Richard Backman
AWS Identity

From: Id-event <[email-masked]> on behalf of Dick Hardt <[email-masked]>
Date: Friday, August 23, 2019 at 11:41 AM
To: Yaron Sheffer <[email-masked]>
Cc: Adam Dawes <adawes=[email-masked]>, Brian Campbell <bcampbell=[email-masked]>, "Morteza Ansari (moransar)" <[email-masked]>, SecEvent <[email-masked]>, Mike Jones <Michael.Jones=[email-masked]>
Subject: Re: [Id-event] WG Last Call for draft-ietf-secevent-http-poll-03 - until Aug. 28

On Thu, Aug 15, 2019 at 9:47 PM Yaron Sheffer <[email-masked]<mailto:[email-masked]>> wrote:
Thank you all for your support, but please use this opportunity to
actually review the draft (even if you've read it in the past) and
provide comments. Even if the draft is very good, it is probably not
perfect.

Thanks,
        Yaron

On 15/08/2019 15:07, Morteza Ansari (moransar) wrote:
> *From: *Id-event <[email-masked]<mailto:[email-masked]>> on behalf of Brian Campbell
> <bcampbell=[email-masked]<mailto:[email-masked]>>
> *To: *Adam Dawes <adawes=[email-masked]<mailto:[email-masked]>>
> *Cc: *Yaron Sheffer <[email-masked]<mailto:[email-masked]>>, Mike Jones
> <Michael.Jones=[email-masked]<mailto:[email-masked]>>, SecEvent <[email-masked]<mailto:[email-masked]>>
> <adawes=[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>
>     <Michael.Jones=[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:40microsoft..com@dmarc..ietf.org>>> wrote:
>
>         From: Id-event <[email-masked]<mailto:[email-masked]>
>         <mailto:[email-masked]<mailto:[email-masked]>>> On Behalf Of Yaron Sheffer
>         To: SecEvent <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>         Please send your comments to the list.. Even if you are perfectly
>         happy
>         [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>         [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>         https://www.ietf..org/mailman/listinfo/id-event<https://www.ietf.org/mailman/listinfo/id-event>
>
>     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>

---

From: Marius Scurtescu <[email-masked]>
Date: Wed, 28 Aug 2019 21:39:08 -0700

On Wed, Aug 28, 2019 at 4:44 PM Richard Backman, Annabelle <richanna=
[email-masked]> wrote:

>    1. The draft currently forbids static Bearer tokens (§4.4.1: “Bearer
>    tokens MUST have a limited lifetime…). There are legitimate use cases for
>    static tokens when dealing with less sophisticated clients/services. I
>    suggest changing the MUST to a SHOULD, or indicating the guidance applies
>    to dynamically generated tokens.
>
>    2. The draft does not describe error responses from the SET
>    Transmitter, e.g., in response to a malformed poll request. This requires a
>    separate set of error codes, since the existing ones are specific to SET
>    reception/processing errors. Additionally, §2.5 must be amended to allow
>    the SET Transmitter to immediately return an error response even when long
>    polling is requested by the SET Receiver.
>
>
>
> --
>
> *From: *Id-event <[email-masked]> on behalf of Dick Hardt <
> [email-masked]>
> *Date: *Friday, August 23, 2019 at 11:41 AM
> *To: *Yaron Sheffer <[email-masked]>
> *Cc: *Adam Dawes <adawes=[email-masked]>, Brian Campbell
> <bcampbell=[email-masked]>, "Morteza Ansari
> (moransar)" <[email-masked]>, SecEvent <[email-masked]>, Mike
> Jones <Michael.Jones=[email-masked]>
> >     <mailto:[email-masked]
> <40microsoft..com@dmarc..ietf.org>>> wrote:
> >
> >         https://www.ietf..org/mailman/listinfo/id-event
> <https://www.ietf.org/mailman/listinfo/id-event>
> >