Subject: Re: [Id-event] [UNVERIFIED SENDER] Re: I-D Action: draft-ietf-secevent-subject-identifiers-05.txt

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Fri, 2 Aug 2019 22:17:39 +0000

I believe the “-“ delimiter in subject identifier types is a carryover from RISC, where it matches the delimiters used in event types (“-“ since those appear as part of full event type URIs). Since we’re standardizing subject identifiers outside of RISC’s profile of SET, I’d be fine with switching “iss-sub” and “phone-number” to “iss_sub” and “phone_number”, respectively.

--
Annabelle Richard Backman
AWS Identity

From: Dick Hardt <[email-masked]>
Date: Wednesday, July 24, 2019 at 3:06 PM
To: "Richard Backman, Annabelle" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [UNVERIFIED SENDER] Re: [Id-event] I-D Action: draft-ietf-secevent-subject-identifiers-05.txt

What was the reason to have a dash in the type “phone-number” rather than an underscore “phone_number”?

On Wed, Jul 24, 2019 at 4:54 PM Richard Backman, Annabelle <richanna=[email-masked]<mailto:[email-masked]>> wrote:
This update to the Subject Identifiers for Security Event Tokens draft addresses comments raised at the secevents working group session this week. Specifically:

* Renamed the "phone" type to "phone-number" and its "phone" claim

to "phone_number".

—
Annabelle Backman
AWS Identity

On Jul 24, 2019, at 5:46 PM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Security Events WG of the IETF.

       Title           : Subject Identifiers for Security Event Tokens
       Authors         : Annabelle Backman
                         Marius Scurtescu
   Filename        : draft-ietf-secevent-subject-identifiers-05.txt
   Pages           : 15
   Date            : 2019-07-24

Abstract:
  Security events communicated within Security Event Tokens may support
  a variety of identifiers to identify the subject and/or other
  principals related to the event.  This specification formalizes the
  notion of subject identifiers as named sets of well-defined claims
  describing the subject, a mechanism for representing subject
  identifiers within a [JSON] object such as a JSON Web Token [JWT] or
  Security Event Token [SET], and a registry for defining and
  allocating names for these claim sets.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-secevent-subject-identifiers/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers-05
https://datatracker.ietf.org/doc/html/draft-ietf-secevent-subject-identifiers-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-secevent-subject-identifiers-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event
_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event

---

From: Mike Jones <[email-masked]>
Date: Fri, 2 Aug 2019 22:23:23 +0000

The registered OpenID Connect claim name is phone_number.  I’d use underscores so the names match.

                                                                -- Mike

From: Id-event <[email-masked]> On Behalf Of Richard Backman, Annabelle
Sent: Friday, August 2, 2019 3:18 PM
To: Dick Hardt <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Id-event] [UNVERIFIED SENDER] Re: I-D Action: draft-ietf-secevent-subject-identifiers-05.txt

From: Dick Hardt <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 24, 2019 at 3:06 PM
To: "Richard Backman, Annabelle" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [UNVERIFIED SENDER] Re: [Id-event] I-D Action: draft-ietf-secevent-subject-identifiers-05.txt

to "phone_number".

—
Annabelle Backman
AWS Identity

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-secevent-subject-identifiers/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-secevent-subject-identifiers%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7Caba6951b02954371797708d7179741d7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637003810743497680&sdata=oWTA1nb9ERYx568GdSZQIwfpkduPS4S2KScql7IqSDM%3D&reserved=0>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers-05<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-secevent-subject-identifiers-05&data=02%7C01%7CMichael.Jones%40microsoft.com%7Caba6951b02954371797708d7179741d7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637003810743507672&sdata=dDdIX1beEaUgQoJES4Cg0C5IXzBZsa1ZXfpfvUNAhCg%3D&reserved=0>
https://datatracker.ietf.org/doc/html/draft-ietf-secevent-subject-identifiers-05<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-secevent-subject-identifiers-05&data=02%7C01%7CMichael.Jones%40microsoft.com%7Caba6951b02954371797708d7179741d7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637003810743507672&sdata=NgsPxBYezXy92OYZgWgLQ6HPtq4Eamy%2Fo1nbu%2FD%2BPgY%3D&reserved=0>

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-secevent-subject-identifiers-05<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-secevent-subject-identifiers-05&data=02%7C01%7CMichael.Jones%40microsoft.com%7Caba6951b02954371797708d7179741d7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637003810743517669&sdata=BdYDGuypPEmgY7ctUO3tfwi2puwM7rIBbClyqK8cTIY%3D&reserved=0>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org&data=02%7C01%7CMichael.Jones%40microsoft.com%7Caba6951b02954371797708d7179741d7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637003810743527665&sdata=uWqmGEKnY%2BD8Y6%2BC568NSs7BwtwJv%2BFcvoDbjEB9Vl4%3D&reserved=0>.

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fid-event&data=02%7C01%7CMichael.Jones%40microsoft.com%7Caba6951b02954371797708d7179741d7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637003810743527665&sdata=FPDo8uBEspfIqb9SU06VzKPFQqMnuMt0yvdrvZYeCNw%3D&reserved=0>
_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fid-event&data=02%7C01%7CMichael.Jones%40microsoft.com%7Caba6951b02954371797708d7179741d7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637003810743537659&sdata=kLDzInm04yegWEjNttjFV%2BowU7anUKdKv9jPq1W0ivc%3D&reserved=0>

---

From: "Hjelm, Bjorn" <[email-masked]>
Date: Fri, 2 Aug 2019 22:35:53 +0000

I would agree with Mike.

BR,
Bjorn

From: Id-event [mailto:[email-masked]] On Behalf Of Mike Jones
Sent: Friday, August 02, 2019 3:23 PM
To: Richard Backman, Annabelle; Dick Hardt
Cc: [email-masked]; [email-masked]
Subject: [E] Re: [Id-event] [UNVERIFIED SENDER] Re: I-D Action: draft-ietf-secevent-subject-identifiers-05.txt

                                                                -- Mike

to "phone_number".

—
Annabelle Backman
AWS Identity

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-secevent-subject-identifiers/<https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fdatatracker.ietf.org-252Fdoc-252Fdraft-2Dietf-2Dsecevent-2Dsubject-2Didentifiers-252F-26data-3D02-257C01-257CMichael.Jones-2540microsoft.com-257Caba6951b02954371797708d7179741d7-257C72f988bf86f141af91ab2d7cd011db47-257C1-257C0-257C637003810743497680-26sdata-3DoWTA1nb9ERYx568GdSZQIwfpkduPS4S2KScql7IqSDM-253D-26reserved-3D0&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=nx7vF4rpVFkVWXwmV7LX6e8Yx7uc8VqWwE7w_5XNLas&s=LO2iqd3fJVE2mlQ_TrNVVcZPjlrLcbJMlaW009POUrg&e=>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers-05<https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Ftools.ietf.org-252Fhtml-252Fdraft-2Dietf-2Dsecevent-2Dsubject-2Didentifiers-2D05-26data-3D02-257C01-257CMichael.Jones-2540microsoft.com-257Caba6951b02954371797708d7179741d7-257C72f988bf86f141af91ab2d7cd011db47-257C1-257C0-257C637003810743507672-26sdata-3DdDdIX1beEaUgQoJES4Cg0C5IXzBZsa1ZXfpfvUNAhCg-253D-26reserved-3D0&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=nx7vF4rpVFkVWXwmV7LX6e8Yx7uc8VqWwE7w_5XNLas&s=uZ_E5YGb3Uqx7apob6FPRYkV5DqBbvzoA8MlRYdTdaY&e=>
https://datatracker.ietf.org/doc/html/draft-ietf-secevent-subject-identifiers-05<https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fdatatracker.ietf.org-252Fdoc-252Fhtml-252Fdraft-2Dietf-2Dsecevent-2Dsubject-2Didentifiers-2D05-26data-3D02-257C01-257CMichael.Jones-2540microsoft.com-257Caba6951b02954371797708d7179741d7-257C72f988bf86f141af91ab2d7cd011db47-257C1-257C0-257C637003810743507672-26sdata-3DNgsPxBYezXy92OYZgWgLQ6HPtq4Eamy-252Fo1nbu-252FD-252BPgY-253D-26reserved-3D0&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=nx7vF4rpVFkVWXwmV7LX6e8Yx7uc8VqWwE7w_5XNLas&s=NsrpcLW-IC0s5BKBsov4J6fJ4j1duq0Dd9-m-RHXLwo&e=>

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-secevent-subject-identifiers-05<https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fwww.ietf.org-252Frfcdiff-253Furl2-253Ddraft-2Dietf-2Dsecevent-2Dsubject-2Didentifiers-2D05-26data-3D02-257C01-257CMichael.Jones-2540microsoft.com-257Caba6951b02954371797708d7179741d7-257C72f988bf86f141af91ab2d7cd011db47-257C1-257C0-257C637003810743517669-26sdata-3DBdYDGuypPEmgY7ctUO3tfwi2puwM7rIBbClyqK8cTIY-253D-26reserved-3D0&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=nx7vF4rpVFkVWXwmV7LX6e8Yx7uc8VqWwE7w_5XNLas&s=7WBy_jqSOq66nyl6_dQaepzjbom9Omsm2plXamJWd4s&e=>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttp-253A-252F-252Ftools.ietf.org-26data-3D02-257C01-257CMichael.Jones-2540microsoft.com-257Caba6951b02954371797708d7179741d7-257C72f988bf86f141af91ab2d7cd011db47-257C1-257C0-257C637003810743527665-26sdata-3DuWqmGEKnY-252BD8Y6-252BC568NSs7BwtwJv-252BFcvoDbjEB9Vl4-253D-26reserved-3D0&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=nx7vF4rpVFkVWXwmV7LX6e8Yx7uc8VqWwE7w_5XNLas&s=1lQHW0t04wu34o9ydIBoBj8VRsEAWACdQS-55cIwE6M&e=>.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/<https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=nx7vF4rpVFkVWXwmV7LX6e8Yx7uc8VqWwE7w_5XNLas&s=5aK_0MpJbWBG20HMK1kcMt67Km2IZCg0tFjHWjQ7wWA&e=>

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event<https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fwww.ietf.org-252Fmailman-252Flistinfo-252Fid-2Devent-26data-3D02-257C01-257CMichael.Jones-2540microsoft.com-257Caba6951b02954371797708d7179741d7-257C72f988bf86f141af91ab2d7cd011db47-257C1-257C0-257C637003810743527665-26sdata-3DFPDo8uBEspfIqb9SU06VzKPFQqMnuMt0yvdrvZYeCNw-253D-26reserved-3D0&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=nx7vF4rpVFkVWXwmV7LX6e8Yx7uc8VqWwE7w_5XNLas&s=JS1JGcK3nUZWcEAgN_bgxn2AIeVLPGVPl285OJfsrRA&e=>
_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event<https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fwww.ietf.org-252Fmailman-252Flistinfo-252Fid-2Devent-26data-3D02-257C01-257CMichael.Jones-2540microsoft.com-257Caba6951b02954371797708d7179741d7-257C72f988bf86f141af91ab2d7cd011db47-257C1-257C0-257C637003810743537659-26sdata-3DkLDzInm04yegWEjNttjFV-252BowU7anUKdKv9jPq1W0ivc-253D-26reserved-3D0&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=nx7vF4rpVFkVWXwmV7LX6e8Yx7uc8VqWwE7w_5XNLas&s=Gk_opYq5aajJX1Cox0K3BShMJnS4ha8rPL838Kw5czM&e=>