Subject: Re: [Ideas] [5gangip] Mapping System Requirements and draft-padma-ideas-problem-statement-00.txt

From: Padmadevi Pillay Esnault <[email-masked]>
Date: Thu, 29 Sep 2016 22:25:19 +0000

See below

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Rex Buddenberg
Sent: Thursday, September 29, 2016 10:35 AM
To: [email-masked]; AshwoodsmithPeter
Cc: [email-masked]; Ca By; Michael Menth; Dino Farinacci
Subject: Re: [5gangip] Mapping System Requirements and draft-padma-ideas-problem-statement-00.txt

On Thu, 2016-09-29 at 11:03 -0500, Behcet Sarikaya wrote:
> 
> In short, multicast mobility type of work is difficult to justify but
> certainly technically challenging :)

Not so (difficult to justify).
[Padma Pillay Esnault] 
Agree here. 

If you look at the nature of emergency services data, a great deal of
it is multicast in nature -- has to go >1 places.  Indeed if you talk
to EMS folks who's view of the world is Land Mobile Radio, they have a
different set of terminology, but it's multicast.

Yes, technically challenging relative to unicast.  But if you get the
multicast right, unicast is a simpler subset.

Belongs in scope.

[Padma Pillay Esnault] Agree. As we are moving towards a hyper-connected society, more and more services will multicast in nature. Do you really want to control/communicate to things as in internet of things one by one?

---

From: Tom Herbert <[email-masked]>
Date: Thu, 29 Sep 2016 18:46:06 -0400

On Sep 29, 2016 6:32 PM, "Padmadevi Pillay Esnault" <[email-masked]>
wrote:
> Subject: Re: [5gangip] Mapping System Requirements and
draft-padma-ideas-problem-statement-00.txt
> [Padma Pillay Esnault] Agree. As we are moving towards a hyper-connected
society, more and more services will multicast in nature. Do you really
want to control/communicate to things as in internet of things one by one?
Security and reliability make this really hard, especially for critical
information like hazard warnings to autonomous vehicles. I'm not sure how
well VANET solves this which would seem to want a lot of multicast.

Tom

> _______________________________________________
> Ideas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ideas

---

From: Padmadevi Pillay Esnault <[email-masked]>
Date: Thu, 29 Sep 2016 23:20:53 +0000

-----Original Message-----
From: Rex Buddenberg [mailto:[email-masked]] 
Sent: Thursday, September 29, 2016 4:12 PM
To: Tom Herbert; Padmadevi Pillay Esnault
Cc: Behcet Sarikaya; Michael Menth; AshwoodsmithPeter; Ca By
Subject: Re: [Ideas] [5gangip] Mapping System Requirements and draft-padma-ideas-problem-statement-00.txt

On Thu, 2016-09-29 at 18:46 -0400, Tom Herbert wrote:
> On Sep 29, 2016 6:32 PM, "Padmadevi Pillay Esnault" <[email-masked]
> > wrote:
> >
> > See below
> >
> > [Padma Pillay Esnault] Agree. As we are moving towards a hyper-
> connected society, more and more services will multicast in nature.
> Do you really want to control/communicate to things as in internet of
> things one by one?
> >
> Security and reliability make this really hard, especially for
> critical information like hazard warnings to autonomous vehicles. I'm
> not sure how well VANET solves this which would seem to want a lot of
> multicast.

Depends on what security you need.  Content authenticity?  Not too bad
-- recipients all need the sendor's public key.  Content
confidentiality is harder using the existing PKI procedures.  
     I can't think of many applications where authenticity is not a
requirement, but there are a lot where confidentiality is not.
[Padma Pillay Esnault] 
True if we think of public information like emergency services or free parking spots.
However, this may still be an issue for groups where you still want some confidentiality.

Reliability.  TCP is a unicast protocol.  Period.  But there are
multicast transport protocols (NORM is one) that provide reliability in
multicast environments.  

Just because a problem is hard does not mean the requirements are not
legit.
[Padma Pillay Esnault] 
IMHO Technical challenge is just a dare :-)