Subject: IGMPv3:Max resp code

From: Abdelkader Lahmadi <[email-masked]>
Date: Fri, 21 Sep 2001 17:47:14 +0200

hi,
on the IGMPv3 internet draft section 4.1.1, i would to know the reasons for
choosing the value 128, to determinate the Max resp Time ?

regards,

---------------------------------------------
  Lahmadi Abdelkader
  LORIA - UHP NANCY I
  CAMPUS SCIENTIFIQUE B.P.239
  54506 VANDOEUVRE-LES-NANCY CEDEX
  E-mail : [email-masked]
---------------------------------------------

---

From: Wilbert de Graaf <[email-masked]>
Date: Fri, 21 Sep 2001 11:54:30 -0700

> choosing the value 128, to determinate the Max resp Time ?

First of all I wasn't there but this is what I was told. Some people with
thousands of hosts on a single router (I believe cable operators) argued the
need for a max response time of more than one hour. This value of 128 has
been picked because it was found to be the best to:

1) express any value below 128 with precision
2) although losing precision, good enough to express those hours

I remember once seeing a plot of those values on a webpage.

Wilbert

---

From: Bill Fenner <[email-masked]>
Date: Mon, 24 Sep 2001 14:45:43 -0700

See http://www.research.att.com/~fenner/mcast/igmpv3/ for the
graphs and charts.  We chose the green line (4-bit mantissa,
3-bit exponent) to give a max value of just over 52 minutes;
the 9 days possible using the blue line seemed like overkill.

  Bill