Subject: RE: [idn] UNIX moving to UTF-8

From: "Russ Rolfe" <[email-masked]>
Date: Sat, 27 Jan 2001 09:24:13 -0800

> There may be other reasons for not using MS Word for editing config 
> files; but MS Word can indeed edit plain text files, in UTF-8 as well 
> as many other encodings. 

Hey even Notepad on Windows 2000 edits UTF-8 files.

Regards, Russ
-----Original Message-----
From: Karlsson Kent - keka [mailto:[email-masked]]
Sent: Saturday, January 27, 2001 3:57 AM
To: 'Keith Moore'
Cc: [email-masked]
Subject: RE: [idn] UNIX moving to UTF-8 

Keith, 
(regarding your reply to Ken:) 
I would suggest you read Ken's e-mail again, slowly. 
It's not that "ACE" didn't start out at ISO that is of concern. 
It's the fact that the "ACE"s have an extremenly narrow field 
if applicability (IDNs) that is of concern.  UTF-{8,16,32} are 
general purpose encodings, that do and will find support 
in many, many places.  "ACE"s can only be used for IDNs, 
and will never find widespread support for anything else. 
(regarding your reply to Mark:) 
There may be other reasons for not using MS Word for editing config 
files; but MS Word can indeed edit plain text files, in UTF-8 as well 
as many other encodings. 
However, to be able to edit config files with "ACE"s in them, there 
is no, and will never be any general purpose editor that supports that. 
You will need an editing tool (or auxilliary tool) SPECIFIC for IDN 
containing config file editing to be able to edit such a config file if 
you want to be able to read what is really encoded there in the 
"ACE"d IDNs. 

                /kent k 
------------------------------------------------------------------------
--------- 
> -----Original Message----- 
> From: Keith Moore [mailto:[email-masked]] 
> Sent: Friday, January 26, 2001 7:01 AM 
> To: Mark Davis 
> Cc: James Seng/Personal; D. J. Bernstein; [email-masked] 
> Subject: Re: [idn] UNIX moving to UTF-8 
> 
> 
> > A huge number of people in non-English speaking countries 
> are using Unicode, 
> > *and don't know it*. Anyone using Windows NT/2000, or 
> Microsoft Office is, 
> > as well as many other products. Many websites use Unicode 
> internally, and 
> > just convert to the user's codepage, etc. 
> 
> sure.  but just because someone is using microsoft office that happens

> to use some encoding of Unicode doesn't mean they can use it to edit 
> a "plain text" config file that expects IDNs to be in UTF-8 format. 
------------------------------------------------------------------------
--------- 
> -----Original Message----- 
> From: Keith Moore [mailto:[email-masked]] 
> Sent: Friday, January 26, 2001 9:23 PM 
> To: Kenneth Whistler 
> Cc: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked] 
> Subject: Re: [idn] UNIX moving to UTF-8 
> 
> 
> > > > People are clearly moving to Unicode. Exactly which UTF 
> they choose (8, 16, 
> > > > 32) is not as important, since they all can be 
> converted to each other very 
> > > > efficiently and without loss. 
> > > 
> > > And since an ACE is just another encoding of Unicode, you 
> can add ACE to 
> > > that set. 
> > 
> > This was malarkey the first time it was stated, and it is 
> still malarkey. 
> > 
> > UTF-8, UTF-16, and UTF-32 are official, standard encoding 
> forms of the 
> > Unicode character encoding. 
> > 
> > ACE is a transformation encoding syntax (TES) -- *not* an 
> encoding form. 
> 
> I didn't use the precise term "encoding form" I used the 
> imprecise term 
> "encoding".  
> 
> ACE most certainly is an encoding of Unicode.  If adopted by 
> IETF, ACE 
> will also be an "official" "standard" - though not an ISO standard.  
> If memory serves, neither Unicode nor UTF-8 started out in 
> ISO either, 
> so the fact that ACE didn't start there shouldn't be cause 
> for concern. 
> 
> > I'm not opposed to the ACE proposals for solving the short-term IDN 
> > issue, but... 
> > 
> > UTF-8 is a general-purpose encoding form for open interchange of 
> > Unicode data is all kinds of contexts. It is also used as a 
> general-purpose 
> > processing form in many systems. 
> 
> UTF-8 certainly has wider applicability than ACE.  However ACE 
> is not designed to meet the constraints of *a* particular protocol, 
> it is designed to meet the constraints of *several* protocols that 
> use ASCII DNS names as protocol elements. 
> 
> Keith 
>

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 27 Jan 2001 19:40:13 +0100

>Hey even Notepad on Windows 2000 edits UTF-8 files.

Does it do nameprep?

   paf