Subject: Re: [idn] An experiment with UTF-8 domain names

From: Dan <[email-masked]>
Date: Sat, 6 Jan 2001 12:08:35 +0100 (MET)

Martin said:

>I think we should be realistic on both sides here.
>We don't have conversions for ASCII, but we have
>prohibited characters. Dan, what would happen if
>you try to register e.g. +-+.cr.yp.to ?
>Also, we have case mapping, currently done on the
>server but for many reasons better moved to the
>client for UCS.

Moving case mapping to the client will break some applications.
While DNS is case insensitive, many applications are not.
Today I have several applications doing a reverse lookup
to get the name of a host, and then use it to compare with
application data.
Today the reverse lookup preserves case and can therefore
be used to compare with hosts names that have mixed case.
If we move case folding to the client, we must teach
everybody that "Peter" is not equivalent to "peter". It might
be easy to a C programmer but not to the normal person.
For them a "p" is a "p" independantly if it is written
in upper or lower case.
We will not be backward compatible.

Regards,

  Dan

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 6 Jan 2001 13:34:46 +0100

>to get the name of a host, and then use it to compare with

If you read the nameprep draft, draft-ietf-idn-nameprep-00.txt, you 
will see that the case mapping is done in the client for the 
non-us-ascii names. So, we will be backward compatible for ascii 
characters.

    paf