Subject: RE: [idn] Interactions between short-term and long-term

From: Karlsson Kent - keka <[email-masked]>
Date: Sat, 27 Jan 2001 12:44:45 +0100

> -----Original Message-----
> From: Patrik Fältström [mailto:[email-masked]]
> Sent: Saturday, January 27, 2001 10:56 AM
> To: [email-masked]
> Subject: Re: [idn] Interactions between short-term and long-term
> 
> 
> At 22.02 +0000 01-01-26, D. J. Bernstein wrote:
> >Paul Hoffman / IMC writes:
> >>  Am I missing some significant effect that ACEs might have on other
> >>  long-term solutions?
> >
> >Yes. If we allow ACE-based IDNs, then we'll have to keep them working
> >during the subsequent transition to UTF-8.
> 
> Why should UTF-8 be the long-term solution? Why not UCS-2 or some 
> other representation?

UCS-2 should be regarded as outdated.  10646-2 (FDIS) and Unicode 3.1
adds characters on plane 01 and plane 02, that cannot be represented
in UCS-2 (though they can be represented in UTF-16, as well as UTF-8
and UTF-32).  Some of those characters may be used in IDNs.

		/kent k

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 27 Jan 2001 17:07:28 +0100

>and UTF-32).  Some of those characters may be used in IDNs.

Understood, but my point was that I didn't see that we should take 
for granted that UTF-8 is what is to be used if not ACE is used.

   paf