Subject: Re: [idn] Question for the Kanji & Hanja cognosentee

From: [email-masked]
Date: Thu, 16 Aug 2001 22:21:52 -0700

On Thu, 16 Aug 2001 22:09:33 -0400 Eric Brunner-Williams in Portland
Maine <[email-masked]> writes:
> Ms. Ydisg,
> 
> Is there a typo right about ...
> 
> > Kanji is Han character in Japanese, while Hanji is 
> > Han character in Korean.  During historical transfering
> > in time or location differences to Japan and Korean, there are
> > some differences in forms between Hanji/SC and Hanji/SC,
>                                     ^     ^^     ^     ^^
>                                     here or here or here or here?
> 
> > but semanticly equivalent, as it is with TC/SC.  Unicode
> > combined all TC, SC, Hanji and Kanji into CJK character
> > table, and that is what we reference the set as CJK character
> > set.
> 
> OK. I've found what had surprised me, simplified (Japan) Chinese 
> characters.
> I'll assume that simplified (Korea) Chinese characters also exist. 
> Ditto for
> Vietnamese.
> 
> The Chinese I learned as a kid (TC) and the Chinese I learned in 
> Beijing (SC),
> clearly isn't all the TC or SC available to choose from, so now I 
> have a better
> understanding of the original comment.
> 
> Thanks for your assistance,
> Eric

Which "original comment" do you refer to?  I forget what I have 
said.

Liana Ye

---

From: [email-masked]
Date: Fri, 17 Aug 2001 00:31:30 -0700

Then can you say Romaji is a good enough IDN 
identifier?  Can you reverse Romaji to Kana or 
even to Kanji with say very high one-to-one rate?

Liana

On Fri, 17 Aug 2001 15:15:58 +0900 "Bruce Thomson"
<[email-masked]> writes:
> > By the way, how do you Romanize a word containing
> > Kanji and Kana?
> > 
> 
> There are two steps:
> 
> 1) Convert all Kanji to kana. Anything that can be pronounced
> in Japanese can be expressed as the kana equivalent of that
> pronunciation. However, Kanji cannot be converted one at a time
> as many words are unique combinations of Kanji with special
> pronuncations. Also, there can be multiple pronunciations for the
> same Kanji string.
> 
> 2) Once you have everything in kana, convert to "Romaji"
> (Romanized characters) using the Hepburn system. Here
> are the Romaji equivalents of all the modern kana:
> 
> a  i  u  e  o
> ka ki ku ke ko
> sa shi su se so
> ta chi tsu te to
> na ni nu ne no
> ha hi fu he ho
> ma mi mu me mo
> ya yu yo
> ra ri ru re ro
> wa wo
> n
> 
> There is a further complication in that a small kana
> tsu is used to represent a double consonant when
> a word is written as kana, whereas the consonant
> is merely written twice in the Romaji equivalent.
> 
> By the way, Japanese keyboard input is usually
> handled by typing Romaji which can then be
> converted to kana and further converted into
> Kanji.
> 
> http://www.omniglot.com/writing/japanese.htm
> http://www.kanjisite.com/wak1.html
> 
> 
>

---

From: [email-masked]
Date: Fri, 17 Aug 2001 01:51:39 -0700

Now, this sounds better to me now.  There are about 2300
hangul characters and 4888 Hanja.  The 2300 x 2 is more than
the number of Hanja used by Korean.  But how many homophones
per hangul anyway?  Is it less than 10?   

I am proposing a [nameprep] case folding for Korean:

Legent:
> fold to
+ concatenating
= output

Hangul > Romaji  =  Hangul in ACE
hangul + a digit  >  Romaji + a digit to select a Hanja  = Hanja in ACE

Hangul in ACE + Hanja in ACE  = ACE  identifier for DNS 

 You can get your Hangul and Hanja back when you reverse
 the process.  All your work for IDN is to prepare a conversion
table like SC/TC, and put that in [Nameprep]?  What do you think? 

Liana

On Fri, 17 Aug 2001 16:49:27 +0900 "Soobok Lee" <[email-masked]>
writes:
> Two corrections:
> 
> ----- Original Message ----- 
> From: "Soobok Lee" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>; 
> <[email-masked]>
> Sent: Friday, August 17, 2001 4:14 PM
> Subject: Re: [idn] Question for the Kanji & Hanja cognosentee
> 
> 
> > 
> > ----- Original Message ----- 
> > From: <[email-masked]>
> > To: <[email-masked]>
> > Cc: <[email-masked]>; <[email-masked]>; 
> <[email-masked]>
> > Sent: Friday, August 17, 2001 4:08 PM
> > Subject: Re: [idn] Question for the Kanji & Hanja cognosentee
> > 
> > 
> > > It is correct, there will be no disambiguations in 
> > > DNS for anyone.  It has to be resolved at registration 
> > > time.  Then do you need Hanja in Domain name at all?
> > 
> > Yes, but rarely.
> > some japanese/chinese restaurants in SEOUL Korea
> >  have the primary name in Hanja(Kanji).
> > Most korean individuals/companies won't pay for
> > rarely used HANJA domains, I guess.
> 
> That may change near future..
> 
> Recently, Korean Goverments began to encourage
> HanJa education/Hanja Usages in addition to English ones.
> You know the economic block of Eastern Asia is rapidly 
> expanding its power... :-)
> 
> 
> > 
> > > Why? If Hanja names is only used for Chinese and Japanese,
> > > then how do Korean people separated from each other? 
> > > Are there many people with the same Hangul names?
> > 
> > Most Koreans have their TC-form fullnames. Many Korean
> > businesses , too. But they are not used so frequently
> > as hangul ones.
> > 
> > 
> > In my rough estimation, most frequent 5000 hangul personal full 
> names 
> > form the set of distinct fullnames of about 90% of korean 
> populations.
> > 
> Oh my mistake.  5000 ====> 100,000.
> 
> 100,000 distinct fullnames, and 5,000 distinct given(first) names 
> acount
> for 90% of individual names of south korean population,based on the 
> personal
> study on 600,000 samples of korean fullnames.
> 
> Thanks.
> 
> > South Korean population reached  47,000,000 recently.
> > 
> > > 
> > > I have heard a law suit case here, that a Vietnanese vs. 
> > > another Vietnanese in the San Francisco area, both
> > > sides of the case and a witness of the case all have 
> > > exact the same name!  And they all need interpretations too.
> > > Imagine the headaches for the lawyers!
> > > 
> > 
> > :-))
> > 
> > Soobok
> > 
> > > Liana 
> > > 
> > > 
> > > On Fri, 17 Aug 2001 15:06:01 +0900 "Soobok Lee" 
> <[email-masked]>
> > > writes:
> > > > Hi, Liana
> > > > 
> > > > ----- Original Message ----- 
> > > > From: <[email-masked]>
> > > > > What happen when people read newspapers with Hangul 
> > > > > without Hanji such as it is in North Korean?  
> > > > > How to you get a Hanji through hangul if it is one-to-many 
> > > > > correspondence?
> > > > > 
> > > > Korean have been familiar with many hangeul homonyms that
> > > > share the same hangeul word but have different TC 
> forms/meanings
> > > > and optionally different sounds (long or short vowel etc) .
> > > > Ordinary Korean can disambiguate them  only by the surrounding
> > > > semantical context (sentence or paragraph) in which they 
> appear.
> > > > 
> > > > In DNS, we have no such contextual clue for disambiguations.
> > > > 
> > > > Soobok
> > > > 
> > > 
> > 
>

---

From: [email-masked]
Date: Fri, 17 Aug 2001 11:14:24 -0700

This is the core of the problem.  People want to use their
own script for names, and there will be character conflict
just as any symbol system, and this is the feature 
Internetionalization wanted, isn't this correct?   Let us
use your example for the solution and study the trade offs.

1. There should be:

>   1) in Korea:  kuk
>   2) in Japan:  kuni, kok, ...
>   3) in China:  kuo, ....

> If you designate an unique romanization sequence in 3)  for han 
> 'nation',
>   1) and 2) and even someone in 3) will be unhappy for it  ,

So we shall designate 3 mapping tables!  And remember, 
this is character code, not word codes.  When you do 
registration, the use is "zhongguo"  <china> and the registration 
system should do the Unicode checking for the Unicode
string is taken by Cinese already.  But this does not 
exclude a Korean name says: <KoreanChinaTrading>, 
since the convention for Chinese to to this is 
<ChinaKoreanTrading> so you will have 
>   1) in Korea:  kuk
>   2) in Japan:  kuni, kok, ...
>   3) in China:  kuo, ....
and Unicode <KoreanChinaTrading>.

The naming convention for names are quite different among
Chinese, Japanese and Korean using Kanji.  Similarly we
can look at sirnames to tell people's origins in US, and it is 
more then 95% correct.  The registration process is to catch 
the other say 5% name conflict.  

The three mapping tables are similar with Latin upper-to-lower
case folding, only larger. So for Korean it has five columns:

Unicode		Unicode 	KSC code 	KSC code 	StepCoded
Hangul		Hanja		Hanja		Hangul		Romaji

It is certain the Hanja will have longer list than Hangul. 
So there will be 2 Hangul to 1 Hanja, and your IDNA can decide
which one to use, not the [nameprep].  The StepCode is
concatenation of Romaji+digit and the author has to make it
one-to-one within this kro- table.

Liana

On Fri, 17 Aug 2001 17:53:58 +0900 "Soobok Lee" <[email-masked]>
writes:
> For example,
>  Han letter 'nation' is pronounced :
>   1) in Korea:  kuk
>   2) in Japan:  kuni, kok, ...
>   3) in China:  kuo, ....
> If you designate an unique romanization sequence in 3)  for han 
> 'nation',
>   1) and 2) and even someone in 3) will be unhappy for it  ,
>    saying " looks like a RACE label! ", 
>   since romanization lose its merit:  written as it is pronounced!!!
> 
> Soobok
>   
> 
> Sent: Friday, August 17, 2001 6:06 PM
> > If you use another feature of the character not based on
> > sound in addition to pronounciation, and fix it in your 
> > case folding table, then  you will have one-to-one 
> > mapping, and the language/semantic context is out
> > of the table.   
> > 
> > Liana
> > 
> > On Fri, 17 Aug 2001 17:23:45 +0900 "Soobok Lee" <[email-masked]>
> > writes:
> > > 
> > > Cc: <[email-masked]>; <[email-masked]>
> > > Sent: Friday, August 17, 2001 4:54 PM
> > > > If Hangul mapped to Latin letters like Romaji and then
> > > > add a number to select one Kanji among a few 
> > > > homophones, can this be good enough to idnetify a Hanja
> > > > name in DNS?
> > > 
> > >  some hangul  trailing jamos,
> > > for example , di-geuth, hi-euth and ti-euth,
> > >  have the same sound while their leading jamo 
> > > have different sounds. You need some differenciating 
> > > representation of trailing hangul jamos in romanizing hangeul 
> and
> > > That may cause some overheads...
> > > 
> > > Even a Hanja/Kanji/TC/SC letter often has multiple 
> pronunciations 
> > > in different words and so  multiple romanizations for a hanja 
> > > letter are possible!!
> > > 
> > > IMHO,Pronunciation-based romanization on Hanja/Kanji/TC/SC 
> > > should be performed in word/language context 
> > > (not in individual unicode point context ) , but It's not 
> achievable 
> > > in DNS
> > > which may have no language/script context (in .com) and often 
> have 
> > > no
> > > word sematics in a label (single han letter label).
> > > 
> > > 
> > > Soobok
> > > 
> > > > 
> > > > The same question goes to Bruce Thomson:
> > > > Can Romaji be revered back to Kanji-Kana sequece with
> > > > near 100% rate (with or without case ending)?
> > > > 
> > > > Liana
> > > > 
> > > > On Fri, 17 Aug 2001 16:14:04 +0900 "Soobok Lee" 
> <[email-masked]>
> > > > writes:
> > > > >

---

From: [email-masked]
Date: Sat, 18 Aug 2001 11:20:31 -0700

On Fri, 17 Aug 2001 17:21:35 +0900 Martin Duerst <[email-masked]> writes:
> At 16:49 01/08/17 +0900, Soobok Lee wrote:
> >Two corrections:
> > > Yes, but rarely.
> I think the trend for more Hangul or more Hanja comes
> and goes like waves in Korea. There are actually similar
> waves in North Korea, but of course with different
> amplitutde and wavelength.
> 
> 
> 
> Do you have the numbers for family names also? I guess it must
> be something like "100 most frequent family names cover 99% of the 
> population",
> but it would be nice to know exact figures based on such a large 
> sample.
> 
> 
> Regards,    Martin.

I don't think we need exact figures here, people with some background
in the culture they speaking about do have some experience, which
serves as a good sample of the usage ( rough statistics). And the numbers

from current registration is a reference too, but a little more bias in
its
certainty.

Liana