Subject: Re: [idn] opting out of SC/TC equivalence

From: [email-masked]
Date: Thu, 30 Aug 2001 14:55:33 -0700

On Thu, 30 Aug 2001 09:18:24 +0200 =?ISO-8859-1?Q?Patrik_F=E4ltstr=F6m?=
<[email-masked]> writes:
> --On 2001-08-30 08.41 +0200 Harald Tveit Alvestrand 
> <[email-masked]>
> wrote:
> 
> >>  I hope my explaination can shed a little
> >>  light on CNNIC's feeling about TC/SC arguements.  You also
> >> can tell me that my input is out of the scope of this group, and
> >> I am ready to leave too.
> > 
> > I think the group will have a better chance of delivering output 
> that is
> > useful to both you and me if we declare that the TC/SC issue is 
> not going
> > to be solved inside the IDN work.
> > 
> > I believe this problem is hard enough that it has to be solved at 
> another
> > level. Sorry about that.
> 
> Just because nameprep and what the IDN group is doing is only 
> mechanical
> operations on individual characters in a single character set, my 
> view is
> that SC<->TC conversion can only be done in a keyword like system 
> before
> IDN is even started to be used.
> 
> Reason for this is because of the different kind of equality which 
> James
> described about a year ago and also described in this document. 
> Especially
> see section 2.4.3 about the need for user interaction.
> 
> http://www.basistech.com/articles/C2C.html
> 
> So, outside of IDN, but most certainly part of a system which is 
> described
> in the individual drafts by Dr. Klensin and Mr. Mealling.
> 
> Further, as James pointed out, if a registry want to set a policy on 
> what
> subset of the characters which IDN group is allowing is to be 
> allowed
> (only), that is perfectly alright, but also not part of what the IDN 
> group
> is doing.
> 
>     paf
> 

Chinese world is a complex world.  If we look at it from inside 
and outside, what we see is a mess, that is what I characterize
all the BDP is doing in this area.  In fact, the 80 vs. 20 rule 
applys all the time.  [nameprep] can be a simple list of 
one-to-one mapping to solve the 80% of TC/SC 
equivalence problem with 20% effort, and provide a door for 
GB to have an easy entry to exchange with Unicode, and let 
the other 20% problem to be dealt with under local treatment. 

I have been respecting John's draft and effort on this issue, but
John, I have to be canned about your view on directory search
too.  It makes the issue more complicate than it already is. 
Type and search is only good for character input.  It is painful
already.  None of Chinese will stand for it, that is why there are
a lot of research goes into a Chinese editor for twenty years
in China, and far behind US on computer software development.
Do you recall, that the first MSDOS was reverse engineered by
a Chinese, after Microsoft refused a source license to them?

The solution is to take care the 80% in a simplest way, and
try to hide 20% of the problems. You see this model in all
areas, especially in politics, where most people paying 
attention and criticizing.  When you hear Chinese 
administrators arguing about something, the 95% 
chances are over which one is belong to the 80% 
group :-)  So minority nationalities have over 
80% in numbers, so they are have higher priority on a 
lot of personnel issues regardless their populations.

To the keyword type of solutions, it is good for name 
registration only.  It is slow and painful, a good toy to
study with, but not good to use as day to day tool,
especially unthinkable if I want cut and paste type of
URL implementation.  So, I am agaist keyword search 
type of e-mail addresses, but still interested in
any solutions to guess how it can be implemented in 
English.  

Liana

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 31 Aug 2001 08:42:15 +0200

to my mind, it seems that you can have keyword search with near-perfect 
TC/SC equivalence, OR cut-and-paste URLs and email addresses without TC/SC 
equivalence.

Not both in the same part of the user interface at the same time.

---

From: Martin Duerst <[email-masked]>
Date: Fri, 31 Aug 2001 16:07:04 +0900

>Not both in the same part of the user interface at the same time.

Well, not both in the same protocol at the same time, I fully agree.
But in the same user interface is possible. The newer versions of
both Netscape Navigator and Internet Explorer do a search if
a domain name isn't found.

Regards,   Martin.