Subject: Re: [idn] opting out of SC/TC equivalence

From: [email-masked]
Date: Thu, 9 Aug 2001 11:09:07 -0700

On Thu, 9 Aug 2001 10:36:15 -0400 "Edmon" <[email-masked]> writes:
> From: "John C Klensin" <[email-masked]>
> > <[email-masked]> wrote:
> > > From: "Dan Ebert" <[email-masked]>
> > >> It seems to me that it would be more confusing if TC/SC behaved
> > >> differently for different TLDs.  One of the (I think
> > >> beneficial) features of DNS is that the behavior is uniform
> > >> across all TLDs (com works like net works like org ...)
> > >
> > > This is not true.  Registration restrictions differ from TLD to
> > > TLD.
> >
> > But a query is interpreted independent of TLD.  And once the
> > query is made, the name is resolved exactly the same way,
> > regardless of the TLD.
> >
> 
> You are right.  I should re-write my point:
> You wont expect to go to the same place if you typed in abc.com vs 
> abc.ca
> so I dont think you would be too surprised to see that <SC>.com 
> doesnt go to
> the same place as <TC>.cn
> Which means that TLD dependent SC=TC should not create any problem 
> on a user
> expectation stand point.
> If you know that typing <SC>.cn and <TC>.cn goes to the same place, 
> it will
> happen no matter where you are connected to the network.
> But that doesnt mean that <SC>.tld and <TC>.tld must therefore go to 
> the
> same place.
> There should be no compelling user expectation for this to happen.
> Edmon
> 
> 
> 

This is not true!  As a Chinese, I do want my hostname to go to the same
place
no matter what the system, either BIG5, GBK, or Unicoded, I've happent to

have at hand! This is the whole point of the IDN.  If I want two places,
I can
take care of that by registering at two places.

Liana

---

From: "Edmon" <[email-masked]>
Date: Fri, 10 Aug 2001 06:33:05 -0400

----- Original Message -----
From: <[email-masked]>
> If I want two places, I can

That is precisely my point.  If we force SC=TC into Nameprep I wont be able
to register the TC and SC as different domains.  I dont have a choice.
Edmon