Subject: Re: [idn] Intro to my I-D

From: "ben" <[email-masked]>
Date: Wed, 1 Aug 2001 06:21:43 -0400

Hi James,

After reading ONE-C as you have suggested, I would like to add a 3rd
benefit to my Supreme system (the draft will be released on Aug 14th):

Benefit C-  A mechanism to match the meaning of the user's input (of
CDN) to the intended meaning of the registrant's CDN thus acting
almost like a "Onomastic Normalization Engine" for the Chinese
language as decribed by the document:
http://playground.i-dns.net/one/onec_sum.htm

(By the way, I can't say that the mechanism will cover everything
described by the "Onomastic Normalization Engine", but it will
certainly be a very good attempt at it.)

Thanks
Ben Chan

----- Original Message -----
From: "James Seng/Personal" <[email-masked]>
To: "ben" <[email-masked]>; "Eric Brunner-Williams in Portland Maine"
<[email-masked]>
Cc: <[email-masked]>
Sent: Monday, July 30, 2001 11:01 PM
Subject: Re: [idn] Intro to my I-D

Ben,

Wearing my i-DNS.net hat, there is a research work we been doing on
Onomastic Normalization Engine (ONE) for Chinese, Japanese and Korean
for registration purposes.

For your I-D on Chinese, maybe it is worthwhile for you to take a look
at ONE-C. You can find it at
http://playground.i-dns.net/one/onec_sum.htm

-James Seng

----- Original Message -----
From: "ben" <[email-masked]>
To: "Eric Brunner-Williams in Portland Maine" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, July 30, 2001 9:17 PM
Subject: Re: [idn] Intro to my I-D

> Hi Eric,
>
> As you are probably somewhat aware, I am indeed working very hard.
I
> want you to know that I am keeping all your questions /input in the
> back of my mind as I work and that can only help.  So I just want to
> thank you for all your efforts.
>
> The only question I want to address at this moment is something that
> caught my eye.  At the very end of your email below, you concluded
by
> saying- "Just what makes your proposal superior?".  Perhaps this is
a
> good time to reiterate what I said at the very beginning:
>
> My system recognizes the same equal importance for:
>
> 1.  Registrants given the freedom/choice to point Tradition CDN to
> tradition website and Simplifed CDN to simplified website.
> 2.  A need for Tradition CDN to Simplified CDN conversion.
>
> (However, I also believe that other CDN systems are absolutely fine
> exactly the way they are.)
>
> Thanks
> Ben Chan
>
>
>
> ----- Original Message -----
> From: "Eric Brunner-Williams in Portland Maine"
<[email-masked]>
> To: "ben" <[email-masked]>
> Cc: "xiang deng" <[email-masked]>; <[email-masked]>;
> <[email-masked]>; <[email-masked]>; <[email-masked]>;
> <[email-masked]>; <[email-masked]>
> Sent: Sunday, July 29, 2001 11:17 AM
> Subject: Re: [idn] Intro to my I-D
>
>
> [I've added [email-masked] back to the cc'd list.
>  Harald, please read and reconsider the "principle of least
surprise".
>  Thx.]
>
> Ben,
>
> What you've proposed is that for some collection of code-points, and
> for
> some equivalency rules (whether zone-scoped or global-scoped),
> allocation
> of one code-point in the collection results in pre-allocation
> (reservation)
> of all code-points in the collection.
>
> Additionally, you've proposed the registrant (recipient of the
> allocated
> code-point equivalency class) may then modify the equivalency rule
> which
> created the class, and assert distinct semantics for distinct
elements
> of
> the original (intact), now fragmented class.
>
> To help me understand your proposal, I'll consider ASCII strings and
> the
> Pan-Algonquin "OU" character (U+0222) and (U+0223). A locally
> constructed
> French character, not present in 17th century French. I know that
most
> of
> the North Americans and Europeans will find this choice strange, but
> more
> accessible, as "Indian French", than an ideogramatic example, and I
> know
> that my friends at CNNIC will speak to the Chinese language
specifics.
>
> Assertion: (zone scope)
>
> In the Algonquin-preferred zone(s), e.g., abenaki.dst.me.us,
> the following code-points and code-point sequences are
> equivalent:
> U+0070 "8" when in an alpha-string
> U+0222 "8" LATIN CAPITAL LETTER OU
> U+0223 "8" LATIN SMALL LETTER OU
> U+0117,U+0125 "OU"
> U+O117,U+0165 "Ou"
> U+0157,U+0165 "ou"
> U+0127 "W"
> U+0167 "w"
>
> Under your proposal, in my zone (abenaki.dst.me.us.), with ASCII
case
> folding
> (applied to the two Latin Extended-B code points), the registrant
for
> "ki8na.abenaki.dst.me.us" ("ki8na" means ourselves or nous-memes),
> would be
> allocated or reserved:
>
> ki{set of 4 code-point sequences}na.abenaki.dst.me.us
>
> The registrant could then be able to associate between 0 and eight
> unique
> ip addresses to these 4 allocated domain names in my zone, e.g.,
>
> ki(U+0070)na.abenaki.dst.me.us and 1.2.3.1
> ki(U+0222)na.abenaki.dst.me.us and 1.2.3.2
> ki(U+0223)na.abenaki.dst.me.us and 1.2.3.2
> ki(U+0117,U+0125)na.abenaki.dst.me.us and 1.2.3.3
> ki(U+O117,U+0165)na.abenaki.dst.me.us and 1.2.3.3
> ki(U+0157,U+0165)na.abenaki.dst.me.us and 1.2.3.3
> ki(U+0127)na.abenaki.dst.me.us and 1.2.3.4
> ki(U+0167)na.abenaki.dst.me.us and 1.2.3.4
>
> Without case folding there could be 8 distinct addresses rather than
> just 4.
>
> This would be very surprising to a modern literate North-Eastern
> Indian, and
> to scholars of the Contact Period and French and Indian literatures
of
> the
> 17th and 18th centuries. As the abenaki.dst.me.us zone manager, I
> don't think
> I would allow it. I would expect the equivalency rule (above) to be
> adopted
> by the {penobscot,passamquoddy,maliseet,micmac}.dst.me.us zone
> managers, and
> by other "Algonquin-aware" NSN.US zone managers. I would not expect
> these to
> be adopted by the dst.me.us or superior zone managers. I would
expect
> the same
> rule and scope to exist in the .ca zone and its dependent zones.
>
> My preference is that ki{set of 4 code-point
> sequences}na.abenaki.dst.me.us
> all map to a single internet address.
>
> In the Chinese language area, which includes North America as well
as
> China,
> your "registrant election" proposal appears to have the same
> surprising set
> of consequences as one registrant following one ideosyncratic
> convention for
> "ki8na" and another registrant, possibly the same one, following a
> different
> ideosyncratic convention for "ni8na" (we and you or nous et vous),
and
> this
> only gets worse as we consider strings such as k8sk8ranmsh8dans8
> (sift).
>
> Just what makes your proposal superior?
>
> Eric
>
> P.S. The advantage of [30], formerly "in" the IDN WG requirements
> draft, was
> that it made zone-specific semantics possible. Writing in modern
> Abenaki (or
> any "8" using French-originating modern script) using ASCII
> equivalency rules
> presents a problem for 0x70 to 0x127,0x167 mapping (simplest case).
>
>

---

From: "James Seng/Personal" <[email-masked]>
Date: Wed, 1 Aug 2001 18:57:24 +0800

Sure, I look forward to your I-D.

Our (as in i-DNS.net) approach have been working on Onomastic
Normalization Engine for registration time to handle possible multiple
names since Nov last year. The work on ONE turns out to be much more
complex and time consuming then originally expected. And there is
different ONE for each language (See ONE-J and ONE-K at
http://playground.i-dns.net/one/index.html).

If you have a better approach, I would love to see it.

*cheers*

-James Seng

----- Original Message -----
From: "ben" <[email-masked]>
To: "James Seng/Personal" <[email-masked]>; "Eric Brunner-Williams in
Portland Maine" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, August 01, 2001 6:21 PM
Subject: Re: [idn] Intro to my I-D

---

From: "ben" <[email-masked]>
Date: Wed, 1 Aug 2001 09:34:13 -0400

If after reading my draft, i-dns.net or anybody else thinks that it is
a good idea... please feel free to implement my idea as I will only be
so honoured / honored.

Thanks
Ben Chan

----- Original Message -----
From: "James Seng/Personal" <[email-masked]>
To: "ben" <[email-masked]>; "Eric Brunner-Williams in Portland Maine"
<[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, August 01, 2001 6:57 AM
Subject: Re: [idn] Intro to my I-D

*cheers*

-James Seng