Subject: Re: [idn] Question for the Kanji & Hanja cognosentee

From: [email-masked]
Date: Thu, 16 Aug 2001 21:18:31 -0700

That is a good news.  I hope to hear more comments
and more frequent from any non-English languages 
users.

By the way, how do you Romanize a word containing
Kanji and Kana?

Liana Ye

On Fri, 17 Aug 2001 11:31:46 +0900 "Bruce Thomson"
<[email-masked]> writes:
> SC are not used in Kanji, and the folding is not particularly
> useful for Japan. In practice it would mean that registering
> a Kanji (TC) name in Japan would block the SC equivalent
> from being registered in China, and vice versa. From the
> Japanese perspective, excepting big multinational corporations,
> this is counterproductive, as it just reduces the number
> of names available.
> 
> ----- Original Message ----- 
> From: "Eric Brunner-Williams in Portland Maine" 
> <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, August 17, 2001 6:12 AM
> Subject: [idn] Question for the Kanji & Hanja cognosentee
> 
> 
> > 
> > >                                      ...  this would means 
> languages
> > > which uses Chinese script (like kanji and Hanja) would also do 
> the
> > > same (TC/SC) folding.
> > 
> > Does anyone know what this might mean?
> > 
> > SC/TC equivalence in Kanji? In Hanja??
> > 
> > Eric
> > 
> > 
> 
>

---

From: "Bruce Thomson" <[email-masked]>
Date: Fri, 17 Aug 2001 15:15:58 +0900

> By the way, how do you Romanize a word containing

There are two steps:

1) Convert all Kanji to kana. Anything that can be pronounced
in Japanese can be expressed as the kana equivalent of that
pronunciation. However, Kanji cannot be converted one at a time
as many words are unique combinations of Kanji with special
pronuncations. Also, there can be multiple pronunciations for the
same Kanji string.

2) Once you have everything in kana, convert to "Romaji"
(Romanized characters) using the Hepburn system. Here
are the Romaji equivalents of all the modern kana:

a  i  u  e  o
ka ki ku ke ko
sa shi su se so
ta chi tsu te to
na ni nu ne no
ha hi fu he ho
ma mi mu me mo
ya yu yo
ra ri ru re ro
wa wo
n

There is a further complication in that a small kana
tsu is used to represent a double consonant when
a word is written as kana, whereas the consonant
is merely written twice in the Romaji equivalent.

By the way, Japanese keyboard input is usually
handled by typing Romaji which can then be
converted to kana and further converted into
Kanji.

http://www.omniglot.com/writing/japanese.htm
http://www.kanjisite.com/wak1.html