Subject: Re: [idn] opting out of SC/TC equivalence

From: [email-masked]
Date: Fri, 31 Aug 2001 22:50:45 -0700

Let me answer your simple question.  Would you 
please tell me where this situation occur?

If it is in [nameprep], it is an error, reject it.

Liana

On Fri, 31 Aug 2001 14:56:38 +0200 Harald Tveit Alvestrand
<[email-masked]> writes:
> 
> 
> --On 31. august 2001 20:46 +0800 
> "=?utf-8?B?dHNlbmdsbUDoqIjntrLkuK3lv4Mu5Lit5aSnLnR3?=" 
> <[email-masked]> wrote:
> 
> >> The problem is that such a table doesn't seem to exist. I have 
> seen in
> >> one draft (as Harald points out) a table with approximately 2000
> >> characters
> > out
> >> of the 20-40000 which exists. Harald have asked valid questions 
> about
> >> what to do with the other characters.
> >>
> >       If you ask an expert of chinese language to give you this 
> "completed
> > table", it will be never delivered , because the characters are in 
> an open
> > set. Even we use chinese, we just use not more than 8000 
> frequently used
> > characters in our newspaper . So no one will answer this 
> impossible
> > problems.
> 
> Please then answer a simpler one:
> 
> When the matching algorithm you envision encounters a character 
> where the 
> tables do not tell what to do about it, what will the algorithm do 
> to it?
> Pass it through unmodified? Reject it? Does something else which you 
> have 
> not defined yet?
> 
> If you tell us this, and claim that this is acceptable treatment of 
> the 
> 20-40.000 characters not in the tables, we can at least discuss this 
> 
> proposal (whether such a partial TC/SC mapping is acceptable), 
> instead of 
> asking again and again what to do about them.
> 
> But it is impossible to implement an algorithm which says "this part 
> will 
> be worked out later".
> 
>                   Harald
>

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Sat, 01 Sep 2001 18:37:56 +0200

> If it is in [nameprep], it is an error, reject it.

so you are saying that any Han character encountered in Nameprep for which 
TC/SC mapping has not been defined should cause the query to be rejected?

I am surprised.

---

From: Jack Halpern <[email-masked]>
Date: Sun, 02 Sep 2001 23:16:29 -0500

Hi, 

I am new to this group. This is just a quick introduction. I am the CEO of the 
The CJK Dictionary Institute (near Tokyo), which specialized in the development
of large-scale CJK lexical databases (see http://www.cjk.org/ for details).

For the last five yars we have been involved in intense research on SC<>TC
conversion, and I have written a detailed paper that may be useful to the current
debate on the subject. Please see:

                    http://cjk.org/cjk/c2c/c2centry.htm

Regards, Jack Halpern
	President, The CJK Dictionary Institute, Inc. 
        http://www.cjk.org Phone: +81-48-473-3508