Subject: Re: [idn] proposed i18n naming rules

From: liana Ye <[email-masked]>
Date: Wed, 21 Nov 2001 14:39:58 -0800

Hi, Ben:
If the Chinese full stop is an legal character in IDN, 
it has to be in [nameprep] profile and is equivalented
 to an ASCII dot.  If IDNA only deals with  a label,
that is a string of LDH, between dot/slash/!/#/@/% and 
whatever, then the Chinese full stop will function 
as a key element to flag a label.  So, if such an 
flag appears within a label, then one label becomes 
two labels, ie.  <zhongguo>.com becomes 
<zhong>.<guo>.com,  we have trouble.   

When we deal with TC/SC for a IDN label, the punctuations
have to be excluded.  But about circled characters,
they have similar processing property with Latin letters 
which have diacritic marks on them, where the only 
differences is circled characters in UCS mostly CJK 
characters, and CJK characters are taboo to talk about
in many WG members' mind.

Liana 

On Wed, 21 Nov 2001 15:17:46 -0500 "ben" <[email-masked]> writes:
> >
> > All other IDNs would fall under the IDN rules. This includes SRV
> entries
> > in the DNS, email addresses stored in SOA and RP RRs (which can
> contain
> > FULL STOP, among others), and so forth.
> >
> 
> Since we are on the subject of "full stop", I remember that it was
> brought up some time ago that the "Chinese full stop" should serve 
> the
> same purpose as the "English full stop"- from what I can tell, it
> currently appears to be still an illegal character.  This certainly 
> is
> indeed an important issue for users of CDNs and hopefully, this
> problem can be address at the same time.
> 
> For example, CDN users can easily type in <whatever>。TLD (instead 
> of
> <whatever>.TLD) and have no clue why he gets an error.
> 
> Thanks,
> Ben Chan
> 
> 
> 
> 
> 
>

---

From: "ben" <[email-masked]>
Date: Wed, 21 Nov 2001 19:35:42 -0500

Hi Liana,

From: "liana Ye" <[email-masked]>
> have to be excluded.  But about circled characters,

Can you explain why you say, "we have trouble"?  Is there a need for
the "Chinese full stop" to serve another purpose other then to act as
a label seperator?

Thanks,
Ben