Subject: Re: Combining characters (was: Re: [idn] hostname historyhell)

From: vint cerf <[email-masked]>
Date: Thu, 22 Nov 2001 13:13:56 -0800

Eric, et al,

I have been observing the vigorous discussion and
appreciate the hard work going on here.

A key element is the purpose for domain names. Are they
just host names or are they labels into information space?
Of course their origin is the former but they seem to have
morphed into something rather more elaborate.

The discussion you are having is very important both for
the future of Internet applications and generally for the
stability and consistency of the DNS itself.

Vint

At 10:33 AM 11/22/2001 -0600, Eric A. Hall wrote:

>"Eric A. Hall" wrote:
>
>> The specific concern I had is already addressed in nameprep so there
>> is no need for the exception.
>
>What I am concerned with is the use of domain name which consist
entirely
>of punctuation, or in this case, which consist entirely of combining
>marks. These represent a rules problem with the principles behind the
>"safe-set". EG, we forbid domain names like ````````.com using U+0060,
but
>````````.com may be legal if the combining character U+0300 is used
>instead.
>
>I get lost in the shrubbery of specs, so can somebody tell me whether
or
>not this is a valid concern? I can't tell for certain what happens at
the
>end of nameprep with such a label.
>
>If this is a problem, a solution might be to change the prohibition
>against leading hyphen to a prohibition against leading hyphen and
>combining characters.
>
>--
>Eric A. Hall
http://www.ehsco.com/
>Internet Core Protocols
http://www.oreilly.com/catalog/coreprot/

---

From: "Tim Langdell" <[email-masked]>
Date: Sat, 24 Nov 2001 08:48:19 -0800

Vint,

Thank you. Might you possibly give us a little more insight into how you
feel about the direction the discussion is going? And perhaps more of your
thoughts on the issue(s)?

Tim