Subject: Re: Combining characters (was: Re: [idn] hostname historyhell)

From: liana Ye <[email-masked]>
Date: Thu, 22 Nov 2001 14:48:02 -0600

Hi, Vint:

  Thanks for the encouragement, and I'd like to 
propose a more specific layering of IDN symbols:

From the top where the user input buffer offers:

 Layer 3:  label seperators and label order normalizing

 Layer 2: Bidi label normalizing (or verticle label normalizing)

 Layer 1.5: diacritic marks and combining symbol normalizing

 Layer 1:  IDN identifier matching or whatever comes out 
               of [nameprep].

The reason for Layer 1.5 is that these symbols can be 
treated in a similar way with Han characters depending on 
what architecture we end up with, and what ACE will be 
our focus. 

Liana

On Thu, 22 Nov 2001 13:13:56 -0800 vint cerf <[email-masked]>
writes:
> Eric, et al,
> 
> I have been observing the vigorous discussion and
> appreciate the hard work going on here.
> 
> A key element is the purpose for domain names. Are they
> just host names or are they labels into information space?
> Of course their origin is the former but they seem to have
> morphed into something rather more elaborate.
> 
> The discussion you are having is very important both for
> the future of Internet applications and generally for the
> stability and consistency of the DNS itself.
> 
> Vint
> 
> At 10:33 AM 11/22/2001 -0600, Eric A. Hall wrote:
> 
> >"Eric A. Hall" wrote:
> >
> >> The specific concern I had is already addressed in nameprep so 
> there
> >> is no need for the exception.
> >
> >What I am concerned with is the use of domain name which consist
> entirely
> >of punctuation, or in this case, which consist entirely of 
> combining
> >marks. These represent a rules problem with the principles behind 
> the
> >"safe-set". EG, we forbid domain names like ````````.com using 
> U+0060,
> but
> >````````.com may be legal if the combining character U+0300 is used
> >instead.
> >
> >I get lost in the shrubbery of specs, so can somebody tell me 
> whether
> or
> >not this is a valid concern? I can't tell for certain what happens 
> at
> the
> >end of nameprep with such a label.
> >
> >If this is a problem, a solution might be to change the prohibition
> >against leading hyphen to a prohibition against leading hyphen and
> >combining characters.
> >
> >--
> >Eric A. Hall
> http://www.ehsco.com/
> >Internet Core Protocols
> http://www.oreilly.com/catalog/coreprot/
> 
> 
> 
>

---

From: "Eric A. Hall" <[email-masked]>
Date: Sun, 25 Nov 2001 11:42:48 -0600

liana Ye wrote:

> I'd like to propose a more specific layering of IDN symbols:
> 

What is the current display order for unstructured and structured data in
right-to-left display systems? Does unstructured data ("the files are on
server1") typically flow RTL, while URLs and other structured data display
as LTR?

It seems that these questions are for the structured data groups to handle
when they decide on an output presentation mechanism. But if URLs and
other structured types will display RTL then that may affect us as well
(your Layer 3 label ordering in particular).

-- 
Eric A. Hall                                        http://www.ehsco.com/
Internet Core Protocols          http://www.oreilly.com/catalog/coreprot/