Subject: Re: [idn] SUMMARY: reordering strawpoll

From: liana Ye <[email-masked]>
Date: Wed, 21 Nov 2001 01:40:51 -0800

My interpretation is the people who are familar with
 Chinese character processing is used to frequence
based methods and love the benefit Reordering is
providing. 

Liana

On Wed, 21 Nov 2001 01:08:48 +0800 "James Seng/Personal"
<[email-masked]> writes:
> Yoneya-san,
> 
> Thanks for posting the strawpoll summaries.
> 
> Remember, strawpoll is not a vote. the number in itself (21 or 30) 
> only
> means something depending on our interpretion.
> 
> So Kenny, let me ask the question back to you :-) What do you think 
> this
> statistic means?
> 
> -James Seng
> 
> ----- Original Message -----
> From: "Kenny Huang" <[email-masked]>
> To: "Yoshiro YONEYA" <[email-masked]>; <[email-masked]>
> Sent: Tuesday, November 20, 2001 5:32 PM
> Subject: RE: [idn] SUMMARY: reordering strawpoll
> 
> 
> What does the statistics mean ?
> 
> Kenny Huang
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On
> > Behalf Of Yoshiro YONEYA
> > Sent: Tuesday, November 20, 2001 5:18 PM
> > To: [email-masked]
> > Subject: [idn] SUMMARY: reordering strawpoll
> >
> >
> > On behalf of counters, I report the summary of reordering 
> strawpoll
> > done during Nov 12-16.
> >
> > There were 55 mail in total during the period, and 2 were from the
> > same, so 53 were valid.  Following list shows senders' domain 
> names.
> >
> > NO: 30 (there were 32 NO but 2 were duplicated)
> > aist.go.jp
> > alldomains.com
> > bic.nus.edu.sg
> > cequrux.com
> > cs.com
> > dsl.gr.jp
> > enic.cc
> > extundo.com
> > fm-net.ne.jp
> > goto.info.waseda.ac.jp
> > imc.org
> > ItsYourDomain.Com
> > jprs.jp
> > jprs.jp
> > linux.or.jp
> > macchiato.com
> > md.chalmers.se
> > microsoft.com
> > nic.ad.jp
> > nominum.com
> > po.ntts.co.jp
> > pobox.org.sg
> > pobox.org.sg
> > realnames.com
> > sra.co.jp
> > verisign.com
> > verisign.com
> > w3.org
> > zetnet.co.uk
> > sharif.edu
> >
> > YES: 21
> > cc.ncu.edu.tw
> > cnnic.net.cn
> > cnnic.net.cn
> > cnnic.net.cn
> > gate.sinica.edu.tw
> > iis.sinica.edu.tw
> > iis.sinica.edu.tw
> > mail.moe.gov.tw
> > ms1.url.com.tw
> > nic-naa.net
> > nic.or.kr
> > ports.se
> > postel.co.kr
> > sinica.edu.tw
> > spsoft.co.kr
> > twnic.net.tw
> > twnic.net.tw
> > twnic.net.tw
> > twnic.net.tw
> > whale.cnnic.net.cn
> > whale.cnnic.net.cn
> >
> > ABSTAIN: 2
> > lysator.liu.se
> > switch.ch
> >
> > --
> > Yoshiro YONEYA <[email-masked]>
> >            aka <[email-masked]>
> >
> > ----
> > From: "James Seng/Personal" <[email-masked]>
> > Subject: [idn] reordering strawpoll
> > Date: Mon, 12 Nov 2001 18:35:49 +0800
> >
> > > The working group co-chairs would like to conduct a strawpoll to
> > > guage the consensus of the working group on reordering
> > > 
> http://www.ietf.org/internet-drafts/draft-ietf-idn-lsb-ace-02.txt
> > >
> > > Instructions:
> > > - Send an email to [email-masked]
> > > - In your subject, put a single word "YES", "NO", or "ABSTAIN"
> > > - Leave your body empty. Any text in body will be ignored.
> > >
> > > The strawpoll will conclude on 16th Nov 23:59 GMT. Counting will 
> be
> > > done by wg members, Yoshiro Yoneya, Yves Arrouye, Dave Crocker 
> and
> > > the co-chairs, Marc Blanchet & James Seng. The result of the 
> poll
> will
> > > be made public after we tally the count.
> > >
> > > --- STRAWPOLL QUESTION ---
> > > Do you agree to include reordering (draft-ietf-idn-lsb-ace) into
> > > NAMEPREP-ACE architecture?
> > >
> > > ---- YES -----: mailto:[email-masked]?Subject=YES
> > > If you say 'yes', then you agree to include reordering into
> > > NAMEPREP-ACE architecture.
> > >
> > > The implication of 'yes' result is that draft-ietf-idn-lsb-ace 
> will
> be
> > > added into NAMEPREP-ACE architecture
> > >
> > > ----- NO -----: mailto:[email-masked]?Subject=NO
> > > If you say 'no', then you disagree to include reordering into
> > > NAMEPREP-ACE architecture.
> > >
> > > The implication of 'no' result is that draft-ietf-idn-lsb-ace
> > > will be dropped from the wg core interest.
> > >
> > > --- ABSTAIN ---: mailto:[email-masked]?Subject=ABSTAIN
> > > If you say 'abstain', then you are happy with either 'yes' or 
> 'no',
> > > following the majority opinion.
> > >
> > > --- SILENT ----: Of course, you may choose to remain silent.
> 
> 
> 
>

---

From: "James Seng/Personal" <[email-masked]>
Date: Wed, 28 Nov 2001 13:44:43 +0800

Thanks Liana.

I hope there are more discussion on this because we certainly cannot
leave this hanging so I am going to post my personal views.

There are few ways we can read this. For example,
1. purely numbers, ie 30 vs 21 vs 2.
2. by group of people, ie many people disagree vs one group of people
   with some individual who wants it

You may insert other ways to read it.

At the minimual, I think it is very safe to say we do not have consensus
to add reordering to NAMEPREP-ACE, either from basic reading of the
numbers or intepretion of the numbers.

-James Seng

---

From: "Bruce Thomson" <[email-masked]>
Date: Thu, 29 Nov 2001 10:52:24 +0900

Obviously the strawpoll was split nearly 100% by country, with
China, Taiwan, and Korea in favor, and everyone else including
Japan opposed.

Personally I am in favor of dropping the whole thing, but it is
disturbing that everyone voting in the strawpoll from those three
countries voted in favor...

It is even possible to consider the compromise solution of
having reordering only apply to scripts from those three
countries only, except that presumably there is no way
to do that without having it apply to Japanese as well. The
Japanese will not like this, I think.

Therefore I would like to hope that the people from those
3 countries reconsider, and let us drop reordering from the
spec. We have a hard time as it is producing something
deliverable, and the gains of reordering are not really going
to make the end user notice a difference.

Bruce

---

From: "James Seng/Personal" <[email-masked]>
Date: Fri, 30 Nov 2001 22:58:56 +0800

Thanks Bruce for sharing your views.

Is it possible to hear from some folk from .tw and .cn who has say YES
and what you think of Bruce comments?

-James Seng

----- Original Message -----
From: "Bruce Thomson" <[email-masked]>
To: "IETF idn working group" <[email-masked]>
Sent: Thursday, November 29, 2001 9:52 AM
Subject: Re: [idn] SUMMARY: reordering strawpoll

> > > > > > --- ABSTAIN ---:
mailto:[email-masked]?Subject=ABSTAIN

---

From: Eric Brunner-Williams in Portland Maine <[email-masked]>
Date: Fri, 30 Nov 2001 12:23:41 -0500

Someone, possibly neither Bruce Thomson nor Liana Ye, at some prior point in
time wrote that the purpose of the chairs in conducting a poll was:

	...
	to guage the consensus of the working group on reordering
	...

The question set was:

	Do you agree to include reordering (draft-ietf-idn-lsb-ace)
	into NAMEPREP-ACE architecture?

I sent a poll reply, which the poll takers recorded, and I think that Bruce's
comments on the subject are uninteresting as any that could be offered on the
analysis of mailing addresses of a set of IETF contributors.

The draft is self-explanitory, no justification is offered, nor is necessary.

If the chair failed to understand the draft, and is seeking clarification, or
if the working group failed to understand the draft, and the chair is seeking
clarification, then that is an appropriate query to send to the authors.

There is no consensus on reordering in the NAMEPREP-ACE architecture, and a
course of action is to construe a meaning that reording is "out", another 
course of action is to construe a meaning that reordering is "in". Neither
is especially consistent with this straw poll's data, nor consensus as a
process.

Can the editors of the affected documents accommodate both reordering and
no-reordering in the same documents from this point forward? I think this
is the better question, rather than trying to finesse "the right answer"
by proxy.

If yes, then the working docs delta with consequences (e.g., [30] comes back).
If no, then the working docs branch into disjoint and seperate trees with
consequences (e.g., "this assumes lsb" and "this assumes no lsb"), and each
proceeds to WG-LC, IESG review, and IETF-wide-LC, and whatever status, and
deployment future lies ahead, for each, both, or neither.

Eric

---

From: David Hopwood <[email-masked]>
Date: Fri, 30 Nov 2001 22:07:02 +0000

-----BEGIN PGP SIGNED MESSAGE-----

Bruce Thomson wrote:
> countries only,

That doesn't solve anything; the people arguing against reordering
were arguing on grounds that would still hold if it were only applied
to Han ideographs and Hangul.

> except that presumably there is no way

That's not an issue: the disadvantages apply if reordering is used at
all, not to specific languages.

> deployment future lies ahead, for each, both, or neither.

This idea is totally without merit. None of the proposed IDN protocols
work if there are two ways to do ACE encoding, and not specifying which
will be used would be disastrous for interoperability.

Since the current specification for the concensus ACE algorithm
(draft-ietf-idn-amc-ace-z-01.txt) does not include reordering, and there is
no concensus on adding it, that document should remain as it is. (If AMC-Z
is used, that is the only document that depends on a decision about
reordering.)

- -- 
David Hopwood <[email-masked]>

Home page & PGP public key: http://www.users.zetnet.co.uk/hopwood/
RSA 2048-bit; fingerprint 71 8E A6 23 0E D3 4C E5  0F 69 8C D4 FA 66 15 01
Nothing in this message is intended to be legally binding. If I revoke a
public key but refuse to specify why, it is because the private key has been
seized under the Regulation of Investigatory Powers Act; see www.fipr.org/rip

---

From: Eric Brunner-Williams in Portland Maine <[email-masked]>
Date: Fri, 30 Nov 2001 18:33:03 -0500

David,

At this point, there isn't even _one_ way that is experimental, informational,
draft standard, or standard. The shibboleth of interoperability is reasonable
to raise, when, even if, we get to one "standard" (other than ASCII-as-ASCII).

Could we, using the rational offered, fix the requirements draft? Someone
(guess who) is rather likely to claim there is consensus for the current
draft as is. Ergo, it can never be fixed, even if 21 contributors ask nicely.

Personally I don't think that first-come, first-served works well enough to
bother with in consensus-rigging. Taken in self-evident bad faith, it leads
to rubber-stamps, and premature versioning. If you want to observe that there
was consensus prior to there not being consensus, and therefore that there is
consensus, be my guest. Fixing the process is in 2026, and anyone can assert
that something we could have fixed _in_ the working group, must be fixed _in_
the IESG, (or the IAB), or not in the IETF at all. Longer route, same end.

I like the style of "This idea is totally without merit." Feel free to use it
again in the future.

> is used, that is the only document that depends on a decision about

Cheers,
Eric