Subject: Re: [idn] SUMMARY: reordering strawpoll

From: liana Ye <[email-masked]>
Date: Mon, 3 Dec 2001 23:28:58 -0600

On Mon, 3 Dec 2001 10:37:17 -0600 liana Ye <[email-masked]> writes:
> James:
> 
>    To be more theoretic in the sense of architecture design 
> of  IDN from the straw poll, I would add a few more comments.  
> 
>   The conventional programming is into procedural approach,
> so does the IEFT standard works.  When we look at UCS
> as a mass of data, we may say that is the problem for UTC
> to deal with. 
> 
>   The fact is as has been discussed on the list for the last 
> (how many months?) months, there is no solution in this
> type of approach.  
> 
>  The straw poll has shown a complete different approach
> in dealing with the data-mass type of problem, or I make 
> it more stylish by saying data-centric programming 
> techniques.  As the author has been saying, it can be 
> adopted to different requirements according to whatever 
> the specifics come up.  
> 
> The straw poll has shown:
>    There is consistent experiences in dealing with CJK by 
> only looking at CJK as data-centric problem.  This is consistent 
> with UTC experiences, and we are talking about more than 
> 100 scripts instead of only 3 scripts. 
> 
> I am about to lunch into another area from this point.  I'll 
> wait for feed-backs (instead of disbute) before I continue.  
> Again, no feed-backs means no disbute to the above 
> comments.

For dealing with Chinese characters the only effective way 
is to looking at the set of data and find some commonality
and treat them by differrent sets of rules. The most effective 
rule is to define TC/SC equivalent set for CJK servers to be 
unified and act consistently.  Once the 85% of the code 
points settled, then we can deal with the 10% and then 
the 5% which adds up to 100%.  Where the 10% and 5%
may be treated separetly by independent language rules.

I am pulling out three layers without justificantion.  But
this is the model in all the Han character processing 
programs I have knowledge of.  Welcome anyone's 
comment on this.  It does not change no matter where 
you tuck it to.  We argue for the 85% codepoints to be deal 
with in the first layer is to laydown the foundation for 100% 
TC/SC solution, which include Japanese Kanji.

Does this has anything to do with reordering?   
If this group has a clear idea on how to deal with 
CJK, what the IDN system is going to look like, then the 
decision can be made.  If we don't even have an agreeable 
architecture I-D to discuss CJK yet, I don't see how we
can make final decision on reordering.  

Liana

---

From: "James Seng/Personal" <[email-masked]>
Date: Tue, 4 Dec 2001 21:39:59 +0800

Liana,

I would appreciate if you can keep things in focus and not mixed various
issues of IDN together. reordering is reordering. TC-SC is TC-SC. CJK is
CJK. Please dont mixed them into a pot and try to talk about them
together.

We are now on the topic of reordering. The strawpoll is done. Now we are
discussing next step. So if you have any views on the next step on
reordering, then please provide them, without the comments of CJK etc.

Thanks.

-James Seng