Subject: Re: Layer 2 and "idn identities" (was: Re: [idn] what are the IDN identifiers?)

From: [email-masked]
Date: Sun, 2 Dec 2001 18:51:02 EST

Liana wrote:

> Please provide your reasoning.

Certainly, and I apologize for the tone of my previous post.

1.  I did NOT agree with the concept of language tagging or script tagging of 
DNS identifiers, either for all scripts or for just a subset of scripts such 
as CJK; and I HAVE said so in the past.  DNS "names" are identifiers, and 
they are *not* necessarily words or true "names" in any natural language.  I 
mentioned the examples of "altavista.com" and "teoma.com" to show that domain 
names need not be identifiable as to language.  Liana responded that it was 
not necessary to identify the language of those two examples, since they were 
unambiguously representable in the Latin script, whereas domain names encoded 
with CJK characters could be mappable to other CJK characters.  But I, and 
others, HAVE stated many times that to provide a SC/TC mapping strategy that 
works for some characters but not others, and could provide some nasty 
surprises for Japanese users who do not equate these characters as the 
Chinese do, does not seem to be a viable part of IDN.  It might be a nice 
marketing solution, but it is not an engineering solution.

2.  I did NOT agree that, had I and others remained silent about the proposed 
language-tagging scheme (which was not true in any event), this would have 
amounted to some sort of approval of the idea; and I DID say so.  Others on 
this list, who have far more experience than I in IETF working groups, have 
stated that this is not the way IETF WGs operate.  Consensus is more commonly 
gauged using straw polls or by compiling lists of participants in favor of 
the idea and opposed to the idea, not by "pocket acceptance."

Having said this, I understand that Liana was trying to demonstrate approval 
of continuing the discussion, not necessarily approval of the idea itself, 
and I don't want to be in the position of trying to pre-empt the introduction 
of new ideas.  So I suppose it wouldn't hurt to look at the I-D, see what we 
think of it, and make our opinions known at that point.  But it is NOT the 
case that "nobody disputed" either this point or (1) above, and to say so 
made it seem like the author was merely ignoring opposing voices.

In a message dated 2001-12-01 20:05:03 Pacific Standard Time, 
[email-masked] writes:

> On Sat, 1 Dec 2001 21:04:13 EST [email-masked] writes:
>
>> In a message dated 2001-12-01 16:35:38 Pacific Standard Time, 
>> [email-masked] writes:
>>
>>> Since nobody disbute with me, I take it as we are agree to
>>> the above discussion.   I'd like to refer to my  I-D 
>>> draft-liana-idn-map-00.txt  for more discussion in this 
>>> direction.
>>
>> I absolutely DID dispute both the notion of language-tagging of IDN 
>> identifiers *and* the notion of tacit agreement to a non-consensus 
>> idea.  But 
>> I guess that wasn't the answer the author was looking for.
>
> Please provide your reasoning.

-Doug Ewell
 Fullerton, California

---

From: "xiang deng" <[email-masked]>
Date: Mon, 3 Dec 2001 11:13:38 +0800

> marketing solution, but it is not an engineering solution.

Thanks for your comments.

About the "SC/TC mapping strategy ", JPNIC,KRNIC,TWNIC,CNNIC had reach
consensus in 7th JET meeting in Beijing. So the "validation" was introduced.

The SC/TC is a real requirement from CDN users.  Current IDN profile causes unpredictable
resolving problem, vast registrating problem and registration disputaion problem of CDN.  All
of these will be suffered by CDN users in the end.

I'm not sure the difference of "marketing solution" and "engineering solution" you mentioned.
I'm try to assume I know it. So, if a reasonable requirement raise from end users, we should
find a theorized solution(engineering solution) to meet the requirement. Then we put it into 
practice(marketing solution) and adjust the improper parts. And, real solution rises. 

Regards.
Deng xiang

---

From: "Bruce Thomson" <[email-masked]>
Date: Mon, 3 Dec 2001 15:07:18 +0900

Written by: xiang deng

> consensus in 7th JET meeting in Beijing. So the "validation" was introduced.

I couldn't find details of this on-line. Can you tell me more about what was discussed?

Specifically,

1) Have the codepoint equivalences been established? Or is there an easy way of doing so?

2) How do the SC/TC mappings affect Japan and Korea, if at all?

3) How long would it take for there to be a draft to look at?

---

From: "xiang deng" <[email-masked]>
Date: Mon, 3 Dec 2001 14:28:43 +0800

> I couldn't find details of this on-line. Can you tell me more about what was discussed?

The subject of this meeting is CJK issue. During the meeting, four solutions were discussed
Finally, the 4th solution was selected. According to the decision of the meeting, we modified
the I-D (draft-ietf-idn-tsconv-02.txt), and rewrote it (draft-ietf-idn-tsconv-03.txt). 

> 1) Have the codepoint equivalences been established? Or is there an easy way of doing so?

It's depended on A Complete Set of Simplified Chinese Characters and Dictionary of 
Chinese Character Variants.
And the "validation" solution is acceptable for all attendees.
 
> 2) How do the SC/TC mappings affect Japan and Korea, if at all?

The "validation" avoid the interactive influence and do the best respect to different opinion.

> 3) How long would it take for there to be a draft to look at?

We had submitted it and will send it to you off-line. If others want it, I'll happy to provide it.

Regards
Deng xiang