Subject: [idn] Please do not pass an IDN document which you know will cause conflicts and chaos

From: "Edward Chuang" <[email-masked]>
Date: Tue, 5 Feb 2002 08:37:59 +0800

I’ve recently come to know that IETF is about to release drafts on
IDN standards, and to my regret, I found that the document does not solve problems for Chinese domain names.  And this defect in your drafts
will result conflicts and chaos for Internet users of Han characters, namely Chinese, Korean and Japanese, and the effect is international because users of these languages are all over the world.

It is important to know that while a certain character can have different appearance in Simplified Chinese and Traditional Chinese Character forms even though they are actually same words with the same meaning; at the same time, a certain character which might look exactly
the same, but in fact are two different words with different meaning when applied to different languages such as Chinese and Japanese.  I believe that IETF bears great responsible in setting standards which will bring order to the Internet world, and any document which might cause disorder, should be carefully reconsidered before release.  Therefore, Before IETF can resolve this problem and identify one mechanism which can differentiate these delicate language difference, IETF should not pass the document which would apply Unicode for IDN resolution, because this irresponsible decision is going to cause conflicts and chaos in DN registration policy and DRP worldwide.

Edward Chuang
[email-masked]
Firebird BBS Project

---

From: Dave Crocker <[email-masked]>
Date: Wed, 06 Feb 2002 15:00:41 -0800

At 08:37 AM 2/5/2002 +0800, Edward Chuang wrote:
>I¡¦ve recently come to know that IETF is about to release drafts on
>IDN standards, and to my regret, I found that the document does not solve 
>problems for Chinese domain names.  And this defect in your drafts

Please review the working group email archive.  It has considered this 
topic extensively.  When you can a) provide explanation for the specific 
failures to the working group discussion, and b) a viable specification for 
solving this open research topic, there might be something to talk about.

The solution you seek can be added to registry administrative policy later.

Until then, please consider that further delay means that there is no 
standardized DNS support at all for any characters other than ASCII.

Please consider whether it is better to wait years for a perfect, complete 
solution, or whether it is better to do something useful sooner.

d/

----------
Dave Crocker  <mailto:[email-masked]>
Brandenburg InternetWorking  <http://www.brandenburg.com>
tel +1.408.246.8253;  fax +1.408.273.6464

---

From: "Soobok Lee" <[email-masked]>
Date: Thu, 7 Feb 2002 09:51:05 +0900

----- Original Message -----
From: "Dave Crocker" <[email-masked]>
> solution,

Sorry. Premature IDN solutions ,if ever issued, will last for several decades .
If just a few years of more work could give us perfect IDN solutions including TSCONV,
I'm willing to be patient living only with IDN testbed registrations or
alternative directory/search solutions which address the need for
internationalized *ACCESS* to LDH domain names. that's enough to today's
needs.

> or whether it is better to do something useful sooner.
>

Solving unresolved IDN issues using Registratation policies above IDN
doesn't remove the apparent serious problem of application-side matching failures.
Policies can guarantee the ownership by the same registrant, but cannot guarantee
the universal identifer equivalence across the entire internet and applications.

Moreover, it is not scalable in general.
disputes resolution processes or zone admin's inspections for IDN-vs-IDN and IDN-vs-LDH RR
conflicts will explode and they will consume very precious time and resources
from zone admins and end users and therefore, they are not scalable to huge zones
and the general public. Dynamic RR insertion/updates features should be turned off
for the fear of introducing new conflicting RR.

The concept of IDN itself has been challenged repeatedly.
When end users - most of them is unilingual or at most bilingual if gifted -
are exposed to exotic IDN labels, the level of confusions and difficulties
will be great but are not measured and researched sufficiently.
Even after more than one century from the invention of telephone networks,
we still have digits-only phone numbers.

Enen though this may looks somewhat drastic and ironic,
If domain names are to be truely *international*, the basic lexical atoms of the domain labels
should be remained as LDH set, the greatest common denominator of characters and scripts used by modern civilized language groups.
LDH is the true IDN, and the "IDN" that we discuss  had better be renamed to LDN (localized domain names) that have requirements to
be internationally interoperable by
machines and human beings but not satisfied.

Soobok Lee