Subject: RE: [idn] IDNs in IE and Google

From: "Michel Suignard" <[email-masked]>
Date: Thu, 22 Jan 2004 17:31:42 -0800

Concerning IRI, it is not a matter of 'preference'. If you present
something like a URI containing a host name presented in non ASCII
repertoire, you are in fact using an illegal URI per RFC2396 definition.
At minimum you need to have a clear definition on how such 'extended'
URI (in other words IRI) are mapped to legal URI. This is a big part of
the IRI draft spec currently worked on. The draft is at
http://www.ietf.org/internet-drafts/draft-duerst-iri-05.txt. The same
goes for http, and any other URI schemes presented in browser user
interface.

To come back to IE, it doesn't really process DNS directly, it only sees
them as part of URI, thus the concern above.

The fact that I am also associated with the development of the IRI spec
(although Martin Duerst from W3C does most of the work) should give you
a hint that we are not just 'waiting' for IRI.

I can't really comment on future product planning (and this isn't really
the forum for that anyway), but obviously we are looking seriously at
IDN support. For the short term, there are many plug-ins available that
could offer partial solution.

I won't comment much on your last sentence, at least you put an
emoticon, so not be taken too seriously, just a tad irritating for the
few of us still trying to make a living writing/designing software.

Michel
PS. The reason I am answering this has to due that I wrote the
presentation linked below.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Stephane Bortzmeyer

On Wed, Jan 21, 2004 at 09:43:44PM +0100,  Georg Ochsner
<[email-masked]> wrote  a message of 10 lines which said:

> does anybody know, when Microsoft will implement the new IDN standards

> in IE (service pack or something)?

The technical director of Microsoft France, Bernard Ourghanlian, queried
by AFNIC, replied that the are no immediate plans to support IDN,
Microsoft prefers to wait for "full" IRI.

A more detailed (and in english) reply from Microsoft is there:

http://www.microsoft.com/globaldev/reference/presentations/unicode23/a6.
pdf

Anyway, Real Men only use free software :-)

---

From: "Martin v. Löwis" <[email-masked]>
Date: Sun, 25 Jan 2004 09:06:11 +0100

> repertoire, you are in fact using an illegal URI per RFC2396 definition.

While this is true, it only imposes constraints on the HTML authors -
not on the Web browser. In particular, B.2.1 of HTML 4.01 explains
that Web browsers should expect authors to violate the constraint,
and gives a suggestion on how to deal with this violation. This
suggestion clearly predates IDNA, so dealing with this violation
using IDNA for the host name part is more sensible.

It is (unfortunately) quite common that HTML authors do not follow
the relevent HTML recommmendations. Some authors even believe that
unlimited extensibility is one of the guiding principles of HTML.

In fact, MSIE 6 does process URLs with non-ASCII characters - even
though not in the suggested way (but instead, apparently by sending
UTF-8 directly to the wire). Changing it to perform IDNA on the
host part (and leaving everything else as-is) would not make it less
standards-conforming, and give users added value.

Regards,
Martin

---

From: "Soobok Lee" <[email-masked]>
Date: Tue, 27 Jan 2004 17:20:07 +0900

----- Original Message ----- 
From: "Martin v. Löwis" <[email-masked]>
> standards-conforming, and give users added value.
 
That makes sense and works in many cases,as cab be seen in some plugin approaches.
 
But, in some cases , it is obvious that it will cause security/architectural problems..

<a href=www.xn--blahblah.com>  is ugly and won't be acceptable to MS
Windows folks. That is why MS waits for  full IRI spec for HTML, i guess.
 
Thinking that Content/Javascript/Java/Cookie security models heavily depends on text 
represenatations of hostname and file path parts of URL(then IRI), MS's current conservative 
postitions may be justified for security reasons.

Still i don't have full information about how Mozilla  implementations of IDNA  had addressed this
security issues clearly.

Soobok Lee

---

From: "Soobok Lee" <[email-masked]>
Date: Wed, 28 Jan 2004 00:12:46 +0900

----- Original Message ----- 
From: "Michel Suignard" <[email-masked]>
To: "Stephane Bortzmeyer" <[email-masked]>; "Georg Ochsner" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, January 23, 2004 10:31 AM
Subject: RE: [idn] IDNs in IE and Google

> goes for http, and any other URI schemes presented in browser user
 
I know the importance of IRI effort. 

BTW,  MSIE/Mozilla seem to support   IRI concept in  "file:" protocol  already.
file: protocol URL had been supporting  NETBIOS PC Name and File/Directory Pathname
in ***LOCAL CHARSET ENCODING***, not in UTF-8 encoding  from very long time ago.
That works in  Windows OS and even in LINUX.

Moreover, Most asian HTML homepages are published in local charset encoding
like euc-kr, big5 and gb2312 etc. UTF-8-encoded HTML pages are extremely *RARE*
in ASIA.

Need for backward compatibility to already deployed IRI-concept and 
Unicode<->Local charset conversion layer may lay another  complexity to IRI effort.
 
Just comparing two IRIs won't be a trivial task, if they can be in two diifferent encodings.

IMHO,  IRI efforts deserve a WG.  I will resume tracking the progress of IRI spec.. :-)

Soobok Lee

---

From: James Seng <[email-masked]>
Date: Wed, 28 Jan 2004 09:20:54 +0800

Dont confuse ability to have "non-english characters in URL like file:" 
with IRI. The former "support" in MS is not IRI.

ps: IRI is not a generic term for internationalization. it refers to a 
work-in-progress by W3C.

-James Seng

---

From: "CONFIRM.TO" <[email-masked]>
Date: Wed, 28 Jan 2004 11:14:24 +0900

IRI's authors can clarify  IRI's exact scope. Would they?
"I18ned Resource" may include  non-english file/directory resources,  because  a filename is a resource identifier.

file: support is also in MOZILLA, not only in MS. 
href=  src= tag values can have   file: protocol URLs is in both MSIE and MOzilla.
They are processed by the same url handling dll/routines in MSIE and MOzilla... 
You can intemix http: and file: protocol urls in a single html page.
file: protocol url can have" file://10.1.1.4/document/brief.ppt".
What's the difference between this and http://10.1.1.4/document/brief.ppt ?
one is served by NETBIOS over TCP/IP, and the other is by HTTP. That's all.
You can change 10.1.1.4 into ascii domain names or even IDN .

I  bet IRI authors won't love the idea  to separete file: from other protocols words like http/ftp...

Soobok Lee

---

From: "Soobok Lee" <[email-masked]>
Date: Wed, 28 Jan 2004 11:45:17 +0900

Soobok Lee