Subject: RE: [idn] punctuation

From: "Michel Suignard" <[email-masked]>
Date: Thu, 24 Feb 2005 10:23:47 -0800

Many web sites use deep DNS sub-zones today (including the company I work for) and I really doubt our customers would appreciate such a radical change in user experience. Most people expect to see www.example.org not org.example.www. These days the 'www' is really noise, but it also frequent to see myzone.example.org which works really well with autocompletion logic. Putting org first would sort of defeat that logic as well.

Don't get me wrong, your idea is good, it is just way too late.

Like somebody else already said, I feel some level of overreaction in these threads.

Michel 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Erik van der Poel
Sent: Thursday, February 24, 2005 10:01 AM
To: IETF idn working group
Subject: Re: [idn] punctuation

> If they were displayed
> in the opposite (big-endian) order, the 3rd example above would become:
> 
> http://xx.baz.com|bar.foo
> 
> Notice how the "com" and "foo" are now separated.

There was a gap in my logic here. A phisher could easily keep the "com" 
and "foo" next to each other. My real point is that big-endian display of domain names would put the important parts of the name near the beginning for a left-to-right reader:

> The "real" (unspoofed)
> URI would look like this:
> 
> http://com.foo

Erik

---

From: Erik van der Poel <[email-masked]>
Date: Thu, 24 Feb 2005 11:03:45 -0800

Michel Suignard wrote:
> Many web sites use deep DNS sub-zones today
> (including the company I work for) and I really
> doubt our customers would appreciate such a
> radical change in user experience.

As has already been pointed out on this list, a phisher could take 
advantage of a very long domain name to push the important part past the 
end of the display area. In the long run, the phishing problem may 
outweigh the user experience problem that would result from the radical 
change that I am talking about.

Besides, there is a much better way to tell the user where they are. See 
the blurb about "breadcrumb trails" at:

http://useit.com/alertbox/20000109.html

You can see these breadcrumb trails near the top of:

http://msdn.microsoft.com/Longhorn/toolsamp/default.aspx

> it also frequent to see
> myzone.example.org which works really well with
> autocompletion logic. Putting org first would
> sort of defeat that logic as well.

I have seen autocompleters that work for the middle or end of a string. 
In fact, Microsoft Internet Explorer has one.

> level of overreaction in these threads.

Ten years from now, let's revisit this topic together, shall we? I am 
not a betting man, but let's just see how it goes.

Erik