Subject: Filtering on IBGP-Sessions ?

From: "Hannes R. Boehm" <[email-masked]>
Date: Mon, 10 Nov 1997 13:26:02 +0100

I wonder wether it is possible (recommended) or not to filter on IBGP sessions.

I've got a transit area in my autonomous system. If I do not filter on the IBGP sessions
all routers in the transit area have full BGP routes. -> since I don't want to upgrade
all my routers to the same amount of RAM, I am thinking about filtering on some
of the IBGP sessions.

-> our Router at the local Exchange does not have to have full BGP routes  
   (-> we do not offer transit for any party at the local Exchange)
   
My Questions:

Is it possible to filter on IBGP sessions (-> is it recommended ?) ?
Should I use a conferderation of two or more private AS to solve this problem ?

Hannes R. Boehm

-- 
--
"The nice thing about standards is that there's so many to choose from." 
        -- Andrew S. Tannenbaum
!------------------------------------------------------------------!
  Hannes R. Boehm
        email   : [email-masked]
        www     : http://hannes.boehm.org
        PGP-key : http://hannes.boehm.org/hannes-pgp.asc
!------------------------------------------------------------------!

---

From: Curtis Villamizar <[email-masked]>
Date: Tue, 11 Nov 1997 00:50:23 -0500

> I wonder wether it is possible (recommended) or not to filter on IBGP

A *Real Bad Idea* (sm).

If you have inconsistent routing within you IBGP mesh you can get
route loops.

Curtis