Subject: Re: draft-chen-rr-oscillation-reduce-00.txt

From: Anindya Basu <[email-masked]>
Date: Thu, 06 Jun 2002 16:48:30 -0400

Yes, we are aware of this -- it turns out that there may be transient
black hole routing while the system is converging, but once the system
converges, everybody will agree on a single, stable set of routes. There
is a proof that actually shows this. Of course, you can be concerned
about black hole routing before the system converges, but then, in any
system undergoing transition, there *will be* some black hole routing
for short periods.
-Anindya

"Abarbanel, Benjamin" wrote:
> 
> Basu:
>   I have a problem with your solution of advertising routes that are not
> best routes to IBGP peers. This in itself can lead to black holes or routing
> loops.
> Even if we can keep the number of routes to a small group, I dont like the
> idea
> of sending suboptimal routes to a peer.
> 
> Ben
> 
> -----Original Message-----
> From: Anindya Basu [mailto:[email-masked]]
> Sent: Thursday, June 06, 2002 4:11 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: draft-chen-rr-oscillation-reduce-00.txt
> 
> I am actually curious -- have any of you out there with access to real
> routing tables applied any of these algorithms (that purport to send
> extra routes) and seen how many extra routes are generated? Two
> datapoints would be of interest:
> (a) For what percentage of routing prefixes are extra routes generated?
> (b) For those prefixes for which extra routes are generated, how many
> extra routes (on an average) are generated per prefix?
> This would provide some ideas about extra memory requirements. Maybe we
> should actually have some numbers before completely dissing a perfectly
> good solution.
> -Anindya
> 
> Danny McPherson wrote:
> >
> > > >not quite, the proposal by wilfong et. al. actually stops it totally
> and
> > > >we can prove it.
> > >
> > > I know it's been said before (and recently) but a reminder just in
> > > case:  scaling matters.
> >
> > Right!  A full IBGP mesh with no heirarchy, or heck, putting the
> > routes in an IGP --  would fix it as well, but please, lets not
> > forget that the solution has to be deployable and the several
> > vendors in my network today aren't exactly begging for more
> > BGP paths.
> >
> > -danny

---

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Thu, 6 Jun 2002 16:43:21 -0400

Basu:

Ben

-----Original Message-----
From: Anindya Basu [mailto:[email-masked]]
Sent: Thursday, June 06, 2002 4:11 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: draft-chen-rr-oscillation-reduce-00.txt

and