Subject: RE: draft-chen-rr-oscillation-reduce-00.txt

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Thu, 6 Jun 2002 12:17:44 -0400

Sounds to me like all the proposals so far attempt to reduce the
probability of route oscillations, but do not control or stop it
totally. So I think another approach is warranted.

Ben

-----Original Message-----
From: Gordon Wilfong [mailto:[email-masked]]
Sent: Wednesday, June 05, 2002 4:14 PM
To: Enke Chen
Cc: [email-masked]
Subject: Re: draft-chen-rr-oscillation-reduce-00.txt

Unfortunately, this method can fail to 
prevent persistent oscillations.

Consider the example below that appears in a work
in progress by Tim Griffin and Gordon Wilfong.
There is a single cluster with one route reflector [RR1] and two
client routers [C1] and [C2].  The client routers
get routes from outside their AS from [AS1] and
[AS2].  The numbers in parentheses represent the
MED values.  The unadorned numbers on the links between
[RR1] and its clients are the IGP metric values.
The unadorned numbers on the links from the client [C1]
to the two outside ASes represent [C1]'s preference
according to BGP tie breaking (with lower number representing
the more preferred route).
The example has the property that it suffers from persistent
route oscillations.  However the method discussed in
draft-chen-rr-oscillation-reduce-00.txt will not prevent this
oscillation since the route reflector's best route is always
a client's route and so the method's behavior will be unchanged
from unmodified I-BGP.

                       4
            [RR1] *************
              *               *
           1  *               *
              *               *
              *               *
              *               *
            [C1]            [C2]
              ***             *
            2 *   *  1        *
              *     *         *
          (2) *   (1) *       * (0)
              *         *     *
           [AS1]          **[AS2]

- Gordon

Enke Chen wrote:
> 
> Hi, folks:
> Two drafts are posted:
> 
>    o draft-chen-rr-oscillation-reduce-00.txt
>    o draft-chen-confed-oscillation-reduce-00.txt
> 
> A simple proposal for Route Reflection and one for Confederration
> are presented for presistent route oscillation reduction. Based
> on our computation, they resolve all the persisitent route oscillation
> cases documented.
> 
> If you have a persistent route oscillatin case that can not be resolved
> by these proposals, we will appreciate greatly if you let us know.
> 
> Comments?
> 
> Regards,   -- Enke
> 
> ------- Forwarded Message
> 
> To: IETF-Announce: ;
> From: [email-masked]
> Reply-To: [email-masked]
> Subject: I-D ACTION:draft-chen-rr-oscillation-reduce-00.txt
> Date: Wed, 05 Jun 2002 07:33:23 -0400
> Sender: [email-masked]
> 
> --NextPart
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
> 
>         Title           : BGP Route Oscillation Reduction with Route
Reflection
>         Author(s)       : E. Chen
>         Filename        : draft-chen-rr-oscillation-reduce-00.txt
>         Pages           : 4
>         Date            : 04-Jun-02
> 
> This document proposes a simple revision to Route Reflection that
> allows a Route Reflector to advertise the best path from its clients
> to other clusters when the overall best path for the RR differs. The
> availability of the routing information to other clusters helps
> achieve stable route selection, and moves route reflection closer to
> IBGP full-mesh equivalence in terms of routing information. It has
> been shown that the proposed mechanism eliminates a number of
> persistent route oscillation cases involving Route Reflection.
> 
> A URL for this Internet-Draft is:
>
http://www.ietf.org/internet-drafts/draft-chen-rr-oscillation-reduce-00.txt
> 
> ------- End of Forwarded Message

---

From: Anindya Basu <[email-masked]>
Date: Thu, 06 Jun 2002 12:40:45 -0400

> totally. So I think another approach is warranted.

not quite, the proposal by wilfong et. al. actually stops it totally and
we can prove it.
-anindya

---

From: "John G. Scudder" <[email-masked]>
Date: Thu, 6 Jun 2002 13:33:03 -0400

>not quite, the proposal by wilfong et. al. actually stops it totally and

I know it's been said before (and recently) but a reminder just in 
case:  scaling matters.

Regards,

--John