Subject: RE: I-BGP Oscillations

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Fri, 7 Jun 2002 13:41:23 -0400

Horrayy Enke, Thank you.  I dont know why I was getting such resistance to 
this method.

Ben

-----Original Message-----
From: Enke Chen [mailto:[email-masked]]
Sent: Friday, June 07, 2002 1:24 PM
To: Alvaro Retana
Cc: [email-masked]; [email-masked]
Subject: Re: I-BGP Oscillations 

> Date: Thu, 6 Jun 2002 21:54:38 -0400 (EDT)
> From: Alvaro Retana <[email-masked]>
> To: "'Pedro Roque Marques'" <[email-masked]>,
> 	"Abarbanel, Benjamin" <[email-masked]>
> Cc: Anindya Basu <[email-masked]>, <[email-masked]>
> Subject: RE: I-BGP Oscillations
> In-Reply-To:
<[email-masked]>
> Message-ID: <[email-masked]>
> MIME-Version: 1.0

[snip]

> 
> -> If we come up with a decent detection mechanism it would be so much
> -> simpler just to reduce the rate of oscilation.
> 
> "reducing the rate of oscillation" sounds to me like dampening. =:-)
> Again, that doesn't solve the problem, it just masks it, potentially
> making the periods of 'incorrect' routing longer (as well as the periods
> of correct routing, of course)...
> 
> 
> -> Note that the answer 'ibgp dampening' that is certain to pop up in
> -> peoples minds by association is a bit misleading.
> 
> I agree that iBGP dampening is not the answer.  However, a
> "dampening-like" (no penalties) mechanism to detect the oscillation and
> then act on it, would work.  Obviously, the oscillation characteristics of
> a MED churn are not the same as the ones of "normal" flapping.

Regarding a "dampening-like" mechanism (but no dampening) for IBGP route
oscillation detection, I would like to point out that not only is such
a mechanism a good idea, it is also feasible to implement. In fact, the
mechanism has been implemented and in production release on Redback SE800
for a while. The command "sho bgp route flap-statistics internal" displays
the IBGP routes that are flapping, and their frequencies. Then one can
look closely at the ones with the high flap frequencies to see if they
are indeed experiencing the "persistent route oscillation".

-- Enke

---

From: Enke Chen <[email-masked]>
Date: Fri, 07 Jun 2002 11:10:52 -0700

Ben,
It seems to me that folks are resisting the idea of "IBGP route dampening"
(which has too many issues). I do not think that folks are resisting the idea
of a "dampening-like" mechanism for detectig IBGP route flap/oscillation
(without actually dampening these routes).

-- Enke

> Message-ID: <[email-masked]>
> From: "Abarbanel, Benjamin" <[email-masked]>
> To: "'Enke Chen'" <[email-masked]>,
> 	Alvaro Retana <[email-masked]>
> Cc: [email-masked]
> Date: Fri, 7 Jun 2002 13:41:23 -0400 
>