Subject: Cooperative Route Filtering Capability

From: "Stephen Waters" <[email-masked]>
Date: Sat, 20 Jul 2002 09:58:36 +0100

What is the correct interpretation on filtering if I receive a REMOVE_ALL/IMMEDIATE?  I delete all the received filters for that AFI/SAFI, but is the default filter action still DENY?

(my view is that the default action should be PERMIT at all times - or at least settable).
Regards, Steve.

---

From: Enke Chen <[email-masked]>
Date: Mon, 22 Jul 2002 11:05:15 -0700

Hi, Steve:

> Subject: Cooperative Route Filtering Capability 
> Date: Sat, 20 Jul 2002 09:58:36 +0100
> Message-ID: <[email-masked]>
> From: "Stephen Waters" <[email-masked]>
> To: <[email-masked]>
> Sender: [email-masked]
> Precedence: bulk
> 
> 
> What is the correct interpretation on filtering if I receive a =
> REMOVE_ALL/IMMEDIATE?  I delete all the received filters for that =
> AFI/SAFI, but is the default filter action still DENY?

REMOVE_ALL would remove all the entries of a particular ORF type.
As a result the filter no longer exists. As there is no filter to
be applied, the action should be PERMIT instead of DENY.

This is different from having implicit DENY for an existing filter.

-- Enke

> 
> 
> (my view is that the default action should be PERMIT at all times - or =
> at least settable).
> Regards, Steve.=20