Subject: TCP state machine doubts

From: [email-masked]
Date: Fri, 05 Jul 2002 12:21:48 +0200

all,

i have a few questions related to the new state machine proposed in the
latest BGP draft.

1. related to terminology related to the connect retry counter.
I find back in the state descriptions following statement:
- "clears the ConnectRetry timer" (e.g. page 35, state connect)
- "Set connect retry timer to zero" (e.g. page 37, state Open sent)
- "Connect retry timer = 0," (e.g. page 38, state Open sent)
 I assume that the meaning in all of the above cases is : "the
ConnectRetry timer is stopped".  If so, would this not be a better
wording for the action?

2. related to the terminology for the holdtimer.
In state Connect on page 34 I find the following text: "set Hold timer
to a large value". I expect that this means "The Hold timer value is set
to a large value, and the Hold timer is started".

3. related to the ConnectRetryCnt.
- Should the value of this counter not be initialsed in the Idle state
as well?

4. General doubt  related to the TCP backoff strategy
Suppose I have a BGP peer that goes down say once every 2hours. With the
current sheme the ConnectRetryCnt keeps on increasing, and as a
consequence the connection takes increasinly more time to be
re-establsihed, even if actually it only fails like every 2 hours.

The mechanism only gives like 'bad points' , but never 'good points'. In
this way a peer never gets rid of his flapping history.
Is this really the intented behavior?

Thanks,
  Hans De Vleeschouwer.

---

From: Kunihiro Ishiguro <[email-masked]>
Date: Fri, 05 Jul 2002 20:49:18 -0700

>i have a few questions related to the new state machine proposed in the

Current draft-17 has some known problems.  I think Sue aleady prepared
draft of draft-18.  So best way is updating the draft to draft-18 then
process IDR working group review to it.

>- Should the value of this counter not be initialsed in the Idle state

These are right.  I believes all of these are fixed in the draft of
draft-18.

>re-establsihed, even if actually it only fails like every 2 hours.

My understanding is once BGP peer is establieshed, the ConnectRetryCnt
is cleared.
-- 
Kunihiro Ishiguro

---

From: Susan Hares <[email-masked]>
Date: Sat, 13 Jul 2002 07:15:17 -0400

Kunihiro:

I've got the FSM text for draft-18 revised.  I'm looking
for a group of people to review 5th round of the FSM
text along with the associated documents:

         1) BGP state machine (ietf-hares-statemt-02.txt)
         2) BGP backoff draft (ietf-hares-backoff-01.txt)
         3) Passive and Call Collision input
         4) BGP update draft (ietf-hares-update-00.txt]

  Thanks for volunteering to review the documents prior to
  me flooding the information to the mail list.  I welcome
  any other early reviewers.

  I submitted the first two as Internet drafts, but I found a few
  typos.

  I've answered your questions below:

> >ConnectRetry timer is stopped".  If so, would this not be a better

I've changed the text to be common.  Let me know if you like the
new wording.  Otherwise, I can add a little more text.

> >to a large value, and the Hold timer is started".

Could you look at the current text

         - Set the Hold timer to a large value (4 minutes),

>These are right.  I believes all of these are fixed in the draft of

See the FSM words and state machine.  I could use another
pair of eyes to look at the FSM.

> >re-establsihed, even if actually it only fails like every 2 hours.

The backoff mechanisms can actually change that.  I would
suggest that is another mechanism we could add in the
backoff section.   We could add a timer at that point or
agree to add another state to the FSM's timer.

Please comment on which one you'd like to see.  Please
suggest text for the backoff draft.

>My understanding is once BGP peer is establieshed, the ConnectRetryCnt

This mechanism does not fix the persistent peer oscillation.
Again, I think we can change this in the backoff draft, but
maybe we need another timer to reduce the connect retry count.

Could you suggest some text based on the backoff draft?

Sue Hares