Subject: RE: Re>Are dynamic capabilities really necessary if peers support gracef ul restart?

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Thu, 11 Jul 2002 14:52:19 -0400

Srihari:

see below
 
> 
> 
> Handling the race condition will be clarified in the draft in the next
> revision.
> 

Thanks for this.

> >
> > I have a question on the current 
> draft-ietf-idr-dynamic-cap-02.txt, section
> > 7 - Operation, 3rd and 4th paragraph:
> >
> >     "The Dynamic Capability itself can not be revised 
> dynamically via a
> >      CAPABILITY message. The lifetime of the Dynamic 
> Capability is the
> >      duration of the BGP session in which the capability is 
> advertised.
> 
> This is referring to the "Dynamic-Capability" itself.  This capability
> can ONLY appear in the OPEN message.
> 

I thought this spec was talking about dynamic capabilities not static 
ones, so why are we assuming its the one in the OPEN message?

What purpose does it serve to talk about static capabilities in this
draft, other than confuse the reader?

> >      Upon receiving a CAPABILITY message from its peer, the 
> BGP speaker
> >      shall update the capabilities previously received from 
> that peer
> >      based on the "Action" in the message, and then 
> function in accordance
> >      with the revised capabilities for the peer. Any unrecognized
> >      capabilities in the message should be ignored."
> 
> This is referring to capabilities other than "Dynamic-Capability".
> 
> >
> > Sounds like the second paragraph contradicts the first one.
> 
> No, it does not.

Same comment as state above.

Ben

---

From: Mathew Richardson <[email-masked]>
Date: Thu, 11 Jul 2002 15:35:03 -0400

> Abarbanel, Benjamin <[email-masked]> [Thu, Jul 11, 2002 at 02:52:19PM -0400]:

May I suggest that this sentence be changed to read:

"The Dynamic Capability Capability can not be revised
dynamically via a ..."

?

Would this change address your concerns, Mr. Abarbanel?

>ones, so why are we assuming its the one in the OPEN message?

I don't think that was an assumption... it was an assertion.  He's
saying that the Capability that advertises the ability to perform
Dynamic-Capability negotiations MUST NOT be negotiated dynamically;
it is only legal to advertise the Dynamic-Capability Capability in
OPEN messages.

>draft, other than confuse the reader?

This is the draft in which the Dynamic-Capability Capability is
introduced.  Hence, it is the logical place to talk about the
limitations of the Dynamic-Capability Capability.

<snip>

mrr