Subject: CEASE problems

From: "Pusz, MateuszX" <[email-masked]>
Date: Fri, 26 Jul 2002 09:07:42 +0200

Hello

I have one problem with CEASE message. 'draft-ietf-idr-bgp4-17' says in 6.7:
   In absence of any fatal errors (that are indicated in this section),
   a BGP peer may choose at any given time to close its BGP connection
   by sending the NOTIFICATION message with Error Code Cease. However,
   the Cease NOTIFICATION message must not be used when a fatal error
   indicated by this section does exist.

but in section 8-Established state:
   In response to a stop event initiated by an operator:
      - release all resources (including deleting all routes),
      - set ConnectRetryCnt to zero (0),
      - set connect retry timer to zero (0), and
      - transition to the Idle.

so how shuold it be? Should BGP router in such a situation send that
notification message or not?

Please help me

Thoughts from IDR community welcome.

Best regards

Mateusz Pusz

---

From: Manav Bhatia <[email-masked]>
Date: Fri, 26 Jul 2002 13:40:40 +0530

Hi Pusz,
If a BGP speaker decides to administratively reset the peering with a
neighbor, then the speaker should send a NOTIFICATION message with the
Error Code Cease, and the Error Subcode "Administratively Reset".

Regards,
Manav
----- Original Message -----
From: "Pusz, MateuszX" <[email-masked]>
To: <[email-masked]>
Sent: Friday, July 26, 2002 12:37 PM
Subject: CEASE problems

| Hello
|
| I have one problem with CEASE message. 'draft-ietf-idr-bgp4-17' says in
6.7:
|    In absence of any fatal errors (that are indicated in this section),
|    a BGP peer may choose at any given time to close its BGP connection
|    by sending the NOTIFICATION message with Error Code Cease. However,
|    the Cease NOTIFICATION message must not be used when a fatal error
|    indicated by this section does exist.
|
| but in section 8-Established state:
|    In response to a stop event initiated by an operator:
|       - release all resources (including deleting all routes),
|       - set ConnectRetryCnt to zero (0),
|       - set connect retry timer to zero (0), and
|       - transition to the Idle.
|
| so how shuold it be? Should BGP router in such a situation send that
| notification message or not?
|
| Please help me
|
| Thoughts from IDR community welcome.
|
| Best regards
|
|
| Mateusz Pusz

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 30 Jul 2002 16:44:36 -0400

> notification message or not?

You are correct, the NOTIFY should be sent.

This is correctly documented in:
http://www.ietf.org/internet-drafts/draft-hares-bgp-statemt-01.txt

-- 
Jeff Haas 
NextHop Technologies