Subject: RE: INFORM proposal and MP-BGP (RFC 2858)

From: "Natale, Jonathan" <[email-masked]>
Date: Tue, 9 Jul 2002 12:17:28 -0400

Where is this proposal? URL???

-----Original Message-----
From: Jeffrey Haas [mailto:[email-masked]] 
Sent: Monday, July 08, 2002 2:43 PM
To: [email-masked]
Subject: INFORM proposal and MP-BGP (RFC 2858)

The proposal for the INFORM message gives the opportunity to redress
an open issue in the MP-BGP specification:

: 6. Error Handling
: 
:    If a BGP speaker receives from a neighbor an Update message that
:    contains the MP_REACH_NLRI or MP_UNREACH_NLRI attribute, and the
:    speaker determines that the attribute is incorrect, the speaker must
:    delete all the BGP routes received from that neighbor whose AFI/SAFI
:    is the same as the one carried in the incorrect MP_REACH_NLRI or
:    MP_UNREACH_NLRI attribute. For the duration of the BGP session over
:    which the Update message was received, the speaker then should ignore
:    all the subsequent routes with that AFI/SAFI received over that
:    session.

This amounts to silently ignoring reachability.

INFORM would at least make this non-silent.  However, additional pushback
might be warranted.  Upon receipt of an INFORM (or similar) message
the receiving peer may wish to choose one or more of the following actions:

o Just log it per INFORM
o Stop sending this AFI/SAFI
o Reset the peering session (contrary to the wishes of the peer?)

Thoughts?

-- 
Jeff Haas 
NextHop Technologies

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 9 Jul 2002 12:22:55 -0400

> Where is this proposal? URL???

:         Title           : BGPv4 INFORM message
:         Author(s)       : G. Nalawade et al.
:         Filename        : draft-nalawade-bgp-inform-00.txt
:         Pages           : 10
:         Date            : 24-Jun-02
:
: This document defines a new message type, the BGP INFORM
: message that communicates Informational data and operational
: warnings without resetting the peering session.
:
: A URL for this Internet-Draft is:
: http://www.ietf.org/internet-drafts/draft-nalawade-bgp-inform-00.txt

-- 
Jeff Haas 
NextHop Technologies