Subject: RE: Re>Are dynamic capabilities really necessary if peers support gracef ul restart?

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Thu, 11 Jul 2002 15:43:02 -0400

Srihari:
  I looked over the draft again and I have to apologize I misunderstood you 
responses below. I would recommend rewording the two paragraph so that
others
do not get confused like me.

I have added the implied changes in the paragraph to fix the issue. Below.

Ben

> >
> > I have a question on the current 
> draft-ietf-idr-dynamic-cap-02.txt, section
> > 7 - Operation, 3rd and 4th paragraph:
> >
> >     "The Dynamic Capability itself can not be revised 
> dynamically via a
> >      CAPABILITY message. The lifetime of the Dynamic 
> Capability is the
> >      duration of the BGP session in which the capability is 
> advertised.
> 

I would reword it as follows:

"The Dynamic Capability feature defined in the OPEN message can not
 be revised dynamically via a CAPABILITY message. The lifetime of the
 Dynamic Capabaility feature is the duration of the BGP session."

> This is referring to the "Dynamic-Capability" itself.  This capability
> can ONLY appear in the OPEN message.
> 
> >      Upon receiving a CAPABILITY message from its peer, the 
> BGP speaker
> >      shall update the capabilities previously received from 
> that peer
> >      based on the "Action" in the message, and then 
> function in accordance
> >      with the revised capabilities for the peer. Any unrecognized
> >      capabilities in the message should be ignored."
> 

"Upon receiving a CAPABILITY message with specific capabilities from
 its peer, the BGP speaker shall update those specific capabilities 
 previously received from that peer based on the "Action" in the 
 message, and then function in accordance with the revised capabilities
 for the peer. 

 Any unrecognized capabilities found in the CAPABALITY message should be 
 ignored".

Regards,
Ben

---

From: "Srihari R. Sangli" <[email-masked]>
Date: Thu, 11 Jul 2002 13:35:50 -0700 (PDT)

Ben,

> do not get confused like me.

Ok. Will be added in the next revision. Thanks for the feedback.

srihari...