Subject: RFC 2545 (Link-Local)

From: [email-masked]
Date: Fri, 19 Jul 2002 07:00:06 -0600

Dear Sirs/Madam,

I'm working with BGP protocol for IPv6 routing and I'm a bit confused with sect.3. Constructing the Next Hop field of RFC 2545.

Could you be so kind to clarify me the following:

The RFC 2545 "Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain Routing" says:

"The link-local address shall be included in the Next Hop field if and
only if the BGP speaker shares a common subnet with the entity identified by the global IPv6 address carried in the Network Address
of Next Hop field and the peer the route is being advertised to.

In all other cases a BGP speaker shall advertise to its peer in the  Network Address field only the global IPv6 address of the next hop   (the value of the Length of Network Address of Next Hop field shall be set to 16)".

If I have a configuration

             Router A (AS1)            Router B (AS1)               Router C (AS2)
             3FFE:0:0:12::2  ------>   3FFE:0:0:22::1 --------->    3FFE:0:0:22::2                 
                                       3FFE:0:0:12::1  __               
						                     |
						                     V
                                           Router D (AS3)
                                           3FFE:0:0:12::3

where router A and router B belong to AS1, router C belongs to AS2 and router D belongs to AS3.

Router A sends UPDATE to Router B with MP_REACH_NLRI containing NEXT_HOP 3FFE:0:0:12::2. I expect that router C should receive UPDATE with MP_REACH_NLRI containing NEXT_HOP 3FFE:0:0:22:1 (only Global) and router D should receive UPDATE with MP_REACH_NLRI containing NEXT_HOP  3FFE:0:0:12::21 (Global) and Link-Local. Am I correct?                

Sincerely,

Andrey Movshin
Software Development Engineer
Qosnetics Product Operation
Agilent Technologies Inc.
75 Rochester Avenue, Unit 1
Portsmouth, NH 03801
[email-masked]
603-559-5769

---

From: Pedro Roque Marques <[email-masked]>
Date: Fri, 19 Jul 2002 10:39:10 -0700 (PDT)

> I'm working with BGP protocol for IPv6 routing and I'm a bit
> confused with sect.3. Constructing the Next Hop field of RFC 2545.

> "The link-local address shall be included in the Next Hop field if
> and only if the BGP speaker shares a common subnet with the entity
> identified by the global IPv6 address carried in the Network Address

You can look at it in another way...
whenever 2 BGP speakers share a link, and the advertising router uses
the global address on the link as a nexthop address it should also
include a link local address.

> In all other cases a BGP speaker shall advertise to its peer in the
> Network Address field only the global IPv6 address of the next hop
> (the value of the Length of Network Address of Next Hop field shall
> be set to 16)".

> Router A sends UPDATE to Router B with MP_REACH_NLRI containing
> NEXT_HOP 3FFE:0:0:12::2. I expect that router C should receive
> UPDATE with MP_REACH_NLRI containing NEXT_HOP 3FFE:0:0:22:1 (only
> Global) and router D should receive UPDATE with MP_REACH_NLRI
> containing NEXT_HOP 3FFE:0:0:12::21 (Global) and Link-Local. Am I
> correct?

It seems to me that in all your examples the nexthop address
advertised is the link address... if that is true the link-local
should be included always... but i'm probably not understanding your
diagram.

  Pedro.