Subject: limit the No. of routes received from a neighbor

From: Tian Fang <[email-masked]>
Date: Tue, 23 Jul 2002 18:11:47 -0400

Hi all,

When the No. of routes received from a neighbor exceeds the configured
limit, is it better to tear down the session or drop the routes received
later on? If dropping routes is a option, is there any preference that we
can use to choose the routes to be dropped? Thx.

Regards,
Tian Fang

---

From: [email-masked]
Date: Tue, 23 Jul 2002 15:43:06 -0700

If max-prefix is exceeded, tear down the session.  In this case there is
no way to know which routes you should listen to and which ones you 
shouldn't.  Tearing down the session will force human intervention who
can either fix the problem, if max-prefix was exceeded accidently, or
request that the limit be raised if max-prefix was triggered by normal
growth.

Andrew

On Tue, Jul 23, 2002 at 06:11:47PM -0400, Tian Fang wrote:
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> From: Tian Fang <[email-masked]>
> To: [email-masked]
> Subject: limit the No. of routes received from a neighbor
> Date: Tue, 23 Jul 2002 18:11:47 -0400
> X-Mailer: Internet Mail Service (5.5.2653.19)
> Precedence: bulk
> X-OriginalArrivalTime: 23 Jul 2002 22:14:42.0869 (UTC) FILETIME=[585BCE50:01C23296]
> 
> Hi all,
>

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 24 Jul 2002 10:55:17 -0400

On Tue, Jul 23, 2002 at 03:43:06PM -0700, [email-masked] wrote:
> shouldn't.

One *could* make an argument that one could discard any more-specific
routes from your adj-ribs-in.  This will maintain *some* reachability
for that peer.  However, one might want to flag the remaining
routes as being required and if they go away, *then* tear down
the peering session.

This is a lot more work and probably not worth it. :-)

-- 
Jeff Haas 
NextHop Technologies