Subject: Route Reflector and client interaction questions

From: Daniel Kushner <[email-masked]>
Date: Mon, 8 Jul 2002 10:17:58 -0700 (PDT)

I have some questions concerning Juniper Route 
Reflector operation where Juniper and Cisco 
differ in operation.

Given:
R1 = Juniper route reflector (RR)
R2 = RR client to Juniper

- I noticed that if a client peer (R2) advertises a 
   route (route A) to a Juniper route reflector (R1), 
   that Juniper route reflector (R1) sends a 
   withdrawal of the route (route A) back to the 
   client (R2) that advertised the route to the 
   Juniper route reflector. Cisco does not do this. 

My questions are:
1) Does Juniper withdraw the route from the client 
     sender on purpose, or is it a Juniper bug?
2) If it is not a bug, what condition/topology exactly

     does sending the withdrawal back to the client 
     protect against?
3) From the provider standpoint, if it is not a bug, 
     is withdrawing the route from the client sender 
     preferred behavior?

- I also noticed that neither Cisco or Juniper 
   prohibits modification to the AS_PATH, 
   NEXT_HOP, LOCAL_PREF, or MED for 
   routes reflected, as required by the RFC. 
   I'm not sure if this is important when 
   considering the above questions.

4) From the provider standpoint, is allowing 
    attribute modification for reflected routes
    preferred behavior?

Thanks,
- Daniel Kushner

__________________________________________________
Do You Yahoo!?
Sign up for SBC Yahoo! Dial - First Month Free
http://sbc.yahoo.com

---

From: "Tsillas, Jim" <[email-masked]>
Date: Mon, 8 Jul 2002 13:42:23 -0400

Daniel,

what you are describing is a "poison reverse" strategy
which would have the benefit of reducing the amount of
state stored in the network. In your example, when R1
sends a withdrawl back to R2, R2 can free the otherwise
useless state since R1's decision process has determined
that R2's route is better. This is usually done between
external peers, but could also be done between RRs.
Not sending the withdraw is not incorrect since the
topology is not affected.

On the topic of prohibiting attribute modification: each
vendor will decide for themselves, but is there really
any value to limiting this function? If I buy a hammer
I can read the (fictional) warning about using it to relieve
headaches and decide if I want to use it in that manner.
Should that hammer then be redesigned to make it impossible
for me to bang my head?

regards,
-Jim.

-----Original Message-----
From: Daniel Kushner [mailto:[email-masked]]
Sent: Monday, July 08, 2002 1:18 PM
To: [email-masked]
Cc: [email-masked]
Subject: Route Reflector and client interaction questions

Given:

My questions are:

Thanks,
- Daniel Kushner