Subject: Re: damping persistent peer oscillations

From: "Tom Petch" <[email-masked]>
Date: Fri, 6 Dec 2002 19:10:15 -0000

Whoops; I asked for the word flapping to be taken out of this section
because it had nothing to do with this RFC and might confuse people
into thinking it had!  (And my comment was accepted by Yakov).

My understanding is different, that peer oscillation damping refers to
IDs such as
draft-hares-bgp-backoff-01.txt
which appeared in the summer and which are on hold, to be returned to
once the base spec has been finalised.

Tom Petch
[email-masked]

-----Original Message-----
From: Curtis Villamizar <[email-masked]>
To: Natale, Jonathan <[email-masked]>
Cc: [email-masked] <[email-masked]>
Date: 06 December 2002 18:34
Subject: Re: damping persistent peer oscillations

>In message
<[email-masked]
>ks.com>, "Natale, Jonathan" writes:
>> >From Draft 18:
>> "Local system automatically starts the BGP peer connection with
persistent
>> peer oscillation damping enabled.  The exact method of damping
persistent
>> peer oscillations is left up to the implementation.   These methods
of
>> damping persistent BGP adjacency flapping are outside the scope of
this
>> document."
>>
>> -- is there a draft describing a "method of damping persistent peer
>> oscillations" ?
>
>
>RFC 2439 "BGP Route Flap Damping":
>
>  4.8.5 Processing A Peer Router Loss
>
>   When a peer routing session is broken, either all individual
routes
>   advertised by that peer may be marked as unstable, or the peering
>   session itself may be marked as unstable.  Marking the peer will
save
>   considerable memory.  Since the individual routes are advertised
as
>   unreachable to routers beyond the immediate problem, per route
state
>   will be incurred beyond the peer immediately adjacent to the BGP
>   session that went down.  If the instability continues, the
>   immediately adjacent router need only keep track of the peer
>   stability history.  The routers beyond that point will receive no
>   further advertisements or withdrawal of routes and will dispose of
>   the damping structure over time.
>
>   BGP notification through an optional transitive attribute that
>   damping will already be applied may be considered in the future to
>   reduce the number of routers that incur damping structure storage
>
>Curtis

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 6 Dec 2002 14:17:42 -0500

Jonathan:

	The draft is below.  I'll be updating the draft-hares-bgp-backoff-00.txt
draft this month.  Please send comments.  The base specification
will simply state "damping persistent BGP adjacency flapping are
outside the scope of this document.

Sue

---------------------                                                                         

 Internet Draft                                              S. Hares 
   Document: draft-hares-bgp-backoff-00.txt                     NextHop 
                                                          Technologies, 
                                                                   Inc. 
   Expires: December 2002                                     June 2002 

                   BGP Peer Restart Backoff Mechanisms 

-----Original Message-----
From: Natale, Jonathan [mailto:[email-masked]]
Sent: Friday, December 06, 2002 10:47 AM
To: [email-masked]
Subject: damping persistent peer oscillations

From Draft 18:
"Local system automatically starts the BGP peer connection with persistent
peer oscillation damping enabled.  The exact method of damping persistent
peer oscillations is left up to the implementation.   These methods of
damping persistent BGP adjacency flapping are outside the scope of this
document."

---

From: "Tom Petch" <[email-masked]>
Date: Fri, 6 Dec 2002 21:02:22 -0000

** comment inline

-----Original Message-----
From: Susan Hares <[email-masked]>
To: Natale, Jonathan <[email-masked]>; [email-masked]
<[email-masked]>
Date: 06 December 2002 19:18
Subject: RE: damping persistent peer oscillations

Jonathan:

The draft is below.  I'll be updating the
draft-hares-bgp-backoff-00.txt
draft this month.  Please send comments.  The base specification
will simply state "damping persistent BGP adjacency flapping

** aka peer oscillation damping :-)

are

Sue

---------------------

Internet Draft                                              S. Hares
   Document: draft-hares-bgp-backoff-00.txt
NextHop

Technologies,

Inc.
   Expires: December 2002                                     June
2002

-----Original Message-----
From: Natale, Jonathan [mailto:[email-masked]]
Sent: Friday, December 06, 2002 10:47 AM
To: [email-masked]
Subject: damping persistent peer oscillations

From Draft 18:

Tom Petch

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 9 Dec 2002 16:49:50 -0500

Tom:

peer oscillation damping ---- 
The document -19 draft already has
the corrections (thanks to yakov).

thanks for catching this.

I'll double check prior to release of 
the document.

Sue

-----Original Message-----
From: Tom Petch [mailto:[email-masked]]
Sent: Friday, December 06, 2002 4:02 PM
To: Susan Hares; Natale, Jonathan; idr
Subject: Re: damping persistent peer oscillations

** comment inline

-----Original Message-----
From: Susan Hares <[email-masked]>
To: Natale, Jonathan <[email-masked]>; [email-masked]
<[email-masked]>

Jonathan:

are

Sue

---------------------

Internet Draft                                              S. Hares

Technologies,

Inc.

-----Original Message-----
From: Natale, Jonathan [mailto:[email-masked]]
Sent: Friday, December 06, 2002 10:47 AM
To: [email-masked]
Subject: damping persistent peer oscillations

From Draft 18:

Tom Petch