Subject: Re: BGP Identifier in draft-ietf-idr-bgp4-18.txt

From: Danny McPherson <[email-masked]>
Date: Fri, 14 Feb 2003 09:15:50 -0700

> 
> I don't think it's possible to get much clearer than that.
> 
> mrr

I agree, I think the current text is more than sufficient.

-danny

---

From: Danny McPherson <[email-masked]>
Date: Fri, 14 Feb 2003 09:30:06 -0700

That's a "virtual router" sort of implementation issue, and 
shouldn't be addressed in the base BGP specification.

-danny

> <snip>
> From the text that you quoted:  "The value of the BGP Identifier is 
> determined on startup and is the same for every local interface and every
> BGP peer."
> <snip>
> 
> Is this true for a BGP/MPLS case, where each BGP peer will be attached to a
> VRF? Each VRF will have a Router_ID (used by IGPs like OSPF). Should the BGP
> Identfier be the same as this Router ID. This would mean that we should have
> different BGP Identifier for each VRF and one for the internet VRF. 
> 
> -Vijay
> 
>