Subject: MED in practise

From: Mareline Sheldon <[email-masked]>
Date: Sun, 23 Feb 2003 21:48:09 -0800 (PST)

Hello,
I want to know if this is a general practise followed by the ISPs to advertise in their MED
thier internal IGP costs to reach the destination to their upstream peers.

If this is done then the ISP which is connected to two other ISPs can decide amongst the
better one by choosing the lower MED advertised by both and sending all the traffic through
it!

On the other hand, if we have the option to compare MEDs only from the same AS then i can use
MED to choose a lesser congested link.

Is this how MED is set or is some other logic followed? And finally why is MED considered so
fatal and there were talks sometime back to get rid of it.

And help in this regard will be appreciated.

Thanks,
Mareline S.

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
http://taxes.yahoo.com/

---

From: Danny McPherson <[email-masked]>
Date: Mon, 24 Feb 2003 08:06:00 -0700

> I want to know if this is a general practise followed by the 
> ISPs to advertise in their MED thier internal IGP costs to reach 
> the destination to their upstream peers.

If you replace "destination" with NEXT_HOP, sure...
 
> If this is done then the ISP which is connected to two other ISPs
> can decide amongst the better one by choosing the lower MED advertised 
> by both and sending all the traffic through it!

Sure, and thereby always selecting the ISP with the metric allocation 
policy that results in lower values for IGP metrics.  Or, perhaps always 
selecting the ISP with the IGP that provides a smaller range of available 
metrics (e.g., IS-IS pre-deployment/"wide metrics"). 

> On the other hand, if we have the option to compare MEDs only from the 
> same AS then i can use MED to choose a lesser congested link.

Sure, as with many other BGP attributes, if you manually configure MEDs 
or employ some dynamic router configuration technique (to configure MEDs).  
  
> Is this how MED is set or is some other logic followed? And finally 
> why is MED considered so fatal and there were talks sometime back to 
> get rid of it.

I've seen MEDs work as prescribed in many scenarios.  However, be wary:

 o aggregation breaks MEDs
 o comparing MEDs between different ASs with different policies 
   isn't typically a good idea
 o MEDs are a primary trigger of route oscillation
 o MEDs often result in superfluous route advertisements per
   IGP link/node/cost changes
 o Most notably, accepting MEDs from peers can have a visible impact on the 
   economics of carrying bits, depending on which network is carrying traffic,  
   how far, etc.. 

Also note that while many service providers send (often by request only) and 
accept MEDs from customers, they typically reset MEDs to some fixed value on 
routes learned from peers.  

-danny

---

From: Mareline Sheldon <[email-masked]>
Date: Tue, 25 Feb 2003 06:22:32 -0800 (PST)

Danny,
 
> If you replace "destination" with NEXT_HOP, sure...

I'm sorry .. that is what i had meant !

> metrics (e.g., IS-IS pre-deployment/"wide metrics"). 

This is a little unclear to me ... AFAIK till some time IS-IS would only support narrow
metrics (the WIDE metrics extensions just came about some time back!). This way the MED
advertised by an AS running IS-IS would always be smaller than one running OSPF .. which would
cause the upstream ISP to always select the AS running IS-IS. 

This is rather unfair for an ISP running OSPF in its network !!! (Atleast in theory!) 
 
>  o aggregation breaks MEDs

How? Can you give me one example?

>    IGP link/node/cost changes

Is this coz some IGP cost would change and we would re-advertise our BGP Updates with that new
MED i.e. if we are directly importing IGP costs into BGP as MED! Isnt it?

> routes learned from peers.  

This would solve most of the problems !!

Thanks a lot!

Mareline S.

---

From: Danny McPherson <[email-masked]>
Date: Tue, 25 Feb 2003 09:30:17 -0700

> This is a little unclear to me ... AFAIK till some time IS-IS would 
> only support narrow metrics (the WIDE metrics extensions just came about 
> some time back!). This way the MED advertised by an AS running IS-IS
>  would always be smaller than one running OSPF .. which would

Indeed.  Of benefit or unfair, depending on where you sit.

> How? Can you give me one example?

Many service providers only announce their aggregates from redundantly-
connected core routers in order to avoid blackholing traffic (e.g., if an 
edge were announcing them and became isolated).  The announcements for the 
aggregates are often sourced from many (or even all) core routers, so 
the metric that's used to derive the MED value is the IGP cost from the 
edge to the local core router, and is often a fixed value between all 
edge-core connections.  

Peers then employ the MED associated with the aggregate to reach some 
specific network within the aggregate.  This can result in making bad
routing decisions that without MED would have been much more optimal.  
It'd work OK if the more specifics and MEDs associated associated with 
internal NEXT_HOPS were made available to the peer, but this isn't a 
viable alternative.

> Is this coz some IGP cost would change and we would re-advertise 
> our BGP Updates with that new MED i.e. if we are directly importing 
> IGP costs into BGP as MED! Isnt it?

Yes, so link flaps, new metrics, etc.. that would otherwise remain
internal now result in new external BGP updates, per "dynamically 
derived" MEDs.

-danny