Subject: [Idr] Violating the BGP std.

From: Mareline Sheldon <[email-masked]>
Date: Tue, 11 Nov 2003 02:02:32 -0800 (PST)

Hi,

If an implementation for some reason doesnt initiate a TCP connection to a remote external
peer and waits for that peer to initiate first, will this be treated as going against the RFC.
I understand that this can lead to higher convergence times, etc. But can this really be
called "violating the standards" ?

Just curious,
Regards,
Mareline S.

__________________________________
Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard
http://antispam.yahoo.com/whatsnewfree

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Mareline Sheldon <[email-masked]>
Date: Tue, 11 Nov 2003 16:17:07 -0800 (PST)

| If it can be configured to do so, then no.  If thats the only way it
| works, then yes, it would be a violation.

Any particular use/reason why somebody would want to configure a "passive" peer? Will it not
increase the convergence time in the network?

Regards,
Mareline S.

---

From: Hunju Park <[email-masked]>
Date: Mon, 17 Nov 2003 23:45:41 -0500 (EST)

Mareline,

> increase the convergence time in the network?

You may not always want to configure a "passive" peer,
sometimes it just becomes one. For eg. Consider two
routers A and B. 

A has two interfaces say, 3.3.3.3/24 and 4.4.4.4/24
while B has just one interface 2.2.2.2

I configure A as 
neighbor 2.2.2.2 remote-as X

while i configure B as 
neighbor 4.4.4.4 remote-as X

Now suppose that the best path for Router A to reach B
is through its 3.3.3.3 interface. This is possible
based on the IGP routes that one has in a network. If
this is so, then router A sends a TCP SYN destined to
2.2.2.2 from its interface 3.3.3.3.

B on the other hand, sends a TCP SYN to Router A from
2.2.2.2 to A's 4.4.4.4

B will reject the TCP request that it receives from A
as its not configured for 3.3.3.3

Thus there is only one way for A to establish a BGP
connection with router B and it is through the TCP
session that has been initiated by router B.

Thus router A acts as a passive peer and can only wait
for a connection that has been initiated from router
B. This is my understanding of the new FSM that has
been put forth in the new bgp draft.

Folks,

Extrapolating this further, an interesting scenario
will arise when because of some IGP routes both the
routers are able to reach each other through different
interfaces than what they are configured to peer with.

Eg. A tries to reach B thru 3.3.3.3, while router B
tries to contact router A thru some other interface,
say 5.5.5.5

Both will then act as passive peers as their active
TCP probe will be rejected by the other. How will then
the session take place? I guess we would need human
intervention then.

Regards,
Park

______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca

---

From: Hunju Park <[email-masked]>
Date: Mon, 17 Nov 2003 23:45:41 -0500 (EST)

Mareline,

I configure A as 

while i configure B as 

Folks,

Regards,
Park