Subject: [Idr] Using a Routing Protocol to resolve reachability to the Remote Peer

From: John Smith <[email-masked]>
Date: Tue, 11 Nov 2003 04:44:04 +0000 (GMT)

Hi,
 
We use the IGPs to resolve the reachability to our BGP neighbors from which we learn
reachability about other networks/destinations. Isnt this a little odd? A routing
protocol (BGP) is building up its routing database and is dependent upon another
routing protocol (RIP/ISIS/OSPF) for doing so?

I mean, when we configure neighbor x.y.z.w remote-as MY_ASNUM for IBGP peering, x.y.z.w 
need not be a directly connected neighbor. I may need to traverse multiple hops to reach
it. The path which i take depends upon what has been constructed by the IGPs at each hop.
Thus, we BGP depends upon an IGP to build up its RIB.
 
 Am I missing something?
 
 Regards,
 John Smith

________________________________________________________________________
Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://mail.messenger.yahoo.co.uk

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Curtis Villamizar <[email-masked]>
Date: Tue, 11 Nov 2003 01:00:24 -0500

In message <[email-masked]>, John Smith 
> Thus, we BGP depends upon an IGP to build up its RIB.

This is the common practice.  For N other routers in the IGP you have
N IBGP adjacnencies and the common ways to reduce that number are
confederations (not used as much these days) and BGP route reflectors.

As far as missing something, you've missed the last 10 years of
discussion of common practice so maybe it would be a good time to dive
into a book on routing.

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Tue, 11 Nov 2003 01:00:24 -0500

Curtis