Subject: RE: [Idr] Last Call on draft-ietf-l3vpn-rfc2547bis-01.txt

From: "Susan Hares" <[email-masked]>
Date: Tue, 4 Nov 2003 14:17:21 -0500

Folks,

A couple queries have arrived asking if this is 
a "normal" review of the document.  Yep, please
review both the mechanisms and the "text" describing
the mechanisms (of the message below).

Sue 

================Original message text===============
Folks,

This is to start the IDR Last Call on draft-ietf-l3vpn-rfc2547bis-01.txt.
The scope of this Last Call is to confirm that the BGP-related
mechanisms used in draft-ietf-l3vpn-rfc2547bis-01.txt
use the existing BGP mechanisms that are either (a) RFCs, or
(b) the IDR WG Internet Drafts.
  
The BGP-related mechanisms used in draft-ietf-l3vpn-rfc2547bis-01.txt
have been summarized in draft-rosen-l3vpn-2547bis-protocol-00.txt, and 
specifically on Section 2 of that draft.

The Last Call ends Nov 18, 2003.

Sue & Yakov.

P.S. The Last Call is done at the request of the Routing AD (Alex Zinin).

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "Parag Deshpande" <[email-masked]>
Date: Fri, 7 Nov 2003 10:51:03 -0600

Hi,

Let's say all routers support End-Of-RIB.
I was just curious to know if bgp disallows withdrawn routes to be part of
initial routing updates.

In other words should a router accept withdrawn routes before receiving
End-Of-RIB.

Thanks
Parag

---

From: "Parag Deshpande" <[email-masked]>
Date: Fri, 7 Nov 2003 10:51:03 -0600

Hi,

Thanks
Parag

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 7 Nov 2003 12:29:18 -0500

IMO, this is an implementation detail.

The "initial blast of routes" is intended to bring the BGP peer
in synch as quickly as possible.  However, you also don't want
to delay convergence too much.  Thus, if you need to send a withdraw
for something you've sent, and you're not done with the intitial
blast, go ahead.

Theoretically the Min*Timers will keep this from being too much of
an issue.

-- 
Jeff Haas 
NextHop Technologies

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 7 Nov 2003 12:29:18 -0500

-- 
Jeff Haas 
NextHop Technologies

---

From: "John G. Scudder" <[email-masked]>
Date: Fri, 7 Nov 2003 14:30:15 -0500

>I was just curious to know if bgp disallows withdrawn routes to be part of

No, it doesn't.

>In other words should a router accept withdrawn routes before receiving

Yes, it should.

--John

---

From: "John G. Scudder" <[email-masked]>
Date: Fri, 7 Nov 2003 14:30:15 -0500

No, it doesn't.

Yes, it should.

--John

---

From: Danny McPherson <[email-masked]>
Date: Fri, 7 Nov 2003 14:09:02 -0700

> I was just curious to know if bgp disallows withdrawn routes to be 

No, BGP does not (as has been mentioned already).  I can't think
of a reason why an implementation would want to "disallow" updates
during initial synchronization, though I CAN think of reasons why
they'd better accept them.

> In other words should a router accept withdrawn routes before receiving

Yes.

-danny

---

From: Danny McPherson <[email-masked]>
Date: Fri, 7 Nov 2003 14:09:02 -0700

Yes.

-danny

---

From: "Parag Deshpande" <[email-masked]>
Date: Fri, 7 Nov 2003 15:20:15 -0600

Yup I agree on all counts - thought the same. 

Thanks for all the help.
Parag

---

From: "Parag Deshpande" <[email-masked]>
Date: Fri, 7 Nov 2003 15:20:15 -0600

Thanks for all the help.
Parag