Subject: [Idr] 2 simulataenous BGP connections ..

From: Hunju Park <[email-masked]>
Date: Sat, 15 Nov 2003 00:13:47 -0500 (EST)

Hi,

I want to know if its legal to have two simulataneous
connections between two BGP speakers.

 -------            -------
 |      |--- . . -- |     |
 |   A  |--- . . -- |  B  |
 --------           --------

I know of one major vendor that allows that. IMHO this
should not be allowed and BGP should check the ROuter
ID when it receives the OPEN message and should ignore
this if it already has a connection with a router
having the same router ID.

This can also prevent it in situations when one of the
routers in the domain is misconfigured with a wrong
router ID. In full mesh case it can be detected as
this router will not peer with the router having the
same Router ID .. but this can create problems when
you have Router Reflectors/Confederations/etc.

And if somebody is thinking of redundancy then he/she
can use loopback addresses.

Any comments,
Park

______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 17 Nov 2003 07:21:36 -0800

Park,

> connections between two BGP speakers.

According to the spec it is legal *as long as* each connection 
uses distinct source or dest IP address (or both). 

Yakov.

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 17 Nov 2003 07:21:36 -0800

Park,

Yakov.

---

From: Hunju Park <[email-masked]>
Date: Mon, 17 Nov 2003 19:35:16 -0500 (EST)

Yakov,

Thanks for responding, however i have a small doubt.
 
> uses distinct source or dest IP address (or both). 

I would have understood had you said that its valid as
long as both sides use distinct source and dest IP
addresses. What i dont understand is how can it work
with just one side using a unique source IP or dest IP
address.

Lets assume Router A uses its two interfaces to
establish a BGP connection, while Router B just uses
one interface.

On Router B I can say,

neighbor 1.1.1.1 remote-as X
neighbor 2.2.2.2 remote-as X

where 1.1.1.1 and 2.2.2.2 both belong to A

But what will i define on Router A?

neighbor 3.3.3.3 remote-as Y
neighbor 3.3.3.3 remote-as Y

where i assume 3.3.3.3 belongs to Router B?

I can understand that the spec allows if both sides
use a distinct source and dest IP address. But how can
it work as the way you said.

Or maybe i missed your point.

Regards,
Park

---

From: Hunju Park <[email-masked]>
Date: Mon, 17 Nov 2003 19:35:16 -0500 (EST)

Yakov,

On Router B I can say,

Regards,
Park