Subject: [Idr] ORF

From: "Rajesh Potti" <[email-masked]>
Date: Mon, 24 Jan 2005 17:27:07 -0500

The draft "cooperative Route Filtering Capability for BGP-4" 

(draft-ietf-idr-route-filter-11.txt) does not specify the action - PERMIT or
DENY, 
if the to be 
Advertised route  Does not have a community, or if the route has a community
which 
does not match any Of the community ORF entries received. The prefix-list
ORF filter draft 
specifies a wildcard Match, which is not the case with the community orf.  

Rajesh
_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 27 Jan 2005 11:45:13 -0500

Rajesh,

>From the draft:
:   The remote peer should consider only those routes whose Communities
:   attribute has at least one Community in common with the Communities
:   list specified in the ORF.

Thus, if the route has no communities, it can not have any communities
in common (at least one) with the ORF.

Put a different way, this is an set intersection operation.  If the
resulting set of the route's communities intersected with the community
orf is the empty set, it doesn't match.

-- 
Jeff Haas 
NextHop Technologies