Subject: [Idr] draft-ietf-grow-diverse-bgp-path-dist ignore IGP metric

From: Jakob Heitz <[email-masked]>
Date: Sun, 27 Mar 2011 15:20:52 -0400

If you ignore IGP metric, you may choose the wrong bestpath.

Suppose 3 paths, 2 RR planes.
Suppose RR clusters in POPs all over the country.
One RR cluster may not choose its closest path at all.
It could choose 2 paths far away when there is one
path closer.

--
Jakob Heitz.

---

From: Robert Raszuk <[email-masked]>
Date: Sun, 27 Mar 2011 23:04:12 +0200

Jakob,

> If you ignore IGP metric, you may choose the wrong bestpath.

This is to be used when RRs are control plane devices somewhere in the 
middle of the network. In case of hierarchical network such RRs would be 
in the core area.

If you have RRs in each POP either at the pop to core boundary or within 
the POP you do not need to use this at all.

Moreover if you have two sessions to any of the RRs this is also not 
needed.

For more discussions on next hop IGP metric influence of BGP best path 
decision I would recommend to take a look at this work:

http://tools.ietf.org/html/draft-raszuk-bgp-optimal-route-reflection-01

Thx,
R.

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>