Subject: Re: [Idr] I-D Action:draft-ietf-idr-deprecate-as-sets-03.txt

From: Curtis Villamizar <[email-masked]>
Date: Sun, 01 May 2011 19:59:54 -0400

In message <[email-masked]>
"t.petch" writes:
>  
> Um.  The trouble with tinkering is that the text may lose its coherence;
> I know, I've done it too often myself.
>  
> Two points.
>  
> "Without AS_SET aggregates must always contain only
>    less specific prefixes (not less than or equal to), and must never
>    aggregate an exact match.  "
> I find a clear, easy to apply statement of what to do, whereas I
> easily get lost in Appendix A, so I would be happy not to have
> Appendix A.  By contrast, I would like to give this sentence more
> emphasis and would do so by making it the start of a new
> paragraph.
>  
> But
> " Route
>    aggregation is possible under some conditions without the use of
>    AS_SETs (please see Appendix A for relevant discussion and
>    suggestions)."
> I think prone to mislead.  OK, it is a part of a paragraph about
> using AS-SET but still think that it overstates the case.  We don't
> want everyone to de-aggregate everything!
> Suggest
> " Route
>    aggregation
>   that was previously performed by proxy aggregation is still
> possible under some conditions without the use of
>    AS_SETs (please see Appendix A for relevant discussion and
>    suggestions)."
>  
> Tom Petch

Tom,

I think the reference to Appendix A may have been before Appendix A
was completely replaced with an attempt to bash any use of AS_SET by
giving an example of where it could go completely wrong if
incopetently configured.  So maybe the sentence could remain and the
reference to Appendix A removed.

I also feel that Appendix A should be removed.  Aggregation was never
meant to be automatic or foolproof.  It was always assumed that
whoever was forming aggregates very well knew what they were doing.

Curtis

> ----- Original Message -----
> From: <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>
> Sent: Sunday, April 24, 2011 7:00 PM
> Subject: [Idr] I-D Action:draft-ietf-idr-deprecate-as-sets-03.txt
>  
>  
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> > This draft is a work item of the Inter-Domain Routing Working Group of the
> IETF.
> >
> >
> > Title           : Deprecation of the use of BGP AS_SET, AS_CONFED_SET.
> > Author(s)       : W. Kumari, K. Sriram
> > Filename        : draft-ietf-idr-deprecate-as-sets-03.txt
> > Pages           : 8
> > Date            : 2011-04-24
> >
> > This document deprecates the use of the AS_SET and AS_CONFED_SET
> > types of the AS_PATH in BGPv4.  This is done to simplify the design
> > and implementation of the BGP protocol and to make the semantics of
> > the originator of a route more clear.  This will also simplify the
> > design, implementation and deployment of ongoing work in the Secure
> > Inter-Domain Routing Working Group.
> >
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-ietf-idr-deprecate-as-sets-03.txt
> >
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> >
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.

---

From: Warren Kumari <[email-masked]>
Date: Mon, 2 May 2011 17:14:45 -0400

On Apr 30, 2011, at 6:40 AM, t.petch wrote:

> Appendix A.

Thank you -- Appendix A has been removed as a number of folk didn't think it helped.

>  By contrast, I would like to give this sentence more

Done.

>   AS_SETs (please see Appendix A for relevant discussion and

Done (well, with the reference to Appendix A removed :-P)

New rev posted.....

I'd like to take a second to thank you for all of your time, input, comments and review on this doc -- I *really* appreciate it....

W
> --------------------------------------------------------------------------------
> 
> 
>> _______________________________________________
>> Idr mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/idr
>> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: Warren Kumari <[email-masked]>
Date: Mon, 2 May 2011 17:24:36 -0400

And I just realized that I forgot to do:

s/will/may/ in "Future work will update the protocol to remove support for the AS_SET path segment type of the AS_PATH attribute"

Amazing how often you notice something like that as you click the confirm button :-)

W