Subject: [Idr] [Technical Errata Reported] RFC4271 (2838)

From: RFC Errata System <[email-masked]>
Date: Thu, 16 Jun 2011 08:44:12 -0700 (PDT)

The following errata report has been submitted for RFC4271,
"A Border Gateway Protocol 4 (BGP-4)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4271&eid=2838

--------------------------------------
Type: Technical
Reported by: Jamie Taylor <[email-masked]>

Section: 8.2.2

Original Text
-------------
on page 72, description of the Established state:

If the HoldTimer_Expires event occurs (Event 10), the local system:
 ...[list of actions to take]...

Corrected Text
--------------
If the HoldTimer_Expires event occurs (Event 10), the local system:
 - deletes all routes associated with this connection
 ...[list of actions in original text]...

Notes
-----
All other transitions from Established to Idle explicitly state that all routes associated with the connection are deleted.  This transition should as well.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4271 (draft-ietf-idr-bgp4-26)
--------------------------------------
Title               : A Border Gateway Protocol 4 (BGP-4)
Publication Date    : January 2006
Author(s)           : Y. Rekhter, Ed., T. Li, Ed., S. Hares, Ed.
Category            : DRAFT STANDARD
Source              : Inter-Domain Routing
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Tony Li <[email-masked]>
Date: Thu, 16 Jun 2011 18:07:44 -0700

This errata seems valid to me.  Other opinions?

Regards,
Tony

---

From: "t.petch" <[email-masked]>
Date: Sat, 18 Jun 2011 12:41:15 +0200

----- Original Message -----
From: "Tony Li" <[email-masked]>
To: "RFC Errata System" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Friday, June 17, 2011 3:07 AM
Subject: Re: [Idr] [Technical Errata Reported] RFC4271 (2838)

> This errata seems valid to me.  Other opinions?

The deletion of routes was added to the FSM between
draft-idr-bgp4-17 and draft-idr-bgp4-18.
Sue was making the changes and this one was triggered by an e-mail in January
2002
from Alex Zinin.  His e-mail explicitly calls out the changes and has deletion
of routes for
some events and not for others, when in the Established state.  I never got to
find out
why he proposed it (at all - for myself, I would have left it as part of the
catchall
'releases all BGP resources').

Tom Petch

> > All other transitions from Established to Idle explicitly state that all
routes associated with the connection are deleted.  This transition should as
well.
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: John Scudder <[email-masked]>
Date: Mon, 20 Jun 2011 05:41:14 -0700

I agree, but given that the other transitions from Established do explicitly call out route deletion for whatever reason, it makes sense to me that it be made consistent.

--John