Subject: [Idr] Fwd: I-D Action: draft-keyur-idr-enhanced-gr-00.txt

From: Enke Chen <[email-masked]>
Date: Wed, 29 Jun 2011 09:25:55 -0700

FYI.  Will appreciate your comments.

Regards,   -- Enke

-------- Original Message --------
Subject: 	I-D Action: draft-keyur-idr-enhanced-gr-00.txt
Date: 	Wed, 29 Jun 2011 09:21:21 -0700
From: 	[email-masked]
Reply-To: 	[email-masked]
To: 	[email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : Accelerated Routing Convergence for BGP Graceful Restart
	Author(s)       : Keyur Patel
                           Enke Chen
                           Rex Fernando
                           John Scudder
	Filename        : draft-keyur-idr-enhanced-gr-00.txt
	Pages           : 9
	Date            : 2011-06-29

    In this document we specify extensions to BGP graceful restart in
    order to avoid unnecessary transmission of the routing information
    preserved across a session restart, thus accelerating the routing
    convergence.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-keyur-idr-enhanced-gr-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-keyur-idr-enhanced-gr-00.txt
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: <[email-masked]>
Date: Thu, 30 Jun 2011 17:11:10 +0200

Keyur, Enke, Rex, John,

> FYI.  Will appreciate your comments.

Please find below some comments on your draft.

5. Operation

1) "Once the acknowledgment from a
   peer is not received within the specified upper bound, and the
   maintained state is compromised, then the speaker MUST clear the "TX
   Routing State" in the GR Capability to be advertised to the peer in
   the next session restart."

Is there a chance to be able to achieve a resync some time later within the same BGP session? E.g. if latter on we receive an acknowledgement, is it possible to start again sending a new version number & maintaining the required state? If so IMHO it could useful to say so since current sentence could be understood as prohibiting this ("MUST clear the "TX Routing State" in the GR Capability to be advertised to the peer in the next session restart.")

2) " During the lifetime of an established session, if needed, a BGP
   speaker MAY use the UPDATE-VERSION message to request updates from
   the last update version that was previously acknowledged as long as
   the speaker has received the Enhanced GR Capability from its peer.

   When a BGP speaker receives such a request, it SHALL try to send
   routing information from the last acknowledged update version that
   the speaker has recorded.  If the speaker is unable to do so for some
   reason (e.g., "slow peer"), then it SHOULD perform a route refresh
   using mechanism defined in [EH-RR] if possible.  Otherwise, the BGP
   speaker SHOULD reset the session."

- I would propose to add the following example as reason for not being able to send the routes "did not maintained required states")
- By "reset the session" do you mean sending a NOTIFICATION or initiating an OPEN with GR enabled? (I understand the former, why not using/allowing the latter?)

Thanks
Regards,
Bruno

---------------
From: [email-masked] [mailto:[email-masked]] On Behalf Of Enke Chen
Sent: Wednesday, June 29, 2011 6:26 PM
To: [email-masked]
Cc: Keyur Patel
Subject: [Idr] Fwd: I-D Action: draft-keyur-idr-enhanced-gr-00.txt

Regards,   -- Enke

-------- Original Message -------- 
Subject: 
I-D Action: draft-keyur-idr-enhanced-gr-00.txt
Date: 
Wed, 29 Jun 2011 09:21:21 -0700
From: 
[email-masked]
Reply-To: 
[email-masked]
To: 
[email-masked]

---

From: Keyur Patel <[email-masked]>
Date: Thu, 30 Jun 2011 15:03:00 -0700

Hi Bruno,

Thanks for the review. :) Comments are inlined. #Keyur

On 6/30/11 8:11 AM, "[email-masked]"
<[email-masked]> wrote:

> Is there a chance to be able to achieve a resync some time later within the
> same BGP session? E.g. if latter on we receive an acknowledgement, is it
> possible to start again sending a new version number & maintaining the
> required state? If so IMHO it could useful to say so since current sentence
> could be understood as prohibiting this ("MUST clear the "TX Routing State" in
> the GR Capability to be advertised to the peer in the next session restart.")
> 

#Keyur: If the maintained state is compromised (e.g wrt Withdrawals) then
you want to re-announce complete BGP table.
> - I would propose to add the following example as reason for not being able to
> send the routes "did not maintained required states")
> - By "reset the session" do you mean sending a NOTIFICATION or initiating an
> OPEN with GR enabled? (I understand the former, why not using/allowing the
> latter?)

#Keyur: Notifications are fine as well as long as you have them on GR
(draft-keyupate-idr-bgp-gr-extension).

In any case we can provide a bit more clarification in the next rev.

Regards,
Keyur