Subject: [Idr] WG adoption call

From: "Susan Hares" <[email-masked]>
Date: Mon, 5 Mar 2012 09:40:31 -0500

This is to start a 2 week WG call for Adoption of
draft-ymbk-rfd-usable-02.txt.

Please send support or comments to the mailing list.  The WG call for
adoption will last from 

3/5 to 3/19.  We'll summarize this before the IDR meeting.

Sue and John

----------------------------

Here's document info:  

http://datatracker.ietf.org/doc/draft-ymbk-rfd-usable/

Abstract: 

   Route Flap Damping (RFD) was first proposed to reduce BGP churn in

   routers.  Unfortunately, RFD was found to severely penalize sites for

   being well-connected because topological richness amplifies the

   number of update messages exchanged.  Many operators have turned RFD

   off.  Based on experimental measurement, this document recommends

   adjusting a few RFD algorithmic constants and limits, to reduce the

   high risks with RFD, with the result being damping a non-trivial

   amount of long term churn without penalizing well-behaved prefixes'

   normal convergence process.

C. Pelsser, R. Bush (IIJ)

K. Patel, P. Mohapatra (Cisco Systems)

O. Maenel (Loughborough University)

---

From: Randy Bush <[email-masked]>
Date: Mon, 05 Mar 2012 23:48:57 +0900

> Please send support or comments to the mailing list.  The WG call for

and, while the issue on the table is whether or not this work should be
adopted by idr, not the minutae of its content, the authors would gladly
take constructive content suggestions before the march 12th dreadline.
send text :)

randy

---

From: Warren Kumari <[email-masked]>
Date: Mon, 5 Mar 2012 10:01:01 -0500

On Mar 5, 2012, at 9:40 AM, Susan Hares wrote:

>  
> This is to start a 2 week WG call for Adoption of draft-ymbk-rfd-usable-02.txt.

Support -- have read, discussed and commented.

Actually, to be 100% honest, I thought that we had already done an adoption call and accepted this (but apparently I am misremembering...)

W

>  
> Please send support or comments to the mailing list.  The WG call for adoption will last from
> 3/5 to 3/19.  We’ll summarize this before the IDR meeting.
>  
> Sue and John
>  
> Here’s document info:  
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Tony Li <[email-masked]>
Date: Mon, 5 Mar 2012 08:12:14 -0800

> 3/5 to 3/19.  We’ll summarize this before the IDR meeting.

I support adoption.

Tony

---

From: "Gaurav Dawra (gdawra)" <[email-masked]>
Date: Mon, 5 Mar 2012 16:18:24 +0000

Support Adoption.

-Gaurav

On 3/5/12 8:12 AM, "Tony Li" <[email-masked]> wrote:

>> 3/5 to 3/19.  We¹ll summarize this before the IDR meeting.
>
>
>I support adoption.
>
>Tony
>

---

From: Bhavani Parise <[email-masked]>
Date: Mon, 05 Mar 2012 11:25:53 -0800

Support Adoption

regards,
Bhavani

---

From: Seiichi Kawamura <[email-masked]>
Date: Tue, 06 Mar 2012 10:19:22 +0900

support.

Seiichi

---

From: "Arjun Sreekantiah (asreekan)" <[email-masked]>
Date: Mon, 5 Mar 2012 17:46:18 -0800

Support adoption.

-Arjun

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Susan Hares
Sent: Monday, March 05, 2012 6:41 AM
To: [email-masked]
Subject: [Idr] WG adoption call

Sue and John

 

Here's document info:  

Abstract:

---

From: "Balaji Pitta Venkatachalapathy (bvenkata)" <[email-masked]>
Date: Mon, 5 Mar 2012 21:39:08 -0600

Support adoption.

Balaji

 

Sue and John

 

Here's document info:  

Abstract:

---

From: Shishio Tsuchiya <[email-masked]>
Date: Tue, 06 Mar 2012 14:24:09 +0900

support adoption!

---

From: Shane Amante <[email-masked]>
Date: Mon, 5 Mar 2012 23:29:26 -0700

I support this draft becoming a WG draft.

-shane

---

From: "Luay Jalil" <[email-masked]>
Date: Tue, 6 Mar 2012 00:40:18 -0600

Support adoption

Luay

From: [email-masked] [mailto:[email-masked]] On Behalf Of Susan
Hares
Sent: Monday, March 05, 2012 8:41 AM
To: [email-masked]
Subject: [Idr] WG adoption call

Sue and John

 

Here's document info:  

Abstract:

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 6 Mar 2012 02:52:59 -0500

Yes/support

Regards,
Jeff

From: [email-masked] [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Monday, March 05, 2012 6:41 AM
To: [email-masked]
Subject: [Idr] WG adoption call

Sue and John

Here's document info:

Abstract:

---

From: "Shyam Sethuram (shsethur)" <[email-masked]>
Date: Tue, 6 Mar 2012 01:21:33 -0800

Support.

thanks--shyam

>-----Original Message-----
Susan Hares
adoption will last from

---

From: Jeffrey Haas <[email-masked]>
Date: Sun, 11 Mar 2012 16:05:15 -0400

> draft-ymbk-rfd-usable-02.txt.

I'd like to support adoption of this draft as a WG document.

Comments to the authors:
- Do you really want this on standards track?  I think informational would
  be a lower bar to publication as an RFC.
- The Pelsser document is the foundation of this work.  While psg.com is
  pretty long-lived, would the authors consider publication of the
  documentation elsewhere so the URL is likely to be even more survivable.
  Perhaps as an informational RFC on its own?
- The metrics noted in Table 1 are, effectively, vendor particular.  One of
  (many) ugly details that has dogged RFC 2439 is that its metrics are not
  what is present in most implementations.  I think this presents a minor
  issue with respect to normative references.  It's also one of the reasons I
  recommend informational.

-- Jeff (who wishes someone would take some of their copious spare time and
issue an 2439-bis that reflects reality someone better.)

---

From: Randy Bush <[email-masked]>
Date: Mon, 12 Mar 2012 21:28:16 +0900

> - Do you really want this on standards track?  I think informational
>   would be a lower bar to publication as an RFC.

it modifies parameters in a standards track rfc

> - The Pelsser document is the foundation of this work.  While psg.com
>   is pretty long-lived, would the authors consider publication of the

it was a paper in PAM.  we may be able to fix the cite presuming PAM
papers are free to download.

> - The metrics noted in Table 1 are, effectively, vendor particular.
>   One of (many) ugly details that has dogged RFC 2439 is that its
>   metrics are not what is present in most implementations.  I think
>   this presents a minor issue with respect to normative references.
>   It's also one of the reasons I recommend informational.

there is spare horizontal space for a couple more vendors if you think
that would enhance things.

> -- Jeff (who wishes someone would take some of their copious spare
>    time and issue an 2439-bis that reflects reality someone better.)

i admire your ambition :)

randy

---

From: Randy Bush <[email-masked]>
Date: Mon, 12 Mar 2012 21:33:08 +0900

>>   documentation elsewhere so the URL is likely to be even more

http://pam2011.gatech.edu/papers/pam2011--Pelsser.pdf

randy

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 12 Mar 2012 09:40:14 -0400

> it modifies parameters in a standards track rfc
[...]

>From Table 1, where do you trace back either vendor's numbers to RFC 2439?
The 15 minute half-life, perhaps.  

That mostly my point.  While a piece of the general suppression algorithm is
implemented from the RFC by multiple vendors, the exact algorithm, floating
point metrics, etc. are not.  (Never mind tracking of path data.)

You're thus not really making recommendations on parameters in the RFC.
You're making recommendations of vendor knobs on implementations that are
vaguely tied to the RFC.

> that would enhance things.

I think getting some more data points would be good, but the general idea is
there.

-- Jeff