Subject: Re: [Idr] WG adoption call for draft-xu-idr-performance-routing-01

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 25 Dec 2014 18:15:22 +0000

Hi all,

I do support the adoption of draft-xu-idr-performance-routing as WG document.

I have however a comment. In section 9, Security Considerations, bullet a, it is mentioned that “it MUST disable Performance Routing Capability negotiation between BGP peers which belong to different administration domains.” As stated along the draft, the performance-based routing capability is created to offer performance route selection criteria to customers of service providers which own networks formed by different ASes. In my understanding those customers are clearly different administration domains with regard the one of the service provider. Then Performance Routing Capability has to be enabled in that cases. So I would relax the sentence in the way: “it MAY be disabled …” or something like that, to be consistent  with the aim of  the draft.

Thanks

Best regards

Luis

From: Susan Hares [mailto:[email-masked]]
Sent: Tuesday, December 23, 2014 10:37 PM
To: idr wg
Cc: Xuxiaohu; John G. Scudder
Subject: WG adoption call for draft-xu-idr-performance-routing-01

This is to begin a 2 Week WG adoption call for draft-xu-idr-performance-routing-01  (12/23/2014 to 01/6/2014).  The draft can be accessed at:

 http://datatracker.ietf.org/doc/draft-xu-idr-performance-routing/.

In your response, please discuss the pros/cons of this approach and indicate “support” or “no support”.

Thank you,

Sue Hares

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Smith, Donald" <[email-masked]>
Date: Thu, 25 Dec 2014 18:47:08 +0000

Good catch, I think: MUST be able to be disabled per peer/AS/session (so you can offer it intra peer, where when you want.)

(coffee != sleep) & (!coffee == sleep)
 [email-masked]<mailto:[email-masked]>
________________________________
From: Idr [[email-masked]] on behalf of LUIS MIGUEL CONTRERAS MURILLO [[email-masked]]
Sent: Thursday, December 25, 2014 11:15 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Idr] WG adoption call for draft-xu-idr-performance-routing-01

Hi all,

Thanks

Best regards

Luis

Thank you,

Sue Hares

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
This communication is the property of CenturyLink and may contain confidential or privileged information. Unauthorized use of this communication is strictly prohibited and may be unlawful. If you have received this communication in error, please immediately notify the sender by reply e-mail and destroy all copies of the communication and any attachments.

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 25 Dec 2014 20:35:34 +0100

The question here is what should be the default behavior. With your
suggestions "MUST be able to be disabled" the default is ON which I
think would be wrong.

If anything one may consider: "MUST be able to be enabled"

Cheers,
r.

On Thu, Dec 25, 2014 at 7:47 PM, Smith, Donald
<[email-masked]> wrote:
> Good catch, I think: MUST be able to be disabled per peer/AS/session (so you
> can offer it intra peer, where when you want.)
>
>
>
>  [email-masked]
> From: Idr [[email-masked]] on behalf of LUIS MIGUEL CONTRERAS MURILLO
> [[email-masked]]
> I have however a comment. In section 9, Security Considerations, bullet a,
> it is mentioned that “it MUST disable Performance Routing Capability
> negotiation between BGP peers which belong to different administration
> domains.” As stated along the draft, the performance-based routing
> capability is created to offer performance route selection criteria to
> customers of service providers which own networks formed by different ASes.
> In my understanding those customers are clearly different administration
> domains with regard the one of the service provider. Then Performance
> Routing Capability has to be enabled in that cases. So I would relax the
> sentence in the way: “it MAY be disabled …” or something like that, to be
> consistent  with the aim of  the draft.
>
>
>
> Thanks
>
>
>
> Best regards
>
>
>
> Luis
>
>
>
> This is to begin a 2 Week WG adoption call for
> draft-xu-idr-performance-routing-01  (12/23/2014 to 01/6/2014).  The draft
> can be accessed at:
>
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de la
> legislación vigente. Si ha recibido este mensaje por error, le rogamos que
> nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição
> This communication is the property of CenturyLink and may contain
> confidential or privileged information. Unauthorized use of this
> communication is strictly prohibited and may be unlawful. If you have
> received this communication in error, please immediately notify the sender
> by reply e-mail and destroy all copies of the communication and any
> attachments.
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 25 Dec 2014 20:25:02 +0000

Hi,

I agree. Probably the best formulation can be: "MUST be able to be enabled", in such a way that the performance routing capabilities are enabled in a by customer fashion.

Regards

Luis

-----Mensaje original-----
De: [email-masked] [mailto:[email-masked]] En nombre de Robert Raszuk
Enviado el: jueves, 25 de diciembre de 2014 20:36
Para: Smith, Donald
CC: LUIS MIGUEL CONTRERAS MURILLO; [email-masked]; [email-masked]
Asunto: Re: [Idr] WG adoption call for draft-xu-idr-performance-routing-01

The question here is what should be the default behavior. With your suggestions "MUST be able to be disabled" the default is ON which I think would be wrong.

Cheers,
r.

On Thu, Dec 25, 2014 at 7:47 PM, Smith, Donald <[email-masked]> wrote:
> Good catch, I think: MUST be able to be disabled per peer/AS/session
> (so you can offer it intra peer, where when you want.)
>
>
>
> (coffee != sleep) & (!coffee == sleep)  [email-masked]
> From: Idr [[email-masked]] on behalf of LUIS MIGUEL CONTRERAS
> MURILLO [[email-masked]]
> I have however a comment. In section 9, Security Considerations,
> bullet a, it is mentioned that “it MUST disable Performance Routing
> Capability negotiation between BGP peers which belong to different
> administration domains.” As stated along the draft, the
> performance-based routing capability is created to offer performance
> route selection criteria to customers of service providers which own networks formed by different ASes.
> In my understanding those customers are clearly different
> administration domains with regard the one of the service provider.
> Then Performance Routing Capability has to be enabled in that cases.
> So I would relax the sentence in the way: “it MAY be disabled …” or
> something like that, to be consistent  with the aim of  the draft.
>
>
>
> Thanks
>
>
>
> Best regards
>
>
>
> Luis
>
>
>
> draft-xu-idr-performance-routing-01  (12/23/2014 to 01/6/2014).  The
> draft can be accessed at:
>
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su
> destinatario, puede contener información privilegiada o confidencial y
> es para uso exclusivo de la persona o entidad de destino. Si no es
> usted. el destinatario indicado, queda notificado de que la lectura,
> utilización, divulgación y/o copia sin autorización puede estar
> prohibida en virtud de la legislación vigente. Si ha recibido este
> mensaje por error, le rogamos que nos lo comunique inmediatamente por
> esta misma vía y proceda a su destrucción.
>
> confidential information intended only for the use of the individual
> or entity named above. If the reader of this message is not the
> intended recipient, you are hereby notified that any dissemination,
> distribution or copying of this communication is strictly prohibited.
> If you have received this transmission in error, do not read it.
> Please immediately reply to the sender that you have received this
> communication in error and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu
> destinatário, pode conter informação privilegiada ou confidencial e é
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
> senhoria o destinatário indicado, fica notificado de que a leitura,
> utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente.
> imediatamente por esta mesma via e proceda a sua destruição This
> communication is the property of CenturyLink and may contain
> received this communication in error, please immediately notify the
> sender by reply e-mail and destroy all copies of the communication and
> any attachments.
>

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 26 Dec 2014 01:29:42 +0000

Hi Robert, Luis and Smith,

Thanks a lot for your valuable comments. The logic of the statement of "MUST be able to be enabled" looks fine to me.

Therefore, how about saying something like "Performance Routing Capability negotiation between BGP peers which belong to different administration domains MUST be disabled by default."? 

Best regards,
Xiaohu

> -----Original Message-----
> From: Idr [mailto:[email-masked]] On Behalf Of LUIS MIGUEL CONTRERAS
> MURILLO
> Sent: Friday, December 26, 2014 4:25 AM
> To: Robert Raszuk; Smith, Donald
> Cc: [email-masked]; [email-masked]
> I agree. Probably the best formulation can be: "MUST be able to be enabled", in
> such a way that the performance routing capabilities are enabled in a by
> customer fashion.
> 
> Regards
> 
> Luis
> 
> De: [email-masked] [mailto:[email-masked]] En nombre de Robert
> Raszuk Enviado el: jueves, 25 de diciembre de 2014 20:36
> Para: Smith, Donald
> The question here is what should be the default behavior. With your suggestions
> "MUST be able to be disabled" the default is ON which I think would be wrong.
> 
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede
> contener información privilegiada o confidencial y es para uso exclusivo de la
> persona o entidad de destino. Si no es usted. el destinatario indicado, queda
> notificado de que la lectura, utilización, divulgación y/o copia sin autorización
> puede estar prohibida en virtud de la legislación vigente. Si ha recibido este
> mensaje por error, le rogamos que nos lo comunique inmediatamente por esta
> misma vía y proceda a su destrucción.
> 
> The information contained in this transmission is privileged and confidential
> information intended only for the use of the individual or entity named above. If
> the reader of this message is not the intended recipient, you are hereby notified
> that any dissemination, distribution or copying of this communication is strictly
> prohibited. If you have received this transmission in error, do not read it. Please
> immediately reply to the sender that you have received this communication in
> error and then delete it.
> 
> pode conter informação privilegiada ou confidencial e é para uso exclusivo da
> pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado,
> fica notificado de que a leitura, utilização, divulgação e/ou cópia sem
> autorização pode estar proibida em virtude da legislação vigente. Se recebeu
> esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por
> esta mesma via e proceda a sua destruição

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Fri, 26 Dec 2014 17:45:46 +0000

Ok for me

Regards

Luis

-----Mensaje original-----
De: Xuxiaohu [mailto:[email-masked]]
Enviado el: viernes, 26 de diciembre de 2014 2:30
Para: LUIS MIGUEL CONTRERAS MURILLO; Robert Raszuk; Smith, Donald
CC: [email-masked]; [email-masked]
Asunto: RE: [Idr] WG adoption call for draft-xu-idr-performance-routing-01

Best regards,
Xiaohu

> From: Idr [mailto:[email-masked]] On Behalf Of LUIS MIGUEL
> CONTRERAS MURILLO
> I agree. Probably the best formulation can be: "MUST be able to be
> enabled", in such a way that the performance routing capabilities are
> enabled in a by customer fashion.
>
> Regards
>
> Luis
>
> suggestions "MUST be able to be disabled" the default is ON which I think would be wrong.
>
> > route selection criteria to customers of service providers which own
> > networks
> formed by different ASes.
> > destinatario, puede contener información privilegiada o confidencial
> > y es para uso exclusivo de la persona o entidad de destino. Si no es
> > mensaje por error, le rogamos que nos lo comunique inmediatamente
> > por esta misma vía y proceda a su destrucción.
> >
> > destinatário, pode conter informação privilegiada ou confidencial e
> > é para uso exclusivo da pessoa ou entidade de destino. Se não é
> > vossa senhoria o destinatário indicado, fica notificado de que a
> > leitura, utilização, divulgação e/ou cópia sem autorização pode
> > estar proibida em
> virtude da legislação vigente.
> > communication is strictly prohibited and may be unlawful. If you
> > have received this communication in error, please immediately notify
> > the sender by reply e-mail and destroy all copies of the
> > communication and any attachments.
> >
> mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.
>
> Please immediately reply to the sender that you have received this communication in error and then delete it.
>
> utilização, divulgação e/ou cópia sem autorização pode estar proibida
> em virtude da legislação vigente. Se recebeu esta mensagem por erro,
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e
> proceda a sua destruição