Subject: [Idr] Status of "Carrying next-hop cost information in BGP" draft

From: Thomas King <[email-masked]>
Date: Thu, 11 Dec 2014 16:41:16 +0000

Hello Ily and Robert,

I am a big fan of your draft "Carrying next-hop cost information in BGP" [0]. Unfortunately, I do not see much progress on the draft since a couple of months. I am currently working with a bunch of guys on a draft about a feature for route servers which relies on ideas proposed by your draft. So it is crucial for me to understand if this draft is dead or still alive. Could you please give me the status of the draft from your point of view?

Thanks in advance,
Thomas

[0]: http://tools.ietf.org/html/draft-ietf-idr-bgp-nh-cost-01

--
Dr. Thomas King
Manager Research & Development

DE-CIX Management GmbH | Lindleystraße 12 | 60314 Frankfurt am Main | Germany | www.de-cix.net
Phone +49 69 1730902 87 | Mobile +49 175 1161428 | Fax +49 69 4056 2716 | [email-masked]
Geschaeftsfuehrer Harald A. Summa | Registergericht AG Koeln HRB 51135

---

From: iLya Varlashkin <[email-masked]>
Date: Thu, 11 Dec 2014 17:22:08 +0000

Hi Thomas,

great to hear about practical case for NH SAFI draft. Although currently the draft is in latent state, it’s not abandoned. Basically there’s a need in implementation to figure out how proposed encoding format fits existing code bases. Are you working on a code that could incorporate this feature? If so, let discuss in more details.

Kind regards,
iLya

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 11 Dec 2014 10:00:23 -0800

Just an update ...

Related draft Optimal RR reflection has been implemented at least by
two big commercial vendors. Exa-BGP was also looking at it.

The comment I got when asking for this extension implementation was
that next hop cost can be already taken from BGP-LS extension so there
is no need to implement yet another mechanism.

While it is possible for just IGP metric the scope of this document
was broader allowing non metric related responses. For those extending
the IGP + BGP-LS as indirect mechanism may not be the most lucky
choice.

Rgs,
r.