Subject: Re: [Idr] WG adoption call for draft-xu-idr-performance-routing-01

From: <[email-masked]>
Date: Mon, 5 Jan 2015 16:21:05 +0000

Hi,

I'm wondering what happens if a specific BGP Speaker in the path vector is supporting this extension but for some (many) reason, cannot provide a latency information.
In this case, there must be an information encoded saying that the NETWORK_LATENCY cannot be used for this specific path because part of the latency will be missing. For example, we can set the value to the worst value  (like a MED missing as worst ? :) ).

Best regards,

Stephane

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 6 Jan 2015 01:14:56 +0000

Hi Stephane,

It's a very good suggestion and I would incorporate it in the future version.

Best regards,
Xiaohu

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, January 06, 2015 12:21 AM
> To: Xuxiaohu
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Idr] WG adoption call for draft-xu-idr-performance-routing-01
> 
> Hi,
> 
> I'm wondering what happens if a specific BGP Speaker in the path vector is
> supporting this extension but for some (many) reason, cannot provide a latency
> information.
> In this case, there must be an information encoded saying that the
> NETWORK_LATENCY cannot be used for this specific path because part of the
> latency will be missing. For example, we can set the value to the worst value
> (like a MED missing as worst ? :) ).
> 
> 
> Best regards,
> 
> Stephane
> 
> 
> _____________________________________________________________
> ____________________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou
> copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le
> signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration, Orange decline toute responsabilite
> si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed, used
> or copied without authorisation.

---

From: Haoweiguo <[email-masked]>
Date: Tue, 6 Jan 2015 01:47:27 +0000

This draft provides a good extension for BGP route decision process, it can facilitate some critical applications deployment with network performance concern. So i support the adoption.

Thanks,
weiguo
________________________________________
From: Idr [[email-masked]] on behalf of Xuxiaohu [[email-masked]]
Sent: Tuesday, January 06, 2015 9:14
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Idr] WG adoption call for draft-xu-idr-performance-routing-01

Hi Stephane,

Best regards,
Xiaohu

> (like a MED missing as worst ? :) ).

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: <[email-masked]>
Date: Wed, 7 Jan 2015 08:36:01 +0000

Hi Stephane,

Good point!

FWIW, we have investigated this issue in a specification that is more generic than what we are doing in draft-xu-idr-performance-routing:
 https://tools.ietf.org/html/draft-boucadair-qos-bgp-spec-01#page-16 (Search for "QoS hole" in that document)

This point is worth to be documented in the next revision of draft-xu-idr-performance-routing.

Cheers,
Med

-----Message d'origine-----
De : Idr [mailto:[email-masked]] De la part de [email-masked]
Envoyé : lundi 5 janvier 2015 17:21
À : Xuxiaohu
Cc : [email-masked]; [email-masked]
Objet : Re: [Idr] WG adoption call for draft-xu-idr-performance-routing-01

Hi,

Best regards,

Stephane