Subject: Re: [Idr] 1 Week Final Call for adoption of draft-dong-idr-rtc-hierarchical-rr-02

From: <[email-masked]>
Date: Tue, 6 Jan 2015 16:38:47 +0000

Hi Sue, John, all

I support WG adoption.

AFAIK, I don't have a use case for this (so personally I could live without) but the RTC  RFC has an issue and therefore, from and STD standpoint, IMO this at least needs to be documented.

Regarding the solution, I would a priori prefer the alternate solution (from Appendix A in v01 / the original solution proposed in v00; ala "Best External") rather than the solution currently proposed in v02 (ala "Add Path") for the following reasons:
- "Add Path" heavily depend on configuration to be done by the Service Provider. This add complexity to the provisioning system which would need to look at the iBGP client's configuration to see if it itself have an iBGP client session
- It looks to me that even the "Add Path" solution requires protocol extension (not crystal clear but the draft asks for STD track) and implementation change. So no specific advantage for "Add Path" on this point.
-The "Best External" solution is IMO more inlined with the current RTC spec/point of view which is to limit BGP states/path at the cost of a specific iBGP propagation rule. Looks more coherent to me and easier from an operational point to have all sessions within the AS behaving along  the same principles.

Specific comment:
- In §3.1 (add path solution)
"The number of RT-Constrain routes to be advertised is a local decision of operators. »
IMO "add path all" is needed, unless you define a new Add Path mode that you would need to specify.

Thanks,
Regards,
Bruno

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, December 19, 2014 2:45 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] 1 Week Final Call for adoption of draft-dong-idr-rtc-hierarchical-rr-02

The IDR Chairs intend to adopt the draft-dong-idr-rtc-hierarchical-rr-02 as a WG draft.  This is a 1 week final call for comments on the adoption of this draft as WG draft.  The draft can be found at:

http://datatracker.ietf.org/doc/draft-dong-idr-rtc-hierarchical-rr/

Sue Hares and John Scudder

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 6 Jan 2015 11:48:48 -0500

Bruno:

The document has been accepted as a WG document.   I hope that people will
engage you in debating the primary solution version the second solution.   I
expect this evening Jie will respond to this email during his working hours
(this evening). 

I agree with many of your points regarding Add-path versus RTC approach.
One question should we allow two solutions – one for people already taking
the heavy weight of add-path and another for the RTC. 

AddPath grouping has entered the standard process, but I did not hold it for
this work.  We can append a standard to the AddPath standard if operators
need this feature. 

Sue 

From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, January 06, 2015 11:39 AM
To: Susan Hares
Cc: [email-masked]; [email-masked]; Dongjie (Jimmy)
Subject: RE: [Idr] 1 Week Final Call for adoption of
draft-dong-idr-rtc-hierarchical-rr-02

Hi Sue, John, all

I support WG adoption.

AFAIK, I don’t have a use case for this (so personally I could live without)
but the RTC  RFC has an issue and therefore, from and STD standpoint, IMO
this at least needs to be documented.

Regarding the solution, I would a priori prefer the alternate solution (from
Appendix A in v01 / the original solution proposed in v00; ala “Best
External”) rather than the solution currently proposed in v02 (ala “Add
Path”) for the following reasons:

- “Add Path” heavily depend on configuration to be done by the Service
Provider. This add complexity to the provisioning system which would need to
look at the iBGP client’s configuration to see if it itself have an iBGP
client session 

- It looks to me that even the “Add Path” solution requires protocol
extension (not crystal clear but the draft asks for STD track) and
implementation change. So no specific advantage for “Add Path” on this
point.

-The “Best External” solution is IMO more inlined with the current RTC
spec/point of view which is to limit BGP states/path at the cost of a
specific iBGP propagation rule. Looks more coherent to me and easier from an
operational point to have all sessions within the AS behaving along  the
same principles.

Specific comment:

“The number of RT-Constrain routes to be advertised is a local decision of
operators. »

IMO “add path all” is needed, unless you define a new Add Path mode that you
would need to specify.

Thanks,

Regards,

Bruno

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, December 19, 2014 2:45 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] 1 Week Final Call for adoption of
draft-dong-idr-rtc-hierarchical-rr-02

The IDR Chairs intend to adopt the draft-dong-idr-rtc-hierarchical-rr-02 as
a WG draft.  This is a 1 week final call for comments on the adoption of
this draft as WG draft.  The draft can be found at:

 

 

____________________________________________________________________________
_____________________________________________
 
Ce message et ses pieces jointes peuvent contenir des informations
confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu
ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou
falsifie. Merci.
 
This message and its attachments may contain confidential or privileged
information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and
delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been
modified, changed or falsified.
Thank you.

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 7 Jan 2015 07:18:48 +0000

Hi Bruno, Sue,

Thanks for the discussion on this draft. Since now it is a WG document, we expect to have more discussions on this list about the choice of a suitable solution, and this is a good start:)

Personally, I'd also prefer the "best external" one, as it does not rely on the "add-path" capability, also does not add complexity in provisioning. The cost is to define new propagation rules for RTC AFI/SAFI. Note that the current propagation rule of RTC is already a little bit different from the BGP default rules.

As for the "add-path" solution, IMO this depends on the requirement of operators. If some of them plan to use add-path and RTC together, this can be one solution for them. "add-path all" can definitely meet the requirement, while we also want to check the possibility of advertising a subset of paths to solve this problem, for example, the "advertise N paths" mode in draft-ietf-idr-add-paths-guidelines.

Regarding the "standard track", we didn't expect protocol extensions with the "add-path" solution, but since the solution space is still open, it is likely that this document will include some protocol extensions.

Thanks again and we'd appreciate more discussions on this list.

Best regards,
Jie

From: Susan Hares [mailto:[email-masked]]
Sent: Wednesday, January 07, 2015 12:49 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; Dongjie (Jimmy)
Subject: RE: [Idr] 1 Week Final Call for adoption of draft-dong-idr-rtc-hierarchical-rr-02

Bruno:

The document has been accepted as a WG document.   I hope that people will engage you in debating the primary solution version the second solution.   I expect this evening Jie will respond to this email during his working hours (this evening).

I agree with many of your points regarding Add-path versus RTC approach.   One question should we allow two solutions - one for people already taking the heavy weight of add-path and another for the RTC.

AddPath grouping has entered the standard process, but I did not hold it for this work.  We can append a standard to the AddPath standard if operators need this feature.

Sue

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, January 06, 2015 11:39 AM
To: Susan Hares
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Dongjie (Jimmy)
Subject: RE: [Idr] 1 Week Final Call for adoption of draft-dong-idr-rtc-hierarchical-rr-02

Hi Sue, John, all

I support WG adoption.

Specific comment:

Thanks,
Regards,
Bruno

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, December 19, 2014 2:45 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Idr] 1 Week Final Call for adoption of draft-dong-idr-rtc-hierarchical-rr-02

Thank you.

---

From: <[email-masked]>
Date: Wed, 7 Jan 2015 08:18:43 +0000

Hi Jie,

Thanks for the discussion. I agree with you.

1 point:

> "add-path all" can definitely meet the requirement, while we also want to check the possibility of advertising a subset of paths to solve this problem, for example, the "advertise N paths" mode in draft-ietf-idr-add-paths-guidelines.

Agreed, but IMO you would need to be more prescriptive in the document rather than just say that operator will figure out.
I agree that advertising N paths can do the job. I'd like to see a text helping operators to define N. A priori, with little to no thinking,  I would say N must at least be (the number of iBGP clients sessions with clients having the same cluster ID) +1. E.g.  2+1=3 in typical scenarios (with redundant RR). This N value would be for the "down" way, assuming in the "up" way a single path is advertised.
Then which paths get advertised is a priori not important, so an option would be to use the mode "Add Path N" defined in draft-ietf-idr-add-paths-guidelines. On the pro side, it's already defined & implemented. On the con side, it's a priori overkilling and comes with a computational cost. Given that RTC is used for scalability purpose, the scale is a priori a point to consider (but the good news is that the states/path are not very dynamic as they are configuration (and failure) driven)

Clearly, this discussion is moot if we select the "best external" solution ;-)

Thanks,
Best regards,
Bruno

From: Dongjie (Jimmy) [mailto:[email-masked]]
Sent: Wednesday, January 07, 2015 8:19 AM
To: Susan Hares; DECRAENE Bruno IMT/OLN
Cc: [email-masked]; [email-masked]
Subject: RE: [Idr] 1 Week Final Call for adoption of draft-dong-idr-rtc-hierarchical-rr-02

Hi Bruno, Sue,

Best regards,
Jie

To: [email-masked]<mailto:[email-masked]>

Bruno:

Sue

Hi Sue, John, all

I support WG adoption.

Specific comment:

Thanks,
Regards,
Bruno

Thank you.

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 8 Jan 2015 06:16:10 +0000

Hi Bruno,

Totally agree with your point. If operators show the interest of using "add-path" solution, we would need to describe these with more details.

The processing cost was also one of my concern, especially if "add-path all" is to be used. But as you said, it is a solution built with implemented features... So I guess we need more opinions to make the decision:)

Besides, we'd also welcome discussions about other potential solutions.

Best regards,
Jie

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, January 07, 2015 4:19 PM
To: Dongjie (Jimmy)
Cc: [email-masked]
Subject: RE: [Idr] 1 Week Final Call for adoption of draft-dong-idr-rtc-hierarchical-rr-02

Hi Jie,

Thanks,
Best regards,
Bruno

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Hi Bruno, Sue,

Best regards,
Jie

Bruno:

Sue

Hi Sue, John, all

I support WG adoption.

Specific comment:

Thanks,
Regards,
Bruno

Thank you.

Thank you.