Subject: [Idr] redirect IPv6 nexthop

From: Shishio Tsuchiya <[email-masked]>
Date: Mon, 12 Jan 2015 21:51:34 +0900

Hi
I think we should define type for Flow spec redirect IPv6 format on
https://tools.ietf.org/html/draft-ietf-idr-flowspec-redirect-rt-bis

or

https://tools.ietf.org/html/draft-ietf-idr-flow-spec-v6

What do you think?

Regards,
-Shishio

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 12 Jan 2015 15:32:00 +0100

Hello Shishio-san,

Would the below text already present in the second draft not address your
question ?

Quote:

Another traffic filtering action defined in [RFC5575] as a BGP extended
community is redirect.  To allow an IPv6 address specific route-target, a
new traffic action IPv6 address specific extended community is provided.
The extended community type has the value  0x800b.

Redirect-IPv6: The redirect IPv6 address specific extended community allows
the traffic to be redirected to a VRF routing instance that lists the
specified IPv6 address specific route-target in its import policy.  If
several local instances match this criteria, the choice between them is a
local matter (for example, the instance with the lowest Route Distinguisher
value can be elected).  This extended community uses the same encoding as
the IPv6 address specific Route Target extended community [RFC5701].

Ref section 4 of: https://tools.ietf.org/html/draft-ietf-idr-flow-spec-v6-06

Many thx,
Robert.

On Mon, Jan 12, 2015 at 1:51 PM, Shishio Tsuchiya <[email-masked]>
wrote:

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: Shishio Tsuchiya <[email-masked]>
Date: Mon, 12 Jan 2015 23:56:30 +0900

Robert
Thanks for reply.
Sorry, this was my fault.
I skipped to read this section.
The draft looks perfect.

Regards,
-Shishio

On 2015/01/12 23:32, Robert Raszuk wrote:
> Hello Shishio-san,
> 
> Would the below text already present in the second draft not address your question ?
> 
> Quote:
> 
> Another traffic filtering action defined in [RFC5575] as a BGP extended community is redirect.  To allow an IPv6 address specific route-target, a new traffic action IPv6 address specific extended community is provided.  The extended community type has the value  0x800b.
> 
> Redirect-IPv6: The redirect IPv6 address specific extended community allows the traffic to be redirected to a VRF routing instance that lists the specified IPv6 address specific route-target in its import policy.  If several local instances match this criteria, the choice between them is a local matter (for example, the instance with the lowest Route Distinguisher value can be elected).  This extended community uses the same encoding as the IPv6 address specific Route Target extended community [RFC5701].
> 
> On Mon, Jan 12, 2015 at 1:51 PM, Shishio Tsuchiya <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Hi
>     [email-masked] <mailto:[email-masked]>

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 12 Jan 2015 16:13:47 +0100

Hello Shishio,

To elaborate a bit more the quote I provided allows you to use IPv6
specific RT to redirect to a VRF. It does not allow to encode IPv6 specific
redirect destination address directly in the actions. While your question
was a bit not specific on first reading I thought you are asking for the
former. On the second reading I realized you may be asking for both :)

Historically the latter was not done in
the draft-ietf-idr-flowspec-redirect-rt-bis-03 draft as IPv6 address simply
does not fit into BGP Extended Community attribute where we have 6 octets
to play with.

If you see a real need for actually encoding IPv6 address as redirect
destination we would need to use IPv6 Address Specific Extended Community
RFC5701 and define a new type value for it. That may cause a bit mess to
handle cases where both such action communities are present.

- - -

In general however the RFC5575 was specifically written to avoid all of the
above by using a concept of indirection where you first redirect to VRF
with plain RT then you can do what you like there. VRF with single default
and v4 or v6 next hop would be a perfect case for it. But it seems that few
folks wanted more protocol build in automation so the IPv4 as redirect
destination was added.

Now I guess based on your input to IDR is a question if we should
update draft-ietf-idr-flowspec-redirect-rt-bis-03 putting IPv6 redirect
destination there or not.

Cheers,
R.

On Mon, Jan 12, 2015 at 3:56 PM, Shishio Tsuchiya <[email-masked]>
wrote:

> > Redirect-IPv6: The redirect IPv6 address specific extended community
> allows the traffic to be redirected to a VRF routing instance that lists
> the specified IPv6 address specific route-target in its import policy.  If
> > Ref section 4 of:
> https://tools.ietf.org/html/draft-ietf-idr-flow-spec-v6-06
> >
> > Many thx,
> > Robert.
> >
> >

---

From: Shishio Tsuchiya <[email-masked]>
Date: Tue, 13 Jan 2015 01:35:20 +0900

Robert
Thnaks for more detail explanation. And your assamption is perfect.;-)
I think if we need "redirect IPv4" then we should need "redirect IPv6" too.
And I agree to create new extended community because redirect only has 6-octet encoding(IPv6 address is 16 octet).

Regards,
-Shishio

On 2015/01/13 0:13, Robert Raszuk wrote:
> Hello Shishio,
> 
> To elaborate a bit more the quote I provided allows you to use IPv6 specific RT to redirect to a VRF. It does not allow to encode IPv6 specific redirect destination address directly in the actions. While your question was a bit not specific on first reading I thought you are asking for the former. On the second reading I realized you may be asking for both :)
> 
> Historically the latter was not done in the draft-ietf-idr-flowspec-redirect-rt-bis-03 draft as IPv6 address simply does not fit into BGP Extended Community attribute where we have 6 octets to play with.
> 
> If you see a real need for actually encoding IPv6 address as redirect destination we would need to use IPv6 Address Specific Extended Community RFC5701 and define a new type value for it. That may cause a bit mess to handle cases where both such action communities are present.
> 
> - - -
> 
> In general however the RFC5575 was specifically written to avoid all of the above by using a concept of indirection where you first redirect to VRF with plain RT then you can do what you like there. VRF with single default and v4 or v6 next hop would be a perfect case for it. But it seems that few folks wanted more protocol build in automation so the IPv4 as redirect destination was added.
> 
> Now I guess based on your input to IDR is a question if we should update draft-ietf-idr-flowspec-redirect-rt-bis-03 putting IPv6 redirect destination there or not.
> 
> Cheers,
> R.
> 
> 
> 
> On Mon, Jan 12, 2015 at 3:56 PM, Shishio Tsuchiya <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Robert
>     Thanks for reply.
>     > Ref section 4 of:https://tools.ietf.org/html/draft-ietf-idr-flow-spec-v6-06
>     >
>     > Many thx,
>     > Robert.
>     >
>     >
>     > On Mon, Jan 12, 2015 at 1:51 PM, Shishio Tsuchiya <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>     >
>     >     Hi
>      > [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>