Subject: [Idr] Idr interim on 6/1/2015 - 10:00am to 11:30am edt

From: "Susan Hares" <[email-masked]>
Date: Sat, 30 May 2015 19:38:30 -0400

IDR Working Group Interim 6/1/2015 [10:00 - 11:30am EDT]

[Note: the Web-ex will be available 30 minutes before starting for the speakers to adjust slides]

Agenda 

             1) Agenda Bashing [10:00 - 10:05]    

                2) BGP Wide communities [draft-raszuk-wide-bgp-communities] 

                   Robert Raszuk [10:05 - 10:10] [Discussion: 10:10-10:20]                   

                   http://datatracker.ietf.org/doc/draft-raszuk-wide-bgp-communities/

                3) BGP RTC [10:25-10:50) 

                                a) Chair overview of RTC choices [10:20-10:25]

                                b) draft-litowski-idr-rtc-interas (Adoption 5/31 to 6/14) [10:25-10:35]

                                c) Discussion [10:35-10:45]

                4) BGP Link state model additions:  [10:45-11:10]

                                a. draft-wang-idr-eag-distribution Update [Michael Wang] [10:45-10:55]

                                b. draft-previdi-idr-bgpls-segement-routing-epe-03 [TBD] [10:55-11:05]

                                c. Discussion of Acee's suggestion [11:05-11:15]

                   Existing ls drafts are: 

                                1) draft-ietf-idr-ls-distribution-10 (In IESG processing)

                                2) draft-ietf-idr-ls-distribution-impl-04 (IESG wants on wiki] 

                                3) draft-ietf-idr-te-lsp-distribution-03 (WG draft )

                                Proposed additions are:                                

                                c) draft-wang-idr-eag-distribution (WG Adoption 5/20 to 6/3)

                                d) draft-previdi-idr-bgpls-segment-routing-epe-03(WG Adoption 5/31 to 6/14)

                                e) draft-psarkar-idr-bgp-ls-node-admin-tag-extension-00 (no request for adoption)

                                Based on the comments from Acee last week 

                                http://www.ietf.org/mail-archive/web/idr/current/msg14425.html) 

                                on harmonizing the additions to draft-idr-ls-distribution. 

                                We are examining the BGP LS additions this week.  

                5) BGP I2RS Use Case  

                                draft-keyupate-idr-i2rs-bgp-usecases-00.txt [Sue Hares] [11:15-11:30]

Background reading: 

RTC Drafts under consideration: 

1) draft-ietf-rtc-no-rtc (WG LC 5/22 to 6/5 in progress) 

  http://datatracker.ietf.org/doc/draft-ietf-idr-rtc-no-rt/

2) draft-litkowski-idr-rtc-interas (WG adoption call 5/31 to 6/14)

   http://datatracker.ietf.org/doc/draft-litkowski-idr-rtc-interas/                               

3) draft-ietf-idr-legacy-rtc-05   (WG draft) 

http://datatracker.ietf.org/doc/draft-ietf-idr-legacy-rtc/

4) draft-ietf-idr-rtc-hierarchical-rr-00 (WG draft) 

http://datatracker.ietf.org/doc/draft-ietf-idr-rtc-hierarchical-rr/

Web ex: 

https://ietf.webex.com/ietf/j.php?MTID=m689576316eaf19b397fbe242a310725f

Meeting number:            649 193 591 

Meeting password:         john.knows.all

1-877-668-4493 Call-in toll free number (US/Canada)

1-650-479-3208 Call-in toll number (US/Canada)

IDR Minutes: 

http://etherpad.tools.ietf.org:9000/p/idr-interim-06-01-2015-Minutes

IDR Interim Virtual Blue Sheets

http://etherpad.tools.ietf.org:9000/p/idr-interim-6-01-2015-vBlueSheets

Next Interims: 6/15 (Yang models) and 6/29 (Route Server, Tools, Yang, and nexthop)

From: IDR Working Group [mailto:[email-masked]] 
Sent: Saturday, May 30, 2015 6:02 PM
To: [email-masked]
Subject: (Forward to others) WebEx meeting invitation: idr interim 6/1/2015

You can forward this invitation to others. 

Hello, 

IDR Working Group invites you to join this WebEx meeting. 

idr interim 6/1/2015 

Monday, June 1, 2015 

10:00 am  |  Eastern Daylight Time (New York, GMT-04:00)  |  1.5 hrs 

 <https://ietf.webex.com/ietf/j.php?MTID=m689576316eaf19b397fbe242a310725f> Join WebEx meeting 

Meeting number: 

649 193 591 

Meeting password:

john.knows.all

Join by phone

1-877-668-4493 Call-in toll free number (US/Canada)

1-650-479-3208 Call-in toll number (US/Canada)

Access code: 649 193 591

 <http://www.webex.com/pdf/tollfree_restrictions.pdf> Toll-free calling restrictions

 <https://ietf.webex.com/ietf/j.php?MTID=m9cf69186e24b5baddb3f7467fb635fc9> Add this meeting to your calendar.

Can't join the meeting?  <https://ietf.webex.com/ietf/mc> Contact support. 

IMPORTANT NOTICE: Please note that this WebEx service allows audio and other information sent during the session to be recorded, which may be discoverable in a legal matter. By joining this session, you automatically consent to such recordings. If you do not consent to being recorded, discuss your concerns with the host or do not join the session.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sun, 31 May 2015 00:30:16 +0000

Unfortunately, I have another IETF Design Team meeting during this slot and will not be able to discuss my suggestion. However, my thought is that since Hannes is the editor of the BGP LS Draft and I was the routing directorate reviewer, we could respectively identify IS-IS and OSPF drafts which would require BGP LS attribute TLVs. At that point, these TLVs could then be added to the IGP draft and a cross-WG review could be done prior to the request for publication.
Thanks,
Acee

From: Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Saturday, May 30, 2015 at 7:38 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: 'Alia Atlas' <[email-masked]<mailto:[email-masked]>>, 'Deborah Brungard' <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] Idr interim on 6/1/2015 - 10:00am to 11:30am edt

Agenda

                3) BGP RTC [10:25-10:50)

                   Existing ls drafts are:

                                Proposed additions are:

                5) BGP I2RS Use Case

Background reading:

Web ex:

IDR Minutes:

From: IDR Working Group [mailto:[email-masked]]
Sent: Saturday, May 30, 2015 6:02 PM
To: [email-masked]<mailto:[email-masked]>
Subject: (Forward to others) WebEx meeting invitation: idr interim 6/1/2015

Hello,

idr interim 6/1/2015

Monday, June 1, 2015

Join WebEx meeting<https://ietf.webex.com/ietf/j.php?MTID=m689576316eaf19b397fbe242a310725f>

Meeting number:

649 193 591

Meeting password:

john.knows.all

Join by phone

Access code: 649 193 591

Toll-free calling restrictions<http://www.webex.com/pdf/tollfree_restrictions.pdf>

Add this meeting<https://ietf.webex.com/ietf/j.php?MTID=m9cf69186e24b5baddb3f7467fb635fc9> to your calendar.

Can't join the meeting? Contact support.<https://ietf.webex.com/ietf/mc>

---

From: "Susan Hares" <[email-masked]>
Date: Sat, 30 May 2015 20:55:00 -0400

Acee: 

This sounds good.  You’ll do WG review and IDR cross-review on the BGP-LS attribute TLVs. If the proposal for this TLV comes first in IDR, how do you want to handle it?  IDR can review the context and then send it on to IS-IS and OSPF. 

Sue 

From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: Saturday, May 30, 2015 8:30 PM
To: Susan Hares; [email-masked]
Cc: 'Alia Atlas'; 'Deborah Brungard'
Subject: Re: [Idr] Idr interim on 6/1/2015 - 10:00am to 11:30am edt

Thanks,

Acee 

From: Susan Hares <[email-masked]>
Date: Saturday, May 30, 2015 at 7:38 PM
To: "[email-masked]" <[email-masked]>
Cc: 'Alia Atlas' <[email-masked]>, 'Deborah Brungard' <[email-masked]>
Subject: [Idr] Idr interim on 6/1/2015 - 10:00am to 11:30am edt

Agenda 

                    <http://datatracker.ietf.org/doc/draft-raszuk-wide-bgp-communities/> http://datatracker.ietf.org/doc/draft-raszuk-wide-bgp-communities/

                3) BGP RTC [10:25-10:50) 

                

                   Existing ls drafts are: 

                                Proposed additions are:                                

                                 <http://www.ietf.org/mail-archive/web/idr/current/msg14425.html> http://www.ietf.org/mail-archive/web/idr/current/msg14425.html) 

                5) BGP I2RS Use Case  

Background reading: 

   <http://datatracker.ietf.org/doc/draft-ietf-idr-rtc-no-rt/> http://datatracker.ietf.org/doc/draft-ietf-idr-rtc-no-rt/

    <http://datatracker.ietf.org/doc/draft-litkowski-idr-rtc-interas/> http://datatracker.ietf.org/doc/draft-litkowski-idr-rtc-interas/                               

 <http://datatracker.ietf.org/doc/draft-ietf-idr-legacy-rtc/> http://datatracker.ietf.org/doc/draft-ietf-idr-legacy-rtc/

 <http://datatracker.ietf.org/doc/draft-ietf-idr-rtc-hierarchical-rr/> http://datatracker.ietf.org/doc/draft-ietf-idr-rtc-hierarchical-rr/

Web ex: 

 <https://ietf.webex.com/ietf/j.php?MTID=m689576316eaf19b397fbe242a310725f> https://ietf.webex.com/ietf/j.php?MTID=m689576316eaf19b397fbe242a310725f

IDR Minutes: 

 <http://etherpad.tools.ietf.org:9000/p/idr-interim-06-01-2015-Minutes> http://etherpad.tools.ietf.org:9000/p/idr-interim-06-01-2015-Minutes

 <http://etherpad.tools.ietf.org:9000/p/idr-interim-6-01-2015-vBlueSheets> http://etherpad.tools.ietf.org:9000/p/idr-interim-6-01-2015-vBlueSheets

From: IDR Working Group [ <mailto:[email-masked]> mailto:[email-masked]] 
Sent: Saturday, May 30, 2015 6:02 PM
To:  <mailto:[email-masked]> [email-masked]
Subject: (Forward to others) WebEx meeting invitation: idr interim 6/1/2015

Hello, 

 

idr interim 6/1/2015

Monday, June 1, 2015 

 

Meeting number: 

649 193 591 

Meeting password:

john.knows.all

Join by phone

Access code: 649 193 591

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sun, 31 May 2015 00:59:15 +0000

Hi Sue,
There will be some BGP LS that is not related to IGP link-state. For example, the BGP Egress Peer Engineering TLVs have no IGP equivalent. For ones that are IGP based, it would seem the IGP draft would need to precede the attendant BGP LS draft. Of course, we’ll have to handle this on a case-by-case basis.
Thanks,
Acee

From: Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Saturday, May 30, 2015 at 8:55 PM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: 'Alia Atlas' <[email-masked]<mailto:[email-masked]>>, 'Deborah Brungard' <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Idr] Idr interim on 6/1/2015 - 10:00am to 11:30am edt

Acee:

Sue

To: Susan Hares; [email-masked]<mailto:[email-masked]>

Agenda

                3) BGP RTC [10:25-10:50)

                   Existing ls drafts are:

                                Proposed additions are:

                5) BGP I2RS Use Case

Background reading:

Web ex:

IDR Minutes:

Hello,

idr interim 6/1/2015

Monday, June 1, 2015

Meeting number:

649 193 591

Meeting password:

john.knows.all

Join by phone

Access code: 649 193 591