Subject: [Idr] 2 week adoption call for draft-wang-idr-eag-distribution-02 (5/22 to 6/5)

From: "Susan Hares" <[email-masked]>
Date: Fri, 22 May 2015 07:26:05 -0400

This begins a 2 week Working Group adoption for
draft-wang-idr-eag-distribution.   You can find the draft at: 

http://datatracker.ietf.org/doc/draft-wang-idr-eag-distribution/

This draft proposes a new BGP-LS 

   As MPLS-TE network grows, administrative Groups advertised as a
   fixed-length 32-bit Bitmask is quite constraining.  "Extended
   Administrative Group" IGP TE extensions sub-TLV defined in [RFC7308
<https://tools.ietf.org/html/rfc7308> ]
   is introduced to provide for additional administrative groups (link
   colors) beyond the current limit of 32.

   The EAG TLV is used in addition to the Administrative Groups when a
   node wants to advertise more than 32 colors for a link.  The EAG TLV
   is optional.  The format and semantics of the 'value' fields in EAG
   TLVs correspond to the format and semantics of value fields in IGP
   extension sub-TLVs, defined in [RFC7308
<https://tools.ietf.org/html/rfc7308> ].
 
   +------------+---------------------+--------------+-----------------+
   |  TLV Code  |     Description     |     IS-IS    |   Defined in:   |
   |    Point   |                     |  TLV/Sub-TLV |                 |
   +------------+---------------------+--------------+-----------------+
   |    xxxx    |       Extended      |     22/xx    |    [RFC7308
<https://tools.ietf.org/html/rfc7308> ]    |
   |            |      Admin Group    |              |                 |
   +------------+---------------------+--------------+-----------------+

Please in your comments include "support" or "no support" for this draft. 

Sue Hares and John Scudder.

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 22 May 2015 15:45:57 +0000

Support as co-author

Cheers,
Jeff

From: Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 22, 2015 at 4:26 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] 2 week adoption call for draft-wang-idr-eag-distribution-02 (5/22 to 6/5)

This begins a 2 week Working Group adoption for draft-wang-idr-eag-distribution.   You can find the draft at:

   Administrative Group" IGP TE extensions sub-TLV defined in [RFC7308<https://tools.ietf.org/html/rfc7308>]

   extension sub-TLVs, defined in [RFC7308<https://tools.ietf.org/html/rfc7308>].

   |    xxxx    |       Extended      |     22/xx    |    [RFC7308<https://tools.ietf.org/html/rfc7308>]    |

   |            |      Admin Group    |              |                 |

Please in your comments include “support” or “no support” for this draft.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 22 May 2015 15:53:56 +0000

I support with one comment.

In the future, I’m wondering if we could standardize the BGP Link State encoding in the corresponding IGP documents? It seems like it would be possible since it is simply the TLV mapping and the  IANA code point(s).

Thanks,
Acee

From: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 22, 2015 at 11:45 AM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] 2 week adoption call for draft-wang-idr-eag-distribution-02 (5/22 to 6/5)

Support as co-author

Cheers,
Jeff

   |            |      Admin Group    |              |                 |

---

From: Uma Chunduri <[email-masked]>
Date: Fri, 22 May 2015 17:22:28 +0000

Support and +1 to what Acee said below.

--
Uma C.

From: Idr [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Friday, May 22, 2015 8:54 AM
To: Jeff Tantsura; Susan Hares; [email-masked]
Subject: Re: [Idr] 2 week adoption call for draft-wang-idr-eag-distribution-02 (5/22 to 6/5)

Thanks,
Acee

Support as co-author

Cheers,
Jeff

   |            |      Admin Group    |              |                 |

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 22 May 2015 14:49:16 -0400

Acee:

This sounds like a good idea. 

Sue 

From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: Friday, May 22, 2015 11:54 AM
To: Jeff Tantsura; Susan Hares; [email-masked]
Subject: Re: [Idr] 2 week adoption call for draft-wang-idr-eag-distribution-02 (5/22 to 6/5)

Thanks,

Acee

From: Jeff Tantsura <[email-masked]>
Date: Friday, May 22, 2015 at 11:45 AM
To: Susan Hares <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Idr] 2 week adoption call for draft-wang-idr-eag-distribution-02 (5/22 to 6/5)

Support as co-author

Cheers,

Jeff

From: Susan Hares <[email-masked]>
Date: Friday, May 22, 2015 at 4:26 AM
To: "[email-masked]" <[email-masked]>
Subject: [Idr] 2 week adoption call for draft-wang-idr-eag-distribution-02 (5/22 to 6/5)

   Administrative Group" IGP TE extensions sub-TLV defined in [RFC7308 <https://tools.ietf.org/html/rfc7308> ]

   extension sub-TLVs, defined in [RFC7308 <https://tools.ietf.org/html/rfc7308> ].
 
   +------------+---------------------+--------------+-----------------+
   |  TLV Code  |     Description     |     IS-IS    |   Defined in:   |
   |    Point   |                     |  TLV/Sub-TLV |                 |
   +------------+---------------------+--------------+-----------------+
   |    xxxx    |       Extended      |     22/xx    |    [RFC7308 <https://tools.ietf.org/html/rfc7308> ]    |
   |            |      Admin Group    |              |                 |
   +------------+---------------------+--------------+-----------------+

---

From: Qin Wu <[email-masked]>
Date: Mon, 25 May 2015 03:36:03 +0000

Agree with Acee and support this draft.

-Qin
发件人: Idr [mailto:[email-masked]] 代表 Acee Lindem (acee)
发送时间: 2015年5月22日 23:54
收件人: Jeff Tantsura; Susan Hares; [email-masked]
主题: Re: [Idr] 2 week adoption call for draft-wang-idr-eag-distribution-02 (5/22 to 6/5)

Thanks,
Acee

Support as co-author

Cheers,
Jeff

   |            |      Admin Group    |              |                 |

---

From: Mach Chen <[email-masked]>
Date: Sat, 30 May 2015 07:03:24 +0000

I read the draft and it's useful, so support the adoption.

BTW, also agree with Acee's comment.

Best regards,
Mach

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, May 22, 2015 7:26 PM
To: [email-masked]
Subject: [Idr] 2 week adoption call for draft-wang-idr-eag-distribution-02 (5/22 to 6/5)

   |            |      Admin Group    |              |                 |

---

From: Haoweiguo <[email-masked]>
Date: Sat, 30 May 2015 07:36:45 +0000

Support this adoption.

I think BGP LS extension is necessary to carry "Extended Administrative Group" IGP TE information.

Thanks,

weiguo

________________________________
From: Idr [[email-masked]] on behalf of Qin Wu [[email-masked]]
Sent: Monday, May 25, 2015 11:36
To: Acee Lindem (acee); Jeff Tantsura; Susan Hares; [email-masked]
Subject: Re: [Idr] 2 week adoption call for draft-wang-idr-eag-distribution-02 (5/22 to 6/5)

-Qin

Thanks,
Acee

Support as co-author

Cheers,
Jeff

   |            |      Admin Group    |              |                 |

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 1 Jun 2015 02:00:36 +0000

Support the adoption and agree with Acee’s comment.

-Jie

From: Idr [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Friday, May 22, 2015 11:54 PM
To: Jeff Tantsura; Susan Hares; [email-masked]
Subject: Re: [Idr] 2 week adoption call for draft-wang-idr-eag-distribution-02 (5/22 to 6/5)

Thanks,
Acee

Support as co-author

Cheers,
Jeff

   |            |      Admin Group    |              |                 |