Subject: Re: [Idr] New Version Notification for draft-scudder-idr-capabilities-registry-change-00.txt

From: "John G. Scudder" <[email-masked]>
Date: Fri, 14 Aug 2015 18:00:42 -0400

On Jul 3, 2015, at 4:29 AM, [email-masked] wrote:
...
> Given that the most probable code point (possibly) picked are likely to be 128 and 255, that's one more reason to have 255 reserved. To be on the extra safe side, I would propose to also have 128 reserved.

Done in -01.

> 1 last question. IINM we would have the following registration policies:
> 
> "1-63 	IETF Review 	
> 64-127 First Come First Served
> 128-250: Standards Action
> 251-254: Experimental Use
> 255: Reserved"
> 
> Then let's suppose that a new STD track RFC ask the IANA for a code point. A priori such RFC is eligible for all ranges. Which range would the IANA (typically) pick the value from? One option is to pick in the "strongest" range. In which case, we introduce a (very low) probability of code point collision for the most "official" code points. I don't feel that this is desirable.
> An option would be to move the FCFS policy to this 128-250 range, and use Standards Action for 64-127.

In thinking about this, we could either just make the range Reserved, or provide explicit instructions to IANA which ranges to use when, but in the end I thought the simplest thing was just make 128-and-up FCFS, which is what you'll see in -01. The rationale for this is basically KISS. 

"But John," you may ask, "what about your earlier rationale for SA, that it prevents a 'run on the bank'?" Well, I am inconsistent. Also, several of you convinced me that if we ever do get that low on code points, we had better long before it happens, introduce an extension mechanism. 

As before, this is of course subject to change according to WG consensus.

Thanks for your comments,

--John

---

From: "John G. Scudder" <[email-masked]>
Date: Fri, 14 Aug 2015 18:01:23 -0400

On Jul 14, 2015, at 11:18 AM, Thomas Mangin <[email-masked]> wrote:
> 
> More seriously anything between 8 and 16 would be fine with me, 12 would be 5% (rounded).

4^2 it is, see -01.

Thanks,

--John