Subject: [Idr] Qusetions about draft-rosen-idr-tunnel-enaps-00

From: Haoweiguo <[email-masked]>
Date: Mon, 3 Aug 2015 03:00:38 +0000

Hi Co-authors,

In this draft,  remote Endpoint sub-TLV is introduced to specify the IP address of tunnel end point. However, in draft-ietf-bess-evpn-overlay,  NVO3 NVE IP is carried in BGP Next Hop field. I am wondering why the remote Endpoint sub-TLV is introduced and why the BGP Next Hop can't satify the requirement?

Thanks,

weiguo

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 3 Aug 2015 10:39:01 +0200

Hi Weiguo

Unlike in overlay signalling here we are using classic BGP control plane
hence next hop will be rewritten across any EBGP boundary.

If you required to construct an overlay data plane using existing BGP
control plane there is a need to signal the tunnel endpoint address.

In evpn-overlay BGP is congruent with data plane and runs in the overlay.

Both approaches have pros and cons and I guess it is helpful to provide
both options to operators.

Best,
r.

On Mon, Aug 3, 2015 at 5:00 AM, Haoweiguo <[email-masked]> wrote:

> Hi Co-authors,
>
> In this draft,  remote Endpoint sub-TLV is introduced to specify the IP
> address of tunnel end point. However, in draft-ietf-bess-evpn-overlay,
> NVO3 NVE IP is carried in BGP Next Hop field. I am wondering why the remote
> Endpoint sub-TLV is introduced and why the BGP Next Hop can't satify the
> requirement?
>
>
>
> Thanks,
>
> weiguo
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>
>