Subject: Re: [Idr] BGP Attribute for Large communities (Attribute 30) was squatted on - Let's get a new attribute number (1 week WG call (10/18 to 10/25)

From: Wesley George <[email-masked]>
Date: Tue, 18 Oct 2016 13:38:56 -0400

On 10/18/16, 12:05 PM, "Nick Hilliard" <[email-masked]> wrote: <>

     I'm not sure if this is a good

    idea, as it could be interpreted as sending a message to vendors that

    squatting path attribute code points will result in being told, "that's

    very naughty and we're going to punish you by ensuring that no-one else

    gets these numbers, so don't do it again!"

I agree with the pragmatic approach of re-allocating so that we aren’t dependent on various network operators to upgrade code to fix this problem before large communities can be deployed, but I share the concern about this setting a bad precedent and rewarding bad behavior. Admittedly we have little leverage beyond finger-wagging, but I think the appropriate response here is to ensure a bit of diulian 丟臉 (lose face) aka name and shame for those making the "mistake".

For example, an addition to the IANA considerations section such as:

IANA is requested to allocate a new codepoint after early testing of the early-allocated codepoint revealed router vendors such as Huawei with production software making unauthorized use of (squatting on) unused codepoints including attribute 30 and 129 in a way that breaks interoperability if the original early-allocation codepoint were used.

Wes George

---

From: Susan Hares <[email-masked]>
Date: Tue, 18 Oct 2016 16:40:44 -0500

Robert
See the iana rules on how long early allocations can be kept and renewed.  RFC was listed in earlier email.
Sue

Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone
-------- Original message --------From: Robert Raszuk <[email-masked]> Date: 10/18/16  3:50 PM  (GMT-06:00) To: Jeffrey Haas <[email-masked]> Cc: Job Snijders <[email-masked]>, IETF IDR WG <[email-masked]>, Kristian Larsson <[email-masked]>, Sue Hares <[email-masked]> Subject: Re: [Idr] BGP Attribute for Large communities (Attribute 30) was squatted on - Let's get a new attribute number (1 week WG call (10/18 to 10/25) 
Hi Jeff,
IDR has a rule to progress any doc which demonstrates two implementations. That means that each draft which requires new BGP attribute and is accepted as an IDR WG doc should get IANA code point such that implementations could be delivered without risking any further inter-operability or deployment issues. 
Not sure how long WG should wait before such code point is depreciated though ... but without it being allocated in some way it is going to always be a challenge.
/RR.

On Tue, Oct 18, 2016 at 10:42 PM, Jeffrey Haas <[email-masked]> wrote:
Robert,
On Oct 18, 2016, at 2:14 PM, Robert Raszuk <[email-masked]> wrote:

I would tend to agree with Job here. 
I see no point to reserve already known to be "overloaded" code point for wide or for that matter any new BGP attribute. 
That's the price we pay for no BGP Police or BGP FBI/GBI  ... (G=global)
To clarify my original point, I think holding onto it for early allocation makes sense.
Whether or not the code Huawei is working on is ready for such an allocation is a different matter.  But if the code point is otherwise associated with the feature, incremental rollout issues aside, seems reasonable to not waste that code point.
-- Jeff (I don't feel super strong about this, but see other threads)

---

From: Susan Hares <[email-masked]>
Date: Tue, 18 Oct 2016 22:19:29 -0400

Michael
<individual contributor hat on>After listening to numerous talks at nanog about open source bgp implementations - it is equally important to consider open source since it is being used in many networks.
What is most important is to protect large communities from having problems.
Sue

Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone
-------- Original message --------From: Michael H Lambert <[email-masked]> Date: 10/18/16  11:44 AM  (GMT-05:00) To: IETF IDR WG <[email-masked]> Cc: Kristian Larsson <[email-masked]> Subject: Re: [Idr] BGP Attribute for Large communities (Attribute 30) was
  squatted on - Let's get a new attribute number (1 week WG call (10/18 to
  10/25) 
> On 18 Oct 2016, at 11:30, Job Snijders <[email-masked]> wrote:
> 
> I support this course of action.
> 
> background: Some in the working group might wonder why Large should
> change instead of Huawei.
> 
> Huawei routers are treating routes with Large BGP Communities as
> "withdraw", which makes Large BGP Communities deployments suffer. Large
> BGP Communities users become unreachable on attribute 30.
> 
> Had the squatting resulted in Huawei routers crashing or some other form
> of damage on the Huawei side, the onus would be on Huawei users. This is
> not the case unfortunatly.
> 
> There are no winners if either side holds their ground and remains on
> the codepoint. For Large BGP Communities it is still early enough to
> update the implementations. Changing the Large BGP Communities path
> attribute value is a risk adverse strategy.

Would the same course of action be recommended if it were an open-source project (eg bird or quagga), rather than a commercial router vendor, squatting on attribute 30?  If the answer is an unequivocal yes, then I agree with the proposed course of action.  Otherwise, I think the burden falls on the vendor to fix their (with respect to standards) broken implementation.

Michael

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr