Subject: Re: [Idr] WG adoption call for draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules"

From: <[email-masked]>
Date: Mon, 6 Feb 2017 16:51:39 +0800 (CST)

Support.

Thanks,

Sandy

原始邮件

发件人： ＜[email-masked]＞
收件人： ＜[email-masked]＞
日 期 ：2017年02月02日 00:41
主 题 ：Re: [Idr] WG adoption call for draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules"

Hi All,

Reminder, this call for adoption is going on and will end in five days. So far, the only reply has been from Christoph (thanks!) with a pointer to his paper "BGP Flow Specification Multi Vendor and Inter AS Interoperability". The paper is long, but I encourage you to look at it. To encourage you, here are a few excerpts from the conclusion:

"we think that what we listed as bugs sometimes is a result of unclear sections and definitions in RFC 5575"

"With this update we think that a proper interoperable implementation should be possible and unambiguous sections have been improved"

and perhaps most motivational to the WG:

"Given the current bugs, interoperability issues and missing features we do not recommend flow specification BGP sessions between different carriers […] Invalid flow specification NLRIs or action filters have the potential to remotely trigger a complete network failure."

If you do NOT support adopting this work, it would be interesting to hear why. For example, do you think RFC 5575 is fine as it is, and if so, why (considering the issues raised in the paper and on the list). Of course, it is not IDR's job to document and fix implementation bugs. But it is *exactly* our job to fix the spec if it's ambiguous and that ambiguity leads to interoperability issues.

If you do support adopting the work, please remember to say so on the list — we can't declare consensus based on silence.

Thanks,

—John

＞ On Jan 21, 2017, at 10:03 AM, John G. Scudder ＜[email-masked]＞ wrote:
＞ 
＞ Hi All,
＞ 
＞ The authors have requested IDR working group adoption of draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules". Please send your comments to the list.
＞ 
＞ This adoption call will conclude on Monday, February 6.
＞ 
＞ Thanks,
＞ 
＞ —John
＞ _______________________________________________
＞ Idr mailing list
＞ [email-masked]
＞ https://www.ietf.org/mailman/listinfo/idr

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 6 Feb 2017 15:05:59 +0000

Support,

Linda Dunbar

原始邮件
发件人： ＜[email-masked]＞;
收件人： ＜[email-masked]＞;
日 期 ：2017年02月02日 00:41

Hi All,

Thanks,

—John

＞ [email-masked]<mailto:[email-masked]>

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr