Subject: [Idr] [Editorial Errata Reported] RFC4360 (4944)

From: RFC Errata System <[email-masked]>
Date: Mon, 20 Feb 2017 22:43:07 -0800 (PST)

The following errata report has been submitted for RFC4360,
"BGP Extended Communities Attribute".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4360&eid=4944

--------------------------------------
Type: Editorial
Reported by: Yang Yu <[email-masked]>

Section: GLOBAL

Original Text
-------------

       0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |  Type high    |  Type low(*)  |                               |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+          Value                |
      |                                                               |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

             0 1 2 3 4 5 6 7
            +-+-+-+-+-+-+-+-+
            |I|T|           |
            +-+-+-+-+-+-+-+-+

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | 0x00 or 0x40  |   Sub-Type    |    Global Administrator       |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                     Local Administrator                       |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | 0x01 or 0x41  |   Sub-Type    |    Global Administrator       |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | Global Administrator (cont.)  |    Local Administrator        |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | 0x03 or 0x43  |   Sub-Type    |                Value          |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                         Value (cont.)                         |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Corrected Text
--------------

      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |  Type high    |  Type low(*)  |                               |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+          Value                |
      |                                                               |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

            0 1 2 3 4 5 6 7
            +-+-+-+-+-+-+-+-+
            |I|T|           |
            +-+-+-+-+-+-+-+-+

   0                   1                   2                   3
   0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | 0x00 or 0x40  |   Sub-Type    |    Global Administrator       |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                     Local Administrator                       |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   0                   1                   2                   3
   0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | 0x01 or 0x41  |   Sub-Type    |    Global Administrator       |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | Global Administrator (cont.)  |    Local Administrator        |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   0                   1                   2                   3
   0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | 0x03 or 0x43  |   Sub-Type    |                Value          |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                         Value (cont.)                         |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Notes
-----
The packet format convention used in this RFC is different from how it is commonly used.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4360 (draft-ietf-idr-bgp-ext-communities-09)
--------------------------------------
Title               : BGP Extended Communities Attribute
Publication Date    : February 2006
Author(s)           : S. Sangli, D. Tappan, Y. Rekhter
Category            : PROPOSED STANDARD
Source              : Inter-Domain Routing
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Thu, 23 Feb 2017 21:26:48 +0000

Reject.
This will waste people's time opening the errata to try to find the difference.
The original makes sense and looks fine.

Thanks,
Jakob.

> -----Original Message-----
> From: Idr [mailto:[email-masked]] On Behalf Of RFC Errata System
> Sent: Monday, February 20, 2017 10:43 PM
> To: Srihari R Sangli (rsrihari) <[email-masked]>; [email-masked]; [email-masked]; [email-masked];
> [email-masked]; Alvaro Retana (aretana) <[email-masked]>; [email-masked]; [email-masked]
> Cc: [email-masked]; text/[email-masked]; [email-masked]; [email-masked]; charset=UTF-
> [email-masked]
> Subject: [Idr] [Editorial Errata Reported] RFC4360 (4944)
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: "John G. Scudder" <[email-masked]>
Date: Thu, 23 Feb 2017 16:50:10 -0500

To save others the trouble of figuring out just exactly what this erratum even *is*: in the original text, the numbers in the diagram rulers align above the minus signs. In the "corrected" text they align above the plus signs. I would like to remind anyone who might submit an erratum in the future: please use the "notes" section to make it clear what your proposed change is, unless it's perfectly obvious.

Looking at https://www.ietf.org/iesg/statement/errata-processing.html, we have 

> 	• Rejected - The erratum is in error, or proposes a change to the RFC that should be done by publishing a new RFC that replaces the current RFC. In the latter case, if the change is to be considered for future updates of the document, it should be proposed using channels other than the errata process, such as a WG mailing list. 
> 	• Hold for Document Update - The erratum is not a necessary update to the RFC. However, any future update of the document might consider this erratum, and determine whether it is correct and merits including in the update. 
> ...
> Guidelines for review are: 
> 
> 	5. Typographical errors which would not cause any confusions to implementation or deployments should be Hold for Document Update.

The erratum either is for a typographical error, in which case it should be Hold for Document Update, or it's in error, in which case it should be Rejected. The guidelines don't offer a "this is a matter of taste" option, which I think is what applies here, unless someone can cite an RFC Editor style guideline specifying that the rulers are supposed to have the numbers above the pluses?

Right now my inclination would be go with Reject, but if someone can cite evidence that the proposed fix is objectively more correct than the current text (or if the mood of the WG supports that option, for that matter) we could do Hold for Document Update instead.

--John

P.S.: FWIW my eyes prefer the as-published text to the proposed "correction".

> On Feb 21, 2017, at 1:43 AM, RFC Errata System <[email-masked]> wrote:
>

---

From: Job Snijders <[email-masked]>
Date: Thu, 23 Feb 2017 22:45:08 +0100

On Thu, Feb 23, 2017 at 09:26:48PM +0000, Jakob Heitz (jheitz) wrote:
> Reject.
> This will waste people's time opening the errata to try to find the
> difference.  The original makes sense and looks fine.

seconded.

Only after reading Jakob's phrase "waste of time" i realised what to
look for and saw the difference. :-)

Kind regards,

Job

---

From: Job Snijders <[email-masked]>
Date: Thu, 23 Feb 2017 22:55:25 +0100

On Thu, Feb 23, 2017 at 04:50:10PM -0500, John G. Scudder wrote:
> > 	• Rejected - The erratum is in error, or proposes a change to
> > 	the RFC that should be done by publishing a new RFC that
> > 	replaces the current RFC. In the latter case, if the change is
> > 	to be considered for future updates of the document, it should
> > 	be proposed using channels other than the errata process, such
> > 	as a WG mailing list. 
> > 	• Hold for Document Update - The erratum is not a necessary
> > 	update to the RFC. However, any future update of the document
> > 	might consider this erratum, and determine whether it is correct
> > 	and merits including in the update. 
> > ...
> > 	5. Typographical errors which would not cause any confusions to
> > 	implementation or deployments should be Hold for Document
> > 	Update.
> 
> The erratum either is for a typographical error, in which case it
> should be Hold for Document Update, or it's in error, in which case it
> should be Rejected. The guidelines don't offer a "this is a matter of
> taste" option, which I think is what applies here, unless someone can
> cite an RFC Editor style guideline specifying that the rulers are
> supposed to have the numbers above the pluses?
> 
> Right now my inclination would be go with Reject, but if someone can
> cite evidence that the proposed fix is objectively more correct than
> the current text (or if the mood of the WG supports that option, for
> that matter) we could do Hold for Document Update instead.

The example provided in RFC 2360 is aligned with the currently published
text:

    https://tools.ietf.org/html/rfc2360#section-3.1

Kind regards,

Job

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Thu, 23 Feb 2017 22:11:26 +0000

I Rejected it already. ☺

Thanks!

Alvaro.

On 2/23/17, 4:50 PM, "John G. Scudder" <[email-masked]> wrote:

    The erratum either is for a typographical error, in which case it should be Hold for Document Update, or it's in error, in which case it should 
be Rejected. The guidelines don't offer a "this is a matter of taste" option, which I think is what applies here, unless someone can cite an RFC Editor style guideline specifying that the rulers are supposed to have the numbers above the pluses?