Subject: Re: [Idr] WG adoption call for draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules"

From: "John G. Scudder" <[email-masked]>
Date: Wed, 1 Feb 2017 11:41:50 -0500

Hi All,

Reminder, this call for adoption is going on and will end in five days. So far, the only reply has been from Christoph (thanks!) with a pointer to his paper "BGP Flow Specification Multi Vendor and Inter AS Interoperability". The paper is long, but I encourage you to look at it. To encourage you, here are a few excerpts from the conclusion:

"we think that what we listed as bugs sometimes is a result of unclear sections and definitions in RFC 5575"

"With this update we think that a proper interoperable implementation should be possible and unambiguous sections have been improved"

and perhaps most motivational to the WG:

"Given the current bugs, interoperability issues and missing features we do not recommend flow specification BGP sessions between different carriers […] Invalid flow specification NLRIs or action filters have the potential to remotely trigger a complete network failure."

If you do NOT support adopting this work, it would be interesting to hear why. For example, do you think RFC 5575 is fine as it is, and if so, why (considering the issues raised in the paper and on the list). Of course, it is not IDR's job to document and fix implementation bugs. But it is *exactly* our job to fix the spec if it's ambiguous and that ambiguity leads to interoperability issues.

If you do support adopting the work, please remember to say so on the list — we can't declare consensus based on silence.

Thanks,

—John

> On Jan 21, 2017, at 10:03 AM, John G. Scudder <[email-masked]> wrote:
> 
> Hi All,
> 
> The authors have requested IDR working group adoption of draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules". Please send your comments to the list.
> 
> This adoption call will conclude on Monday, February 6.
> 
> Thanks,
> 
> —John
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 2 Feb 2017 13:29:19 -0500

<WG chair hat off> 
<individual contributor hat on> 

I support adoption of this work as a co-author.  

Sue Hares 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of John G. Scudder
Sent: Wednesday, February 1, 2017 11:42 AM
To: idr wg
Subject: Re: [Idr] WG adoption call for draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules"

Hi All,

Thanks,

—John

---

From: "John G. Scudder" <[email-masked]>
Date: Thu, 2 Feb 2017 14:49:29 -0500

Folks, 

It was pointed out to me that due to Chinese New Year, a significant number of WG members may not have had the opportunity to respond (I don't know what everyone else's excuse is...). We will extend the adoption call until February 13 unless there are objections. (If there are objections feel free to unicast them to me, or send them to the list, as you prefer.)

Thanks,

—John

---

From: "Bacher, Martin" <[email-masked]>
Date: Thu, 2 Feb 2017 20:56:15 +0100

Hi,

I support the adoption of this draft as an co-author.  

Martin Bacher

-----Ursprüngliche Nachricht-----
Von: Idr [mailto:[email-masked]] Im Auftrag von John G. Scudder
Gesendet: Mittwoch, 01. Februar 2017 17:42
An: idr wg <[email-masked]>
Betreff: Re: [Idr] WG adoption call for draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules"

Hi All,

Thanks,

—John

__________________________________________________________________________________________
Notice: This e-mail and any attachments are confidential and may be privileged.
If you are not the intended recipient, notify the sender immediately, destroy all
copies from your system and do not disclose or use the information for any purpose.
Diese E-Mail inklusive aller Anhaenge ist vertraulich und koennte bevorrechtigtem
Schutz unterliegen. Wenn Sie nicht der beabsichtigte Adressat sind, informieren Sie
bitte den Absender unverzueglich, loeschen Sie alle Kopien von Ihrem System und
veroeffentlichen Sie oder nutzen Sie die Information keinesfalls, gleich zu welchem Zweck.

Think before you print!

T-Mobile Austria GmbH
Geschaeftsfuehrung: Dr. Andreas Bierwirth (Vorsitzender), Aufsichtsrat: Branka Skaramuca (Vorsitzende)
Firmenbuch: Handelsgericht Wien, Sitz Wien, FN 171112k, UID ATU 45011703, DVR 0898295
Konto: UniCredit Bank Austria AG IBAN: AT93 1200 0528 4407 2301, BIC: BKAUATWW

T-Mobile – Das verbindet uns.
__________________________________________________________________________________________

---

From: Justin Ryburn <[email-masked]>
Date: Sun, 5 Feb 2017 22:03:16 +0000

I supported this draft. Definitely needed by the industry.

-Justin

On Jan 21, 2017, at 9:03 AM, John G. Scudder <[email-masked]> wrote:

Hi All,

Thanks,

—John

---

From: pete <[email-masked]>
Date: Sun, 5 Feb 2017 14:10:24 -0800

+1

Thanks.
pete

On Sun, Feb 5, 2017 at 2:03 PM, Justin Ryburn <[email-masked]> wrote:

> The authors have requested IDR working group adoption of
> draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules".
> Please send your comments to the list.
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 6 Feb 2017 02:39:38 +0000

Support the adoption. 

It is quite useful to clarify the ordering of traffic filtering and the rules of traffic action conflicts for better interoperability.

Best regards,
Jie

> Sent: Saturday, January 21, 2017 11:03 PM
> To: [email-masked]
> Subject: [Idr] WG adoption call for draft-hr-idr-rfc5575bis-02 "Dissemination of
> Flow Specification Rules"
> 
> Hi All,
> 
> draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules". Please
> send your comments to the list.
>

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 05 Feb 2017 23:40:03 -0800

yes/support

Cheers,
Jeff

    Hi All,

    
    Thanks,
    
    —John

---

From: Zhuangshunwan <[email-masked]>
Date: Tue, 7 Feb 2017 11:28:25 +0000

Support. It is a quite useful work to improve better interoperability.

Cheers,
Shunwan

-----邮件原件-----
发件人: Idr [mailto:[email-masked]] 代表 John G. Scudder
发送时间: 2017年2月3日 3:49
收件人: [email-masked]
主题: Re: [Idr] WG adoption call for draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules"

Folks, 

Thanks,

—John

---

From: Zhuangshunwan <[email-masked]>
Date: Tue, 7 Feb 2017 11:36:05 +0000

Hi  Christoph,

I have read your paper, the paper gives me a deep impression and a more profound understanding on the principle of flowspec.
It makes me believe that the work to improve the flowspec interoperability is very necessary.
Thanks for your great work!

Regards,
Shunwan

发件人: Idr [mailto:[email-masked]] 代表 Christoph Loibl
发送时间: 2017年1月30日 4:04
收件人: John G. Scudder
抄送: [email-masked]
主题: Re: [Idr] WG adoption call for draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules"

Hi All,

As an co-author of the draft I support the adoption.

However, I noticed that I missed to post our recent paper on Flowspec interop to the IDR list. This paper illustrates (based on our lab setup) the current state of Flowspec implementations. Because of the incompatibilities observed we were inspired to co-author the draft-hr-idr-rfc5575bis to improve interoperability and stability.

You may download our paper at:

http://p4.tix.at/~cl/fs/loibl-bacher-bgp-flowspec-interop-012017.pdf

Regards
Christoph

On 21 Jan 2017, at 16:03, John G. Scudder <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,

Thanks,

—John
_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

--
Christoph Loibl
[email-masked]<mailto:[email-masked]> | CL8-RIPE | PGP-Key-ID: 0x4B2C0055 | http://www.nextlayer.at

---

From: Mach Chen <[email-masked]>
Date: Wed, 8 Feb 2017 06:18:22 +0000

Hi,

I have read the draft and think it's useful, so I support the adoption!

Best regards,
Mach

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 10 Feb 2017 15:40:21 +0800

Hello All,

I support the adoption of your draft. But I want to ask a question. rfc5575bis is for IPv4, as stated in the abstract. However, IPv4 is declared to be historic. Do we still need a RFC specifically designed for IPv4? 

Best Regards,

[email-masked]
 
From: John G. Scudder
Date: 2017-02-03 03:49
To: [email-masked]

Thanks,
 
—John

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Fri, 10 Feb 2017 18:27:46 +0000

Yes.
IPv4 is still very much in use, regardless of the "historic" label.

Thanks,
Jakob.

From: Idr [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, February 09, 2017 11:40 PM
To: John Scudder <[email-masked]>; idr <[email-masked]>
Subject: Re: [Idr] WG adoption call for draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules"

Hello All,

Best Regards,

________________________________
[email-masked]

From: John G. Scudder<mailto:[email-masked]>
Date: 2017-02-03 03:49
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Idr] WG adoption call for draft-hr-idr-rfc5575bis-02 "Dissemination of Flow Specification Rules"
Folks,

Thanks,

—John

---

From: "John G. Scudder" <[email-masked]>
Date: Wed, 22 Feb 2017 16:24:03 -0500

Hi All,

The draft has consensus to be accepted as an IDR WG item. Authors, please resubmit as draft-ietf-idr-rfc5575bis-00.

Thanks,

--John

> On Feb 2, 2017, at 2:49 PM, John G. Scudder <[email-masked]> wrote:
> 
> Folks, 
>