Subject: Re: [Idr] FW: New Version Notification for draft-vandevelde-idr-bgp-ls-segment-routing-rld-01.txt

From: "Ketan Talaulikar Talaulikar (ketant)" <[email-masked]>
Date: Mon, 10 Apr 2017 15:30:35 +0000

Hi Jeff/Authors,

Could we get this MSD BGP-LS draft polled for IDR WG adoption? The corresponding IGP drafts are already respective WG documents.

Thanks,
Ketan

From: Idr [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: 04 March 2017 16:21
To: Robert Raszuk <[email-masked]>
Cc: idr wg <[email-masked]>; Van De Velde, Gunter (Nokia - BE) <[email-masked]>
Subject: Re: [Idr] FW: New Version Notification for draft-vandevelde-idr-bgp-ls-segment-routing-rld-01.txt

Robert,

Please take a look at 02 isis draft published yesterday, we have added type flag that defines the type of a SID and could be used with v6 dataplane.
The limitations wrt label operations are well understood across both custom and merchant  silicon and from use case prospective had to be addressed first.
V6 dataplane will be added.

Please let me know if this answers your questions and addresses concerns.

Regards,
Jeff

On Mar 4, 2017, at 06:24, Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:
Jeff,

MSD drafts (yours invluded) talks about labels while MSD as such seems to be defined as maximum SID depth.

In SRv6 SID is *NOT* a label. So why not to define MSD properly across all SR scenarios?

Are we going to have now new zoo of drafts now defining MSD for SRv6 vs current docs just defining MSD for SR-MPLS ?

Cheers,
R.

On Mar 4, 2017 9:41 AM, "Jeff Tantsura" <[email-masked]<mailto:[email-masked]>> wrote:
Robert,

That's done in MSD drafts.
In the recently published isis draft we have also introduced MSD type flag that would be used to signal different types of SID's: recirculated labels, EL's, etc

Cheers,
Jeff

On Fri, Mar 3, 2017 at 22:35 Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:
Hey Gunter,

Good proposal however why do you only think about labels ?

Seriously if this is to move fwd let's add ability to signal also following elements:

* ability to punt SR-MPLS to local CPU (slow path) when not handled in hardware (per node basis)

* add signalling for number of SRv6 SRHs supported per node/per LC

* add signalling for depth per SRH and total of SIDs supported per node/per LC

* signal ability to punt to slow path or not for longer then support SRH stack or number of SIDs in each SRH structure.

Cheers,
Robert.

On Fri, Mar 3, 2017 at 3:55 PM, Van De Velde, Gunter (Nokia - BE) <[email-masked]<mailto:[email-masked]>> wrote:
Heads-up… Happy to learn feedback and comments.

This draft is short and defines the attribute to use for BGP-LS to expose a
node RLD "Readable Label Depth" to a centralised controller (PCE/SDN).

G/

On 03/03/2017, 14:21, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

    A new version of I-D, draft-vandevelde-idr-bgp-ls-segment-routing-rld-01.txt
    has been successfully submitted by Gunter Van de Velde and posted to the
    IETF repository.

    Name:               draft-vandevelde-idr-bgp-ls-segment-routing-rld
    Revision:   01
    Title:              Signalling RLD using BGP-LS
    Document date:      2017-03-03
    Group:              Individual Submission
    Pages:              5
    URL:            https://www.ietf.org/internet-drafts/draft-vandevelde-idr-bgp-ls-segment-routing-rld-01.txt
    Status:         https://datatracker.ietf.org/doc/draft-vandevelde-idr-bgp-ls-segment-routing-rld/
    Htmlized:       https://tools.ietf.org/html/draft-vandevelde-idr-bgp-ls-segment-routing-rld-01
    Diff:           https://www.ietf.org/rfcdiff?url2=draft-vandevelde-idr-bgp-ls-segment-routing-rld-01

    Abstract:
       This document defines the attribute to use for BGP-LS to expose a
       node RLD "Readable Label Depth" to a centralised controller (PCE/
       SDN).

    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

    The IETF Secretariat

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 10 Apr 2017 09:10:37 -0700

Hi Ketan,

During my presentation in Chicago I have asked for adoption, I assume they would do so soon.

Wrt email topic – please do not mix MSD documents with RLD ones.

Thanks!

Cheers,

Jeff

From: "Ketan Talaulikar Talaulikar (ketant)" <[email-masked]>
Date: Monday, April 10, 2017 at 08:30
To: Jeff Tantsura <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: idr wg <[email-masked]>, "Van De Velde, Gunter (Nokia - BE)" <[email-masked]>
Subject: RE: [Idr] FW: New Version Notification for draft-vandevelde-idr-bgp-ls-segment-routing-rld-01.txt

Hi Jeff/Authors,

Thanks,

Ketan

Robert,

Regards,

Jeff

On Mar 4, 2017, at 06:24, Robert Raszuk <[email-masked]> wrote:

Jeff,

Cheers,

R.

On Mar 4, 2017 9:41 AM, "Jeff Tantsura" <[email-masked]> wrote:

Robert,

Cheers,

Jeff

On Fri, Mar 3, 2017 at 22:35 Robert Raszuk <[email-masked]> wrote:

Hey Gunter,

Cheers,
Robert.

On Fri, Mar 3, 2017 at 3:55 PM, Van De Velde, Gunter (Nokia - BE) <[email-masked]> wrote:

G/

On 03/03/2017, 14:21, "[email-masked]" <[email-masked]> wrote:

    Abstract:

    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.

    The IETF Secretariat

[email-masked]

[email-masked]

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 10 Apr 2017 12:36:20 -0400

Jeff:

I will start IPR for WG adoption calls later today. 

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Monday, April 10, 2017 12:11 PM
To: Ketan Talaulikar Talaulikar (ketant); Robert Raszuk
Cc: idr wg; Van De Velde, Gunter (Nokia - BE)
Subject: Re: [Idr] FW: New Version Notification for draft-vandevelde-idr-bgp-ls-segment-routing-rld-01.txt

Hi Ketan,

Thanks!

Cheers,

Jeff

Hi Jeff/Authors,

Thanks,

Ketan

Robert,

Regards,

Jeff

Jeff,

Cheers,

R.

Robert,

Cheers,

Jeff

Hey Gunter,

Cheers,
Robert.

G/

    Abstract:

    The IETF Secretariat

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 10 Apr 2017 10:34:29 -0700

Thanks Sue, much appreciated!

Cheers,

Jeff

From: Susan Hares <[email-masked]>
Date: Monday, April 10, 2017 at 09:36
To: 'Jeff Tantsura' <[email-masked]>, "'Ketan Talaulikar Talaulikar (ketant)'" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: 'idr wg' <[email-masked]>, "'Van De Velde, Gunter (Nokia - BE)'" <[email-masked]>
Subject: RE: [Idr] FW: New Version Notification for draft-vandevelde-idr-bgp-ls-segment-routing-rld-01.txt

Jeff:

Sue 

Hi Ketan,

Thanks!

Cheers,

Jeff

Hi Jeff/Authors,

Thanks,

Ketan

Robert,

Regards,

Jeff

Jeff,

Cheers,

R.

Robert,

Cheers,

Jeff

Hey Gunter,

Cheers,
Robert.

G/

    Abstract:

    The IETF Secretariat