Subject: [Idr] SR-Capabilities TLV in draft-ietf-idr-bgp-ls-segment-routing-ext-01

From: Simon Zhong <[email-masked]>
Date: Sun, 9 Apr 2017 18:20:46 +0000

Hi,

I'm working on Wireshark bgp dissector and following description confuses me.

2.1.1.  SR-Capabilities TLV

   The SR Capabilities sub-TLV has following format:
......
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                  Range Size                   |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   //                SID/Label Sub-TLV (variable)                 //
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

This implies that there's one "Range Size" and one or more "SID/Lable Sub-TLV), however later in this section, it says:

     One or more entries, each of which have the following format:

         Range Size: 3 octet value indicating the number of labels in
         the range.

         SID/Label sub-TLV (as defined in Section 2.3.7.2).

Which sounds like one or more "Range Size" + "SID/Lable sub-TLV" combo are allowed.

The same applies to SR Local Block TLV as well.

So what's the intended behaviour? Thanks.

/Simon

---

From: "Ketan Talaulikar Talaulikar (ketant)" <[email-masked]>
Date: Mon, 10 Apr 2017 15:25:45 +0000

Hi Simon,

The pair "Range Size + SID/Label sub-TLV" would be repeated if there are more than one SRGB/SRLB ranges advertised by a node.

Thanks,
Ketan

From: Idr [mailto:[email-masked]] On Behalf Of Simon Zhong
Sent: 09 April 2017 11:21
To: [email-masked]
Subject: [Idr] SR-Capabilities TLV in draft-ietf-idr-bgp-ls-segment-routing-ext-01

Hi,

/Simon

---

From: Simon Zhong <[email-masked]>
Date: Tue, 11 Apr 2017 00:42:13 +0000

Thanks for the clarification Ketan.

/Simon

From: Ketan Talaulikar Talaulikar (ketant) [mailto:[email-masked]]
Sent: Monday, April 10, 2017 11:26
To: Simon Zhong <[email-masked]>; [email-masked]
Subject: RE: SR-Capabilities TLV in draft-ietf-idr-bgp-ls-segment-routing-ext-01

Hi Simon,

Thanks,
Ketan

From: Idr [mailto:[email-masked]] On Behalf Of Simon Zhong
Sent: 09 April 2017 11:21
To: [email-masked]<mailto:[email-masked]>
Subject: [Idr] SR-Capabilities TLV in draft-ietf-idr-bgp-ls-segment-routing-ext-01

Hi,

/Simon