Subject: Re: [Idr] I-D Action: draft-ietf-idr-bgp-prefix-sid-05.txt

From: <[email-masked]>
Date: Fri, 16 Jun 2017 13:44:36 +0000

Hi Stefano,

Thanks for the updated version.

-05 address my comments.

1 possible nit.

In §3.3, IMHO the (primary) goal is that the SRGB TLV must not be changed. Then that it should not be removed.

I believe that the following change would better reflect the goal.

OLD:

   The Originator SRGB TLV contains the SRGB of the node originating the

   prefix to which the BGP Prefix-SID is attached and MUST be kept in

   the Prefix-SID Attribute unchanged during the propagation of the BGP

   update.

NEW:

   The Originator SRGB TLV contains the SRGB of the node originating the

   prefix to which the BGP Prefix-SID is attached and MUST be kept unchanged in

   the Prefix-SID Attribute during the propagation of the BGP

   update.

---

Possibly, what was really meant is “MUST NOT be changed”

Please feel free to silently drop this comment.

Regards,

--Bruno

> -----Original Message-----

> From: Idr [mailto:[email-masked]] On Behalf Of Stefano Previdi (sprevidi)

> Sent: Thursday, April 20, 2017 11:56 AM

> To: idr wg

> Subject: Re: [Idr] I-D Action: draft-ietf-idr-bgp-prefix-sid-05.txt

 > This is the updated version after comments from many reviews in IDR and SPRING.

 > Note that section 3.2. "IPv6 SID” proposes now a new format for the IPv6 SID. It shouldn’t be

> a problem since I don’t know any ipv6 implementations yet.

 > Thanks.

> s.

 > > On Apr 20, 2017, at 11:51 AM, [email-masked]<mailto:[email-masked]> wrote:

> > A New Internet-Draft is available from the on-line Internet-Drafts directories.

> > This draft is a work item of the Inter-Domain Routing of the IETF.

> >        Title           : Segment Routing Prefix SID extensions for BGP

> >        Authors         : Stefano Previdi

> >                          Clarence Filsfils

> >                          Acee Lindem

> >                          Arjun Sreekantiah

> >                          Hannes Gredler

> >        Filename        : draft-ietf-idr-bgp-prefix-sid-05.txt

> >        Pages           : 16

> >        Date            : 2017-04-20

> > Abstract:

> >   Segment Routing (SR) architecture allows a node to steer a packet

> >   flow through any topological path and service chain by leveraging

> >   source routing.  The ingress node prepends a SR header to a packet

> >   containing a set of segment identifiers (SID).  Each SID represents a

> >   topological or a service-based instruction.  Per-flow state is

> >   maintained only at the ingress node of the SR domain.

> >   This document describes the BGP extension for announcing BGP Prefix

> >   Segment Identifier (BGP Prefix-SID) information.

> > The IETF datatracker status page for this draft is:

> > https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-prefix-sid/

> > There are also htmlized versions available at:

> > https://tools.ietf.org/html/draft-ietf-idr-bgp-prefix-sid-05

> > https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-prefix-sid-05

> > A diff from the previous version is available at:

> > https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-bgp-prefix-sid-05

> > Please note that it may take a couple of minutes from the time of submission

> > until the htmlized version and diff are available at tools.ietf.org.

> > Internet-Drafts are also available by anonymous FTP at:

> > ftp://ftp.ietf.org/internet-drafts/

> > _______________________________________________

> > I-D-Announce mailing list

> > [email-masked]<mailto:[email-masked]>

> > https://www.ietf.org/mailman/listinfo/i-d-announce

> > Internet-Draft directories: http://www.ietf.org/shadow.html

> > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

 > _______________________________________________

> Idr mailing list

> [email-masked]<mailto:[email-masked]>

> https://www.ietf.org/mailman/listinfo/idr

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Fri, 16 Jun 2017 17:41:41 +0000

Hi Bruno,

thanks for the comment. I’d propose following text:

      The Originator SRGB TLV contains the SRGB of the node 
      originating the prefix to which the BGP Prefix-SID is 
      attached. The Originator SRGB TLV MUST NOT be changed 
      during the propagation of the BGP update.

Let me know if address your concern.

Thanks.
s.

> On Jun 16, 2017, at 3:44 PM, [email-masked] wrote:
> 
> Hi Stefano,
>  
>  > > On Apr 20, 2017, at 11:51 AM, [email-masked] wrote:
> > >
> > >
> > > [email-masked]
> > [email-masked]

---

From: <[email-masked]>
Date: Mon, 19 Jun 2017 07:35:01 +0000

Hi Stefano,

> From: Stefano Previdi (sprevidi) [mailto:[email-masked]]  > Sent: Friday, June 16, 2017 7:42 PM
> 
 > Hi Bruno,
 > 

Looks good.
Thanks,
--Bruno
 
 > ______________________________________________________________________
 > ___________________________________________________
 > >