Subject: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

From: "Susan Hares" <[email-masked]>
Date: Wed, 14 Jun 2017 20:20:24 -0400

This begins a 2 week WG adoption call for
draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 (6/14/2017 to 6/28/2017).
The chairs would appreciate if the operators would indicate whether they
would deploy this draft.   

The authors should within the first 5 days do the following: 

1)      Send a statement to the WG indicating whether you know of any IPR 

2)      Indicate whether you know of existing implementations 

3)      Please respond to the IDR list questions on a daily basis 

Sue Hares and John Scudder

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 15 Jun 2017 03:32:04 +0000

This document is useful, however I would like to suggest if the authors could consider merging this with draft-tantsura-idr-bgp-ls-segment-routing-msd where the RLD becomes another MSD sub-type. I believe draft-tantsura-idr-bgp-ls-segment-routing-msd provides a much better extensible mechanism for signalling of other such label limits at link and node level. Not to mention, this also is more efficient encoding.

While I am not sure if similar would be possible at this stage in the under-lying IGPs, but it is perhaps not too late to consider for BGP-LS protocol?

Thanks,
Ketan

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: 15 June 2017 05:50
To: 'idr wg' <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

This begins a 2 week WG adoption call for draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 (6/14/2017 to 6/28/2017).    The chairs would appreciate if the operators would indicate whether they would deploy this draft.

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 15 Jun 2017 01:44:37 -0700

Hi Sue,

I support the adoption, I also think that RLD would make sense as a MSD type.

Cheers,

Jeff

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Wednesday, June 14, 2017 at 17:20
To: 'idr wg' <[email-masked]>
Cc: <[email-masked]>, <[email-masked]>
Subject: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

_______________________________________________ Idr mailing list [email-masked] https://www.ietf.org/mailman/listinfo/idr

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 15 Jun 2017 01:49:49 -0700

Ketan,

I’m of the same opinion, wrt IGP’s – RLD has been there for quite some time already: draft-ietf-(ospf|isis)-mpls-elc

Cheers,

Jeff

From: Idr <[email-masked]> on behalf of "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wednesday, June 14, 2017 at 20:32
To: Susan Hares <[email-masked]>, 'idr wg' <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

Thanks,

Ketan

---

From: [email-masked]
Date: Thu, 15 Jun 2017 09:09:21 +0000 (UTC)

Indeed, i feel no big issue in merging the documents... the question i do ask myself is that for IGP (for both ospf and isis) there is an individual draft to signal MSD and another for RLD... i feel that for consistency maybe 2 documents for BGP seem also logical. However i'm not that strongly against merging the documents either.

If we do decide for a merger of documents then lets maybe not call it either MSD or RLD as that will be confusing to people that read the IGP documents... Maybe something as SDS (Segment Depth Signaling) makes more sense? Small change to reduce confusion and  provides potential future extensibility if needed).

G/

Get Outlook for Android

From: Jeff Tantsura

Sent: Thursday, June 15, 10:50

To: Ketan Talaulikar (ketant), Susan Hares, 'idr wg'

Cc: [email-masked], [email-masked]

Ketan,

 

Cheers,

Jeff

 

 

 

Thanks,

Ketan

Sent: 15 June 2017 05:50

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 15 Jun 2017 09:19:32 +0000

Hi Jeff,

On the point of the IGPs. There are 2 parts there the ELC capability and the RLDC. The later part (RLDC) is somewhat independent IMHO. As a corollary IGPs signal SR capability separately from the base MSD size supported.

I see that the corresponding drafts have expired recently. I am not sure if there are implementations out there already for these. Is it too late to change/fix this?

Thanks,
Ketan

From: Jeff Tantsura [mailto:[email-masked]]
Sent: 15 June 2017 14:20
To: Ketan Talaulikar (ketant) <[email-masked]>; Susan Hares <[email-masked]>; 'idr wg' <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

Ketan,

Cheers,
Jeff
From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of "Ketan Talaulikar (ketant)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, June 14, 2017 at 20:32
To: Susan Hares <[email-masked]<mailto:[email-masked]>>, 'idr wg' <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

Thanks,
Ketan

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: 15 June 2017 05:50
To: 'idr wg' <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

_______________________________________________ Idr mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/idr

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 15 Jun 2017 09:31:35 +0000

Also FWIW, there are no codepoints allocated by IANA or even suggested in the drafts for the OSPF and ISIS drafts.

So Jeff, I think it might not be still too late to fix even in the IGPs if the authors of those drafts agree to it. And to restate, we are only talking of moving out RLDC and ELC parts remain in those respective drafts.

Thanks,
Ketan

From: Ketan Talaulikar (ketant)
Sent: 15 June 2017 14:49
To: 'Jeff Tantsura' <[email-masked]>; Susan Hares <[email-masked]>; 'idr wg' <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: RE: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

Hi Jeff,

Thanks,
Ketan

From: Jeff Tantsura [mailto:[email-masked]]
Sent: 15 June 2017 14:20
To: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; 'idr wg' <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

Ketan,

Cheers,
Jeff

Thanks,
Ketan

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 15 Jun 2017 13:47:07 +0200

Gunter,

We don't necessarily need to merge drafts, I'm against renaming, there's quite some work being done around MSD.
My point is about encoding - having it as MSD type. It is absolutely up to you/co-authors though.

Regards,
Jeff

> On Jun 15, 2017, at 11:09, [email-masked] wrote:
>

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 15 Jun 2017 12:59:33 +0000

Agree and it is more about the encodings than the drafts per se.

Thanks,
Ketan

From: Jeff Tantsura [mailto:[email-masked]]
Sent: 15 June 2017 17:17
To: [email-masked]
Cc: Ketan Talaulikar (ketant) <[email-masked]>; Susan Hares <[email-masked]>; idr wg <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

Gunter,

Regards,
Jeff

On Jun 15, 2017, at 11:09, [email-masked]<mailto:[email-masked]> wrote:
Indeed, i feel no big issue in merging the documents... the question i do ask myself is that for IGP (for both ospf and isis) there is an individual draft to signal MSD and another for RLD... i feel that for consistency maybe 2 documents for BGP seem also logical. However i'm not that strongly against merging the documents either.
If we do decide for a merger of documents then lets maybe not call it either MSD or RLD as that will be confusing to people that read the IGP documents... Maybe something as SDS (Segment Depth Signaling) makes more sense? Small change to reduce confusion and  provides potential future extensibility if needed).
G/
Get Outlook for Android<https://aka.ms/ghei36>

From: Jeff Tantsura
Sent: Thursday, June 15, 10:50
Subject: Re: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)
To: Ketan Talaulikar (ketant), Susan Hares, 'idr wg'
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

Ketan,

Cheers,
Jeff

Thanks,
Ketan

---

From: Keyur Patel <[email-masked]>
Date: Thu, 15 Jun 2017 21:46:25 +0000

Support and not aware of any IPR.

Regards,
Keyur

From: Susan Hares <[email-masked]>
Date: Wednesday, June 14, 2017 at 5:20 PM
To: 'idr wg' <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "'Dongjie (Jimmy)'" <[email-masked]>
Subject: draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Wednesday, June 14, 2017 at 5:26 PM

---

From: Mohan Nanduri <[email-masked]>
Date: Fri, 16 Jun 2017 11:19:30 -0400

Support WG adoption.

Cheers,
-Mohan

On Wed, Jun 14, 2017 at 8:20 PM, Susan Hares <[email-masked]> wrote:
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Fri, 16 Jun 2017 17:33:11 +0000

I support the extensions defined in draft-vandevelde-idr-bgp-ls-segment-routing-rld but I’d suggest to group all SR BGP-LS extensions in one document which is available and work in progress: draft-ietf-idr-bgp-ls-segment-routing-ext.

This would ease to centralize all SR extensions in one place and allows a better codepoint management.

Thanks.
s.

> On Jun 16, 2017, at 5:19 PM, Mohan Nanduri <[email-masked]> wrote:
> 
> Support WG adoption.
> 
> Cheers,
> -Mohan
> 
>

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 19 Jun 2017 16:33:52 -0400

> The chairs would appreciate if the operators would indicate whether they

I support adoption of this draft.  I ambivalent to the notion that RLD and 
MSD might be worth merging into the same document.

-- Jeff

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 20 Jun 2017 02:07:16 +0000

Support the adoption of this document.

And I agree that the encodings could be aligned with the msd draft.

Best regards,
Jie

From: Susan Hares [mailto:[email-masked]]
Sent: Thursday, June 15, 2017 8:20 AM
To: 'idr wg' <[email-masked]>
Cc: [email-masked]; [email-masked]; Dongjie (Jimmy) <[email-masked]>
Subject: draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

---

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Tue, 20 Jun 2017 08:49:21 +0000

Support as a co-author.

I am not aware of any IPR on the draft.

Regards

Matthew

From: Susan Hares <[email-masked]>
Date: Thursday, 15 June 2017 at 01:20
To: 'idr wg' <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "'Dongjie (Jimmy)'" <[email-masked]>
Subject: draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Thursday, 15 June 2017 at 01:26

  1.  Send a statement to the WG indicating whether you know of any IPR
  2.  Indicate whether you know of existing implementations
  3.  Please respond to the IDR list questions on a daily basis

---

From: <[email-masked]>
Date: Tue, 20 Jun 2017 13:37:07 +0000

Support,

I would be in favor to change the document name to "bgp-ls-segment-routing-erld" rather than using the "legacy" rld name.

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, June 15, 2017 02:20
To: 'idr wg'
Cc: [email-masked]; [email-masked]
Subject: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 20 Jun 2017 13:52:11 +0000

Support.

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Stephane Litkowski <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, June 20, 2017 at 9:37 AM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>, IDR List <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)

Support,

I would be in favor to change the document name to “bgp-ls-segment-routing-erld” rather than using the “legacy” rld name.

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Mon, 26 Jun 2017 10:55:10 +0000

Support as a co-author.

Regards,

G/

From: Susan Hares <[email-masked]>
Date: Thursday, 15 June 2017 at 02:20
To: 'idr wg' <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "'Dongjie (Jimmy)'" <[email-masked]>
Subject: draft-vandevelde-idr-bgp-ls-segment-routing-rld-03 - 2 week WG Adoption call (6/14 to 6/28)
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Thursday, 15 June 2017 at 02:26