Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Sat, 5 Aug 2017 05:23:49 +0000

Hi All,

The IANA early allocation has been done for the BGP-LS SR extension drafts now, but the other two drafts related to MSD and draft-idr-te-pm are still pending early allocations. May I request the authors to please request for the same at the earliest?

We have a collision right now between these drafts with their previously “suggested” code point values so would appreciate if this was resolved ASAP to aid implementations.

For the record, the previously suggested values were:

      TLV Type                   Value
   --------------------------------------------------------
    1104 (Suggested)  Unidirectional Link Delay

    1105 (Suggested)  Min/Max Unidirectional Link Delay

    1106 (Suggested)  Unidirectional Delay Variation

    1107 (Suggested)  Unidirectional Packet Loss

    1108 (Suggested)  Unidirectional Residual Bandwidth

    1109 (Suggested)  Unidirectional Available Bandwidth

    1110 (Suggested)  Unidirectional Bandwidth Utilization

Then from the MSD draft, we have collision

   Code-point: 1110 (Suggested value - to be assigned by IANA) from BGP-

   LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute

   TLVs registry

Thanks,
Ketan

From: Jeff Tantsura [mailto:[email-masked]]
Sent: 15 July 2017 19:48
To: Job Snijders <[email-masked]>; John G. Scudder <[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>
Cc: Stefano Previdi <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]; [email-masked]; idr wg <[email-masked]>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

That’s the plan!

Cheers,
Jeff

From: Job Snijders <[email-masked]<mailto:[email-masked]>>
Date: Saturday, July 15, 2017 at 16:15
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, "John G. Scudder" <[email-masked]<mailto:[email-masked]>>, "Ketan Talaulikar (ketant)" <[email-masked]<mailto:[email-masked]>>
Cc: Stefano Previdi <[email-masked]<mailto:[email-masked]>>, Susan Hares <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, idr wg <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

On Sat, 15 Jul 2017 at 15:35, Jeff Tantsura <[email-masked]<mailto:[email-masked]>> wrote:
Would  you want the authors of draft-tantsura-idr-bgp-ls-segment-routing-msd  to remove suggested values or wait for early allocation and replace?

The outcome of the IANA Early Allocation process is not directly connected to self-assigning (squatting) in the current document. I would suggest the squatted codepoint should be removed at the earliest opportunity (Monday morning). Uploading new drafts is cheap and easy after all.

Kind regards,

Job

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 5 Aug 2017 17:48:24 +0000

Hi Ketan,
When I spoke to Jeff in Prague, he was not attached to the specific code point, his main concern was getting early allocation for deployments requiring MSD advertisement. So, I think we are aligned.
Thanks,
Acee

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of "Ketan Talaulikar (ketant)" <[email-masked]<mailto:[email-masked]>>
Date: Saturday, August 5, 2017 at 1:23 AM
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, Job Snijders <[email-masked]<mailto:[email-masked]>>, John Scudder <[email-masked]<mailto:[email-masked]>>, "Les Ginsberg (ginsberg)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, IDR List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Stefano Previdi <[email-masked]<mailto:[email-masked]>>, Susan Hares <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Hi All,

      TLV Type                   Value

   TLVs registry

Thanks,
Ketan

From: Jeff Tantsura [mailto:[email-masked]]
Sent: 15 July 2017 19:48
To: Job Snijders <[email-masked]<mailto:[email-masked]>>; John G. Scudder <[email-masked]<mailto:[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>
Cc: Stefano Previdi <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; idr wg <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

That’s the plan!

Cheers,
Jeff

Kind regards,

Job

---

From: Jeff Tantsura <[email-masked]>
Date: Sat, 5 Aug 2017 12:28:58 -0700

Hi,

Thanks Acee!

To comply with IDR chairs request we have removed all "suggested" code points (see updated drafts).

Regards,
Jeff

> On Aug 5, 2017, at 10:48, Acee Lindem (acee) <[email-masked]> wrote:
> 
> Hi Ketan, 
> From: Idr <[email-masked]> on behalf of "Ketan Talaulikar (ketant)" <[email-masked]>
> To: Jeff Tantsura <[email-masked]>, Job Snijders <[email-masked]>, John Scudder <[email-masked]>, "Les Ginsberg (ginsberg)" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, IDR List <[email-masked]>, "[email-masked]" <[email-masked]>, Stefano Previdi <[email-masked]>, Susan Hares <[email-masked]>
> From: Job Snijders <[email-masked]>
> To: Jeff Tantsura <[email-masked]>, "John G. Scudder" <[email-masked]>, "Ketan Talaulikar (ketant)" <[email-masked]>
> Cc: Stefano Previdi <[email-masked]>, Susan Hares <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, idr wg <[email-masked]>
> On Sat, 15 Jul 2017 at 15:35, Jeff Tantsura <[email-masked]> wrote:

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Sun, 6 Aug 2017 04:34:39 +0000

Hi Jeff/Acee,

I think we are all on the same page and not attached to specific code-points necessarily (unless there are implementations out there which already have shipped with these “suggestions”).

Could the authors confirm that IANA early allocations have been requested?

Thanks,
Ketan

From: Jeff Tantsura [mailto:[email-masked]]
Sent: 06 August 2017 00:59
To: Acee Lindem (acee) <[email-masked]>
Cc: Ketan Talaulikar (ketant) <[email-masked]>; Job Snijders <[email-masked]>; John G. Scudder <[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]>; [email-masked]; idr wg <[email-masked]>; [email-masked]; Stefano Previdi <[email-masked]>; Susan Hares <[email-masked]>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Hi,

Thanks Acee!

Regards,
Jeff

On Aug 5, 2017, at 10:48, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Ketan,
When I spoke to Jeff in Prague, he was not attached to the specific code point, his main concern was getting early allocation for deployments requiring MSD advertisement. So, I think we are aligned.
Thanks,
Acee

Hi All,

      TLV Type                   Value

   TLVs registry

Thanks,
Ketan

That’s the plan!

Cheers,
Jeff

Kind regards,

Job

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 7 Aug 2017 08:51:44 +0000

Hi Jeff, et al,

If we have not already done so, can we request early allocation of the BGP-LS MSD code point?

Thanks,
Acee

From: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Saturday, August 5, 2017 at 3:28 PM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: "Ketan Talaulikar (ketant)" <[email-masked]<mailto:[email-masked]>>, Job Snijders <[email-masked]<mailto:[email-masked]>>, John Scudder <[email-masked]<mailto:[email-masked]>>, "Les Ginsberg (ginsberg)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, IDR List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Stefano Previdi <[email-masked]<mailto:[email-masked]>>, Susan Hares <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Hi,

Thanks Acee!

Regards,
Jeff

Hi Ketan,

Hi All,

      TLV Type                   Value

   TLVs registry

Thanks,
Ketan

That’s the plan!

Cheers,
Jeff

Kind regards,

Job

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 14 Aug 2017 05:03:53 +0000

WG Chairs –

If you have not already done so please initiate early allocation of code points for https://datatracker.ietf.org/doc/draft-ietf-idr-te-pm-bgp/
Thanx.

   Les

From: Ketan Talaulikar (ketant)
Sent: Friday, August 04, 2017 10:24 PM
To: Jeff Tantsura; Job Snijders; John G. Scudder; Les Ginsberg (ginsberg)
Cc: Stefano Previdi; Susan Hares; [email-masked]; [email-masked]; idr wg
Subject: RE: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Hi All,

      TLV Type                   Value

   TLVs registry

Thanks,
Ketan

That’s the plan!

Cheers,
Jeff

Kind regards,

Job