Subject: [Idr] Reg BGP LS identifier for different ISIS levels

From: kotesh <[email-masked]>
Date: Fri, 8 Sep 2017 12:22:09 +0530

Hi,

 Is it mandatory to configure different BGP LS identfier for different ISIS
levels under a given AS? What are the implications if we configure same BGP
LS identifier in different ISIS levels?

Thanks,
Kotesh babu.Chundu

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 15 Sep 2017 08:49:23 +0000

Hi Kotesh,

The BGP-LS Identifier is meant for when dealing with multiple ISIS protocol instances. If you have a ISIS protocol instance with L1 and L2 levels, they will share the same BGP-LS identifier.

Thanks,
Ketan

From: Idr [mailto:[email-masked]] On Behalf Of kotesh
Sent: 08 September 2017 12:22
To: [email-masked]
Subject: [Idr] Reg BGP LS identifier for different ISIS levels

Hi,
 Is it mandatory to configure different BGP LS identfier for different ISIS levels under a given AS? What are the implications if we configure same BGP LS identifier in different ISIS levels?

Thanks,
Kotesh babu.Chundu

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 15 Sep 2017 15:54:38 +0000

Hi Kotesh, 

Furthermore, note that the Protocol ID in the NLRI can be used to
discriminate between IS-IS level 1 and IS-IS level 2 (which is all that is
needed for single instance of IS-IS).  The Protocol-ID field can contain
one of the following values (from RFC 7752):

            +-------------+----------------------------------+
            | Protocol-ID | NLRI information source protocol |
            +-------------+----------------------------------+
            |      1      | IS-IS Level 1                    |
            |      2      | IS-IS Level 2                    |
            |      3      | OSPFv2                           |
            |      4      | Direct                           |
            |      5      | Static configuration             |
            |      6      | OSPFv3                           |
            +-------------+----------------------------------+

                       Table 2: Protocol Identifiers
Hope this helps,
Acee   

From:  Idr <[email-masked]> on behalf of "Ketan Talaulikar (ketant)"
<[email-masked]>
Date:  Friday, September 15, 2017 at 4:49 AM
To:  kotesh <[email-masked]>, IDR List <[email-masked]>
Subject:  Re: [Idr] Reg BGP LS identifier for different ISIS levels

>Hi Kotesh,
> 
>The BGP-LS Identifier is meant for when dealing with multiple ISIS
>protocol instances. If you have a ISIS protocol instance with L1
> and L2 levels, they will share the same BGP-LS identifier.
> 
>Thanks,
>Ketan
> 
> Is it mandatory to configure different BGP LS identfier for different
>ISIS levels under a given AS? What are the implications if we configure
>same BGP LS identifier in different ISIS levels?
>
>
>
>Thanks, 
>
>Kotesh babu.Chundu