Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 28 Sep 2017 02:21:20 +0000

Hi Jeff/Authors,

Can we know the status of the IANA allocation process for early allocation of the code points for draft-ietf-idr-bgp-ls-segment-routing-msd? Can we please expedite this?

The other two drafts mentioned in this email thread have got the code points allocated already.

Also, the latest versions have removed the code point “suggestions” based on the discussions on this matter on the WG email list here AND at the past IETF. It would be great though if we could get the same code points as below from IANA, if they are still available.
https://tools.ietf.org/html/draft-tantsura-idr-bgp-ls-segment-routing-msd-02
Node MSD : 1050
Link MSD : 1110

Thanks,
Ketan

From: Les Ginsberg (ginsberg)
Sent: 14 August 2017 10:34
To: Ketan Talaulikar (ketant) <[email-masked]>; Jeff Tantsura <[email-masked]>; Job Snijders <[email-masked]>; John G. Scudder <[email-masked]>
Cc: Stefano Previdi <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]; [email-masked]; idr wg <[email-masked]>
Subject: RE: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

WG Chairs –

If you have not already done so please initiate early allocation of code points for https://datatracker.ietf.org/doc/draft-ietf-idr-te-pm-bgp/
Thanx.

   Les

From: Ketan Talaulikar (ketant)
Sent: Friday, August 04, 2017 10:24 PM
To: Jeff Tantsura; Job Snijders; John G. Scudder; Les Ginsberg (ginsberg)
Cc: Stefano Previdi; Susan Hares; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; idr wg
Subject: RE: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Hi All,

The IANA early allocation has been done for the BGP-LS SR extension drafts now, but the other two drafts related to MSD and draft-idr-te-pm are still pending early allocations. May I request the authors to please request for the same at the earliest?

We have a collision right now between these drafts with their previously “suggested” code point values so would appreciate if this was resolved ASAP to aid implementations.

For the record, the previously suggested values were:

      TLV Type                   Value
   --------------------------------------------------------
    1104 (Suggested)  Unidirectional Link Delay

    1105 (Suggested)  Min/Max Unidirectional Link Delay

    1106 (Suggested)  Unidirectional Delay Variation

    1107 (Suggested)  Unidirectional Packet Loss

    1108 (Suggested)  Unidirectional Residual Bandwidth

    1109 (Suggested)  Unidirectional Available Bandwidth

    1110 (Suggested)  Unidirectional Bandwidth Utilization

Then from the MSD draft, we have collision

   Code-point: 1110 (Suggested value - to be assigned by IANA) from BGP-

   LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute

   TLVs registry

Thanks,
Ketan

From: Jeff Tantsura [mailto:[email-masked]]
Sent: 15 July 2017 19:48
To: Job Snijders <[email-masked]<mailto:[email-masked]>>; John G. Scudder <[email-masked]<mailto:[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>
Cc: Stefano Previdi <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; idr wg <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

That’s the plan!

Cheers,
Jeff

From: Job Snijders <[email-masked]<mailto:[email-masked]>>
Date: Saturday, July 15, 2017 at 16:15
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, "John G. Scudder" <[email-masked]<mailto:[email-masked]>>, "Ketan Talaulikar (ketant)" <[email-masked]<mailto:[email-masked]>>
Cc: Stefano Previdi <[email-masked]<mailto:[email-masked]>>, Susan Hares <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, idr wg <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

On Sat, 15 Jul 2017 at 15:35, Jeff Tantsura <[email-masked]<mailto:[email-masked]>> wrote:
Would  you want the authors of draft-tantsura-idr-bgp-ls-segment-routing-msd  to remove suggested values or wait for early allocation and replace?

The outcome of the IANA Early Allocation process is not directly connected to self-assigning (squatting) in the current document. I would suggest the squatted codepoint should be removed at the earliest opportunity (Monday morning). Uploading new drafts is cheap and easy after all.

Kind regards,

Job

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 28 Sep 2017 00:10:03 -0400

Ketan:

I will work on expediting this in the morning (ET (eastern US)). 

Sue Hares 

IDR WG Chair 

From: Idr [mailto:[email-masked]] On Behalf Of Ketan Talaulikar (ketant)
Sent: Wednesday, September 27, 2017 10:21 PM
To: Jeff Tantsura; [email-masked]
Cc: idr wg; Stefano Previdi; Susan Hares
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Hi Jeff/Authors,

Node MSD : 1050

Link MSD : 1110

Thanks,

Ketan

WG Chairs –

Thanx.

   Les

Cc: Stefano Previdi; Susan Hares; [email-masked]; [email-masked]; idr wg

Hi All,

      TLV Type                   Value

Thanks,

Ketan

From: Jeff Tantsura [mailto:[email-masked]] 
Sent: 15 July 2017 19:48
To: Job Snijders <[email-masked]>; John G. Scudder <[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>
Cc: Stefano Previdi <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]; [email-masked]; idr wg <[email-masked]>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

That’s the plan!

Cheers,

Jeff

From: Job Snijders <[email-masked]>
Date: Saturday, July 15, 2017 at 16:15
To: Jeff Tantsura <[email-masked]>, "John G. Scudder" <[email-masked]>, "Ketan Talaulikar (ketant)" <[email-masked]>
Cc: Stefano Previdi <[email-masked]>, Susan Hares <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, idr wg <[email-masked]>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

On Sat, 15 Jul 2017 at 15:35, Jeff Tantsura <[email-masked]> wrote:

 

Kind regards,

Job

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 28 Sep 2017 10:50:41 -0400

Ketan and Jeff: 

After looking at my email and notes on this, I found that I had put this on pause because of Acee’s note with the following information on September 3rd (I’ve reformatted Acce’s 9/3 note for consumption).  The following email chain left me awaiting a draft describing the registry.  

Is there a document I should review or put before the IDR WG in addition to draft-ietf-idr-bgp-ls-segment-routing-msd? 

Susan Hares 

PS - Normally, I do not do WG calls on Early adoptions during August because for 8 years the response has been terrible and then the AD (Alvaro) or the IESG asks me if there is support.   Getting this response on the 3rd of September slowed down the progress.  I apologize for the delay.  I should have actively pushed to get a resolution of the msd registry. 

=============

 (This has been informally discussed in the past with some of the folks on this thread – but wanted to present this more formally as the set of drafts matures.)

IS-IS/OSPF/IDR WG Chairs –

The authors of:

draft-ietf-isis-segment-routing-msd

draft-ietf-ospf-segment-routing-msd

draft-ietf-idr-bgp-ls-segment-routing-msd

would like to highlight the point that we wish to create a shared protocol independent registry for defining the MSD types which will be advertised as described in the three drafts mentioned above. We think having a single common registry will make it easier to maintain the consistency of additional MSD types when/if they are added in the future.

The description of the new registry is most accurately described in the IANA section of draft-ietf-isis-segment-routing-msd:

<snip>

  This document requests the creation of a new IANA managed registry to  identify MSD types as proposed in Section 3, Section 4.  The  registration procedure is "Expert Review" as defined in [RFC5226]. Suggested registry name is "MSD Sub-types".  Types are an unsigned 8    bit number.  The following values are defined by this document

       Value     Name                             Reference

      0         Reserved                            This document

      1         Base MSD                           This document

      2-250     Unassigned                    This document

      251-254   Experimental              This document

      255       Reserved                         This document

                Figure 4: MSD Sub-type Codepoints Registry

<end snip>

If any of you have concerns or suggestions regarding this plan we (the set of authors) welcome your input.

Les (on behalf of all the authors)

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, September 28, 2017 12:10 AM
To: 'Ketan Talaulikar (ketant)'; 'Jeff Tantsura'; [email-masked]
Cc: 'idr wg'; 'Stefano Previdi'
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Ketan:

Sue Hares 

IDR WG Chair 

Hi Jeff/Authors,

Node MSD : 1050

Link MSD : 1110

Thanks,

Ketan

WG Chairs –

Thanx.

   Les

Hi All,

      TLV Type                   Value

Thanks,

Ketan

That’s the plan!

Cheers,

Jeff

 

 

Kind regards,

Job

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 28 Sep 2017 15:00:01 +0000

Hi Susan,

Thanks for sharing this and I do remember this discussion. But I thought this proposed registry was about MSD sub-types which we wanted to share across the protocols.

The early allocation in question on this thread is the BGP-LS code points for the Node and Link MSD attributes. These come from within BGP-LS registry. The corresponding code-points in OSPF and ISIS have already got through the early allocation process after those drafts became WG items.

While we do want to close on the common registry for the MSD sub-types at the earliest, does the WG want to gate the BGP-LS code points early allocation for this?

Thanks,
Ketan

From: Susan Hares [mailto:[email-masked]]
Sent: 28 September 2017 20:21
To: Ketan Talaulikar (ketant) <[email-masked]>; 'Jeff Tantsura' <[email-masked]>; [email-masked]
Cc: 'idr wg' <[email-masked]>; 'Stefano Previdi' <[email-masked]>
Subject: RE: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Ketan and Jeff:

Susan Hares

=============

<end snip>

To: 'Ketan Talaulikar (ketant)'; 'Jeff Tantsura'; [email-masked]<mailto:[email-masked]>

Ketan:

Sue Hares
IDR WG Chair

To: Jeff Tantsura; [email-masked]<mailto:[email-masked]>

Hi Jeff/Authors,

Thanks,
Ketan

To: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Job Snijders <[email-masked]<mailto:[email-masked]>>; John G. Scudder <[email-masked]<mailto:[email-masked]>>

WG Chairs –

   Les

Hi All,

      TLV Type                   Value

   TLVs registry

Thanks,
Ketan

That’s the plan!

Cheers,
Jeff

Kind regards,

Job

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 28 Sep 2017 17:17:08 +0000

Sue –

I also am confused.

The thread you included below is – as Ketan states – about a common registry for defining MSD types.

What Ketan is asking for is early allocation of BGP-LS code points for advertising the MSD types in BGP-LS. These are not the same thing and I see no reason why early allocation of the BGP-LS codepoints should be blocked by the final disposition of the MSD registry.
Given that the MSD registry will be a NEW registry (in whatever location), there will be no early allocation for those codepoints because there is no existing usage to create potential conflicts. So we should be able to go full speed ahead with BGP-LS early allocation.

???

   Les

From: Ketan Talaulikar (ketant)
Sent: Thursday, September 28, 2017 8:00 AM
To: Susan Hares; 'Jeff Tantsura'; [email-masked]
Cc: 'idr wg'; 'Stefano Previdi'; Acee Lindem (acee); Les Ginsberg (ginsberg)
Subject: RE: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Hi Susan,

Thanks,
Ketan

From: Susan Hares [mailto:[email-masked]]
Sent: 28 September 2017 20:21
To: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; 'Jeff Tantsura' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: 'idr wg' <[email-masked]<mailto:[email-masked]>>; 'Stefano Previdi' <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Ketan and Jeff:

Susan Hares

=============

<end snip>

Ketan:

Sue Hares
IDR WG Chair

Hi Jeff/Authors,

Thanks,
Ketan

WG Chairs –

   Les

Hi All,

      TLV Type                   Value

   TLVs registry

Thanks,
Ketan

That’s the plan!

Cheers,
Jeff

Kind regards,

Job

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 28 Sep 2017 14:33:14 -0400

Les:

I’m not trying to block any allocation.  I simply misunderstood the email thread where I clarified things with Acee.  I thought you wanted to set-up the registry first, and then get the BGP allocation afterward. 

I’m happy to start a WG call for early allocation.   Here’s what you’ll answer in the call:

1)      Are there multiple vendors wishing to implement? 

2)      Is there IPR on the specification? 

3)      Is the specification stable and accurate? 

4)      How quickly do the implementers wish to progress the specification?

5)      Do you (as an individual) have any concerns on granting this early allocation? 

Do you feel this set of questions is reasonable for this specification?  If so,  I’ll start the early allocation call as soon as I receive your message. 

Thank you for clearing up my confusion,

Sue Hares 

From: Les Ginsberg (ginsberg) [mailto:[email-masked]] 
Sent: Thursday, September 28, 2017 1:17 PM
To: Ketan Talaulikar (ketant); Susan Hares; 'Jeff Tantsura'; [email-masked]
Cc: 'idr wg'; 'Stefano Previdi'; Acee Lindem (acee)
Subject: RE: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Sue –

I also am confused.

???

   Les

To: Susan Hares; 'Jeff Tantsura';  <mailto:[email-masked]> [email-masked]

Hi Susan,

Thanks,

Ketan

Ketan and Jeff: 

Susan Hares 

 

=============

The authors of:

<snip>

       Value     Name                             Reference

      0         Reserved                            This document

      1         Base MSD                           This document

<end snip>

 

From: Idr [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, September 28, 2017 12:10 AM
To: 'Ketan Talaulikar (ketant)'; 'Jeff Tantsura';  <mailto:[email-masked]> [email-masked]
Cc: 'idr wg'; 'Stefano Previdi'
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Ketan:

Sue Hares 

IDR WG Chair 

From: Idr [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Ketan Talaulikar (ketant)
Sent: Wednesday, September 27, 2017 10:21 PM
To: Jeff Tantsura;  <mailto:[email-masked]> [email-masked]
Cc: idr wg; Stefano Previdi; Susan Hares
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Hi Jeff/Authors,

 <https://tools.ietf.org/html/draft-tantsura-idr-bgp-ls-segment-routing-msd-02> https://tools.ietf.org/html/draft-tantsura-idr-bgp-ls-segment-routing-msd-02

Node MSD : 1050

Link MSD : 1110

Thanks,

Ketan

WG Chairs –

Thanx.

   Les

Cc: Stefano Previdi; Susan Hares;  <mailto:[email-masked]> [email-masked];  <mailto:[email-masked]> [email-masked]; idr wg

Hi All,

      TLV Type                   Value

Thanks,

Ketan

That’s the plan!

Cheers,

Jeff

From: Job Snijders < <mailto:[email-masked]> [email-masked]>
Date: Saturday, July 15, 2017 at 16:15
To: Jeff Tantsura < <mailto:[email-masked]> [email-masked]>, "John G. Scudder" < <mailto:[email-masked]> [email-masked]>, "Ketan Talaulikar (ketant)" < <mailto:[email-masked]> [email-masked]>
Cc: Stefano Previdi < <mailto:[email-masked]> [email-masked]>, Susan Hares < <mailto:[email-masked]> [email-masked]>, " <mailto:[email-masked]> [email-masked]" < <mailto:[email-masked]> [email-masked]>, " <mailto:[email-masked]> [email-masked]" < <mailto:[email-masked]> [email-masked]>, idr wg < <mailto:[email-masked]> [email-masked]>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

 

Kind regards,

Job

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 28 Sep 2017 18:46:45 +0000

Sue -

From: Susan Hares [mailto:[email-masked]]
Sent: Thursday, September 28, 2017 11:33 AM
To: Les Ginsberg (ginsberg); Ketan Talaulikar (ketant); 'Jeff Tantsura'; [email-masked]
Cc: 'idr wg'; 'Stefano Previdi'; Acee Lindem (acee)
Subject: RE: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Les:

[Les:] Nope – the two things are not directly related.

[Les:] Yes

2)      Is there IPR on the specification?
[Les:] None that I know of.

[Les:] Yes

[Les:] Yesterday. ☺

5)      Do you (as an individual) have any concerns on granting this early allocation?
[Les:] No concerns – but I am not sure who you are asking this of. Clearly the authors want early allocation or they would not have asked.
Are you asking the WG?

[Les:] Please start ASAP.

   Les

To: Ketan Talaulikar (ketant); Susan Hares; 'Jeff Tantsura'; [email-masked]<mailto:[email-masked]>

Sue –

I also am confused.

???

   Les

To: Susan Hares; 'Jeff Tantsura'; [email-masked]<mailto:[email-masked]>

Hi Susan,

Thanks,
Ketan

Ketan and Jeff:

Susan Hares

=============

<end snip>

Ketan:

Sue Hares
IDR WG Chair

Hi Jeff/Authors,

Thanks,
Ketan

WG Chairs –

   Les

Hi All,

      TLV Type                   Value

   TLVs registry

Thanks,
Ketan

That’s the plan!

Cheers,
Jeff

Kind regards,

Job

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 28 Sep 2017 11:54:25 -0700

Hi,

Great to see we are all on the same page.

There’s IPR that has been disclosed - https://datatracker.ietf.org/ipr/3023/

Thanks,

Jeff

From: Susan Hares <[email-masked]>
Date: Thursday, September 28, 2017 at 11:47
To: "'Ketan Talaulikar (ketant)'" <[email-masked]>, 'Jeff Tantsura' <[email-masked]>, <[email-masked]>
Cc: 'idr wg' <[email-masked]>, 'Stefano Previdi' <[email-masked]>, "'Acee Lindem (acee)'" <[email-masked]>, "'Les Ginsberg (ginsberg)'" <[email-masked]>
Subject: RE: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Ketan:

No.  The working group would encourage you to get early allocations.  The chair was simply confused.  I thought you wanted to establish the registry first.  

I’m awaiting a response from Les and then I will start the early allocation call today. 

Sue    

From: Ketan Talaulikar (ketant) [mailto:[email-masked]] 
Sent: Thursday, September 28, 2017 11:00 AM
To: Susan Hares; 'Jeff Tantsura'; [email-masked]
Cc: 'idr wg'; 'Stefano Previdi'; Acee Lindem (acee); Les Ginsberg (ginsberg)
Subject: RE: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

Hi Susan,

Thanks,

Ketan

Ketan and Jeff: 

Susan Hares 

 

=============

The authors of:

<snip>

       Value     Name                             Reference

      0         Reserved                            This document

      1         Base MSD                           This document

<end snip>

 

Ketan:

Sue Hares 

IDR WG Chair 

Hi Jeff/Authors,

Node MSD : 1050

Link MSD : 1110

Thanks,

Ketan

WG Chairs –

Thanx.

   Les

Hi All,

      TLV Type                   Value

Thanks,

Ketan

That’s the plan!

Cheers,

Jeff

 

 

Kind regards,

Job

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 28 Sep 2017 14:47:03 -0400

Ketan:

Sue    

Hi Susan,

Thanks,

Ketan

Ketan and Jeff: 

Susan Hares 

 

=============

The authors of:

<snip>

       Value     Name                             Reference

      0         Reserved                            This document

      1         Base MSD                           This document

<end snip>

 

Ketan:

Sue Hares 

IDR WG Chair 

Hi Jeff/Authors,

Node MSD : 1050

Link MSD : 1110

Thanks,

Ketan

WG Chairs –

Thanx.

   Les

Hi All,

      TLV Type                   Value

Thanks,

Ketan

That’s the plan!

Cheers,

Jeff

 

 

Kind regards,

Job