Subject: [Idr] I-D Action: draft-ietf-idr-rfc5575bis-05.txt

From: [email-masked]
Date: Thu, 19 Oct 2017 23:41:09 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : Dissemination of Flow Specification Rules
        Authors         : Susan Hares
                          Christoph Loibl
                          Robert Raszuk
                          Danny McPherson
                          Martin Bacher
	Filename        : draft-ietf-idr-rfc5575bis-05.txt
	Pages           : 33
	Date            : 2017-10-19

Abstract:
   This document updates [RFC5575] which defines a Border Gateway
   Protocol Network Layer Reachability Information (BGP NLRI) encoding
   format that can be used to distribute traffic Flow Specifications.
   This allows the routing system to propagate information regarding
   more specific components of the traffic aggregate defined by an IP
   destination prefix.

   It specifies IPv4 traffic Flow Specifications via a BGP NLRI which
   carries traffic Flow Specification filter, and an Extended community
   value which encodes actions a routing system can take if the packet
   matches the traffic flow filters.  The flow filters and the actions
   are processed in a fixed order.  Other drafts specify IPv6, MPLS
   addresses, L2VPN addresses, and NV03 encapsulation of IP addresses.

   This document updates [RFC5575] to correct unclear specifications in
   the flow filters and to provide rules for actions which interfere
   (e.g. redirection of traffic and flow filtering).

   Applications which use the bgp Flow Specification are: 1) application
   which automate inter-domain coordination of traffic filtering, such
   as what is required in order to mitigate (distributed) denial-of-
   service attacks; 2) applications which control traffic filtering in
   the context of a BGP/MPLS VPN service, and 3) applications with
   centralized control of traffic in a SDN or NFV context.  Some
   deployments of these three applications can be handled by the strict
   ordering of the BGP NLRI traffic flow filters, and the strict actions
   encoded in the extended community Flow Specification actions.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-rfc5575bis/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-rfc5575bis-05
https://datatracker.ietf.org/doc/html/draft-ietf-idr-rfc5575bis-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-rfc5575bis-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Christoph Loibl <[email-masked]>
Date: Fri, 20 Oct 2017 09:26:35 +0200

Hi,

I just uploaded a new version of the Flow Specification draft draft-ietf-idr-rfc5575bis-05.

I want to point out that it contains several minor edits after Job’s review during WG-LC (see the recent mails on the mailinglist), but also one more *complex* change that I would ask to review:

5.1.  Ordering of Traffic Filtering Rules (changes to the paragraph and the pseudocode)

The pseudocode of the sorting algorithm has been replaced by an actual runnable and tested python3 implementation. While you should also read it in the draft, you may want to view it on github (since you get all the syntax highlighting there https://github.com/stoffi92/flowspec-cmp - or you can even download the repository, add test-cases to the unit-test that is included).

Even though the python source is slightly longer than the pseudocode, I think it is a good idea to actually have a runnable code sample as a reference for actual behaviour. During the on-list discussion there were no objections.

Other smaller changes:

4.2.3.  Type 3 - IP Protocol

*) Small change to the wording in the Bit-Operator

The bits do not produce a “value” but a “relational operator”:

OLD:

The bits lt, gt, and eq can be combined to produce "less or equal
"greater or equal", and inequality values.

NEW:

The bits lt, gt, and eq can be combined to produce common relational
operators such as "less or equal", "greater or equal", and "not equal
to".

13. Original authors

Removed the editorial note 'Note: Any original author...'

ENTIRE Document:

*) Consistent use of the name "Flow Specification”

*) Correction of some missing cross-references and typos (mainly in the Abstract, Introduction)

Thank you, Job for your review and the feedback!

Cheers
Christoph

--
Christoph Loibl
[email-masked] | CL8-RIPE | PGP-Key-ID: 0x4B2C0055 | http://www.nextlayer.at

> On 20 Oct 2017, at 08:41, [email-masked] wrote:
> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: John Scudder <[email-masked]>
Date: Fri, 20 Oct 2017 11:56:19 +0300

Thanks for the update and the summary, Christoph. We will extend the WGLC until Wednesday to allow the WG a chance to review. I intend to review -05 myself and hope at least a few others will do the same and will send a note to the list saying they have done so. (If you've already reviewed the doc in detail, there's always rfcdiff.)

--John

> On Oct 20, 2017, at 10:26 AM, Christoph Loibl <[email-masked]> wrote:
> 
> Hi,
> 
> The pseudocode of the sorting algorithm has been replaced by an actual runnable and tested python3 implementation. While you should also read it in the draft, you may want to view it on github (since you get all the syntax highlighting there https://github.com/stoffi92/flowspec-cmp <https://github.com/stoffi92/flowspec-cmp> - or you can even download the repository, add test-cases to the unit-test that is included).
> 
> [email-masked] <mailto:[email-masked]> | CL8-RIPE | PGP-Key-ID: 0x4B2C0055 | http://www.nextlayer.at <http://www.nextlayer.at/>
> 
> 
> 
>> On 20 Oct 2017, at 08:41, [email-masked] <mailto:[email-masked]> wrote:
>> 
>> 
>> https://datatracker.ietf.org/doc/draft-ietf-idr-rfc5575bis/ <https://datatracker.ietf.org/doc/draft-ietf-idr-rfc5575bis/>
>> 
>> https://tools.ietf.org/html/draft-ietf-idr-rfc5575bis-05 <https://tools.ietf.org/html/draft-ietf-idr-rfc5575bis-05>
>> https://datatracker.ietf.org/doc/html/draft-ietf-idr-rfc5575bis-05 <https://datatracker.ietf.org/doc/html/draft-ietf-idr-rfc5575bis-05>
>> 
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-rfc5575bis-05 <https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-rfc5575bis-05>
>> 
>> 
>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>> 
>> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/idr <https://www.ietf.org/mailman/listinfo/idr>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/idr <https://www.ietf.org/mailman/listinfo/idr>