Subject: [Idr] Progressing draft-ietf-idr-rfc5575bis -- implementation reports?

From: John Scudder <[email-masked]>
Date: Tue, 26 Jun 2018 14:37:38 +0000

Hi All,

I've just been reviewing the mailing list traffic on draft-ietf-idr-rfc5575bis as well as the shepherd's report. It looks to me like we're ready to go, except that we have no reported implementations, at least I don't see anything at https://trac.ietf.org/trac/idr/wiki/Protocol%20implementations%20Reports, and the shepherd report reflects this too.

I'm hoping this will be easy to remedy since this is of course a bis document intended to clarify things, so hopefully many or most existing flowspec implementations already comply. If we can get a few reported soon, that will make for smooth sailing. 

Thanks,

--John

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 26 Jun 2018 10:46:11 -0400

John,

> On Jun 26, 2018, at 10:37 AM, John Scudder <[email-masked]> wrote:
> 
> Hi All,
> 

Since I've been living in flowspec land recently in the employer's code, I should be able to provide a review vs. implementation before IETF in Montreal.

An open point on the mailing list though has been whether the ipv6 flowspec work should be merged in.  See prior comments from Sue.

I'm personally ambivalent about doing that bit of merge work, but it's a good fit as long as the Working Group doesn't feel it's an issue to encumber the update to the core spec with the IPv6 stuff which is optional.  But if so, we'd need to see a merge to continue.

-- Jeff

---

From: John Scudder <[email-masked]>
Date: Tue, 26 Jun 2018 17:47:25 +0000

Jeff,

On Jun 26, 2018, at 10:46 AM, Jeffrey Haas <[email-masked]<mailto:[email-masked]>> wrote:

Unless I've missed it, there hasn't been an outcry from the WG to roll the work in. On the balance, my take (with co-chair propeller beanie on) is that since we are so far along with progressing 5575bis, and as Christop previously has pointed out, the original scope was set to be "clarification" and not more, we shouldn't hold it up further.

This is not to say the work isn't important or relevant, just that we have a doc pretty much ready for publication, respinning it now is maybe not the best use of anyone's time.

All that said, if I've missed discussion suggesting the WG *does* have consensus to re-open 5575bis (or that the consensus is ambiguous) I'm open to correction.

Thanks,

--John

---

From: Justin Ryburn <[email-masked]>
Date: Tue, 26 Jun 2018 11:54:49 -0600

I would tend to agree with John here. The clarification 5575bis brings is much needed. I would like to see the WG proceed with approvals and not hold it up for the IPv6 work. That are important as well but seem out of scope for this draft.

Just my 2 cents.

-Justin

> On Jun 26, 2018, at 11:47 AM, John Scudder <[email-masked]> wrote:
> 
> Jeff,
> 
> On Jun 26, 2018, at 10:46 AM, Jeffrey Haas <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 26 Jun 2018 14:24:09 -0400

John,

> On Jun 26, 2018, at 1:47 PM, John Scudder <[email-masked]> wrote:

As I mentioned, I'm ambivalent.  

That said, I promise to have provided review by IETF in Montreal.
I'd ask the WG chairs to push for refreshing of the v6 spec and a subsequent WGLC after we've advanced the bis and hopefully have incorporated -bis learnings into the v6 spec.

-- Jeff (two birds, an iterative number of stones)

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 26 Jun 2018 15:18:22 -0400

Jeff:

Since I'm not a co-author on the v6 version, I will ask that the v6 people
spin their draft and get it read for WG LC. 

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Jeffrey Haas
Sent: Tuesday, June 26, 2018 2:24 PM
To: John Scudder
Cc: [email-masked]; [email-masked]
Subject: Re: [Idr] Progressing draft-ietf-idr-rfc5575bis -- implementation
reports?

John,

On Jun 26, 2018, at 10:46 AM, Jeffrey Haas <[email-masked]> wrote:

An open point on the mailing list though has been whether the ipv6 flowspec
work should be merged in.  See prior comments from Sue.

I'm personally ambivalent about doing that bit of merge work, but it's a
good fit as long as the Working Group doesn't feel it's an issue to encumber
the update to the core spec with the IPv6 stuff which is optional.  But if
so, we'd need to see a merge to continue.

Unless I've missed it, there hasn't been an outcry from the WG to roll the
work in. On the balance, my take (with co-chair propeller beanie on) is that
since we are so far along with progressing 5575bis, and as Christop
previously has pointed out, the original scope was set to be "clarification"
and not more, we shouldn't hold it up further.

This is not to say the work isn't important or relevant, just that we have a
doc pretty much ready for publication, respinning it now is maybe not the
best use of anyone's time.

I'd ask the WG chairs to push for refreshing of the v6 spec and a subsequent
WGLC after we've advanced the bis and hopefully have incorporated -bis
learnings into the v6 spec.

---

From: Christoph Loibl <[email-masked]>
Date: Wed, 27 Jun 2018 12:45:19 +0200

Hi,

I actually brought up the discussion of merging the ipv6 draft into the 5575bis and Sue did a poll on IDR about a year ago. Based on this decision was made *NOT* to merge these two drafts and proceed with 5575bis without ipv6. I think non of the prerequisites that lead to that decision have changed since then. From today’s point of view I fully support what John and Justin already pointed out.

As a bis-draft our main scope was to clarify things and increase interoperability. It was 1) mostly writing down what was already implemented by a majority of the larger vendors, but not clearly defined (or even wrong) in the RFC5575. 2) Defining the behaviour in case of contradicting actions and future extensions.

Christoph

-- 
Christoph Loibl
[email-masked] | CL8-RIPE | PGP-Key-ID: 0x4B2C0055 | http://www.nextlayer.at

> On 26.06.2018, at 19:54, Justin Ryburn <[email-masked]> wrote:
>