Subject: [Idr] I-D Action: draft-ietf-idr-route-leak-detection-mitigation-10.txt

From: [email-masked]
Date: Mon, 22 Oct 2018 09:37:06 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : Methods for Detection and Mitigation of BGP Route Leaks
        Authors         : Kotikalapudi Sriram
                          Alexander Azimov
	Filename        : draft-ietf-idr-route-leak-detection-mitigation-10.txt
	Pages           : 11
	Date            : 2018-10-22

Abstract:
   Problem definition for route leaks and enumeration of types of route
   leaks are provided in RFC 7908.  This document describes a solution
   for detection and mitigation route leaks which is based on conveying
   route-leak protection (RLP) information in a Border Gateway Protocol
   (BGP) community.  The RLP information is carried in a new well-known
   transitive BGP community, called the RLP community.  The RLP
   community helps with detection and mitigation of route leaks at ASes
   downstream from the leaking AS (in the path of the BGP update).  This
   is an inter-AS (multi-hop) solution mechanism.  This solution
   complements the intra-AS (local AS) route-leak avoidance solution
   that is described in ietf-idr-bgp-open-policy draft.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-route-leak-detection-mitigation/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-route-leak-detection-mitigation-10
https://datatracker.ietf.org/doc/html/draft-ietf-idr-route-leak-detection-mitigation-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-route-leak-detection-mitigation-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Mon, 22 Oct 2018 21:57:55 +0000

Very substantial changes made from -09 to -10 version:
- Changes in the semantics of the RLP mechanism and the detection-mitigation algorithms
- In the draft, we're proposing to use BGP Large Community (transitive) to carry info about RLP
        * However, we are looking for WG feedback about the options -- Regular Community vs. Large vs. Extended?
        * See slides 19-24 for some details on these options (link to the slides below).

Authors' Team Discussion Slides may be helpful to see helpful graphics, scenario analyses:
https://www.nist.gov/sites/default/files/documents/2018/10/22/rlp_using_bgp_community-v4.pdf

Looking forward to your comments. Thanks.

Sriram

--------------------------------------------------------------

                          Alexander Azimov

        Pages           : 11

        Date            : 2018-10-22

Abstract:

URL: https://tools.ietf.org/html/draft-ietf-idr-route-leak-detection-mitigation-10

Diff: https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-route-leak-detection-mitigation-10