Subject: Re: [Idr] Status of draft-ietf-idr-ext-opt-param?

From: Jeffrey Haas <[email-masked]>
Date: Thu, 11 Jul 2019 10:19:20 -0400

Followup, since this also popped up on my TODO:

Juniper and Nokia have implementations.

I requested in 2016 an early allocation on the BGP optional parameter code
point.  This has not been done.

I believe once we have a re-publish of the document that we should proceed
with a working group last call.

-- Jeff

On Tue, Mar 12, 2019 at 01:56:09PM +0100, Robert Varga wrote:
> Hello,
> 
> what is the current status of draft-ietf-idr-ext-opt-param?
> 
> The document itself is expired and looking through archives I only found
> the June 2016 discussion which resulted in -05 and Jeff's July 2016
> mention the draft is being deployed and missing an early allocation.
> 
> Has the document been actively abandoned, or is it just something that
> fell through the cracks?
> 
> Thanks,
> Robert
> 

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 11 Jul 2019 15:49:54 -0400

Do you still want an early allocation?  We can suggest the value you already
have used. 

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Jeffrey Haas
Sent: Thursday, July 11, 2019 10:19 AM
To: Robert Varga
Cc: [email-masked]
Subject: Re: [Idr] Status of draft-ietf-idr-ext-opt-param?

-- Jeff

On Tue, Mar 12, 2019 at 01:56:09PM +0100, Robert Varga wrote:
> The document itself is expired and looking through archives I only 
> found the June 2016 discussion which resulted in -05 and Jeff's July 
> 2016 mention the draft is being deployed and missing an early allocation.
>

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 11 Jul 2019 17:15:07 -0400

Sue,

> Do you still want an early allocation?  We can suggest the value you already

We're largely not burning through optional parameter code points very
quickly.  That said, we should get this registered by the most expedient
manner possible to prevent conflicts.

A WGLC of this document would do that.  John has it queueud for re-publish
once the submission gates are open.

If we think process will stall it for whatever reason, perhaps consider the
early allocation.

-- Jeff

---

From: Robert Varga <[email-masked]>
Date: Mon, 15 Jul 2019 22:00:35 +0200

> If we think process will stall it for whatever reason, perhaps consider the

+1, we should nail the allocation down ASAP.

Regards,
Robert

---

From: Robert Varga <[email-masked]>
Date: Mon, 15 Jul 2019 22:07:27 +0200

> Juniper and Nokia have implementations.

FWIW, OpenDaylight will ship an implementation of
draft-ietf-idr-ext-opt-param-05 in the next major release (Sep 2019).

> point.  This has not been done.

Yes. If there is rough consensus, we need to get at least this done.

Regards,
Robert