Subject: Re: [Idr] draft-ietf-idr-capabilities-registry-change-05.txt - WG LC []6/9/2019 to 6/16/2019] - extending this for a 3rd week (7/8 to 7/15)

From: "Susan Hares" <[email-masked]>
Date: Mon, 8 Jul 2019 12:59:38 -0400

Greetings: 

The email list support for this draft did not receive as many comments as I
expected.   Perhaps, this lack of comments was due to vacations or due to
this idea "just making sense".  

Since one of the WG chairs is an author, I do need a strong sense of
support.  Please send in comments or just a comment for "support" or "no
support" for this draft. 

Cheerily, Susan Hares

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Sunday, June 9, 2019 1:33 PM
To: [email-masked]
Subject: [Idr] draft-ietf-idr-capabilities-registry-change-05.txt - WG LC
[]6/9/2019 to 6/16/2019]

This begins a 2 week IDR  WG Last Call (LC) on
ft-ietf-idr-capabilities-registry-change-05.txt.  

The document is at: 

https://datatracker.ietf.org/doc/draft-ietf-idr-capabilities-registry-change
/

As registration document, there is no implementation report.  

Please indicate in comments to the IDR "support" or "no support" for WG LC. 

Consider:

1)      Does this change to registration procedures for BGP capability codes
help speed up processing? 

2)      Is there any technical or operational issue in making this change? 

3)      Do we need to pass this to the IESG at the same time as any GROW
document? 

John Scudder is an author so I am the shepherd/chair on this draft.  

Cheerily, Susan Hares

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 8 Jul 2019 15:35:37 -0400

> this idea "just making sense".  

I support publication.  Such janitorial drafts don't get a lot of attention,
but are needed bits of IETF process.

-- Jeff

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 8 Jul 2019 12:35:44 -0700

Sue,

yes/support

Cheers,
Jeff
On Jul 8, 2019, 10:03 AM -0700, Susan Hares <[email-masked]>, wrote:
> Greetings:
>
> The email list support for this draft did not receive as many comments as I expected.   Perhaps, this lack of comments was due to vacations or due to this idea “just making sense”.
>
> Since one of the WG chairs is an author, I do need a strong sense of support.  Please send in comments or just a comment for “support” or “no support” for this draft.
>
> Cheerily, Susan Hares
>
>
> Subject: [Idr] draft-ietf-idr-capabilities-registry-change-05.txt - WG LC []6/9/2019 to 6/16/2019]
>
> This begins a 2 week IDR  WG Last Call (LC) on ft-ietf-idr-capabilities-registry-change-05.txt.
>
> The document is at:
> https://datatracker.ietf.org/doc/draft-ietf-idr-capabilities-registry-change/
>
> Please indicate in comments to the IDR “support” or “no support” for WG LC.
> Consider:
>
> Does this change to registration procedures for BGP capability codes help speed up processing?
> Is there any technical or operational issue in making this change?
> Do we need to pass this to the IESG at the same time as any GROW document?
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Martin Djernaes <[email-masked]>
Date: Tue, 9 Jul 2019 06:20:48 +0000

Hi,

I support the publication.

Martin

Juniper Business Use Only
From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: Monday, July 8, 2019 19:00
To: [email-masked]
Subject: Re: [Idr] draft-ietf-idr-capabilities-registry-change-05.txt - WG LC []6/9/2019 to 6/16/2019] - extending this for a 3rd week (7/8 to 7/15)

Greetings:

The email list support for this draft did not receive as many comments as I expected.   Perhaps, this lack of comments was due to vacations or due to this idea "just making sense".

Since one of the WG chairs is an author, I do need a strong sense of support.  Please send in comments or just a comment for "support" or "no support" for this draft.

Cheerily, Susan Hares

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Sunday, June 9, 2019 1:33 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Idr] draft-ietf-idr-capabilities-registry-change-05.txt - WG LC []6/9/2019 to 6/16/2019]

The document is at:
https://datatracker.ietf.org/doc/draft-ietf-idr-capabilities-registry-change/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Didr-2Dcapabilities-2Dregistry-2Dchange_&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=s0Y71ouoKyO4OJa8xaM_9EJqgyc49ogpQh3JuXpLnpQ&m=G8EXHDpM7ganorLTrQ2LzCLpByLYBQ1IfNpXNdW9K1I&s=dcmYjBYWAUVUx7OPaFrzzPm3bjVpNZNLepdosnWLaIQ&e=>

  1.  Does this change to registration procedures for BGP capability codes help speed up processing?
  2.  Is there any technical or operational issue in making this change?
  3.  Do we need to pass this to the IESG at the same time as any GROW document?

Cheerily, Susan Hares

---

From: <[email-masked]>
Date: Tue, 9 Jul 2019 09:35:04 +0000

I support progressing this draft.

1)      As the introduction states it, the current situation is not satisfactory. We need to improve to it, so IMHO in this case, the bias should be toward progressing the document rather than not progressing it.

2)      That specific proposal is good and has been commented multiple times on the list. AFAIR, the author has updated the document to reflect WG comments.

On a side note, as this document is not proposing a new fancy feature, it feels like understandable that it does not generate much excitation on the list.

Ø  Is there any technical or operational issue in making this change?

Quite the opposite. There is operational issue in not making this change.
https://tools.ietf.org/html/rfc5226#section-4.1
      Private Use - For private or local use only, with the type and
            purpose defined by the local site.  No attempt is made to
            prevent multiple sites from using the same value in
            different (and incompatible) ways.  [...] It is the responsibility of the sites
            making use of the Private Use range to ensure that no
            conflicts occur (within the intended scope of use).

EBGP sessions are very likely to not be limited to a "local site", and rfc5492 did not made any provision to handle such "private" code points any differently over EBGP session. (such as restricting/filtering over EBGP (both when sending and receiving), or creating a local context/translation for this EBGP peer ). As a result, two implementations could advertise the same "Private" code point over an EBGP session, for a different meaning, thereby creating an interop issue that the network operator would likely can't protect from).

Thank you,
--Bruno

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Monday, July 8, 2019 7:00 PM
To: [email-masked]
Subject: Re: [Idr] draft-ietf-idr-capabilities-registry-change-05.txt - WG LC []6/9/2019 to 6/16/2019] - extending this for a 3rd week (7/8 to 7/15)

Greetings:

Cheerily, Susan Hares

The document is at:

1)      Does this change to registration procedures for BGP capability codes help speed up processing?

3)      Do we need to pass this to the IESG at the same time as any GROW document?

Cheerily, Susan Hares

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 9 Jul 2019 11:01:22 +0000

I support publication as well.
Thanks,
Acee

From: Idr <[email-masked]> on behalf of Jeff Tantsura <[email-masked]>
Date: Monday, July 8, 2019 at 3:53 PM
To: IDR List <[email-masked]>, Susan Hares <[email-masked]>
Subject: Re: [Idr] draft-ietf-idr-capabilities-registry-change-05.txt - WG LC []6/9/2019 to 6/16/2019] - extending this for a 3rd week (7/8 to 7/15)

Sue,

yes/support

Cheers,
Jeff

Greetings:

Cheerily, Susan Hares

The document is at:

Cheerily, Susan Hares

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 25 Jul 2019 15:46:19 -0400

IDR

The draft-ietf-idr-capabilities has reach a moderate working group consensus
and it will be sent to the IESG for publication. 

I want to thank the people who responded to my plea for additional response
from IDR (see below).  This an important registry change.    For those who
would like to send additional comments (support/no support), please continue
to send these comments.  

Alvaro and the IESG read these lists to see how strong the consensus is on
documents. 

Sue Hares 

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Monday, July 8, 2019 1:00 PM
To: [email-masked]
Subject: Re: [Idr] draft-ietf-idr-capabilities-registry-change-05.txt - WG
LC []6/9/2019 to 6/16/2019] - extending this for a 3rd week (7/8 to 7/15)

Greetings: 

Cheerily, Susan Hares

The document is at: 

Consider:

Cheerily, Susan Hares