Subject: Re: [Idr] [draft-ietf-idr-segment-routing-te-policy] Error handling for Explicit NULL Label Policy Sub-TLV

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 3 Jul 2019 12:28:34 +0000

Hi Mano/PK,

I also agree with your proposal for (1).

Regarding (2), I also agree that it is better to treat the values 0 and >  4 as reserved and if these values are used then the headend can ignore the TLV (which would actually be falling back to local config, if any).

I would request the authors to please consider updating the draft with the same if they agree.

Thanks,
Ketan

From: Przemyslaw Krol <[email-masked]>
Sent: 18 May 2019 07:29
To: Manoharan Sundaramoorthy <[email-masked]>
Cc: Nandan Saha <[email-masked]>; [email-masked]; Ketan Talaulikar (ketant) <[email-masked]>; Paul Mattes <[email-masked]>; [email-masked]
Subject: Re: [draft-ietf-idr-segment-routing-te-policy] Error handling for Explicit NULL Label Policy Sub-TLV

Hi Mano,

Oh, I see. Thanks for clarification and apologies for my irrelevant comment then.
FWIW, I support your proposal to consider these values as reserved and fallback to local poli..., erm, behavior defined by config :-)

pk

On Fri, May 17, 2019, 17:09 Manoharan Sundaramoorthy <[email-masked]<mailto:[email-masked]>> wrote:
Hi Pk,

In 2(b) we meant, "For values 0 and 5-255, treat as if the Sub-TLV was not received and take default ENLP action that is configured locally" (or) "if these values are to be treated as illegal, then do TAW".

Thanks,
Mano

On Fri, May 17, 2019 at 11:20 PM Przemyslaw Krol <[email-masked]<mailto:[email-masked]>> wrote:
Hi Nandan,

I personally agree with your proposal for handling multiple ENLP sub-TLV (1). It's clear and consistent with other similar cases

In terms of ENLP = 0 || >=5 (2), my concern regarding 2b (fallback to static) is that there may be multiple instances of BGP policy (different advertisers) with the same or lower preference and valid ENLP values. Failing back to static would basically skip those BGP policies and "bypass" policy selection. I suspect it's undesirable. For this reason, treating it as reserved (2a) sounds to me like a better option. Unless you really meant ignoring offending policy and moving to the next one (which can be static or BGP, depending on the selection algo), but regardless, 2a) seems safer and less disruptive in the future (if/when we need ENLP >=5 ).

thanks,
pk

On Thu, May 16, 2019 at 12:42 AM Nandan Saha <[email-masked]<mailto:[email-masked]>> wrote:
Hi folks,
 There error handling for the ENLP sub-TLV isn't defined in
draft-ietf-idr-segment-routing-te-policy-05 [1].

There are 2 things that need to be clarified:-

1. The behavior when ENLP sub-TLV occurs more than once:
  For this, my preference is to add text like we have for policy
priority sub-TLV [2] (and some other sub-TLVs), mandating only one
occurrence and treat-as-withdraw when present more than once.

2. Behavior when ENLP value is either 0 or >= 5.
  The only meaningful/legal values defined now are 1-4. My preference is to
2a: mark other values as reserved for future use. (We could mark them
illegal but that'll rule out trying to extended them if ever needed)
and
2.b: Upon receipt ENLP = 0 || >=5 the headend call fall back to local
policy. (If we go down the route of marking 0 || >= 5 as illegal, we
can do TAW)

Please let me know what you think, and if this seems reasonable.

[1] - https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-05#section-2.4.4
[2] - https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-05#section-2.4.5

Thanks,
Nandan

--
Przemyslaw "PK" Krol |
 Strategic Network Engineer
ing | [email-masked]<mailto:[email-masked]>

--
Thanks,
Manoharan

---

From: "Kausik Majumdar (kmajumda)" <[email-masked]>
Date: Mon, 8 Jul 2019 05:05:41 +0000

Hi Mano, PK,

The SR-TE Policy version 07 draft updated to capture the Error handling for Explicit NULL Label Policy Sub-TLV.

Please let us know if you have any other suggestions/improvement in the draft.

Thanks,
Kausik

From: Idr <[email-masked]> On Behalf Of Ketan Talaulikar (ketant)
Sent: Wednesday, July 3, 2019 5:29 AM
To: Przemyslaw Krol <[email-masked]>; Manoharan Sundaramoorthy <[email-masked]>
Cc: Paul Mattes <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Idr] [draft-ietf-idr-segment-routing-te-policy] Error handling for Explicit NULL Label Policy Sub-TLV

Hi Mano/PK,

Thanks,
Ketan

From: Przemyslaw Krol <[email-masked]<mailto:[email-masked]>>
Sent: 18 May 2019 07:29
To: Manoharan Sundaramoorthy <[email-masked]<mailto:[email-masked]>>
Cc: Nandan Saha <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; Paul Mattes <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [draft-ietf-idr-segment-routing-te-policy] Error handling for Explicit NULL Label Policy Sub-TLV

Hi Mano,

pk

Thanks,
Mano

thanks,
pk

Thanks,
Nandan

--
Thanks,
Manoharan