Subject: [Idr] [RTG-DIR] RtgDir review : draft-ietf-idr-bgp-extended-messages-33.txt

From: "Shah, Himanshu" <[email-masked]>
Date: Fri, 19 Jul 2019 01:31:01 +0000

Hello,

I have been selected as the Routing Directorate reviewer for this draft.
The Routing Directorate seeks to review all routing or routing-related
drafts as they pass through IETF last call and IESG review, and
sometimes on special request. The purpose of the review is to provide
assistance to the Routing ADs. For more information about the Routing
Directorate, please see
​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it
would be helpful if you could consider them along with any other IETF
Last Call comments that you receive, and strive to resolve them through
discussion or by updating the draft.

Document: draft-ietf-idr-bgp-extended-messages-33.txt
Reviewer: Himanshu Shah
Review Date: 18 July 2019
IETF LC End Date: Unknown
Intended Status: Standards Track

Summary:

I have some suggestions to improve the document by adding more context to the goal of this draft.

Comments:

The document is concise, clear and easy to read.

Since this is my first review as Routing directorate, the suggestions I have,
could be out-of-scope. Will leave at the discretion of AD and authors, if suggestions are worth pursuing or not.

While Introduction section briefly mentions newer capabilities as the reason for extended
message size for the BGP, it may help the reader to expand on the advantages of extended message
as compared to current limitation of 4K BGP messages.  For me, subsequent reading of the
document as it underlines the migration, error cases and security risks, the advantages of
extended message size seems to dissipate.

I also suggest that authors address issue of extended delay at the receiver in processing of large size BGP
messages while TCP’s reliable transport is building a complete message under challenging
network conditions and compare that against smaller messages in distressed network.

In my view, making a strong case on why extended message size, would greatly add value.

 Major Issues:

No major issues found.

Minor Issues:

No minor issues found. Please note the suggestion in the comment section above.

Nits:

None.

Thanks,
Himanshu

---

From: Alvaro Retana <[email-masked]>
Date: Fri, 19 Jul 2019 09:25:57 -0700

Himanshu:

Thanks for the review!

Alvaro.

On July 18, 2019 at 10:31:08 PM, Shah, Himanshu ([email-masked]) wrote:

Hello,

Directorate, please see

Reviewer: Himanshu Shah

Summary:

I have some suggestions to improve the document by adding more context to
the goal of this draft.

Comments:

Since this is my first review as Routing directorate, the suggestions I
have,

could be out-of-scope. Will leave at the discretion of AD and authors, if
suggestions are worth pursuing or not.

While Introduction section briefly mentions newer capabilities as the
reason for extended

message size for the BGP, it may help the reader to expand on the
advantages of extended message

as compared to current limitation of 4K BGP messages.  For me, subsequent
reading of the

document as it underlines the migration, error cases and security risks,
the advantages of

I also suggest that authors address issue of extended delay at the receiver
in processing of large size BGP

messages while TCP’s reliable transport is building a complete message
under challenging

network conditions and compare that against smaller messages in distressed
network.

In my view, making a strong case on why extended message size, would
greatly add value.

 Major Issues:

No major issues found.

Minor Issues:

No minor issues found. Please note the suggestion in the comment section
above.

Nits:

None.

*Thanks,*

*Himanshu*