Subject: Re: [Idr] Do you mind that draft-ietf-idr-bgp-ls-segment-routing-msd-05.txt has IPR? [6/9/2019 to 6/16/2019]

From: "Susan Hares" <[email-masked]>
Date: Mon, 8 Jul 2019 12:42:24 -0400

WG: 

This is to formally call for the WG to consider that the draft-ietf-bgp-ls-segment-routing-msd-05.txt has 1 IPR Statement (see comments below).  I started this discussion on June 9th, but I did not bring it to a good conclusion.  

As far as I can tell, there is no IDR objection to WG LC draft-ietf-idr-bgp-ls-segment-routing-msd-05.txt.   Please comment by 7/12/2019 if you object to the WG LC.  The shepherd is waiting for -06.txt of this document with additional error handling in order to begin WG LC.   Hopefully, that draft will appear today. 

Cheerily, Susan Hares 

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Sunday, June 9, 2019 12:19 PM
To: 'Jeff Tantsura'; [email-masked]
Cc: [email-masked]
Subject: Re: [Idr] Shepherd Review for draft-ietf-bgp-ls-segment-routing-msd-05.txt

Jeff:

Thank you for indicating as an inventor there is only one patent, but 2 claims. The discussion of the patent is outside of my purview as IDR WG co-Chair or the IDR WG’s appropriate discussion.    

The shepherd statement is still accurate, I need to make an IPR call to decide whether the WG approves in WG LC any document with IPR on the document.   Since all IPR statements have been made, and you are going to revise the document, I will start the IPR call based on the 1 patent (2 IPR claims below).  

Cheerily, Susan Hares 

https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-segment-routing-msd/

Date

ID

Statement

2018-08-30

3273

 <https://datatracker.ietf.org/ipr/3273/> Telefonaktiebolaget LM Ericsson (publ)'s Statement about IPR related to draft-ietf-idr-bgp-ls-segment-routing-msd

2017-06-26

3023

 <https://datatracker.ietf.org/ipr/3023/> Telefonaktiebolaget LM Ericsson (publ)'s Statement about IPR related to draft-tantsura-idr-bgp-ls-segment-routing-msd

 

From: Idr [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Sunday, June 9, 2019 3:29 AM
To: [email-masked]; Susan Hares
Cc: [email-masked]
Subject: Re: [Idr] Shepherd Review for draft-ietf-bgp-ls-segment-routing-msd-05.txt

Sue, 

Wrt 2 IPR statements:

this is the same IPR, one published against individual draft, another, after idr has adopted it.

The author will be working to address your comments..

Cheers, 

Jeff

On Jun 7, 2019, 7:27 PM -0700, Susan Hares <[email-masked]>, wrote:

Jeff, Ketan, Uma, Greg, and Nikos: 

My initial shepherd review of draft-ietf-bgp-ls-segment-routing-msd-05.txt  has three points:

2 IPR statements means the draft will have to go through an IPR call for the IPR issues

Error handling section needs to be added to the draft (requires -06.txt)

The implementation report needs to be improved (see below)

After all things are completed, I will start the WG LC.

Sue Hares

(Shepherd/WG co-chair)

2 IPR Statements

-----------------------

The 2 IPR statements for this draft means that after all authors indicate IPR knowledge,

I will need to do a WG call for considering the draft with 2 IPR statements.

Otherwise, the IESG may wish to cycle a discussion on the IPR.   

It takes less time to just do it up-front..

Error handling

----------------

This draft must add an error handling section that indicates what happen if the

Node MSD TLV and the Link MSD TLV are incorrectly parsed. 

This is a requirement for the shepherd/WG chair to send this to WG LC or the

QA reviews (RTG-DIR, OPS-DIR). 

I also would prefer to see

https://datatracker.ietf.org/doc/draft-ketant-idr-rfc7752bis/

as a WG document prior to sending this to the IESG.  

Could you check with the authors to determine its status?

Otherwise, the error handling section in this draft will need

to be improved.  

Implementation report improvement

--------------------------------------

The implementation reports for draft-ietf-idr-bgp-ls-segment-routing-msd-05 needs improving and your draft needs to have additional error handling specified. 

You need to indicate key features:

MSD and SR routing interaction

MSD advertisements MAY be useful even if SR itself is not enabled. 

MSD and BGP-LS interaction  

2a) The BGP-LS speaker may also advertise the
      MSD information for the local node and its links when not running any
      link-state IGP protocol e.g. when running BGP as the only routing
      protocol.

      2b) This enables sharing of MSD-Types that may
      be defined in the future by the IGPs in BGP-LS.

Support for Node TLV parsing

3a – feature support ( yes/no)

3b-  MUST  (yes/20)

         MSD-Value : a number in the range of 0-255.  For all MSD-Types,

         0 represents the lack of ability to impose an MSD stack of any

         depth; any other value represents that of the node.  This value

         MUST represent the lowest value supported by any link

         configured for use by the advertising protocol instance.

        3c) Support for Error handling if Node TLV is incorrectly parsed – This needs to be specified your draft

Support for Link MSD TLV

4a) support for feature

4b) support for error handling if Link MSD is incorrectly parsed

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 25 Jul 2019 17:29:32 -0400

Greeting IDR: 

All the discussion regarding the IPR in
draft-ietf-idr-bgp-ls-segment-routing-msd-05.txt has completed.  All IPR
statements have been made. 

The WG will start WG LC.   Watch for the next message. 

Cheerily, Susan Hares 

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Sunday, June 9, 2019 1:09 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] Do you mind that
draft-ietf-idr-bgp-ls-segment-routing-msd-05.txt has IPR? [6/9/2019 to
6/16/2019]

IDR WG: 

This 2 week WG call to determine if the WG wishes to do a WG LC on
draft-ietf-idr-bgp-ls-segment-routing-msd.   

If you wish the IDR WG to consider a WG LC, then indicate "support" in your
comments. 

If you wish the IDR WG to not consider a WG LC due to the IPR, then please
indicate "no support" in your comments. 

If you wish to provide additional comments for the authors as we head toward
WG LC, then please add these comments. 

The chairs read all comments related to a WG LC (including those with this
IPR call). 

Normally we do the calls at the same time, but the authors need to revise
the draft to address concerns from the shepherd.   Therefore, I'm pushing
ahead with the IPR call - so we can focus on the technical issues when
-06.txt is submitted. 

Cheerily, 

Sue Hares 

How to check IPR

----------------------

You can look at the IPR by clicking on the IPR button associated 

The IPR can be looked at directly at: 

https://datatracker.ietf.org/ipr/3273/

https://datatracker.ietf.org/ipr/3023/

Jeff Tantsura (one of the inventors) indicates these IPRs are on 1 patent.