Subject: [Idr] Mail regarding draft-ietf-idr-bgp-open-policy

From: Zhuangshunwan <[email-masked]>
Date: Wed, 31 Jul 2019 02:50:01 +0000

Hi guys,

Section 9 of draft-ietf-idr-bgp-open-policy-06 says:
...
   This document defines a new optional, transitive BGP Path Attributes
   option, named "Only To Customer", assigned value <TBD3> [To be
   removed upon publication: http://www.iana.org/assignments/bgp-
   parameters/bgp-parameters.xhtml#bgp-parameters-2] [RFC4271].  The
   length of this attribute is 0.

[Comment]  The length of this attribute should be 4 per the description of section 6.
Type 35 with the name "Internal Only To Customer" has been assigned to previous version of draft-ietf-idr-bgp-open-policy. Can we simply use Type 35 for "Only To Customer" attribute, or apply a new one?

Thanks,
Shunwan

---

From: Brian Dickson <[email-masked]>
Date: Wed, 31 Jul 2019 13:48:16 -0700

On Tue, Jul 30, 2019 at 7:50 PM Zhuangshunwan <[email-masked]>
wrote:

> …
> Type 35 with the name “Internal Only To Customer” has been assigned to
> previous version of draft-ietf-idr-bgp-open-policy. Can we simply use Type
> 35 for "Only To Customer" attribute, or apply a new one?
>
>
IMNSHO, apply for a new one.
(It's not like there is a danger of running out any time soon.)

Technically, the previous one had different meaning/semantics, and was
assigned.
The principal of "don't re-use, no matter what" should apply to be 100%
certain no one did an early implementation that now conflicts with the new
semantics.
It is the only way to be safe for absolute certain.

Brian

>  Thanks,
>
> Shunwan
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>