Subject: RE: [Ieprep] Comments on draft-carlberg-ieprep-framework

From: "Bob Bell" <[email-masked]>
Date: Thu, 14 Mar 2002 13:20:53 -0600

James, et. al. - 
 
In the stated example, loosing 1% of the stream would probably not cause a great deal of distortion so as to render all conversations unusable. However, if you continue the process of stealing chunks of bandwidth, as more calls are "shoehorned" through the restriction point, you will quickly reach that condition. This is the reason I would believe that associating a precidence level with a call and using policy to terminate a lower precidence level session in favor of a higher precidence level would be more "fair". In this way, only the lowest precidence session would suffer, not all sessions. Even if you were to remove bandwidth from sessions proportinate to the their precidence (e.g. the lower the precidence, the more bandwidth could be stolen), unless some method of reducing their "billing" for this reduced clarity call is in place, then persons would be "paying" for services that they could not get. This is asking for trouble in the form of govenrment intervention and law suites. At least, if the lower precidence call is terminated, the "billing" also ends.
 
Bob

-----Original Message-----
From: James Polk 
Sent: Thursday, 14 March, 2002 12:08 PM
To: [email-masked]
Subject: Re: [Ieprep] Comments on draft-carlberg-ieprep-framework

At 09:20 AM 3/14/2002 -0500, Scott  Bradner wrote:
>
>Mike sez:
>  The reference I made about "It's what the US military does" is a 
>  basic requirement for voice service operation.
>
>we are talking past each other
>
>I maintain that N-levels of priority is a solution not a requirement
>
>the question that needs to be answered is what functions are needed to
>be supported - not how to do them
>
>specifically - what problem is thought to be solved by N levels of priority?
>
>       is it that there should be a different probibility for
>       calls to be completed based on who you are or what you are doing?
>
>       is it that the quality of the call should depends on who you
>       are and what you are doing?
>
>       or is it someting else

Let's pose a strict set of circumstances to address part of this thread that's not answered yet explicitly (to my understanding - and others I believe)

Let assume RSVP worked completely everywhere and between every phone in the Internet. A VoIP call using RSVP would work almost identically to a circuit switched call in taking up a defined amount of bandwidth through each transit interface between two phones. Lets say that all VoIP calls push aside all other (data) traffic always with no hesitation. In a case where each call is 80kbps traversing a T1 (1.544Mbps), 19 calls are possible at any one time. Even though there is 56kbps of bandwidth remaining, that 20th call cannot be completed if it requires an 80kbps Reservation across this link.

This is an example where codecs aren't changeable -- I want a specific analysis to this scenario

What Mike is suggesting is the potential for dropping < 1kbps from all 19 existing calls to make this 20th one exist (if all 19 calls have the same precedence level and the new 20th call has a higher precedence level). That instead of clearing one of the calls (preemption), merely degrading all 19 existing calls by about 1 packet per second (of the 50pps for a normal VoIP call).

Is this considered unacceptable?

One existing example/analogy:  even though the Cellular industry isn't packet-based, I believe most calls remain *up* AND loose more than 1% of the media signal during a call (if not much more). 

>
>Scott
>
>_______________________________________________
>Ieprep mailing list
>[email-masked]
> https://www1.ietf.org/mailman/listinfo/ieprep

*************************************
"People generally demand more respect for their own rights than they are willing to allow for others"

James M. Polk
Consulting Engineer
Office of the CTO

Cisco Systems
2200 East President George Bush Turnpike 
Richardson, TX  75082 USA
w) 972.813.5208
f)  972.813.5280
www.cisco.com <http://www.cisco.com/>

---

From: "Stuart (Stu) Goldman" <[email-masked]>
Date: Sun, 17 Mar 2002 15:28:22 -0700

Bob,

I am a little confused about what you have written.

I agree that should more and more calls just be "shoehorned" in, then
the QoS would continue to go down IF we were just looking at a SNAPSHOT
of the network where no calls ever end.

However, if we can assume that the vast bulk of the traffic is not
emergency calls, can we not also logically assume that as such non-
emergency calls individually end, the bandwidth would revert back to the
network. The existing admission policy would not allow additional non
emergency calls to be established.

So, my question is would not the QoS return to normal as soon as an
equal number of non emergency calls have completed their sessions?

It seems to me that the "overlooking" of the admission policy for
emergency calls would at the most only temporarily impact the QoS of the
network. The normal QoS would be quickly restored.  I would think that
QoS would not be more than momentarily impacted unless and until the
emergency traffic has completely displaced all of the multitude of POTS
traffic.

Am I missing something?

Bob Bell wrote:

>  James, et. al. - In the stated example, loosing 1% of the stream
> would probably not cause a great deal of distortion so as to render
> all conversations unusable. However, if you continue the process of
> stealing chunks of bandwidth, as more calls are "shoehorned" through
> the restriction point, you will quickly reach that condition. This is
> the reason I would believe that associating a precidence level with a
> call and using policy to terminate a lower precidence level session in
> favor of a higher precidence level would be more "fair". In this way,
> only the lowest precidence session would suffer, not all sessions.
> Even if you were to remove bandwidth from sessions proportinate to the
> their precidence (e.g. the lower the precidence, the more bandwidth
> could be stolen), unless some method of reducing their "billing" for
> this reduced clarity call is in place, then persons would be "paying"
> for services that they could not get. This is asking for trouble in
> the form of govenrment intervention and law suites. At least, if the
> lower precidence call is terminated, the "billing" also ends.Bob
>
>      At 09:20 AM 3/14/2002 -0500, Scott  Bradner wrote:>>Mike
>      sez:>  The reference I made about "It's what the US military
>      does" is a>  basic requirement for voice service
>      operation.>>we are talking past each other>>I maintain that
>      N-levels of priority is a solution not a requirement>>the
>      question that needs to be answered is what functions are
>      needed to>be supported - not how to do them>>specifically -
>      what problem is thought to be solved by N levels of
>      priority?>>is it that there should be a different
>      probibility for>calls to be completed based on who you are
>      or what you are doing?>>is it that the quality of the call
>      should depends on who you>are and what you are doing?>>or is
>      it someting elseLet's pose a strict set of circumstances to
>      address part of this thread that's not answered yet
>      explicitly (to my understanding - and others I believe)Let
>      assume RSVP worked completely everywhere and between every
>      phone in the Internet. A VoIP call using RSVP would work
>      almost identically to a circuit switched call in taking up a
>      defined amount of bandwidth through each transit interface
>      between two phones. Lets say that all VoIP calls push aside
>      all other (data) traffic always with no hesitation. In a
>      case where each call is 80kbps traversing a T1 (1.544Mbps),
>      19 calls are possible at any one time. Even though there is
>      56kbps of bandwidth remaining, that 20th call cannot be
>      completed if it requires an 80kbps Reservation across this
>      link.This is an example where codecs aren't changeable -- I
>      want a specific analysis to this scenarioWhat Mike is
>      suggesting is the potential for dropping < 1kbps from all 19
>      existing calls to make this 20th one exist (if all 19 calls
>      have the same precedence level and the new 20th call has a
>      higher precedence level). That instead of clearing one of
>      the calls (preemption), merely degrading all 19 existing
>      calls by about 1 packet per second (of the 50pps for a
>      normal VoIP call).Is this considered unacceptable?One
>      existing example/analogy:  even though the Cellular industry
>      isn't packet-based, I believe most calls remain *up* AND
>      loose more than 1% of the media signal during a call (if not
>      much more).
>       >>Scott>>_
>      _____________________________________________>Ieprep mailing
>      list>[email-masked]>https://www1.ietf.org/mailman/listinfo/ieprep
>       "People generally demand more respect for their own rights
>               than they are willing to allow for others"
>
>       James M. Polk
>      Consulting Engineer
>      Office of the CTO
>
>      Cisco Systems
>      www.cisco.com