Subject: RE: [Ieprep] multicast

From: "Nguyen, An" <[email-masked]>
Date: Fri, 29 Mar 2002 13:55:06 -0500

Setting aside a block of class D addresses for emergency multicast traffic
is needed. You have my vote on it.

Regards,

An Nguyen

-----Original Message-----
From: Marshall Eubanks [mailto:[email-masked]]
Sent: Friday, March 29, 2002 1:37 PM
To: Gunn, Janet NE; 'Marshall Eubanks'; Nguyen, An
Cc: [email-masked]
Subject: Re: [Ieprep] multicast

On Fri, 29 Mar 2002 13:18:01 -0500
 "Gunn, Janet NE" <[email-masked]> wrote:
> What, if any, priority mechanism would be appropriate
> with multicast?

Hello;

The method that I intend to recommend is to have IANA set up
an emergency allocation block from the RFC 3138  
Class D address pool, and then set up ASM and SSM
suballocations in that block (there are at least 1000 /24's
available for this, if needed). All other multicast
addresses could then be filtered out if necessary in an
emergency, and these filters could be set up in advance.
(There could be pools set up in this for European
broadcasts, the USA, Japan, the UN, etc., etc.)

This, of course, means that priority is a manual
intervention scheme that would have to be triggered in the
NOC's or the equivalent, but a static, preconfigured,
allocation scheme offers certain advantages in an emergency,
akin to "tune to channel 2 in case of an actual emergency".

Regards
Marshall Eubanks

> 
> -----Original Message-----
> From: Marshall Eubanks [mailto:[email-masked]]
> Sent: Friday, March 29, 2002 12:49 PM
> To: Nguyen, An; 'Marshall Eubanks'
> Cc: [email-masked]
> Subject: Re: [Ieprep] Public Safety?
> 
> 
> I would strongly urge (and am working on an I-D for) the
> use of multicast to distribute video in this situation,
> as
> it scales well and avoids edge melt-downs.
> See, e.g., my presentation to NANOG-23
> 
> http://www.nanog.org/mtg-0110/eubanks.html
> 
> Regards
> Marshall Eubanks
> 

_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep

---

From: Sean Donelan <[email-masked]>
Date: Fri, 29 Mar 2002 14:34:38 -0500 (EST)

> is needed. You have my vote on it.

Setting aside a block of Class D addresses is just a waste of space
unless someone can come up with a way to use it, secure it and
activate it during an emergency.  It may be an especially bad idea
to filter out other multicast space in an emergency.

For example, during September 11 the EBS/EAS system was never activated by
the government.  In informal conversations, the broadcast community felt
the government pre-empting the response already in progress by the
commercial news community would have been more disruptive and caused more
harm than it would have helped.  Government spokespeople didn't have very
much to say.  Please standby wouldn't have been very helpful.  When
government officials did want to make a statement, they didn't seem
to have much difficulty obtaining coverage by the news organizations.
The news media was already reporting the story across multiple outlets,
often converting non-news broadcasts to simulcast of news sources.  But
some news organizations deliberately choose not to convert some outlets,
such as the cartoon channel.  If the government had activated the EBS/EAS,
they wouldn't not have had the option to keep the cartoon channel on
the air.  It would have been automatically taken off the air by the
SAGE ENDEC boxes.

Government directed pre-emption isn't always the best way to handle an
emergency.

---

From: "Stuart (Stu) Goldman" <[email-masked]>
Date: Fri, 29 Mar 2002 16:16:13 -0700

How large should such a block be?

---

From: "Marshall Eubanks" <[email-masked]>
Date: Fri, 29 Mar 2002 18:31:07 -0500

On Fri, 29 Mar 2002 13:55:06 -0500
> is needed. You have my vote on it.

Well, we have talked to RIPE and IANA about doing this.
The mechanisms are there, and I am sure that we
could get through a proposal from this WG.

Regards
Marshall

---

From: Fred Baker <[email-masked]>
Date: Fri, 29 Mar 2002 16:07:51 -0800

>could get through a proposal from this WG.

Is there a shortage of multicast addresses at times when emergency workers 
need them? Can you point me to a demonstration of the fact?

---

From: "Marshall Eubanks" <[email-masked]>
Date: Sun, 31 Mar 2002 14:24:31 -0500

On Fri, 29 Mar 2002 14:34:38 -0500 (EST)
 Sean Donelan <[email-masked]> wrote:

Dear Sean;

I agree with you. I believe that government preemption of
regular communications channels in a crises is almost
certainly a bad idea.

I thought, however, that we were discussing protecting
emergency communications between members of emergency
services. If their communications require priority, then (in
the Internet context) filtering is one way of doing this. I
am not sure about the desirability of filtering even in this
case, however.

The general experience with crises is that any activity that
is not planned and rehearsed in advanced will be messed up
when the moment comes. By this light, I doubt that
government news channels, activated only during a crises,
would be superior to the commercial channels (which do deal
with regular crisis situations). Filtering should also be
viewed dubiously unless it is routinely practiced. 

So, IMHO, what's needed are routine means of communications
between emergency services, or between them and the public,
that are in more or less continual use, and can be hardened
for use in a crisis. 

As for what these should be, engineering experience says
that extreme events, by their nature, are very hard to
predict and simulate properly, and engineering practice says
that what worked and what didn't work in an extreme
situation should be studied seriously for a guide to what is
likely to work in future such situations. This is routinely
done in civil engineering, and should be applied here.

On 9/11 I was a direct observer of the reaction of the
Internet to a massive demand for information, as I am sure
you all were. I was also a participant, like most or all of
you, in that I was part of that demand for information.
Somewhat like a cardiologist who starts taking notes during
his own heart attack, I found myself professionally
surprised by what was going on.

I noticed, and subsequent surveys and discussions
confirmed, that what worked was 

- e-mail
- multicast

and what weren't very useful at peak were

- news related web sites
- unicast streaming sites

(At the time I was not part of instant messengering, so I
made no direct observations of that communications channel.
I would be curious to hear of reports on its use and
usability in the crisis.)

Avi Freedman of Akamai told me that the Akamai
infrastructure functioned well on 9/11, so the problems that
I and many others noticed were presumablely between sources
and caches.

I am well aware that there have been "spins" of the 9/11
Internet status in other directions; all I can say is that
some of these disagree with my direct observations.

The technology exists to set up video channels on the
Internet between any emergency services that wish it. It
seems clear to me, based on what happened on 9/11, that
multicasting should be given serious consideration for the
transport for these channels. If these are set up and put
into use now, they can be available during the next crisis.
It seems to me that this fits squarely within the charter of
the working group.

Regards
Marshall Eubanks

---

From: Dean Bogdanovic <[email-masked]>
Date: Sun, 31 Mar 2002 21:16:51 -0500

> usability in the crisis.)

I can tell from own experience and from other people that I have heard
that IM was working well. I can not say that was the general case, but
in cases that I know, it was working well. I believe that IM could be
a good solution for emergency communications (either data or voice),
expecially if endusers can establish sessions without a middlebox and
that, from a technical perspective is possible today. It requires end
user device to be more detailed configured, but it makes it pretty
independent as long the basic infrastucture (IP connectivity) is
available.
Using SIMPLE today (I am not saying that is the best solution, but
something to start with), endusers can configure without a middlebox
and establish end to end sessions as long the IP communications is
present. The enduser device needs to have all necessary configuration
available and that device is pretty independent. 
This makes the emergency communications pretty hard to stop by DoS
attacks, because it is distributed without a central point of failure
(no addtional services are needed, but usefull if available).

> I and many others noticed were presumablely between sources

Akamai infrastructure works well for static content, but there are
problems for dymanic content delivery or when there are lot of changes
at the source, as stated above.

> It seems to me that this fits squarely within the charter of

Multicast is a nice technology and I agree that it should be
considered, but it is also stopable with good designed DoS attacks
(delivery comes from few sources, so those sources need good
protection. I do not believe that akamaizing would help, because of
dynamic nature of content delivery).

--br

Dean