Subject: RE: [Ieprep] Comments on draft-carlberg-ieprep-framework

From: "Bob Bell" <[email-masked]>
Date: Mon, 18 Mar 2002 10:24:47 -0600

Stu, et. al. - 
 
You are correct in that call duration is finite. An average internal call (at least from my days in circuit mode) is typically on the order of 1-1.5 minutes. External calls (i.e. those involving the PSTN) have an average duration of 3-5 minutes. Given that, 5 minutes is a very long time at internet speeds. Yes, call termination will free resources and as the general QoS degradation increases, the length of calls will go down. It would be interesting to see what the usage curve would look like. One important note in this area is that the emergency calls we are discussing are not isolated calls like a single instance of 911, but a coordinated attempt by several governmental agencies to initiate coordination during a disaster event when the trunk lines will be jammed by people calling to check on spouse, kids, parents, friends, etc. I don't believe that normal call dynamics apply under these conditions.
 
Bob

-----Original Message-----
From: Stuart (Stu) Goldman [mailto:[email-masked]]
Sent: Sunday, 17 March, 2002 3:28 PM
To: Bob Bell
Cc: [email-masked]
Subject: Re: [Ieprep] Comments on draft-carlberg-ieprep-framework

Bob, 

I am a little confused about what you have written. 

I agree that should more and more calls just be "shoehorned" in, then the QoS would continue to go down IF we were just looking at a SNAPSHOT of the network where no calls ever end. 

However, if we can assume that the vast bulk of the traffic is not emergency calls, can we not also logically assume that as such non- emergency calls individually end, the bandwidth would revert back to the network. The existing admission policy would not allow additional non emergency calls to be established. 

So, my question is would not the QoS return to normal as soon as an equal number of non emergency calls have completed their sessions? 

It seems to me that the "overlooking" of the admission policy for emergency calls would at the most only temporarily impact the QoS of the network. The normal QoS would be quickly restored.  I would think that QoS would not be more than momentarily impacted unless and until the emergency traffic has completely displaced all of the multitude of POTS traffic. 

Am I missing something? 

Bob Bell wrote: 

 James, et. al. - In the stated example, loosing 1% of the stream would probably not cause a great deal of distortion so as to render all conversations unusable. However, if you continue the process of stealing chunks of bandwidth, as more calls are "shoehorned" through the restriction point, you will quickly reach that condition. This is the reason I would believe that associating a precidence level with a call and using policy to terminate a lower precidence level session in favor of a higher precidence level would be more "fair". In this way, only the lowest precidence session would suffer, not all sessions. Even if you were to remove bandwidth from sessions proportinate to the their precidence (e.g. the lower the precidence, the more bandwidth could be stolen), unless some method of reducing their "billing" for this reduced clarity call is in place, then persons would be "paying" for services that they could not get. This is asking for trouble in the form of govenrment intervention and law suites. At least, if the lower precidence call is terminated, the "billing" also ends.Bob 

-----Original Message----- 
From: James Polk 
Sent: Thursday, 14 March, 2002 12:08 PM 
To: [email-masked] 
Subject: Re: [Ieprep] Comments on draft-carlberg-ieprep-framework 
 
At 09:20 AM 3/14/2002 -0500, Scott  Bradner wrote:>>Mike sez:>  The reference I made about "It's what the US military does" is a>  basic requirement for voice service operation.>>we are talking past each other>>I maintain that N-levels of priority is a solution not a requirement>>the question that needs to be answered is what functions are needed to>be supported - not how to do them>>specifically - what problem is thought to be solved by N levels of priority?>>is it that there should be a different probibility for>calls to be completed based on who you are or what you are doing?>>is it that the quality of the call should depends on who you>are and what you are doing?>>or is it someting elseLet's pose a strict set of circumstances to address part of this thread that's not answered yet explicitly (to my understanding - and others I believe)Let assume RSVP worked completely everywhere and between every phone in the Internet. A VoIP call using RSVP would work almost identically to a circuit switched call in taking up a defined amount of bandwidth through each transit interface between two phones. Lets say that all VoIP calls push aside all other (data) traffic always with no hesitation. In a case where each call is 80kbps traversing a T1 (1.544Mbps), 19 calls are possible at any one time. Even though there is 56kbps of bandwidth remaining, that 20th call cannot be completed if it requires an 80kbps Reservation across this link.This is an example where codecs aren't changeable -- I want a specific analysis to this scenarioWhat Mike is suggesting is the potential for dropping < 1kbps from all 19 existing calls to make this 20th one exist (if all 19 calls have the same precedence level and the new 20th call has a higher precedence level). That instead of clearing one of the calls (preemption), merely degrading all 19 existing calls by about 1 packet per second (of the 50pps for a normal VoIP call).Is this considered unacceptable?One existing example/analogy:  even though the Cellular industry isn't packet-based, I believe most calls remain *up* AND loose more than 1% of the media signal during a call (if not much more). 
 >>Scott>>_______________________________________________>Ieprep mailing list>[email-masked]> https://www1.ietf.org/mailman/listinfo/ieprep 
************************************* 
"People generally demand more respect for their own rights than they are willing to allow for others"

 James M. Polk 
Consulting Engineer 
Office of the CTO 

Cisco Systems 
2200 East President George Bush Turnpike 
Richardson, TX  75082 USA 
w) 972.813.5208 
f)  972.813.5280 
www.cisco.com <http://www.cisco.com/>

---

From: "Stuart (Stu) Goldman" <[email-masked]>
Date: Mon, 18 Mar 2002 10:56:15 -0700

Bob,

I think we are pretty much in agreement on the facts.

5 minutes is indeed a very long time. However, since we only need the
first call release to occur to make up for the first emergency call we
let in over the limits, we do not need to wait for 5 minutes, but just
for the next one of the already established calls to release. If there
were thousands of calls in session and these calls were following the
normal statistical arrival rates and length distributions, then one
should release momentarily.

It is very true that in an emergency there very well might be a much
greater concentration of emergency calls, and following the above, on a
call by call basis, they would be displacing  non emergency calls on the
network.

I agree with you totally on the difficulty of modeling human behavior in
a future attack. Depending on its nature there could be many short calls
check if people are OK, or there could be very long calls to address
topics such as evacuation, etc.  Our best strength is in the network's
flexibility and diversity.

What I am saying about the traffic does stop working if we were to get
into a situation where the emergency traffic totally replaces the non
emergency traffic. While I think this is unlikely to occur in the
aggregate, I see that it could happen at focal points.

I just don't know what the next natural or man made disaster will look
like. We need to be prepared for the unanticipated. I know a number of
people of commented on how well the Internet stood up to the attack on
Sept. 11 th. I am sad to say that the hospitals in the New York area
also were not overwhelmed by the injured. However, I would not want to
draw the conclusion that therefore the hospitals do not need to beef up
for future attacks.

Bob Bell wrote:

>  Stu, et. al. - You are correct in that call duration is finite. An
> average internal call (at least from my days in circuit mode) is
> typically on the order of 1-1.5 minutes. External calls (i.e. those
> involving the PSTN) have an average duration of 3-5 minutes. Given
> that, 5 minutes is a very long time at internet speeds. Yes, call
> termination will free resources and as the general QoS degradation
> increases, the length of calls will go down. It would be interesting
> to see what the usage curve would look like. One important note in
> this area is that the emergency calls we are discussing are not
> isolated calls like a single instance of 911, but a coordinated
> attempt by several governmental agencies to initiate coordination
> during a disaster event when the trunk lines will be jammed by people
> calling to check on spouse, kids, parents, friends, etc. I don't
> believe that normal call dynamics apply under these conditions.Bob
>
>      I agree that should more and more calls just be "shoehorned"
>      in, then the QoS would continue to go down IF we were just
>      looking at a SNAPSHOT of the network where no calls ever
>      end.
>
>      However, if we can assume that the vast bulk of the traffic
>      is not emergency calls, can we not also logically assume
>      that as such non- emergency calls individually end, the
>      bandwidth would revert back to the network. The existing
>      admission policy would not allow additional non emergency
>      calls to be established.
>
>      So, my question is would not the QoS return to normal as
>      soon as an equal number of non emergency calls have
>      completed their sessions?
>
>      It seems to me that the "overlooking" of the admission
>      policy for emergency calls would at the most only
>      temporarily impact the QoS of the network. The normal QoS
>      would be quickly restored.  I would think that QoS would not
>      be more than momentarily impacted unless and until the
>      emergency traffic has completely displaced all of the
>      multitude of POTS traffic.
>
>      Am I missing something?
>
>
>
>      Bob Bell wrote:
>
>     > James, et. al. - In the stated example, loosing 1% of the
>     > stream would probably not cause a great deal of distortion
>     > so as to render all conversations unusable. However, if
>     > you continue the process of stealing chunks of bandwidth,
>     > as more calls are "shoehorned" through the restriction
>     > point, you will quickly reach that condition. This is the
>     > reason I would believe that associating a precidence level
>     > with a call and using policy to terminate a lower
>     > precidence level session in favor of a higher precidence
>     > level would be more "fair". In this way, only the lowest
>     > precidence session would suffer, not all sessions. Even if
>     > you were to remove bandwidth from sessions proportinate to
>     > the their precidence (e.g. the lower the precidence, the
>     > more bandwidth could be stolen), unless some method of
>     > reducing their "billing" for this reduced clarity call is
>     > in place, then persons would be "paying" for services that
>     > they could not get. This is asking for trouble in the form
>     > of govenrment intervention and law suites. At least, if
>     > the lower precidence call is terminated, the "billing"
>     > also ends.Bob
>     >
>     >      At 09:20 AM 3/14/2002 -0500, Scott  Bradner
>     >      wrote:>>Mike sez:>  The reference I made about
>     >      "It's what the US military does" is a>  basic
>     >      requirement for voice service operation.>>we are
>     >      talking past each other>>I maintain that
>     >      N-levels of priority is a solution not a
>     >      requirement>>the question that needs to be
>     >      answered is what functions are needed to>be
>     >      supported - not how to do them>>specifically -
>     >      what problem is thought to be solved by N levels
>     >      of priority?>>is it that there should be a
>     >      different probibility for>calls to be completed
>     >      based on who you are or what you are doing?>>is
>     >      it that the quality of the call should depends
>     >      on who you>are and what you are doing?>>or is it
>     >      someting elseLet's pose a strict set of
>     >      circumstances to address part of this thread
>     >      that's not answered yet explicitly (to my
>     >      understanding - and others I believe)Let assume
>     >      RSVP worked completely everywhere and between
>     >      every phone in the Internet. A VoIP call using
>     >      RSVP would work almost identically to a circuit
>     >      switched call in taking up a defined amount of
>     >      bandwidth through each transit interface between
>     >      two phones. Lets say that all VoIP calls push
>     >      aside all other (data) traffic always with no
>     >      hesitation. In a case where each call is 80kbps
>     >      traversing a T1 (1.544Mbps), 19 calls are
>     >      possible at any one time. Even though there is
>     >      56kbps of bandwidth remaining, that 20th call
>     >      cannot be completed if it requires an 80kbps
>     >      Reservation across this link.This is an example
>     >      where codecs aren't changeable -- I want a
>     >      specific analysis to this scenarioWhat Mike is
>     >      suggesting is the potential for dropping < 1kbps
>     >      from all 19 existing calls to make this 20th one
>     >      exist (if all 19 calls have the same precedence
>     >      level and the new 20th call has a higher
>     >      precedence level). That instead of clearing one
>     >      of the calls (preemption), merely degrading all
>     >      19 existing calls by about 1 packet per second
>     >      (of the 50pps for a normal VoIP call).Is this
>     >      considered unacceptable?One existing
>     >      example/analogy:  even though the Cellular
>     >      industry isn't packet-based, I believe most
>     >      calls remain *up* AND loose more than 1% of the
>     >      media signal during a call (if not much more).
>     >       >>Scott>>____________________________________
>     >      __________>Ieprep mailing
>     >      list>[email-masked]>https://www1.ietf.org/mailman/listinfo/ieprep
>     >       "People generally demand more respect for their
>     >        own rights than they are willing to allow for
>     >                           others"
>     >
>     >       James M. Polk
>     >      Consulting Engineer
>     >      Office of the CTO
>     >
>     >      Cisco Systems
>     >      www.cisco.com