Subject: RE: Wednesday June 26th - [Ieprep] I-D ACTION:draft-talauliker-ieprep-diffserv-00.txt

From: "Talauliker, Salil Ulhas (UMKC-Student)" <[email-masked]>
Date: Mon, 8 Jul 2002 13:33:44 -0500

Dear Dr.Munro,
 
This is in response to you comment below about using DSCP mechanisms for its original purpose dated Wednesday June 26th.
 
> The Talauliker draft seems to be about priority using DSCPs and RED mechanisms. I would prefer to use them
>  their best advantage in doing what they were designed for without imposing a secondary purpose on them. Priority 
> a different issue and known to be difficult to resolve. Did I mistake what was written?
 
Sir, I'd like to point out that your comment has the answer to the issue that you raise. I would like to stress the following first:
 
1. We here at UMKC agree with you that Priority is definitely a difficult issue to resolve.
2. My draft is focussed on Internet Emergency provision issues rather than "Priority" in particular.
3. And I have mentioned in my draft that no current "standard" mechanism exists that treats this problem.
4. The draft is focussed towards providing Priority Treatment in a Diffserv environment using CURRENT available practices.
 
Hence I have proposed the idea of extending the RED mechanism to solve the problem of priority. At the current time this seems to be the best approach in a DIFFSERV domain. The stream of new RED-related papers from Infocom 2002 has strengthened our original belief in RED as a viable option. I would also like to point out that we are not talking about a particular implementation of RED by a firm. Instead we are talking about RED and its variants as known to IETF and the networking community.
 
I appreciate your comments and would like to add that we are open for further comments and suggestions from you.
 
Thanks,
 
Salil Talauliker
University of Missouri-Kansas City
[email-masked]
 
References: draft-talauliker-ieprep-diffserv-00.txt

_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep

---

From: "Alistair Munro" <[email-masked]>
Date: Tue, 9 Jul 2002 15:52:46 +0100

Dear Salil,

Thank your for your feedback and observations on my comments.

I'm happy to accept your view of the purpose of the draft. My comments on it were concerned with its value as current best practice - I like the ideas in it but I may not get time and resource to do all the study that seems to be implied. 

There are probably people who know better about this than I do as I have never used RIO and I don't know who implements it. Is there an RFC for it? Do others have comments?

Regards,

Alistair

--
Dr. Alistair Munro,
Chief Systems Engineer, Degree2 Innovations Ltd.
Regus House, 1 Friary, Temple Quay, Bristol, BS1 6EA, U.K.
E-mail: [email-masked]
Tel: (work) +44-117-900-8114, (home) +44-1275-462707, (mobile) +44-7974-922-442;
Fax: +44-117-900-8151
Web: http://www.u4eagroup.com

> -----Original Message-----
> From: Talauliker, Salil Ulhas (UMKC-Student) [mailto:[email-masked]] 
> Sent: 08 July 2002 19:34
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: Wednesday June 26th - [Ieprep] I-D 
> ACTION:draft-talauliker-ieprep-diffserv-00.txt
> 
> 
> Dear Dr.Munro,
>  
> This is in response to you comment below about using DSCP 
> mechanisms for its original purpose dated Wednesday June 26th.
>  
> > The Talauliker draft seems to be about priority using DSCPs and RED 
> > mechanisms. I would prefer to use them  their best 
> advantage in doing 
> > what they were designed for without imposing a secondary purpose on 
> > them. Priority a different issue and known to be difficult 
> to resolve. 
> > Did I mistake what was written?
>  
> Sir, I'd like to point out that your comment has the answer 
> to the issue that you raise. I would like to stress the 
> following first:
>  
> 1. We here at UMKC agree with you that Priority is definitely 
> a difficult issue to resolve. 2. My draft is focussed on 
> Internet Emergency provision issues rather than "Priority" in 
> particular. 3. And I have mentioned in my draft that no 
> current "standard" mechanism exists that treats this problem. 
> 4. The draft is focussed towards providing Priority Treatment 
> in a Diffserv environment using CURRENT available practices.
>  
> Hence I have proposed the idea of extending the RED mechanism 
> to solve the problem of priority. At the current time this 
> seems to be the best approach in a DIFFSERV domain. The 
> stream of new RED-related papers from Infocom 2002 has 
> strengthened our original belief in RED as a viable option. I 
> would also like to point out that we are not talking about a 
> particular implementation of RED by a firm. Instead we are 
> talking about RED and its variants as known to IETF and the 
> networking community.
>  
> I appreciate your comments and would like to add that we are 
> open for further comments and suggestions from you.
>  
> Thanks,
>  
> Salil Talauliker

---

From: senthil ayyasamy <[email-masked]>
Date: Tue, 9 Jul 2002 14:18:14 -0700 (PDT)

> I have never used RIO and I don't know
> who implements it. Is there an RFC for it? Do others
> have comments?
    RIO is an academic work from MIT's lcs lab. Their
is an IEEE TON paper on RIO by clark et all.

D. Clark, W. Fang, "Explicit Allocation of Best Effort
Packet Delivery Service", IEEE/ACM Transactions on
Networking, August 1998, Vol 6. No. 4, pp. 362-373.

It is widely used as RED with drop precedence. It was
used for providing rate adaptation in differentited
services [RFC 2963]. It is the base for effective use
of many works on three color markers. 

I have no details with repect to deployment.

But analysing emergency service with respect to drop
precedence is interesting. It can provide some useful
insight to both academic and engineering community for
possible use of various AQM variants towards ieprep.

__________________________________________________
Do You Yahoo!?
Sign up for SBC Yahoo! Dial - First Month Free
http://sbc.yahoo.com

---

From: "Alistair Munro" <[email-masked]>
Date: Wed, 10 Jul 2002 08:02:08 +0100

Hi Senthil,

Thanks very much for this.

Speaking as an implementer, I feel that output from this group should
position itself as far as possible as standalone documents. RFC2963
contains both theory, practice and configurations with minimal need to
dig around in the library. If Salil's draft can be extended to include
similar detail then I believe that it will be very valuable.

Regards,

AListair

Tel: (work) +44-117-900-8114, (home) +44-1275-462707, (mobile)
+44-7974-922-442;

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of senthil ayyasamy
> Sent: 09 July 2002 22:18
> To: Alistair Munro; 'Talauliker, Salil Ulhas (UMKC-Student)'
> Cc: [email-masked]
> Sign up for SBC Yahoo! Dial - First Month Free http://sbc.yahoo.com
>