Subject: RE: [Ieprep] requirements document(s) to SIPPING

From: "King, Kimberly S." <[email-masked]>
Date: Tue, 1 Oct 2002 15:47:13 -0400

> > 
> > 2. Introduce priority scheme at SIP endpoints (e.g., SIP 
> user agents,
> > gateways, media servers).
> > 
> > This would allow new optional functionality such as 
> providing emergency
> > users preferred access to gateway or media server 
> resources, allowing
> > preemption to occur at endpoints, etc.  This option 
> increases complexity and
> > has security issues that will also need to be addressed.
> 
> I believe the security issues aren't all that different than those we 
> already face - you need to prevent unauthorized access. 

I'm glad to hear you say that.  I wasn't sure how to read some of the
security requirements.  

"SEC-1: More rigorous: Prioritized access to network and end
             system resources imposes particularly stringent
             requirements on authentication and authorization mechanisms
             since access to prioritized resources may impact overall
             system stability and performance, not just result in theft
             of, say, a single phone call."

Part of this process is just understanding what is being said.

> don't see how 
> this increases protocol complexity. It may increase implementation 
> complexity slightly, but many existing media systems already have 
> priorities of one sort or another. Maintaining two (or more) queues 
> instead of one isn't terribly challenging for an application, 
> particularly if you don't do preemption. The pseudo is nothing but
> 
> if (incoming request has high priority)
>     insert into queue1
> else
>     insert into queue2
> 
> and
> 
> if request is done
>    pick next from queue1
>    if empty, pick next from queue2
> 

The case of endpoint prioritization is an important case that we should
address.  Sure, the above pseudo code is trivial and represents a policy
saying high priority can starve everything else (assuming you want this in a
loop).  That's one policy.  It's fine that this is trivial after working out
the requirements but part of the complexity is figuring out the
requirements.  

> > 
> > Questions for WG:  What are the requirements for these 
> endpoints?  Would a
> > SIP endpoint be required to determine what priority 
> scheme(s) a gateway
> > employs?  Would the gateway be required to communicate the security
> > information it must have before allowing priority access to 
> resources?  
> 
> I'm confused by your distinction. A gateway *is* a special 
> case of a SIP 
> endpoint. (I'm treating a decomposed MG/MGC as a logical 
> gateway here.) 
> The gateway or, in case of a decomposed version, the MGC, speaks SIP.

Yes, the gateway *is* a special case of a SIP endpoint.  I brought it out as
an example because it has resources that your document specifies as
potentially a bottleneck.  

The purpose of the exchange was to focus on underlying assumptions and
requirements so we can provide a good requirements document for SIP/SIPPING
that meets the needs of the ieprep community.

_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 01 Oct 2002 16:16:09 -0400

>              of, say, a single phone call."

I added a more explicit reference to the resource mentioned earlier. 
SEC-1 applies to all of them. (I'm not sure if that's where the 
confusion came from.)

> the requirements but part of the complexity is figuring out the

I don't think we need to specify a particular queueing policy. I'm a bit 
lost as to what impact on requirements this might have. (I can't see any 
new ones.)

> that meets the needs of the ieprep community.
Thanks for all your close reading and comments.