Subject: RE: [Ieprep] IEPREP SIP REQ-10 (w/14)

From: "King, Kimberly S." <[email-masked]>
Date: Tue, 1 Oct 2002 12:07:47 -0400

> > Does REQ-10, taken along with  REQ-14, say all network elements must
> > understand the mechanism (at least enough to provide a list 
> of supported
> > name spaces or enough to be tell the name space is not supported)?
> 
> Not really. It could just mean that one should be able to 
> find out if a 
> network element supports any scheme. If the network element doesn't 
> support the scheme at all, it can return the protocol equivalent of 
> "Huh?", without having a clue whether this was a feature asking for 
> priority treatment or a Big Mac.
> 

What happens if I ask for a Big Mac feature today?  Do all network elements
return the protocol equivalent of "Huh?" or does this reflect a modification
of all network elements?
_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 01 Oct 2002 12:15:32 -0400

> return the protocol equivalent of "Huh?" or does this reflect a modification

To be concrete: One way to ask for a feature in SIP is via the Require 
header, as in (many details elided)

INVITE sip:[email-masked] SIP/2.0
Require: BigMac

would return the status response

SIP/2.0 420 Bad Extension
Unsupported: BigMac

(Methods would be requested via OPTIONS and returned in Allow, but 
that's not likely to be applicable in our application.) All SIP systems 
have to support this mechanism today, as it is the foundation of the 
feature negotiation mechanism.

Henning